xpdf in -current broken

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

xpdf in -current broken

Edd Barrett
Hi,

I have installed  a recent xpdf package on -current (xpdf-3.01p0) and it
behaves strangely if you maximize the window. It doesnt utilize the whole
area, and if it passes off the edge, no scrollbar is displayed. difficult to
explain.

The issue was reported initially in another thread (acroread broken), but we
dont like to hijack threads right? ;)

This error isnt present on my 3.8 box.

DMESG as usual:

OpenBSD 3.8-current (GENERIC) #585: Mon Jan 16 12:34:44 MST 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Celeron(R) M processor 1500MHz ("GenuineIntel" 686-class)
1.50 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,TM,SBF
real mem  = 258449408 (252392K)
avail mem = 228839424 (223476K)
using 3180 buffers containing 13025280 bytes (12720K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(60) BIOS, date 02/21/05, BIOS32 rev. 0 @ 0xfd740
pcibios0 at bios0: rev 2.1 @ 0xfd6d0/0x930
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdeb0/256 (14 entries)
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82371FB ISA" rev 0x00)
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0xd000! 0xcd000/0x1000 0xce000/0x1000
0xdc000/0x4000! 0xe0000/0x10000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82852GM Hub-PCI" rev 0x02
"Intel 82852GM Memory" rev 0x02 at pci0 dev 0 function 1 not configured
"Intel 82852GM Configuration" rev 0x02 at pci0 dev 0 function 3 not
configured
vga1 at pci0 dev 2 function 0 "Intel 82852GM AGP" rev 0x02: aperture at
0xe0000000, size 0x8000000
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Intel 82852GM AGP" rev 0x02 at pci0 dev 2 function 1 not configured
uhci0 at pci0 dev 29 function 0 "Intel 82801DB USB" rev 0x01: irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 1 "Intel 82801DB USB" rev 0x01: irq 11
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 29 function 2 "Intel 82801DB USB" rev 0x01: irq 11
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 29 function 7 "Intel 82801DB USB" rev 0x01: irq 11
usb3 at ehci0: USB revision 2.0
uhub3 at usb3
uhub3: Intel EHCI root hub, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
ppb0 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x81
pci1 at ppb0 bus 1
cbb0 at pci1 dev 0 function 0 "Texas Instruments PCI1510 CardBus" rev 0x00:
irq 11
iwi0 at pci1 dev 2 function 0 "Intel PRO/Wireless 2200BG" rev 0x05: irq 11,
address 00:12:f0:79:36:41
fxp0 at pci1 dev 8 function 0 "Intel PRO/100 VE" rev 0x81, i82562: irq 11,
address 00:0a:e4:33:68:74
inphy0 at fxp0 phy 1: i82562ET 10/100 PHY, rev. 0
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x8, lattimer 0xb0
pcmcia0 at cardslot0
ichpcib0 at pci0 dev 31 function 0 "Intel 82801DBM LPC" rev 0x01: SpeedStep
pciide0 at pci0 dev 31 function 1 "Intel 82801DBM IDE" rev 0x01: DMA,
channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <HTS424030M9AT00>
wd0: 16-sector PIO, LBA, 28615MB, 58605120 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TEAC, DW-225, 2.6A> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801DB SMBus" rev 0x01: irq 11
iic0 at ichiic0
auich0 at pci0 dev 31 function 5 "Intel 82801DB AC97" rev 0x01: irq 11, ICH4
AC97
ac97: codec id 0x41445374 (Analog Devices AD1981B)
ac97: codec features headphone, 20 bit DAC, No 3D Stereo
audio0 at auich0
"Intel 82801DB Modem" rev 0x01 at pci0 dev 31 function 6 not configured
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt2 at isa0 port 0x3bc/4: polled
npx0 at isa0 port 0xf0/16: using exception 16
biomask effd netmask effd ttymask ffff
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302


Have a great day

Regards

Edd
Reply | Threaded
Open this post in threaded view
|

Re: xpdf in -current broken

Nikolay Sturm-2
* Edd Barrett [2006-01-22]:
> I have installed  a recent xpdf package on -current (xpdf-3.01p0) and
> it behaves strangely if you maximize the window. It doesnt utilize the
> whole area, and if it passes off the edge, no scrollbar is displayed.
> difficult to explain.

In the hopes this email works the same way the acroread one did: I
cannot reproduce this problem.

Are you sure you don't have any old libraries around? Do base and X
snapshots match?

Nikolay

Reply | Threaded
Open this post in threaded view
|

Re: xpdf in -current broken

steven mestdagh
In reply to this post by Edd Barrett
On Sun, Jan 22, 2006 at 01:28:34AM +0000, Edd Barrett wrote:

> Hi,
>
> I have installed  a recent xpdf package on -current (xpdf-3.01p0) and it
> behaves strangely if you maximize the window. It doesnt utilize the whole
> area, and if it passes off the edge, no scrollbar is displayed. difficult to
> explain.
>
> The issue was reported initially in another thread (acroread broken), but we
> dont like to hijack threads right? ;)
>
> This error isnt present on my 3.8 box.

I have been seeing the same kind of problem. Start from a small window,
enlarge it, and the content does not follow the window size, it just
sits in the original smaller size and also scrolls there.

Now, I think I narrowed this problem down a bit... this seems to only
happen with the fluxbox window manager on my box. I have tried twm and
blackbox, and xpdf works fine with those.
So, which window manager are you using?

steven

Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm

Reply | Threaded
Open this post in threaded view
|

Re: xpdf in -current broken

Matthieu Herrb
steven mestdagh wrote:

> On Sun, Jan 22, 2006 at 01:28:34AM +0000, Edd Barrett wrote:
>
>>Hi,
>>
>>I have installed  a recent xpdf package on -current (xpdf-3.01p0) and it
>>behaves strangely if you maximize the window. It doesnt utilize the whole
>>area, and if it passes off the edge, no scrollbar is displayed. difficult to
>>explain.
>>
>>The issue was reported initially in another thread (acroread broken), but we
>>dont like to hijack threads right? ;)
>>
>>This error isnt present on my 3.8 box.
>
>
> I have been seeing the same kind of problem. Start from a small window,
> enlarge it, and the content does not follow the window size, it just
> sits in the original smaller size and also scrolls there.
>
> Now, I think I narrowed this problem down a bit... this seems to only
> happen with the fluxbox window manager on my box. I have tried twm and
> blackbox, and xpdf works fine with those.
> So, which window manager are you using?
>
> steven
>
> Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm

Are any 64 bit machines involved in the path that leads to this bug?
--
Matthieu Herrb

Reply | Threaded
Open this post in threaded view
|

Re: xpdf in -current broken

steven mestdagh
On Sun, Jan 22, 2006 at 10:42:39AM +0100, Matthieu Herrb wrote:

> >>I have installed  a recent xpdf package on -current (xpdf-3.01p0) and it
> >>behaves strangely if you maximize the window. It doesnt utilize the whole
> >>area, and if it passes off the edge, no scrollbar is displayed. difficult
> >>to
> >>explain.
> >>
> >>The issue was reported initially in another thread (acroread broken), but
> >>we
> >>dont like to hijack threads right? ;)
> >>
> >>This error isnt present on my 3.8 box.
> >
> >
> >I have been seeing the same kind of problem. Start from a small window,
> >enlarge it, and the content does not follow the window size, it just
> >sits in the original smaller size and also scrolls there.
> >
> >Now, I think I narrowed this problem down a bit... this seems to only
> >happen with the fluxbox window manager on my box. I have tried twm and
> >blackbox, and xpdf works fine with those.
> >So, which window manager are you using?
> >
>
> Are any 64 bit machines involved in the path that leads to this bug?

no, all this happens on i386.  can't test any 64 bit archs right now.

steven

Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm

Reply | Threaded
Open this post in threaded view
|

Re: xpdf in -current broken

Matthias Kilian
In reply to this post by steven mestdagh
On Sun, Jan 22, 2006 at 10:17:00AM +0100, steven mestdagh wrote:
> I have been seeing the same kind of problem. Start from a small window,
> enlarge it, and the content does not follow the window size, it just
> sits in the original smaller size and also scrolls there.
>
> Now, I think I narrowed this problem down a bit... this seems to only
> happen with the fluxbox window manager on my box. I have tried twm and
> blackbox, and xpdf works fine with those.

I've similar effects with ratpoison: starting xpdf within a
"fullscreen" frame initially gives too small content, altthough
I've "initialZoom width" in .xpdfrc. Switching size to a smaller
frame and then back to fullscreen results in correct display.

Ciao,
        Kili

Reply | Threaded
Open this post in threaded view
|

Re: xpdf in -current broken

Edd Barrett
In reply to this post by steven mestdagh
> Now, I think I narrowed this problem down a bit... this seems to only
> happen with the fluxbox window manager on my box. I have tried twm and
> blackbox, and xpdf works fine with those.
> So, which window manager are you using?
>

I was using mwm, but a quick switch to fvwm confirms your suspision. How
odd. Next question is why?

Regards

Edd
Reply | Threaded
Open this post in threaded view
|

Re: xpdf in -current broken

Marcos Latas
In reply to this post by Matthieu Herrb
On 22/01/06, Matthieu Herrb <[hidden email]> wrote:
>
> Are any 64 bit machines involved in the path that leads to this bug?
> --
> Matthieu Herrb
>
>

On my amd64 -current system, I just need to launch the program and
touch the mouse wheel for a core dump. I have also experienced the
problem Edd reported. Details follow.


$ gdb -core xpdf.core /usr/local/bin/xpdf
Core was generated by `xpdf'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libpthread.so.6.2...done.
Loaded symbols for /usr/lib/libpthread.so.6.2
Reading symbols from /usr/local/lib/libt1.so.6.0...done.
Loaded symbols for /usr/local/lib/libt1.so.6.0
Reading symbols from /usr/X11R6/lib/libfreetype.so.13.1...done.
Loaded symbols for /usr/X11R6/lib/libfreetype.so.13.1
Reading symbols from /usr/local/lib/libXm.so.3.0...done.
Loaded symbols for /usr/local/lib/libXm.so.3.0
Reading symbols from /usr/X11R6/lib/libXt.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libXt.so.9.0
Reading symbols from /usr/X11R6/lib/libXp.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libXp.so.9.0
Reading symbols from /usr/X11R6/lib/libXext.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.9.0
Reading symbols from /usr/X11R6/lib/libXpm.so.7.0...done.
Loaded symbols for /usr/X11R6/lib/libXpm.so.7.0
Reading symbols from /usr/X11R6/lib/libSM.so.8.0...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.8.0
Reading symbols from /usr/X11R6/lib/libICE.so.8.1...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.8.1
Reading symbols from /usr/X11R6/lib/libX11.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.9.0
Reading symbols from /usr/lib/libstdc++.so.42.0...done.
Loaded symbols for /usr/lib/libstdc++.so.42.0
Reading symbols from /usr/lib/libm.so.2.1...done.
Loaded symbols for /usr/lib/libm.so.2.1
Symbols already loaded for /usr/lib/libpthread.so.6.2
Reading symbols from /usr/lib/libc.so.39.0...done.
Loaded symbols for /usr/lib/libc.so.39.0
Reading symbols from /usr/libexec/ld.so...done.
Loaded symbols for /usr/libexec/ld.so
Reading symbols from /usr/X11R6/lib/libXcursor.so.3.0...done.
Loaded symbols for /usr/X11R6/lib/libXcursor.so.3.0
Reading symbols from /usr/X11R6/lib/libXrender.so.4.1...done.
Loaded symbols for /usr/X11R6/lib/libXrender.so.4.1
Reading symbols from /usr/X11R6/lib/libXfixes.so.4.0...done.
Loaded symbols for /usr/X11R6/lib/libXfixes.so.4.0
#0  0x0000000000480a17 in ?? ()
(gdb) bt
#0  0x0000000000480a17 in ?? ()
#1  0x0000000048dc56cb in XtCallCallbackList () from /usr/X11R6/lib/libXt.so.9.0
#2  0x00000000476988ad in _XmDrawingAreaInput () from
/usr/local/lib/libXm.so.3.0
#3  0x0000000048df5c4c in HandleActions () from /usr/X11R6/lib/libXt.so.9.0
#4  0x0000000048df611b in HandleSimpleState () from /usr/X11R6/lib/libXt.so.9.0
#5  0x0000000048df66e0 in _XtTranslateEvent () from /usr/X11R6/lib/libXt.so.9.0
#6  0x0000000048dd14e2 in XtDispatchEventToWidget () from
/usr/X11R6/lib/libXt.so.9.0
#7  0x0000000048dd1f19 in _XtDefaultDispatcher () from
/usr/X11R6/lib/libXt.so.9.0
#8  0x0000000048dd2134 in XtDispatchEvent () from /usr/X11R6/lib/libXt.so.9.0
#9  0x0000000048dd2575 in XtAppMainLoop () from /usr/X11R6/lib/libXt.so.9.0
#10 0x000000000048bac7 in ?? ()
#11 0x0000000000405d5b in ?? ()
#12 0x0000000000000001 in ?? ()
#13 0x00007f7ffffc9390 in ?? ()
#14 0x0000000000000000 in ?? ()
(gdb)


OpenBSD 3.8-current (GENERIC) #0: Mon Jan 16 15:17:38 WET 2006
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC
real mem = 1073016832 (1047868K)
avail mem = 908443648 (887152K)
using 22937 buffers containing 107507712 bytes (104988K) of memory
mainbus0 (root)
cpu0 at mainbus0: (uniprocessor)
cpu0: AMD Athlon(tm) 64 Processor 3200+, 2002.89 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MM
X,FXSR,SSE,SSE2,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB
64b/line 16-way L
2 cache
cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
pci0 at mainbus0 bus 0: configuration mode 1
pchb0 at pci0 dev 0 function 0 "VIA K8HTB Host" rev 0x00
pchb1 at pci0 dev 0 function 1 "VIA K8HTB Host" rev 0x00
pchb2 at pci0 dev 0 function 2 "VIA K8HTB Host" rev 0x00
pchb3 at pci0 dev 0 function 3 "VIA K8HTB Host" rev 0x00
pchb4 at pci0 dev 0 function 4 "VIA K8HTB Host" rev 0x00
pchb5 at pci0 dev 0 function 7 "VIA K8HTB Host" rev 0x00
ppb0 at pci0 dev 1 function 0 "VIA K8HTB AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Radeon 9600 Pro" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"ATI Radeon 9600 Pro Sec" rev 0x00 at pci1 dev 0 function 1 not configured
"VIA VT6306 FireWire" rev 0x80 at pci0 dev 7 function 0 not configured
pciide0 at pci0 dev 8 function 0 "Promise PDC20378" rev 0x02: DMA
pciide0: using irq 5 for native-PCI interrupt
skc0 at pci0 dev 10 function 0 "Marvell Yukon 88E8001/8003/8010" rev
0x13, Marvell Yuko
n Lite (0x9): irq 10
sk0 at skc0 port A, address 00:11:d8:9c:c5:1f
eephy0 at sk0 phy 0: Marvell 88E1011 Gigabit PHY, rev. 5
pciide1 at pci0 dev 15 function 0 "VIA VT6420 SATA" rev 0x80: DMA
pciide1: using irq 10 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0: <SAMSUNG SP0812C>
wd0: 16-sector PIO, LBA48, 76351MB, 156368016 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
pciide2 at pci0 dev 15 function 1 "VIA VT82C571 IDE" rev 0x06: DMA,
channel 0 configure
d to compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide2 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVDRAM GSA-4040B, A300> SCSI0
5/cdrom removabl
e
cd0(pciide2:0:0): using PIO mode 4, DMA mode 2
pciide2: channel 1 disabled (no drives)
uhci0 at pci0 dev 16 function 0 "VIA VT83C572 USB" rev 0x81: irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: VIA UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 16 function 1 "VIA VT83C572 USB" rev 0x81: irq 11
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: VIA UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 16 function 2 "VIA VT83C572 USB" rev 0x81: irq 10
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: VIA UHCI root hub, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3 at pci0 dev 16 function 3 "VIA VT83C572 USB" rev 0x81: irq 10
usb3 at uhci3: USB revision 1.0
uhub3 at usb3
uhub3: VIA UHCI root hub, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 16 function 4 "VIA VT6202 USB" rev 0x86: irq 5
usb4 at ehci0: USB revision 2.0
uhub4 at usb4
uhub4: VIA EHCI root hub, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
viapm0 at pci0 dev 17 function 0 "VIA VT8237 ISA" rev 0x00
iic0 at viapm0
"w83791sd" at iic0 addr 0x2f not configured
iic0: addr 0x2f 00=00 01=00 02=00 03=00 04=00 05=00 06=00 07=00 08=00
09=80 0a=00 0b=00
 0c=01 0d=00 0e=00 10=00 11=00 12=7f 13=00 14=00 15=10 16=00 17=00
18=00 19=00 1a=00 1b
=00 1c=00 1d=00 1e=00 1f=80 20=05 21=01 22=0f 23=be 24=01 25=01 26=01
27=7f 2b=7e 2c=68
 2d=00 2e=00 2f=ed 30=b0 31=00 32=00 33=01 34=70 35=00 36=88 37=00
38=00 39=10 3a=80 3b
=40 3c=00 3d=80 40=01 41=30 42=6f 43=00 44=00 45=00 46=00 47=50 48=2f
49=10 4a=01 4b=44
 4c=01 4d=95 4e=80 4f=5c 56=00 57=80 58=72 59=70 5b=00 5c=00 5d=00
5e=05 80=01 82=01 84
=00 85=00 86=00 87=00 88=01 89=01 8a=01 8b=01 8c=3c 8d=3c 8e=0a 8f=0a
90=00 91=00 92=00
 93=01 95=00 96=00 97=00 98=01 99=01 9a=3c 9b=18 9c=00 9d=00 9e=01
9f=01 a3=00 a4=00 a5
=00 a6=00 a7=00 a8=13 aa=6f ab=18 ac=00 b0=be b1=00 b2=01 b4=08 b5=02
b6=80 b7=10 b8=00
 b9=00 bc=88 bd=04 c0=7f c1=00 c2=00 c3=4b c4=00 c5=50 c6=00 c8=7f
c9=00 ca=00 cb=4b cc
=00 cd=50 ce=00 f2=00 f4=00 f5=01 f6=00 f9=02 fb=00 fc=00 fd=15 ff=1d: w83791sd
iic0: addr 0x48 00=7f 01=00 02=4b 03=50 04=7f 05=00 06=4b 07=50 08=7f
09=00 0a=4b 0b=50
 0c=7f 0d=00 0e=4b 0f=50 10=7f 11=00 12=4b 13=50 14=7f 15=00 16=4b
17=50 18=7f 19=00 1a
=4b 1b=50 1c=7f 1d=00 1e=4b 1f=50 20=7f 21=00 22=4b 23=50 24=7f 25=00
26=4b 27=50 28=7f
 29=00 2a=4b 2b=50 2c=7f 2d=00 2e=4b 2f=50 30=7f 31=00 32=4b 33=50
34=7f 35=00 36=4b 37
=50 38=7f 39=00 3a=4b 3b=50 3c=7f 3d=00 3e=4b 3f=50 40=7f 41=00 42=4b
43=50 44=7f 45=00
 46=4b 47=50 48=7f 49=00 4a=4b 4b=50 4c=7f 4d=00 4e=4b 4f=50 50=7f
51=00 52=4b 53=50 54
=7f 55=00 56=4b 57=50 58=7f 59=00 5a=4b 5b=50 5c=7f 5d=00 5e=4b 5f=50
60=7f 61=00 62=4b
 63=50 64=7f 65=00 66=4b 67=50 68=7f 69=00 6a=4b 6b=50 6c=7f 6d=00
6e=4b 6f=50 70=7f 71
=00 72=4b 73=50 74=7f 75=00 76=4b 77=50 78=7f 79=00 7a=4b 7b=50 7c=7f
7d=00 7e=4b 7f=50
 80=7f 81=00 82=4b 83=50 84=7f 85=00 86=4b 87=50 88=7f 89=00 8a=4b
8b=50 8c=7f 8d=00 8e
=4b 8f=50 90=7f 91=00 92=4b 93=50 94=7f 95=00 96=4b 97=50 98=7f 99=00
9a=4b 9b=50 9c=7f
 9d=00 9e=4b 9f=50 a0=7f a1=00 a2=4b a3=50 a4=7f a5=00 a6=4b a7=50
a8=7f a9=00 aa=4b ab
=50 ac=7f ad=00 ae=4b af=50 b0=7f b1=00 b2=4b b3=50 b4=7f b5=00 b6=4b
b7=50 b8=7f b9=00
 ba=4b bb=50 bc=7f bd=00 be=4b bf=50 c0=7f c1=00 c2=4b c3=50 c4=7f
c5=00 c6=4b c7=50 c8
=7f c9=00 ca=4b cb=50 cc=7f cd=00 ce=4b cf=50 d0=7f d1=00 d2=4b d3=50
d4=7f d5=00 d6=4b
 d7=50 d8=7f d9=00 da=4b db=50 dc=7f dd=00 de=4b df=50 e0=7f e1=00
e2=4b e3=50 e4=7f e5
=00 e6=4b e7=50 e8=7f e9=00 ea=4b eb=50 ec=7f ed=00 ee=4b ef=50 f0=7f
f1=00 f2=4b f3=50
 f4=7f f5=00 f6=4b f7=50 f8=7f f9=00 fa=4b fb=50 fc=7f fd=00 fe=4b ff=50
iic0: addr 0x49 00=7f 01=00 02=4b 03=50 04=7f 05=00 06=4b 07=50 08=7f
09=00 0a=4b 0b=50
 0c=7f 0d=00 0e=4b 0f=50 10=7f 11=00 12=4b 13=50 14=7f 15=00 16=4b
17=50 18=7f 19=00 1a
=4b 1b=50 1c=7f 1d=00 1e=4b 1f=50 20=7f 21=00 22=4b 23=50 24=7f 25=00
26=4b 27=50 28=7f
 29=00 2a=4b 2b=50 2c=7f 2d=00 2e=4b 2f=50 30=7f 31=00 32=4b 33=50
34=7f 35=00 36=4b 37
=50 38=7f 39=00 3a=4b 3b=50 3c=7f 3d=00 3e=4b 3f=50 40=7f 41=00 42=4b
43=50 44=7f 45=00
 46=4b 47=50 48=7f 49=00 4a=4b 4b=50 4c=7f 4d=00 4e=4b 4f=50 50=7f
51=00 52=4b 53=50 54
=7f 55=00 56=4b 57=50 58=7f 59=00 5a=4b 5b=50 5c=7f 5d=00 5e=4b 5f=50
60=7f 61=00 62=4b
 63=50 64=7f 65=00 66=4b 67=50 68=7f 69=00 6a=4b 6b=50 6c=7f 6d=00
6e=4b 6f=50 70=7f 71
=00 72=4b 73=50 74=7f 75=00 76=4b 77=50 78=7f 79=00 7a=4b 7b=50 7c=7f
7d=00 7e=4b 7f=50
 80=7f 81=00 82=4b 83=50 84=7f 85=00 86=4b 87=50 88=7f 89=00 8a=4b
8b=50 8c=7f 8d=00 8e
=4b 8f=50 90=7f 91=00 92=4b 93=50 94=7f 95=00 96=4b 97=50 98=7f 99=00
9a=4b 9b=50 9c=7f
 9d=00 9e=4b 9f=50 a0=7f a1=00 a2=4b a3=50 a4=7f a5=00 a6=4b a7=50
a8=7f a9=00 aa=4b ab
=50 ac=7f ad=00 ae=4b af=50 b0=7f b1=00 b2=4b b3=50 b4=7f b5=00 b6=4b
b7=50 b8=7f b9=00
 ba=4b bb=50 bc=7f bd=00 be=4b bf=50 c0=7f c1=00 c2=4b c3=50 c4=7f
c5=00 c6=4b c7=50 c8
=7f c9=00 ca=4b cb=50 cc=7f cd=00 ce=4b cf=50 d0=7f d1=00 d2=4b d3=50
d4=7f d5=00 d6=4b
 d7=50 d8=7f d9=00 da=4b db=50 dc=7f dd=00 de=4b df=50 e0=7f e1=00
e2=4b e3=50 e4=7f e5
=00 e6=4b e7=50 e8=7f e9=00 ea=4b eb=50 ec=7f ed=00 ee=4b ef=50 f0=7f
f1=00 f2=4b f3=50
 f4=7f f5=00 f6=4b f7=50 f8=7f f9=00 fa=4b fb=50 fc=7f fd=00 fe=4b ff=50
auvia0 at pci0 dev 17 function 5 "VIA VT8233 AC97" rev 0x60: irq 5
ac97: codec id 0x414c4790 (Avance Logic ALC850)
audio0 at auvia0
pchb6 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb7 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb8 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb9 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
isa0 at mainbus0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
lm0 at isa0 port 0x290/8: W83627THF
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

Reply | Threaded
Open this post in threaded view
|

Re: xpdf in -current broken

Christian Weisgerber
Marcos Latas <[hidden email]> wrote:

> On my amd64 -current system, I just need to launch the program and
> touch the mouse wheel for a core dump.

That happens on i386, too.  It doesn't happen if you actually specify
a PDF document.

--
Christian "naddy" Weisgerber                          [hidden email]