xorg issues on powerbook g4 6,1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

xorg issues on powerbook g4 6,1

Herminio Hernandez Jr.
I am looking for some help. I have OpenBSD 6.0 install on my PowerBook G4.
I installed the XFCE package however when I run 'startxfce4' Xorg fails to
start. I see the following errors in the Xorg.0.log.

# cat /var/log/Xorg.0.log |grep -e WW -e EE

        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1408.921] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card
support
[  1408.937] (EE) NV(0): pci_device_map_range failed: Invalid argument
[  1408.938] (EE) Segmentation fault at address 0x4
[  1408.939] (EE)
[  1408.939] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  1408.940] (EE)
[  1408.941] (EE)
[  1408.942] (EE) Please also check the log file at "/var/log/Xorg.0.log"
for additional information.
[  1408.942] (EE)
[  1408.946] (EE) Server terminated with error (1). Closing log file.

I did find a link where this issue was discussed *here
<http://misc.openbsd.narkive.com/d6drr7IN/current-macppc-on-a-powerbook6-1>*.
It suggest setting to ttyC0 off in /etc/ttys. However that did not work for
me and I saw in the xenocara release notes for 5.8 that I should no longer
need to do this on macppc. Below is my dmesg. Has anyone been able to get
this to work?

Thanks!

Herminio

# dmesg

[ using 694220 bytes of bsd ELF symbol table ]
console out [NVDA,Display-A] console in [keyboard], using ADB
using parent NVDA,Parent:: memaddr 94000000, size 4000000 : consaddr
94004000 : ioaddr 91000000, size 1000000: width 1024 linebytes 1024 height
768 depth 8
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2016 OpenBSD. All rights reserved.
http://www.OpenBSD.org

OpenBSD 6.0 (GENERIC) #1097: Tue Jul 26 18:22:06 MDT 2016
    [hidden email]:/usr/src/sys/arch/macppc/compile/GENERIC
real mem = 1207959552 (1152MB)
avail mem = 1152307200 (1098MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root: model PowerBook6,1
cpu0 at mainbus0: 7455 (Revision 0x303): 533 MHz: 256KB L2 cache
mem0 at mainbus0
spdmem0 at mem0: no EEPROM found
spdmem1 at mem0: 1GB DDR SDRAM non-parity PC2700CL2.5
memc0 at mainbus0: uni-n rev 0xd2
"hw-clock" at memc0 not configured
kiic0 at memc0 offset 0xf8001000
iic0 at kiic0
admtmp0 at iic0 addr 0xac
mpcpcibr0 at mainbus0 pci: uni-north
pci0 at mpcpcibr0 bus 0
pchb0 at pci0 dev 11 function 0 "Apple UniNorth AGP" rev 0x00
agp at pchb0 not configured
vgafb0 at pci0 dev 16 function 0 "NVIDIA GeForce4 440 Go 64M" rev 0xa3, mmio
wsdisplay0 at vgafb0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
mpcpcibr1 at mainbus0 pci: uni-north
pci1 at mpcpcibr1 bus 0
macobio0 at pci1 dev 23 function 0 "Apple Intrepid" rev 0x00
openpic0 at macobio0 offset 0x40000: version 0x4614 feature 3f0302 LE
macgpio0 at macobio0 offset 0x50
macgpio1 at macgpio0 offset 0x9: irq 47
"programmer-switch" at macgpio0 offset 0x11 not configured
"gpio4" at macgpio0 offset 0x1e not configured
"gpio5" at macgpio0 offset 0x6f not configured
"gpio6" at macgpio0 offset 0x70 not configured
"extint-gpio4" at macgpio0 offset 0x5c not configured
"gpio11" at macgpio0 offset 0x75 not configured
"extint-gpio15" at macgpio0 offset 0x67 not configured
"escc-legacy" at macobio0 offset 0x12000 not configured
zs0 at macobio0 offset 0x13000: irq 22,23
zstty0 at zs0 channel 0
zstty1 at zs0 channel 1
snapper0 at macobio0 offset 0x10000: irq 30,1,2
"timer" at macobio0 offset 0x15000 not configured
adb0 at macobio0 offset 0x16000: irq 25, via-pmu, 3 targets
apm0 at adb0: battery flags 0x5, 99% charged
piic0 at adb0
iic1 at piic0
akbd0 at adb0 addr 2: PowerBook G4 keyboard (Inverted T)
wskbd0 at akbd0: console keyboard, using wsdisplay0
ams0 at adb0 addr 3: EMP trackpad <tpad> 2-button, 400 dpi
wsmouse0 at ams0 mux 0
abtn0 at adb0 addr 7: brightness/volume/eject buttons
"battery" at macobio0 offset 0x0 not configured
"backlight" at macobio0 offset 0xf300 not configured
kiic1 at macobio0 offset 0x18000
iic2 at kiic1
wdc0 at macobio0 offset 0x20000 irq 24: DMA
atapiscsi0 at wdc0 channel 0 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <MATSHITA, CD-RW CW-8122, BA21> ATAPI 5/cdrom
removable
cd0(wdc0:0:0): using BIOS timings, DMA mode 2
audio0 at snapper0
bwi0 at pci1 dev 18 function 0 "Broadcom BCM4306" rev 0x03: irq 52, address
00:0d:93:e9:9e:00
ohci0 at pci1 dev 24 function 0 "Apple Intrepid USB" rev 0x00: irq 27,
version 1.0, legacy support
ohci1 at pci1 dev 25 function 0 "Apple Intrepid USB" rev 0x00: irq 28,
version 1.0, legacy support
ohci2 at pci1 dev 26 function 0 "Apple Intrepid USB" rev 0x00: irq 29,
version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0 "Apple OHCI root hub" rev 1.00/1.00 addr 1
usb1 at ohci1: USB revision 1.0
uhub1 at usb1 "Apple OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci2: USB revision 1.0
uhub2 at usb2 "Apple OHCI root hub" rev 1.00/1.00 addr 1
mpcpcibr2 at mainbus0 pci: uni-north
pci2 at mpcpcibr2 bus 0
kauaiata0 at pci2 dev 13 function 0 "Apple Intrepid ATA" rev 0x00
wdc1 at kauaiata0 irq 39: DMA
wd0 at wdc1 channel 0 drive 0: <OWC Aura Pro 3G SSD>
wd0: 1-sector PIO, LBA48, 114473MB, 234441648 sectors
wd0(wdc1:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 5
"Apple UniNorth Firewire" rev 0x81 at pci2 dev 14 function 0 not configured
gem0 at pci2 dev 15 function 0 "Apple Uni-N2 GMAC" rev 0x80: irq 41,
address 00:0a:95:7c:b3:5c
bmtphy0 at gem0 phy 0: BCM5221 100baseTX PHY, rev. 4
ugen0 at uhub0 port 2 "Apple Computer product 0x8203" rev 1.10/5.26 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
bootpath: /pci@f4000000/ata-6@d/disk@0:/bsd
root on wd0a (79102c408f00b6ee.a) swap on wd0b dump on wd0b
Reply | Threaded
Open this post in threaded view
|

Re: xorg issues on powerbook g4 6,1

Ryan S. Northrup
On Thu, 17 Nov 2016 12:37:18 -0700
"Herminio Hernandez, Jr." <[hidden email]> wrote:

> I am looking for some help. I have OpenBSD 6.0 install on my
> PowerBook G4. I installed the XFCE package however when I run
> 'startxfce4' Xorg fails to start.

Does "startx" work?  Does letting XDM start on boot (and thus handle
the X11 startup) work?

I can try reproducing on my own Powerbook G4 (which is currently
running 5.7 and can use an upgrade to 6.0 anyway), but...

> # dmesg
>
> [...]
>
> pchb0 at pci0 dev 11 function 0 "Apple UniNorth AGP" rev 0x00
> agp at pchb0 not configured

That's peculiar.  My own Powerbook seems to be lacking the "not
configured" line.  Maybe something changed there between 5.7 and 6.0?

> vgafb0 at pci0 dev 16 function 0 "NVIDIA GeForce4 440 Go 64M" rev
> 0xa3, mmio wsdisplay0 at vgafb0 mux 1: console (std, vt100 emulation)
> wsdisplay0: screen 1-5 added (std, vt100 emulation)

Looks like you've got a NVIDIA card, whereas mine has an ATI card
(relevant dmesg line: 'radeondrm0 at pci0 dev 16 function 0 "ATI Radeon
Mobility M10" rev 0x00').  That might be part of the problem (OpenBSD
and NVIDIA go together like milk and orange juice), and will certainly
affect my ability to help pin down your troubles.

Regardless, your full Xorg.0.log might be useful for someone smarter at
X11 troubleshooting than me.

--
Ryan S. Northrup
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: xorg issues on powerbook g4 6,1

Herminio Hernandez Jr.
I have another PowerBook G4 with a radeon card that did not have this
issue. So I am thinking it is Nvidia related. Also as a side not I tried to
manually create an xorg.conf with 'Xorg -configure' and the 'configure'
option is no longer available, is this something new? Below is the complete
Xorg log

# cat /var/log/Xorg.0.log

[  1408.808] (--) Using wscons driver on /dev/ttyC4
[  1408.849]
X.Org X Server 1.18.3
Release Date: 2016-04-04
[  1408.850] X Protocol Version 11, Revision 0
[  1408.850] Build Operating System: OpenBSD 6.0 macppc
[  1408.851] Current Operating System: OpenBSD openbsd-ppc.localdomain 6.0
GENERIC#1097 macppc
[  1408.852] Build Date: 26 July 2016  08:23:45PM
[  1408.852]
[  1408.853] Current version of pixman: 0.32.8
[  1408.853]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  1408.853] Markers: (--) probed, (**) from config file, (==) default
setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1408.856] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 17
12:28:55 2016
[  1408.859] (==) Using system config directory
"/usr/X11R6/share/X11/xorg.conf.d"
[  1408.859] (==) No Layout section.  Using the first Screen section.
[  1408.859] (==) No screen section available. Using defaults.
[  1408.859] (**) |-->Screen "Default Screen Section" (0)
[  1408.860] (**) |   |-->Monitor "<default monitor>"
[  1408.861] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[  1408.861] (==) Disabling SIGIO handlers for input devices
[  1408.862] (==) Automatically adding devices
[  1408.862] (==) Automatically enabling devices
[  1408.862] (==) Not automatically adding GPU devices
[  1408.862] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  1408.862] (==) FontPath set to:
        /usr/X11R6/lib/X11/fonts/misc/,
        /usr/X11R6/lib/X11/fonts/TTF/,
        /usr/X11R6/lib/X11/fonts/OTF/,
        /usr/X11R6/lib/X11/fonts/Type1/,
        /usr/X11R6/lib/X11/fonts/100dpi/,
        /usr/X11R6/lib/X11/fonts/75dpi/
[  1408.862] (==) ModulePath set to "/usr/X11R6/lib/modules"
[  1408.863] (II) The server relies on wscons to provide the list of input
devices.
        If no devices become available, reconfigure wscons or disable
AutoAddDevices.
[  1408.863] (II) Loader magic: 0x6d41450
[  1408.863] (II) Module ABI versions:
[  1408.863]    X.Org ANSI C Emulation: 0.4
[  1408.863]    X.Org Video Driver: 20.0
[  1408.863]    X.Org XInput driver : 22.1
[  1408.863]    X.Org Server Extension : 9.0
[  1408.869] (--) PCI:*(0:0:16:0) 10de:0179:10de:0010 rev 163, Mem @
0x91000000/16777216, 0x94000000/67108864, 0x00000000/524288, BIOS @
0x????????/131072
[  1408.869] (II) LoadModule: "glx"
[  1408.872] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
[  1408.902] (II) Module glx: vendor="X.Org Foundation"
[  1408.902]    compiled for 1.18.3, module version = 1.0.0
[  1408.902]    ABI class: X.Org Server Extension, version 9.0
[  1408.902] (==) AIGLX enabled
[  1408.902] (==) Matched nv as autoconfigured driver 0
[  1408.902] (==) Assigned the driver to the xf86ConfigLayout
[  1408.902] (II) LoadModule: "nv"
[  1408.904] (II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.so
[  1408.906] (II) Module nv: vendor="X.Org Foundation"
[  1408.906]    compiled for 1.18.3, module version = 2.1.20
[  1408.906]    Module class: X.Org Video Driver
[  1408.906]    ABI class: X.Org Video Driver, version 20.0
[  1408.906] (II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA
TNT2,
        Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
        Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
        GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
        GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
        Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
        GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
        GeForce4 420 Go 32M, GeForce4 460 Go, Quadro4 550 XGL,
        GeForce4 MX (Mac), Quadro NVS, Quadro4 500 GoGL, GeForce4 410 Go
16M,
        GeForce4 MX 440 with AGP8X, GeForce4 MX 440SE with AGP8X,
        GeForce4 MX 420 with AGP8X, GeForce4 MX 4000, GeForce4 448 Go,
        GeForce4 488 Go, Quadro4 580 XGL, GeForce4 MX with AGP8X (Mac),
        Quadro4 NVS 280 SD, Quadro4 380 XGL, Quadro NVS 50 PCI,
        GeForce4 448 Go, GeForce4 MX Integrated GPU, GeForce3,
        GeForce3 Ti 200, GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600,
        GeForce4 Ti 4400, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750
XGL,
        Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
        GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
        Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
        GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
        GeForce FX 5600 Ultra, GeForce FX 5600, GeForce FX 5600XT,
        GeForce FX Go5600, GeForce FX Go5650, Quadro FX Go700,
        GeForce FX 5200, GeForce FX 5200 Ultra, GeForce FX 5200,
        GeForce FX 5200LE, GeForce FX Go5200, GeForce FX Go5250,
        GeForce FX 5500, GeForce FX 5100, GeForce FX Go5200 32M/64M,
        GeForce FX 5200 (Mac), Quadro NVS 55/280 PCI, Quadro FX 500/600 PCI,
        GeForce FX Go53xx Series, GeForce FX Go5100, GeForce FX 5900 Ultra,
        GeForce FX 5900, GeForce FX 5900XT, GeForce FX 5950 Ultra,
        GeForce FX 5900ZT, Quadro FX 3000, Quadro FX 700,
        GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
        GeForce FX 5700VE, GeForce FX Go5700, GeForce FX Go5700,
        Quadro FX Go1000, Quadro FX 1100, GeForce 6800 Ultra, GeForce 6800,
        GeForce 6800 LE, GeForce 6800 XE, GeForce 6800 XT, GeForce 6800 GT,
        GeForce 6800 GT, GeForce 6800 GS, GeForce 6800 XT, Quadro FX 4000,
        GeForce 6800 GS, GeForce 6800, GeForce 6800 LE, GeForce 6800 XT,
        GeForce Go 6800, GeForce Go 6800 Ultra, Quadro FX Go1400,
        Quadro FX 3450/4000 SDI, Quadro FX 1400, GeForce 6600 GT,
        GeForce 6600, GeForce 6600 LE, GeForce 6600 VE, GeForce Go 6600,
        GeForce 6610 XL, GeForce Go 6600 TE/6200 TE, GeForce 6700 XL,
        GeForce Go 6600, GeForce Go 6600 GT, Quadro NVS 440, Quadro FX 550,
        Quadro FX 550, Quadro FX 540, GeForce 6200, GeForce 6500,
        GeForce 6200 TurboCache(TM), GeForce 6200SE TurboCache(TM),
        GeForce 6200 LE, GeForce Go 6200, Quadro NVS 285, GeForce Go 6400,
        GeForce Go 6200, GeForce Go 6400, GeForce 6250, GeForce 7100 GS,
        GeForce 6800, GeForce 6800 LE, GeForce 6800 GT, GeForce 6800 XT,
        GeForce 6200, GeForce 6200 A-LE, GeForce 7800 GTX, GeForce 7800 GTX,
        GeForce 7800 GT, GeForce 7800 GS, GeForce 7800 SLI, GeForce Go 7800,
        GeForce Go 7800 GTX, Quadro FX 4500, GeForce 7350 LE,
        GeForce 7300 LE, GeForce 7300 SE, GeForce Go 7200, GeForce Go 7300,
        GeForce Go 7400, GeForce Go 7400 GS, Quadro NVS 110M,
        Quadro NVS 120M, Quadro FX 350M, GeForce 7500 LE, Quadro FX 350,
        GeForce 7300 GS, GeForce 7650 GS, GeForce 7600 GT, GeForce 7600 GS,
        GeForce 7300 GT, GeForce 7600 LE, GeForce 7300 GT, GeForce Go 7700,
        GeForce Go 7600, GeForce Go 7600 GT, Quadro NVS 300M,
        GeForce Go 7900 SE, Quadro FX 550M, Quadro FX 560, GeForce 7900 GTX,
        GeForce 7900 GT, GeForce 7900 GS, GeForce 7950 GX2, GeForce 7950
GX2,
        GeForce 7950 GT, GeForce Go 7950 GTX, GeForce Go 7900 GS,
        GeForce Go 7900 GTX, Quadro FX 2500M, Quadro FX 1500M,
        Quadro FX 5500, Quadro FX 3500, Quadro FX 1500, Quadro FX 4500 X2,
        GeForce 6150, GeForce 6150 LE, GeForce 6100, GeForce Go 6150,
        Quadro NVS 210S / NVIDIA GeForce 6150LE, GeForce Go 6100,
        GeForce 6150SE, GeForce 6100 nForce 405, GeForce 6100 nForce 400,
        GeForce 6100 nForce 420, GeForce 7150M / nForce 630M,
        GeForce 7000M / nForce 610M, GeForce 7050 PV / nForce 630a,
        GeForce 7050 PV / nForce 630a, GeForce 7025 / nForce 630a,
        GeForce 8800 GTX, GeForce 8800 GTS, GeForce 8800 Ultra,
        Quadro FX 5600, Quadro FX 4600, GeForce 8600 GTS, GeForce 8600 GT,
        GeForce 8600 GT, GeForce 8600 GS, GeForce 8400 GS, GeForce 9500M GS,
        GeForce 8300 GS, GeForce 8600M GT, GeForce 9650M GS,
        GeForce 8700M GT, Quadro FX 370, Quadro NVS 320M, Quadro FX 570M,
        Quadro FX 1600M, Quadro FX 570, Quadro FX 1700, GeForce GT 330,
        GeForce 8400 SE, GeForce 8500 GT, GeForce 8400 GS, GeForce 8300 GS,
        GeForce 8400 GS, GeForce 8600M GS, GeForce 8400M GT,
        GeForce 8400M GS, GeForce 8400M G, Quadro NVS 140M, Quadro NVS 130M,
        Quadro NVS 135M, GeForce 9400 GT, Quadro FX 360M, GeForce 9300M G,
        Quadro NVS 290, GeForce GTX 295, GeForce GTX 280, GeForce GTX 260,
        GeForce GTX 285, GeForce GTX 275, GeForce GTX 260, GeForce GTX 295,
        Quadroplex 2200 D2, Quadroplex 2200 S4, Quadro CX, Quadro FX 5800,
        Quadro FX 4800, Quadro FX 3800, GeForce 8800 GTS 512,
        GeForce 9800 GT, GeForce 8800 GT, GeForce GT 230, GeForce 9800 GX2,
        GeForce 9800 GT, GeForce 8800 GS, GeForce GTS 240, GeForce 9800M
GTX,
        GeForce 8800M GTS, GeForce GTX 280M, GeForce 9800M GT,
        GeForce 8800M GTX, GeForce 8800 GS, GeForce GTX 285M,
        GeForce 9600 GSO, GeForce 8800 GT, GeForce 9800 GTX/9800 GTX+,
        GeForce 9800 GTX+, GeForce 9800 GT, GeForce GTS 250,
        GeForce 9800M GTX, GeForce GTX 260M, Quadro FX 4700 X2,
        Quadro FX 3700, Quadro VX 200, Quadro FX 3600M, Quadro FX 2800M,
        Quadro FX 3700M, Quadro FX 3800M, GeForce 9600 GT, GeForce 9600 GS,
        GeForce 9600 GSO 512, GeForce GT 130, GeForce GT 140,
        GeForce 9800M GTS, GeForce 9700M GTS, GeForce 9800M GS,
        GeForce 9800M GTS, GeForce 9600 GT, GeForce 9600 GT,
        GeForce GTS 160M, GeForce GTS 150M, GeForce 9600 GSO,
        GeForce 9600 GT, Quadro FX 1800, Quadro FX 2700M, GeForce 9500 GT,
        GeForce 9400 GT, GeForce 9500 GT, GeForce 9500 GS, GeForce 9500 GS,
        GeForce GT 120, GeForce 9600M GT, GeForce 9600M GS, GeForce 9600M
GT,
        GeForce 9700M GT, GeForce 9500M G, GeForce 9650M GT, GeForce G 110M,
        GeForce GT 130M, GeForce GT 120M, GeForce GT 220M, GeForce 9650 S,
        Quadro FX 380, Quadro FX 580, Quadro FX 1700M, GeForce 9400 GT,
        Quadro FX 770M, GeForce 9300 GE, GeForce 9300 GS, GeForce 8400,
        GeForce 8400 SE, GeForce 8400 GS, GeForce 9300M GS, GeForce G100,
        GeForce 9300 SE, GeForce 9200M GS, GeForce 9300M GS, Quadro NVS
150M,
        Quadro NVS 160M, GeForce G 105M, GeForce G 103M, GeForce G105M,
        Quadro NVS 420, Quadro FX 370 LP, Quadro NVS 450, Quadro FX 370M,
        Quadro NVS 295, GeForce 9100M G, GeForce 8200M G, GeForce 9200,
        GeForce 9100, GeForce 8300, GeForce 8200, nForce 730a, GeForce 9200,
        nForce 980a/780a SLI, nForce 750a SLI, GeForce 8100 / nForce 720a,
        GeForce 9400, GeForce 9400, GeForce 9400M G, GeForce 9400M,
        GeForce 9300, ION, GeForce 9400M G, GeForce 9400, nForce 760i SLI,
        GeForce 9400, GeForce 9300 / nForce 730i, GeForce 9200,
        GeForce 9100M G, GeForce 8200M G, GeForce 9400M, GeForce 9200,
        GeForce G102M, GeForce G102M, ION, ION, GeForce 9400, ION, ION LE,
        ION LE, GeForce GT 220, GeForce 315, GeForce 210, GeForce GT 230M,
        GeForce GT 330M, GeForce GT 230M, GeForce GT 330M, NVS 5100M,
        GeForce GT 320M, GeForce GT 240M, GeForce GT 325M, Quadro FX 880M,
        GeForce G210, GeForce 205, GeForce 310, ION, GeForce 210,
        GeForce 310, GeForce 315, GeForce G105M, GeForce G105M, NVS 2100M,
        NVS 3100M, GeForce 305M, ION, GeForce 310M, GeForce 305M,
        GeForce 310M, GeForce 305M, GeForce G210M, GeForce 310M,
        Quadro FX 380 LP, Quadro FX 380M, GeForce GT 330, GeForce GT 320,
        GeForce GT 240, GeForce GT 340, GeForce GT 330, GeForce GTS 260M,
        GeForce GTS 250M, GeForce 315, GeForce GT 335M, GeForce GTS 350M,
        GeForce GTS 360M, Quadro FX 1800M
[  1408.920] (--) NV: Found NVIDIA GeForce4 MX (Mac) at 00@00:16:0
[  1408.921] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card
support
[  1408.921] (II) Loading sub module "int10"
[  1408.921] (II) LoadModule: "int10"
[  1408.925] (II) Loading /usr/X11R6/lib/modules/libint10.so
[  1408.927] (II) Module int10: vendor="X.Org Foundation"
[  1408.927]    compiled for 1.18.3, module version = 1.0.0
[  1408.927]    ABI class: X.Org Video Driver, version 20.0
[  1408.927] (--) NV(0): Chipset: "GeForce4 MX (Mac)"
[  1408.928] (II) NV(0): Creating default Display subsection in Screen
section
        "Default Screen Section" for depth/fbbpp 24/32
[  1408.928] (==) NV(0): Depth 24, (--) framebuffer bpp 32
[  1408.928] (==) NV(0): RGB weight 888
[  1408.928] (==) NV(0): Default visual is TrueColor
[  1408.928] (II) Loading sub module "vgahw"
[  1408.928] (II) LoadModule: "vgahw"
[  1408.933] (II) Loading /usr/X11R6/lib/modules/libvgahw.so
[  1408.935] (II) Module vgahw: vendor="X.Org Foundation"
[  1408.935]    compiled for 1.18.3, module version = 0.1.0
[  1408.935]    ABI class: X.Org Video Driver, version 20.0
[  1408.936] (==) NV(0): Using HW cursor
[  1408.936] (--) NV(0): Linear framebuffer at 0x94000000
[  1408.936] (--) NV(0): MMIO registers at 0x91000000
[  1408.937] (EE) NV(0): pci_device_map_range failed: Invalid argument
[  1408.938] (EE) Segmentation fault at address 0x4
[  1408.939] (EE)
Fatal server error:
[  1408.939] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  1408.940] (EE)
[  1408.941] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  1408.942] (EE) Please also check the log file at "/var/log/Xorg.0.log"
for additional information.
[  1408.942] (EE)
[  1408.946] (EE) Server terminated with error (1). Closing log file.
#


On Thu, Nov 17, 2016 at 1:54 PM, Ryan Northrup <[hidden email]>
wrote:

> On Thu, 17 Nov 2016 12:37:18 -0700
> "Herminio Hernandez, Jr." <[hidden email]> wrote:
>
> > I am looking for some help. I have OpenBSD 6.0 install on my
> > PowerBook G4. I installed the XFCE package however when I run
> > 'startxfce4' Xorg fails to start.
>
> Does "startx" work?  Does letting XDM start on boot (and thus handle
> the X11 startup) work?
>
> I can try reproducing on my own Powerbook G4 (which is currently
> running 5.7 and can use an upgrade to 6.0 anyway), but...
>
> > # dmesg
> >
> > [...]
> >
> > pchb0 at pci0 dev 11 function 0 "Apple UniNorth AGP" rev 0x00
> > agp at pchb0 not configured
>
> That's peculiar.  My own Powerbook seems to be lacking the "not
> configured" line.  Maybe something changed there between 5.7 and 6.0?
>
> > vgafb0 at pci0 dev 16 function 0 "NVIDIA GeForce4 440 Go 64M" rev
> > 0xa3, mmio wsdisplay0 at vgafb0 mux 1: console (std, vt100 emulation)
> > wsdisplay0: screen 1-5 added (std, vt100 emulation)
>
> Looks like you've got a NVIDIA card, whereas mine has an ATI card
> (relevant dmesg line: 'radeondrm0 at pci0 dev 16 function 0 "ATI Radeon
> Mobility M10" rev 0x00').  That might be part of the problem (OpenBSD
> and NVIDIA go together like milk and orange juice), and will certainly
> affect my ability to help pin down your troubles.
>
> Regardless, your full Xorg.0.log might be useful for someone smarter at
> X11 troubleshooting than me.
>
> --
> Ryan S. Northrup
> [hidden email]
>
Reply | Threaded
Open this post in threaded view
|

Re: xorg issues on powerbook g4 6,1

Herminio Hernandez Jr.
Here is my /etc/sysctl.conf file

$ cat /etc/sysctl.conf

machdep.allowaperture=2 # See xf86(4)
$


On Thu, Nov 17, 2016 at 2:06 PM, Herminio Hernandez, Jr. <
[hidden email]> wrote:

> I have another PowerBook G4 with a radeon card that did not have this
> issue. So I am thinking it is Nvidia related. Also as a side not I tried to
> manually create an xorg.conf with 'Xorg -configure' and the 'configure'
> option is no longer available, is this something new? Below is the complete
> Xorg log
>
> # cat /var/log/Xorg.0.log
>
> [  1408.808] (--) Using wscons driver on /dev/ttyC4
> [  1408.849]
> X.Org X Server 1.18.3
> Release Date: 2016-04-04
> [  1408.850] X Protocol Version 11, Revision 0
> [  1408.850] Build Operating System: OpenBSD 6.0 macppc
> [  1408.851] Current Operating System: OpenBSD openbsd-ppc.localdomain 6.0
> GENERIC#1097 macppc
> [  1408.852] Build Date: 26 July 2016  08:23:45PM
> [  1408.852]
> [  1408.853] Current version of pixman: 0.32.8
> [  1408.853]    Before reporting problems, check http://wiki.x.org
>         to make sure that you have the latest version.
> [  1408.853] Markers: (--) probed, (**) from config file, (==) default
> setting,
>         (++) from command line, (!!) notice, (II) informational,
>         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> [  1408.856] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 17
> 12:28:55 2016
> [  1408.859] (==) Using system config directory "/usr/X11R6/share/X11/xorg.
> conf.d"
> [  1408.859] (==) No Layout section.  Using the first Screen section.
> [  1408.859] (==) No screen section available. Using defaults.
> [  1408.859] (**) |-->Screen "Default Screen Section" (0)
> [  1408.860] (**) |   |-->Monitor "<default monitor>"
> [  1408.861] (==) No monitor specified for screen "Default Screen Section".
>         Using a default monitor configuration.
> [  1408.861] (==) Disabling SIGIO handlers for input devices
> [  1408.862] (==) Automatically adding devices
> [  1408.862] (==) Automatically enabling devices
> [  1408.862] (==) Not automatically adding GPU devices
> [  1408.862] (==) Max clients allowed: 256, resource mask: 0x1fffff
> [  1408.862] (==) FontPath set to:
>         /usr/X11R6/lib/X11/fonts/misc/,
>         /usr/X11R6/lib/X11/fonts/TTF/,
>         /usr/X11R6/lib/X11/fonts/OTF/,
>         /usr/X11R6/lib/X11/fonts/Type1/,
>         /usr/X11R6/lib/X11/fonts/100dpi/,
>         /usr/X11R6/lib/X11/fonts/75dpi/
> [  1408.862] (==) ModulePath set to "/usr/X11R6/lib/modules"
> [  1408.863] (II) The server relies on wscons to provide the list of input
> devices.
>         If no devices become available, reconfigure wscons or disable
> AutoAddDevices.
> [  1408.863] (II) Loader magic: 0x6d41450
> [  1408.863] (II) Module ABI versions:
> [  1408.863]    X.Org ANSI C Emulation: 0.4
> [  1408.863]    X.Org Video Driver: 20.0
> [  1408.863]    X.Org XInput driver : 22.1
> [  1408.863]    X.Org Server Extension : 9.0
> [  1408.869] (--) PCI:*(0:0:16:0) 10de:0179:10de:0010 rev 163, Mem @
> 0x91000000/16777216, 0x94000000/67108864, 0x00000000/524288, BIOS @
> 0x????????/131072
> [  1408.869] (II) LoadModule: "glx"
> [  1408.872] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
> [  1408.902] (II) Module glx: vendor="X.Org Foundation"
> [  1408.902]    compiled for 1.18.3, module version = 1.0.0
> [  1408.902]    ABI class: X.Org Server Extension, version 9.0
> [  1408.902] (==) AIGLX enabled
> [  1408.902] (==) Matched nv as autoconfigured driver 0
> [  1408.902] (==) Assigned the driver to the xf86ConfigLayout
> [  1408.902] (II) LoadModule: "nv"
> [  1408.904] (II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.so
> [  1408.906] (II) Module nv: vendor="X.Org Foundation"
> [  1408.906]    compiled for 1.18.3, module version = 2.1.20
> [  1408.906]    Module class: X.Org Video Driver
> [  1408.906]    ABI class: X.Org Video Driver, version 20.0
> [  1408.906] (II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA
> TNT2,
>         Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
>         Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
>         GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
>         GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
>         Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
>         GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
>         GeForce4 420 Go 32M, GeForce4 460 Go, Quadro4 550 XGL,
>         GeForce4 MX (Mac), Quadro NVS, Quadro4 500 GoGL, GeForce4 410 Go
> 16M,
>         GeForce4 MX 440 with AGP8X, GeForce4 MX 440SE with AGP8X,
>         GeForce4 MX 420 with AGP8X, GeForce4 MX 4000, GeForce4 448 Go,
>         GeForce4 488 Go, Quadro4 580 XGL, GeForce4 MX with AGP8X (Mac),
>         Quadro4 NVS 280 SD, Quadro4 380 XGL, Quadro NVS 50 PCI,
>         GeForce4 448 Go, GeForce4 MX Integrated GPU, GeForce3,
>         GeForce3 Ti 200, GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600,
>         GeForce4 Ti 4400, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750
> XGL,
>         Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
>         GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
>         Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
>         GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
>         GeForce FX 5600 Ultra, GeForce FX 5600, GeForce FX 5600XT,
>         GeForce FX Go5600, GeForce FX Go5650, Quadro FX Go700,
>         GeForce FX 5200, GeForce FX 5200 Ultra, GeForce FX 5200,
>         GeForce FX 5200LE, GeForce FX Go5200, GeForce FX Go5250,
>         GeForce FX 5500, GeForce FX 5100, GeForce FX Go5200 32M/64M,
>         GeForce FX 5200 (Mac), Quadro NVS 55/280 PCI, Quadro FX 500/600
> PCI,
>         GeForce FX Go53xx Series, GeForce FX Go5100, GeForce FX 5900 Ultra,
>         GeForce FX 5900, GeForce FX 5900XT, GeForce FX 5950 Ultra,
>         GeForce FX 5900ZT, Quadro FX 3000, Quadro FX 700,
>         GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
>         GeForce FX 5700VE, GeForce FX Go5700, GeForce FX Go5700,
>         Quadro FX Go1000, Quadro FX 1100, GeForce 6800 Ultra, GeForce 6800,
>         GeForce 6800 LE, GeForce 6800 XE, GeForce 6800 XT, GeForce 6800 GT,
>         GeForce 6800 GT, GeForce 6800 GS, GeForce 6800 XT, Quadro FX 4000,
>         GeForce 6800 GS, GeForce 6800, GeForce 6800 LE, GeForce 6800 XT,
>         GeForce Go 6800, GeForce Go 6800 Ultra, Quadro FX Go1400,
>         Quadro FX 3450/4000 SDI, Quadro FX 1400, GeForce 6600 GT,
>         GeForce 6600, GeForce 6600 LE, GeForce 6600 VE, GeForce Go 6600,
>         GeForce 6610 XL, GeForce Go 6600 TE/6200 TE, GeForce 6700 XL,
>         GeForce Go 6600, GeForce Go 6600 GT, Quadro NVS 440, Quadro FX 550,
>         Quadro FX 550, Quadro FX 540, GeForce 6200, GeForce 6500,
>         GeForce 6200 TurboCache(TM), GeForce 6200SE TurboCache(TM),
>         GeForce 6200 LE, GeForce Go 6200, Quadro NVS 285, GeForce Go 6400,
>         GeForce Go 6200, GeForce Go 6400, GeForce 6250, GeForce 7100 GS,
>         GeForce 6800, GeForce 6800 LE, GeForce 6800 GT, GeForce 6800 XT,
>         GeForce 6200, GeForce 6200 A-LE, GeForce 7800 GTX, GeForce 7800
> GTX,
>         GeForce 7800 GT, GeForce 7800 GS, GeForce 7800 SLI, GeForce Go
> 7800,
>         GeForce Go 7800 GTX, Quadro FX 4500, GeForce 7350 LE,
>         GeForce 7300 LE, GeForce 7300 SE, GeForce Go 7200, GeForce Go 7300,
>         GeForce Go 7400, GeForce Go 7400 GS, Quadro NVS 110M,
>         Quadro NVS 120M, Quadro FX 350M, GeForce 7500 LE, Quadro FX 350,
>         GeForce 7300 GS, GeForce 7650 GS, GeForce 7600 GT, GeForce 7600 GS,
>         GeForce 7300 GT, GeForce 7600 LE, GeForce 7300 GT, GeForce Go 7700,
>         GeForce Go 7600, GeForce Go 7600 GT, Quadro NVS 300M,
>         GeForce Go 7900 SE, Quadro FX 550M, Quadro FX 560, GeForce 7900
> GTX,
>         GeForce 7900 GT, GeForce 7900 GS, GeForce 7950 GX2, GeForce 7950
> GX2,
>         GeForce 7950 GT, GeForce Go 7950 GTX, GeForce Go 7900 GS,
>         GeForce Go 7900 GTX, Quadro FX 2500M, Quadro FX 1500M,
>         Quadro FX 5500, Quadro FX 3500, Quadro FX 1500, Quadro FX 4500 X2,
>         GeForce 6150, GeForce 6150 LE, GeForce 6100, GeForce Go 6150,
>         Quadro NVS 210S / NVIDIA GeForce 6150LE, GeForce Go 6100,
>         GeForce 6150SE, GeForce 6100 nForce 405, GeForce 6100 nForce 400,
>         GeForce 6100 nForce 420, GeForce 7150M / nForce 630M,
>         GeForce 7000M / nForce 610M, GeForce 7050 PV / nForce 630a,
>         GeForce 7050 PV / nForce 630a, GeForce 7025 / nForce 630a,
>         GeForce 8800 GTX, GeForce 8800 GTS, GeForce 8800 Ultra,
>         Quadro FX 5600, Quadro FX 4600, GeForce 8600 GTS, GeForce 8600 GT,
>         GeForce 8600 GT, GeForce 8600 GS, GeForce 8400 GS, GeForce 9500M
> GS,
>         GeForce 8300 GS, GeForce 8600M GT, GeForce 9650M GS,
>         GeForce 8700M GT, Quadro FX 370, Quadro NVS 320M, Quadro FX 570M,
>         Quadro FX 1600M, Quadro FX 570, Quadro FX 1700, GeForce GT 330,
>         GeForce 8400 SE, GeForce 8500 GT, GeForce 8400 GS, GeForce 8300 GS,
>         GeForce 8400 GS, GeForce 8600M GS, GeForce 8400M GT,
>         GeForce 8400M GS, GeForce 8400M G, Quadro NVS 140M, Quadro NVS
> 130M,
>         Quadro NVS 135M, GeForce 9400 GT, Quadro FX 360M, GeForce 9300M G,
>         Quadro NVS 290, GeForce GTX 295, GeForce GTX 280, GeForce GTX 260,
>         GeForce GTX 285, GeForce GTX 275, GeForce GTX 260, GeForce GTX 295,
>         Quadroplex 2200 D2, Quadroplex 2200 S4, Quadro CX, Quadro FX 5800,
>         Quadro FX 4800, Quadro FX 3800, GeForce 8800 GTS 512,
>         GeForce 9800 GT, GeForce 8800 GT, GeForce GT 230, GeForce 9800 GX2,
>         GeForce 9800 GT, GeForce 8800 GS, GeForce GTS 240, GeForce 9800M
> GTX,
>         GeForce 8800M GTS, GeForce GTX 280M, GeForce 9800M GT,
>         GeForce 8800M GTX, GeForce 8800 GS, GeForce GTX 285M,
>         GeForce 9600 GSO, GeForce 8800 GT, GeForce 9800 GTX/9800 GTX+,
>         GeForce 9800 GTX+, GeForce 9800 GT, GeForce GTS 250,
>         GeForce 9800M GTX, GeForce GTX 260M, Quadro FX 4700 X2,
>         Quadro FX 3700, Quadro VX 200, Quadro FX 3600M, Quadro FX 2800M,
>         Quadro FX 3700M, Quadro FX 3800M, GeForce 9600 GT, GeForce 9600 GS,
>         GeForce 9600 GSO 512, GeForce GT 130, GeForce GT 140,
>         GeForce 9800M GTS, GeForce 9700M GTS, GeForce 9800M GS,
>         GeForce 9800M GTS, GeForce 9600 GT, GeForce 9600 GT,
>         GeForce GTS 160M, GeForce GTS 150M, GeForce 9600 GSO,
>         GeForce 9600 GT, Quadro FX 1800, Quadro FX 2700M, GeForce 9500 GT,
>         GeForce 9400 GT, GeForce 9500 GT, GeForce 9500 GS, GeForce 9500 GS,
>         GeForce GT 120, GeForce 9600M GT, GeForce 9600M GS, GeForce 9600M
> GT,
>         GeForce 9700M GT, GeForce 9500M G, GeForce 9650M GT, GeForce G
> 110M,
>         GeForce GT 130M, GeForce GT 120M, GeForce GT 220M, GeForce 9650 S,
>         Quadro FX 380, Quadro FX 580, Quadro FX 1700M, GeForce 9400 GT,
>         Quadro FX 770M, GeForce 9300 GE, GeForce 9300 GS, GeForce 8400,
>         GeForce 8400 SE, GeForce 8400 GS, GeForce 9300M GS, GeForce G100,
>         GeForce 9300 SE, GeForce 9200M GS, GeForce 9300M GS, Quadro NVS
> 150M,
>         Quadro NVS 160M, GeForce G 105M, GeForce G 103M, GeForce G105M,
>         Quadro NVS 420, Quadro FX 370 LP, Quadro NVS 450, Quadro FX 370M,
>         Quadro NVS 295, GeForce 9100M G, GeForce 8200M G, GeForce 9200,
>         GeForce 9100, GeForce 8300, GeForce 8200, nForce 730a, GeForce
> 9200,
>         nForce 980a/780a SLI, nForce 750a SLI, GeForce 8100 / nForce 720a,
>         GeForce 9400, GeForce 9400, GeForce 9400M G, GeForce 9400M,
>         GeForce 9300, ION, GeForce 9400M G, GeForce 9400, nForce 760i SLI,
>         GeForce 9400, GeForce 9300 / nForce 730i, GeForce 9200,
>         GeForce 9100M G, GeForce 8200M G, GeForce 9400M, GeForce 9200,
>         GeForce G102M, GeForce G102M, ION, ION, GeForce 9400, ION, ION LE,
>         ION LE, GeForce GT 220, GeForce 315, GeForce 210, GeForce GT 230M,
>         GeForce GT 330M, GeForce GT 230M, GeForce GT 330M, NVS 5100M,
>         GeForce GT 320M, GeForce GT 240M, GeForce GT 325M, Quadro FX 880M,
>         GeForce G210, GeForce 205, GeForce 310, ION, GeForce 210,
>         GeForce 310, GeForce 315, GeForce G105M, GeForce G105M, NVS 2100M,
>         NVS 3100M, GeForce 305M, ION, GeForce 310M, GeForce 305M,
>         GeForce 310M, GeForce 305M, GeForce G210M, GeForce 310M,
>         Quadro FX 380 LP, Quadro FX 380M, GeForce GT 330, GeForce GT 320,
>         GeForce GT 240, GeForce GT 340, GeForce GT 330, GeForce GTS 260M,
>         GeForce GTS 250M, GeForce 315, GeForce GT 335M, GeForce GTS 350M,
>         GeForce GTS 360M, Quadro FX 1800M
> [  1408.920] (--) NV: Found NVIDIA GeForce4 MX (Mac) at 00@00:16:0
> [  1408.921] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card
> support
> [  1408.921] (II) Loading sub module "int10"
> [  1408.921] (II) LoadModule: "int10"
> [  1408.925] (II) Loading /usr/X11R6/lib/modules/libint10.so
> [  1408.927] (II) Module int10: vendor="X.Org Foundation"
> [  1408.927]    compiled for 1.18.3, module version = 1.0.0
> [  1408.927]    ABI class: X.Org Video Driver, version 20.0
> [  1408.927] (--) NV(0): Chipset: "GeForce4 MX (Mac)"
> [  1408.928] (II) NV(0): Creating default Display subsection in Screen
> section
>         "Default Screen Section" for depth/fbbpp 24/32
> [  1408.928] (==) NV(0): Depth 24, (--) framebuffer bpp 32
> [  1408.928] (==) NV(0): RGB weight 888
> [  1408.928] (==) NV(0): Default visual is TrueColor
> [  1408.928] (II) Loading sub module "vgahw"
> [  1408.928] (II) LoadModule: "vgahw"
> [  1408.933] (II) Loading /usr/X11R6/lib/modules/libvgahw.so
> [  1408.935] (II) Module vgahw: vendor="X.Org Foundation"
> [  1408.935]    compiled for 1.18.3, module version = 0.1.0
> [  1408.935]    ABI class: X.Org Video Driver, version 20.0
> [  1408.936] (==) NV(0): Using HW cursor
> [  1408.936] (--) NV(0): Linear framebuffer at 0x94000000
> [  1408.936] (--) NV(0): MMIO registers at 0x91000000
> [  1408.937] (EE) NV(0): pci_device_map_range failed: Invalid argument
> [  1408.938] (EE) Segmentation fault at address 0x4
> [  1408.939] (EE)
> Fatal server error:
> [  1408.939] (EE) Caught signal 11 (Segmentation fault). Server aborting
> [  1408.940] (EE)
> [  1408.941] (EE)
> Please consult the The X.Org Foundation support
>          at http://wiki.x.org
>  for help.
> [  1408.942] (EE) Please also check the log file at "/var/log/Xorg.0.log"
> for additional information.
> [  1408.942] (EE)
> [  1408.946] (EE) Server terminated with error (1). Closing log file.
> #
>
>
> On Thu, Nov 17, 2016 at 1:54 PM, Ryan Northrup <[hidden email]>
> wrote:
>
>> On Thu, 17 Nov 2016 12:37:18 -0700
>> "Herminio Hernandez, Jr." <[hidden email]> wrote:
>>
>> > I am looking for some help. I have OpenBSD 6.0 install on my
>> > PowerBook G4. I installed the XFCE package however when I run
>> > 'startxfce4' Xorg fails to start.
>>
>> Does "startx" work?  Does letting XDM start on boot (and thus handle
>> the X11 startup) work?
>>
>> I can try reproducing on my own Powerbook G4 (which is currently
>> running 5.7 and can use an upgrade to 6.0 anyway), but...
>>
>> > # dmesg
>> >
>> > [...]
>> >
>> > pchb0 at pci0 dev 11 function 0 "Apple UniNorth AGP" rev 0x00
>> > agp at pchb0 not configured
>>
>> That's peculiar.  My own Powerbook seems to be lacking the "not
>> configured" line.  Maybe something changed there between 5.7 and 6.0?
>>
>> > vgafb0 at pci0 dev 16 function 0 "NVIDIA GeForce4 440 Go 64M" rev
>> > 0xa3, mmio wsdisplay0 at vgafb0 mux 1: console (std, vt100 emulation)
>> > wsdisplay0: screen 1-5 added (std, vt100 emulation)
>>
>> Looks like you've got a NVIDIA card, whereas mine has an ATI card
>> (relevant dmesg line: 'radeondrm0 at pci0 dev 16 function 0 "ATI Radeon
>> Mobility M10" rev 0x00').  That might be part of the problem (OpenBSD
>> and NVIDIA go together like milk and orange juice), and will certainly
>> affect my ability to help pin down your troubles.
>>
>> Regardless, your full Xorg.0.log might be useful for someone smarter at
>> X11 troubleshooting than me.
>>
>> --
>> Ryan S. Northrup
>> [hidden email]
>>
>
>