xhci isochronous transfers (was: Re: CVS: cvs.openbsd.org: src)

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

xhci isochronous transfers (was: Re: CVS: cvs.openbsd.org: src)

Christian Weisgerber
On 2019-03-15, Patrick Wildt <[hidden email]> wrote:

> CVSROOT: /cvs
> Module name: src
> Changes by: [hidden email] 2019/03/15 17:20:35
>
> Modified files:
> sys/dev/usb    : xhci.c
>
> Log message:
> Improve and enable isochronous transfers in xhci(4). [...]

Wow, that appears to be the crucial step many people have been
waiting for.  With this, I can now play sound through my USB audio
dongle connected to a "new" (~5-year old) machine:

usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
...
uaudio0 at uhub0 port 9 configuration 1 interface 1 "C-Media INC. USB Sound Device" rev 1.10/0.10 addr 4
uaudio0: class v1, full-speed, sync, channels: 2 play, 0 rec, 4 ctls audio1 at uaudio0

--
Christian "naddy" Weisgerber                          [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: xhci isochronous transfers (was: Re: CVS: cvs.openbsd.org: src)

Solene Rapenne
On Sat, Mar 16, 2019 at 12:38:09PM -0000, Christian Weisgerber wrote:

> On 2019-03-15, Patrick Wildt <[hidden email]> wrote:
>
> > CVSROOT: /cvs
> > Module name: src
> > Changes by: [hidden email] 2019/03/15 17:20:35
> >
> > Modified files:
> > sys/dev/usb    : xhci.c
> >
> > Log message:
> > Improve and enable isochronous transfers in xhci(4). [...]
>
> Wow, that appears to be the crucial step many people have been
> waiting for.  With this, I can now play sound through my USB audio
> dongle connected to a "new" (~5-year old) machine:
>
> usb0 at xhci0: USB revision 3.0
> uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
> ..
> uaudio0 at uhub0 port 9 configuration 1 interface 1 "C-Media INC. USB Sound Device" rev 1.10/0.10 addr 4
> uaudio0: class v1, full-speed, sync, channels: 2 play, 0 rec, 4 ctls audio1 at uaudio0
>
> --
> Christian "naddy" Weisgerber                          [hidden email]
>

On my T480 with usb3 only, I can now:

- use the built in webcam
- use an usb webcam
- use the usb phone tethering (lineageos) with urndis0

Thanks!

Reply | Threaded
Open this post in threaded view
|

Re: xhci isochronous transfers

Nam Nguyen

Thank you for all the work that went into this.

I am testing USB 3 on a Thinkpad x230i for my headphone DAC, an
ODAC-revB. I tested a Youtube video, and it does not begin playback. The
relevant error is at the end of the pasted dmesg. I also tested this on
a Thinkpad X1 Carbon Gen 4 to the same result, but that dmesg is omitted
for brevity.

I tried setting sndiod to use the DAC, as described in the FAQs
(https://www.openbsd.org/faq/faq13.html#confaudio). This procedure is
sufficient when I use a USB 2 port.
--8<---------------cut here---------------start------------->8---
# rcctl set sndiod flags -f rsnd/1
# rcctl restart sndiod
--8<---------------cut here---------------end--------------->8---

full dmesg:
--8<---------------cut here---------------start------------->8---
OpenBSD 6.5-beta (GENERIC.MP) #798: Sat Mar 16 10:12:15 MDT 2019
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 16872108032 (16090MB)
avail mem = 16350453760 (15593MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xdae9d000 (69 entries)
bios0: vendor LENOVO version "G2ET33WW (1.13 )" date 07/24/2012
bios0: LENOVO 2306CTO
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP SLIC TCPA SSDT SSDT SSDT HPET APIC MCFG ECDT FPDT ASF! UEFI UEFI POAT SSDT SSDT UEFI
acpi0: wakeup devices LID_(S4) SLPB(S3) IGBE(S4) EXP3(S4) XHCI(S3) EHC1(S3) EHC2(S3) HDEF(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i3-3120M CPU @ 2.50GHz, 2494.75 MHz, 06-3a-09
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,XSAVE,AVX,F16C,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.1.2, IBE
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Core(TM) i3-3120M CPU @ 2.50GHz, 2494.34 MHz, 06-3a-09
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,XSAVE,AVX,F16C,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 0, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0
acpimcfg0: addr 0xf8000000, bus 0-63
acpiec0 at acpi0
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEG_)
acpiprt2 at acpi0: bus 2 (EXP1)
acpiprt3 at acpi0: bus 3 (EXP2)
acpiprt4 at acpi0: bus -1 (EXP3)
acpicpu0 at acpi0: C2(350@80 mwait.1@0x20), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C2(350@80 mwait.1@0x20), C1(1000@1 mwait.1), PSS
acpipwrres0 at acpi0: PUBS, resource for XHCI, EHC1, EHC2
acpitz0 at acpi0: critical temperature is 103 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: SLPB
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
acpicmos0 at acpi0
tpm0 at acpi0: TPM_ addr 0xfed40000/0x5000: device 0x0000104a rev 0x4e
acpibat0 at acpi0: BAT0 model "45N1023" serial  4025 type LION oem "SANYO"
acpiac0 at acpi0: AC unit online
acpithinkpad0 at acpi0
"PNP0C14" at acpi0 not configured
"PNP0C14" at acpi0 not configured
acpidock0 at acpi0: GDCK not docked (0)
acpivideo0 at acpi0: VID_
acpivout at acpivideo0 not configured
acpivideo1 at acpi0: VID_
cpu0: Enhanced SpeedStep 2494 MHz: speeds: 2500, 2400, 2300, 2200, 2100, 2000, 1900, 1800, 1700, 1600, 1500, 1400, 1300, 1200 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 3G Host" rev 0x09
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics 4000" rev 0x09
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 1366x768, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
xhci0 at pci0 dev 20 function 0 "Intel 7 Series xHCI" rev 0x04: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
"Intel 7 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
em0 at pci0 dev 25 function 0 "Intel 82579LM" rev 0x04: msi, address 3c:97:0e:36:95:a5
ehci0 at pci0 dev 26 function 0 "Intel 7 Series USB" rev 0x04: apic 2 int 16
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 7 Series HD Audio" rev 0x04: msi
azalia0: codecs: Realtek ALC269, Intel/0x2806, using Realtek ALC269
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 7 Series PCIE" rev 0xc4: msi
pci1 at ppb0 bus 2
sdhc0 at pci1 dev 0 function 0 "Ricoh 5U822 SD/MMC" rev 0x07: apic 2 int 16
sdhc0: SDHC 3.0, 50 MHz base clock
sdmmc0 at sdhc0: 4-bit, sd high-speed, mmc high-speed, dma
ppb1 at pci0 dev 28 function 1 "Intel 7 Series PCIE" rev 0xc4: msi
pci2 at ppb1 bus 3
iwn0 at pci2 dev 0 function 0 "Intel Centrino Advanced-N 6205" rev 0x34: msi, MIMO 2T2R, MoW, address 60:67:20:42:68:52
ehci1 at pci0 dev 29 function 0 "Intel 7 Series USB" rev 0x04: apic 2 int 23
usb2 at ehci1: USB revision 2.0
uhub2 at usb2 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel QM77 LPC" rev 0x04
ahci0 at pci0 dev 31 function 2 "Intel 7 Series AHCI" rev 0x04: msi, AHCI 1.3
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, KINGSTON SV300S3, 505A> SCSI3 0/direct fixed naa.50026b723902475d
sd0: 114473MB, 512 bytes/sector, 234441648 sectors, thin
ichiic0 at pci0 dev 31 function 3 "Intel 7 Series SMBus" rev 0x04: apic 2 int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
spdmem1 at iic0 addr 0x51: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT
error: [drm:pid0:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
error: [drm:pid0:intel_pch_fifo_underrun_irq_handler] *ERROR* PCH transcoder A FIFO underrun
uhidev0 at uhub0 port 1 configuration 1 interface 0 "Yoyodyne Consulting ODAC-revB" rev 1.10/0.01 addr 2
uhidev0: iclass 3/0
uhid0 at uhidev0: input=19, output=28, feature=0
uaudio0 at uhub0 port 1 configuration 1 interface 3 "Yoyodyne Consulting ODAC-revB" rev 1.10/0.01 addr 2
uaudio0: class v1, full-speed, sync, channels: 2 play, 0 rec, 3 ctls
audio1 at uaudio0
uhub3 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uvideo0 at uhub3 port 6 configuration 1 interface 0 "Chicony Electronics Co., Ltd. Integrated Camera" rev 2.00/5.18 addr 3
video0 at uvideo0
uhub4 at uhub2 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2 0/direct fixed
sd1: 114470MB, 512 bytes/sector, 234435953 sectors
root on sd1a (cf7f15501dc7b7fb.a) swap on sd1b dump on sd1b
uaudio0: can't get iface handle
uaudio0: can't get iface handle
audio1: failed to start playback
uaudio0: can't get iface handle
--8<---------------cut here---------------end--------------->8---

Reply | Threaded
Open this post in threaded view
|

Re: xhci isochronous transfers

Nam Nguyen

> This procedure is sufficient when I use a USB 2 port.

I forgot to test USB 2 at the time of my original e-mail. There is
actually a regression and both USB 2 and USB 3 ports throw the same
error.

--8<---------------cut here---------------start------------->8---
uaudio0: can't get iface handle
uaudio0: can't get iface handle
audio1: failed to start playback
uaudio0: can't get iface handle
--8<---------------cut here---------------end--------------->8---

Reply | Threaded
Open this post in threaded view
|

Re: xhci isochronous transfers

Stefan Sperling-5
On Sat, Mar 16, 2019 at 06:58:55PM -0700, Nam Nguyen wrote:
>
> > This procedure is sufficient when I use a USB 2 port.
>
> I forgot to test USB 2 at the time of my original e-mail. There is
> actually a regression and both USB 2 and USB 3 ports throw the same
> error.

If it is now broken on ehci(4) as well, a more likely cause for this
regression is the new USB audio driver which was committed on March 12.

> --8<---------------cut here---------------start------------->8---
> uaudio0: can't get iface handle
> uaudio0: can't get iface handle
> audio1: failed to start playback
> uaudio0: can't get iface handle
> --8<---------------cut here---------------end--------------->8---
>

Reply | Threaded
Open this post in threaded view
|

Re: xhci isochronous transfers

Alexandre Ratchov-2
In reply to this post by Nam Nguyen
On Sat, Mar 16, 2019 at 06:58:55PM -0700, Nam Nguyen wrote:

>
> > This procedure is sufficient when I use a USB 2 port.
>
> I forgot to test USB 2 at the time of my original e-mail. There is
> actually a regression and both USB 2 and USB 3 ports throw the same
> error.
>
> --8<---------------cut here---------------start------------->8---
> uaudio0: can't get iface handle
> uaudio0: can't get iface handle
> audio1: failed to start playback
> uaudio0: can't get iface handle
> --8<---------------cut here---------------end--------------->8---

This this caused by the uaudio driver itself. Could you send me the
dmesg output of a kernel with UAUDIO_DEBUG defined?

Thanks in advance.

Reply | Threaded
Open this post in threaded view
|

Re: xhci isochronous transfers

Nam Nguyen
Alexandre Ratchov <[hidden email]> writes:

> On Sat, Mar 16, 2019 at 06:58:55PM -0700, Nam Nguyen wrote:
>>
>> > This procedure is sufficient when I use a USB 2 port.
>>
>> I forgot to test USB 2 at the time of my original e-mail. There is
>> actually a regression and both USB 2 and USB 3 ports throw the same
>> error.
>>
>> --8<---------------cut here---------------start------------->8---
>> uaudio0: can't get iface handle
>> uaudio0: can't get iface handle
>> audio1: failed to start playback
>> uaudio0: can't get iface handle
>> --8<---------------cut here---------------end--------------->8---
>
> This this caused by the uaudio driver itself. Could you send me the
> dmesg output of a kernel with UAUDIO_DEBUG defined?
>
> Thanks in advance.

This is with the DAC attached to USB 3.

--8<---------------cut here---------------start------------->8---
OpenBSD 6.5-beta (GENERIC) #0: Sun Mar 17 21:40:48 PDT 2019
    [hidden email]:/sys/arch/amd64/compile/GENERIC
real mem = 16872108032 (16090MB)
avail mem = 16350568448 (15593MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xdae9d000 (69 entries)
bios0: vendor LENOVO version "G2ET33WW (1.13 )" date 07/24/2012
bios0: LENOVO 2306CTO
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP SLIC TCPA SSDT SSDT SSDT HPET APIC MCFG ECDT FPDT ASF! UEFI UEFI POAT SSDT SSDT UEFI
acpi0: wakeup devices LID_(S4) SLPB(S3) IGBE(S4) EXP3(S4) XHCI(S3) EHC1(S3) EHC2(S3) HDEF(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i3-3120M CPU @ 2.50GHz, 2494.79 MHz, 06-3a-09
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,XSAVE,AVX,F16C,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.1.2, IBE
cpu at mainbus0: not configured
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0
acpimcfg0: addr 0xf8000000, bus 0-63
acpiec0 at acpi0
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEG_)
acpiprt2 at acpi0: bus 2 (EXP1)
acpiprt3 at acpi0: bus 3 (EXP2)
acpiprt4 at acpi0: bus -1 (EXP3)
acpicpu0 at acpi0: C2(350@80 mwait.1@0x20), C1(1000@1 mwait.1), PSS
acpipwrres0 at acpi0: PUBS, resource for XHCI, EHC1, EHC2
acpitz0 at acpi0: critical temperature is 103 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: SLPB
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
acpicmos0 at acpi0
tpm0 at acpi0: TPM_ addr 0xfed40000/0x5000: device 0x0000104a rev 0x4e
acpibat0 at acpi0: BAT0 model "45N1023" serial  4025 type LION oem "SANYO"
acpiac0 at acpi0: AC unit online
acpithinkpad0 at acpi0
"PNP0C14" at acpi0 not configured
"PNP0C14" at acpi0 not configured
acpidock0 at acpi0: GDCK not docked (0)
acpivideo0 at acpi0: VID_
acpivout at acpivideo0 not configured
acpivideo1 at acpi0: VID_
cpu0: Enhanced SpeedStep 2494 MHz: speeds: 2500, 2400, 2300, 2200, 2100, 2000, 1900, 1800, 1700, 1600, 1500, 1400, 1300, 1200 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 3G Host" rev 0x09
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics 4000" rev 0x09
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 1366x768, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
xhci0 at pci0 dev 20 function 0 "Intel 7 Series xHCI" rev 0x04: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
"Intel 7 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
em0 at pci0 dev 25 function 0 "Intel 82579LM" rev 0x04: msi, address 3c:97:0e:36:95:a5
ehci0 at pci0 dev 26 function 0 "Intel 7 Series USB" rev 0x04: apic 2 int 16
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 7 Series HD Audio" rev 0x04: msi
azalia0: codecs: Realtek ALC269, Intel/0x2806, using Realtek ALC269
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 7 Series PCIE" rev 0xc4: msi
pci1 at ppb0 bus 2
sdhc0 at pci1 dev 0 function 0 "Ricoh 5U822 SD/MMC" rev 0x07: apic 2 int 16
sdhc0: SDHC 3.0, 50 MHz base clock
sdmmc0 at sdhc0: 4-bit, sd high-speed, mmc high-speed, dma
ppb1 at pci0 dev 28 function 1 "Intel 7 Series PCIE" rev 0xc4: msi
pci2 at ppb1 bus 3
iwn0 at pci2 dev 0 function 0 "Intel Centrino Advanced-N 6205" rev 0x34: msi, MIMO 2T2R, MoW, address 60:67:20:42:68:52
ehci1 at pci0 dev 29 function 0 "Intel 7 Series USB" rev 0x04: apic 2 int 23
usb2 at ehci1: USB revision 2.0
uhub2 at usb2 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel QM77 LPC" rev 0x04
ahci0 at pci0 dev 31 function 2 "Intel 7 Series AHCI" rev 0x04: msi, AHCI 1.3
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, KINGSTON SV300S3, 505A> SCSI3 0/direct fixed naa.50026b723902475d
sd0: 114473MB, 512 bytes/sector, 234441648 sectors, thin
ichiic0 at pci0 dev 31 function 3 "Intel 7 Series SMBus" rev 0x04: apic 2 int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
spdmem1 at iic0 addr 0x51: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT
error: [drm:pid0:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
error: [drm:pid0:intel_pch_fifo_underrun_irq_handler] *ERROR* PCH transcoder A FIFO underrun
uhidev0 at uhub0 port 1 configuration 1 interface 0 "Yoyodyne Consulting ODAC-revB" rev 1.10/0.01 addr 2
uhidev0: iclass 3/0
uhid0 at uhidev0: input=19, output=28, feature=0
uaudio0 at uhub0 port 1 configuration 1 interface 3 "Yoyodyne Consulting ODAC-revB" rev 1.10/0.01 addr 2
uaudio_process_conf: skipped iface
uaudio_process_ac: ifnum = 1, 159 bytes to processs
uaudio_process_header: version 0x100
06: in, nch = 2, term = 0x101, assoc = 0
09: feature id = 6, nch = 2, size = 1
        mute[-1]
uaudio_req: type = 0xa1, req = 0x82, val = 0x201, index = 0x901, size = 2
uaudio_req: type = 0xa1, req = 0x83, val = 0x201, index = 0x901, size = 2
uaudio_req: type = 0xa1, req = 0x84, val = 0x201, index = 0x901, size = 2
[-14080:0]/128 (14081 vals)
        level[0]
uaudio_req: type = 0xa1, req = 0x82, val = 0x202, index = 0x901, size = 2
uaudio_req: type = 0xa1, req = 0x83, val = 0x202, index = 0x901, size = 2
uaudio_req: type = 0xa1, req = 0x84, val = 0x202, index = 0x901, size = 2
[-14080:0]/128 (14081 vals)
        level[1]
02: out, id = 9, nch = 2, term = 0x301, assoc = 0
uaudio0: units list:
06: input <play>, dest = 09 <play>
09: feature <play>, src = 06 <play>, dst = 02 <spkr>, cls = 1
02: output <spkr>, source = 09 <play>
uaudio0: mixer controls:
09: play.level[0]
09: play.level[1]
09: play.mute
uaudio_process_conf: stop altnum 0
uaudio_process_as_ep: addr = 0x3, adapt/data, maxpktsz = 400, ival = 1
uaudio_process_as_ep: addr = 0x3, adapt/data, maxpktsz = 600, ival = 1
00: <record>, next = -1, prev = -1, class = -1
01: <outputs>, next = -1, prev = -1, class = -1
02: <inputs>, next = -1, prev = -1, class = -1
uaudio_req: type = 0xa1, req = 0x81, val = 0x201, index = 0x901, size = 2
uaudio_req: type = 0xa1, req = 0x81, val = 0x202, index = 0x901, size = 2
03: <play>, next = -1, prev = -1, class = 1, nch = 2, delta = 1, val = 255 255
uaudio_req: type = 0xa1, req = 0x81, val = 0x100, index = 0x901, size = 1
04: <play_mute>, next = -1, prev = -1, class = 1, members: off(=0) on(=1), val = 0
5 controls
alts:
mode = play, ifnum = 3, altnum = 2, addr = 0x3, maxpkt = 600, sync = 0x0, nch = 2, fmt = s24le3, rates: 32000 44100 48000 88200 96000
mode = play, ifnum = 3, altnum = 1, addr = 0x3, maxpkt = 400, sync = 0x0, nch = 2, fmt = s16le2, rates: 32000 44100 48000 88200 96000
parameters:
pchan = 2, s24le3, rchan = 0, s0le0, rates: 32000 44100 48000 88200 96000
pchan = 2, s16le2, rchan = 0, s0le0, rates: 32000 44100 48000 88200 96000
uaudio0: class v1, full-speed, sync, channels: 2 play, 0 rec, 3 ctls
audio1 at uaudio0
uhub3 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uvideo0 at uhub3 port 6 configuration 1 interface 0 "Chicony Electronics Co., Ltd. Integrated Camera" rev 2.00/5.18 addr 3
video0 at uvideo0
uhub4 at uhub2 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2 0/direct fixed
sd1: 114470MB, 512 bytes/sector, 234435953 sectors
root on sd1a (cf7f15501dc7b7fb.a) swap on sd1b dump on sd1b
uaudio_set_params: rate 48000 -> 48000 (index 8)
uaudio_set_params: rate = 48000
uaudio_set_params: rate 48000 -> 48000 (index 8)
uaudio_set_params: rate = 48000
uaudio_stream_open: play: blksz = 3840, rate = 48000, fps = 1000
uaudio_stream_open: spf = 0xf00000 in [0xef1000:0xf0f000]
uaudio_stream_open: nframes_max = 21, nframes_mask = 0, maxpkt = 196
uaudio_stream_open: safe_blksz = 3872, nxfers = 2
uaudio0: can't get iface handle
uaudio0: can't get iface handle
audio1: failed to start playback
uaudio0: can't get iface handle
--8<---------------cut here---------------end--------------->8---