xenodm Radeon driver error on AMD GX-420CA SoC + Radeon HD 8400E

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

xenodm Radeon driver error on AMD GX-420CA SoC + Radeon HD 8400E

Denis Lapshin-2
OpenBSD6.4 -stable with X.org from -current
AMD GX-420CA SoC + Radeon HD 8400E

While running xenodm from /etc/rc.d/xenodm (boot) getting some errors:

initializing kernel modesetting (KABINI 0x1002:0x9831 0x1022:0x1234).
drm:pid0:radeon_uvd_init *ERROR* radeon_uvd: Can't load firmware
"radeon/BONAIRE_uvd.bin"
drm:pid0:radeon_vce_init *ERROR* radeon_vce: Can't load firmware
"radeon/BONAIRE_vce.bin"
drm:pid0:cik_startup *ERROR* VCE init error (-22).
error: [drm:pid0:cik_ring_test] *ERROR* radeon: ring 2 test failed
(scratch(0x3010C)=0xCAFEDEAD)
radeondrm0: 1920x1200, 32bpp
wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)

Reply | Threaded
Open this post in threaded view
|

Re: xenodm Radeon driver error on AMD GX-420CA SoC + Radeon HD 8400E

Denis Lapshin-2
/etc/firmware/radeon/ contains bonaire_uvd.bin & bonaire_vce.bin

by soft linking them to BONAIRE_uvd.bin & BONAIRE_vce.bin don't bring
any positive results. The error is persistent.

It seems radeonsi should be fixed for firmware paths and names.

Thank you for attention to a problem.

On 12/13/2018 3:08 PM, Denis wrote:

> OpenBSD6.4 -stable with X.org from -current
> AMD GX-420CA SoC + Radeon HD 8400E
>
> While running xenodm from /etc/rc.d/xenodm (boot) getting some errors:
>
> initializing kernel modesetting (KABINI 0x1002:0x9831 0x1022:0x1234).
> drm:pid0:radeon_uvd_init *ERROR* radeon_uvd: Can't load firmware
> "radeon/BONAIRE_uvd.bin"
> drm:pid0:radeon_vce_init *ERROR* radeon_vce: Can't load firmware
> "radeon/BONAIRE_vce.bin"
> drm:pid0:cik_startup *ERROR* VCE init error (-22).
> error: [drm:pid0:cik_ring_test] *ERROR* radeon: ring 2 test failed
> (scratch(0x3010C)=0xCAFEDEAD)
> radeondrm0: 1920x1200, 32bpp
> wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using wskbd0
> wsdisplay0: screen 1-5 added (std, vt100 emulation)
>

Reply | Threaded
Open this post in threaded view
|

Re: xenodm Radeon driver error on AMD GX-420CA SoC + Radeon HD 8400E

Jonathan Gray-11
On Sat, Dec 15, 2018 at 10:34:00AM +0300, Denis wrote:
> /etc/firmware/radeon/ contains bonaire_uvd.bin & bonaire_vce.bin
>
> by soft linking them to BONAIRE_uvd.bin & BONAIRE_vce.bin don't bring
> any positive results. The error is persistent.
>
> It seems radeonsi should be fixed for firmware paths and names.
>
> Thank you for attention to a problem.

$ pkg_info -E /etc/firmware/radeon/BONAIRE_vce.bin  
/etc/firmware/radeon/BONAIRE_vce.bin: radeondrm-firmware-20170119

since at least 6.3

>
> On 12/13/2018 3:08 PM, Denis wrote:
> > OpenBSD6.4 -stable with X.org from -current
> > AMD GX-420CA SoC + Radeon HD 8400E

Mixing -stable and -current like that is completely unsupported.

Reply | Threaded
Open this post in threaded view
|

Re: xenodm Radeon driver error on AMD GX-420CA SoC + Radeon HD 8400E

Denis Lapshin-2
After deleting /etc/firmware and rerun firmware update no absent
firmware errors present.

But

error: [drm:pid0:cik_ring_test] *ERROR* radeon: ring 2 test failed
(scratch(0x3010C)=0xCAFEDEAD)
radeondrm0: 1920x1200, 32bpp

is still there.

Can it be because of unsupported video card or what?

On 12/15/2018 11:56 AM, Jonathan Gray wrote:

> On Sat, Dec 15, 2018 at 10:34:00AM +0300, Denis wrote:
>> /etc/firmware/radeon/ contains bonaire_uvd.bin & bonaire_vce.bin
>>
>> by soft linking them to BONAIRE_uvd.bin & BONAIRE_vce.bin don't bring
>> any positive results. The error is persistent.
>>
>> It seems radeonsi should be fixed for firmware paths and names.
>>
>> Thank you for attention to a problem.
>
> $ pkg_info -E /etc/firmware/radeon/BONAIRE_vce.bin  
> /etc/firmware/radeon/BONAIRE_vce.bin: radeondrm-firmware-20170119
>
> since at least 6.3
>
>>
>> On 12/13/2018 3:08 PM, Denis wrote:
>>> OpenBSD6.4 -stable with X.org from -current
>>> AMD GX-420CA SoC + Radeon HD 8400E
>
> Mixing -stable and -current like that is completely unsupported.
>