xedit dumps core on startup (sparc64)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

xedit dumps core on startup (sparc64)

Jasper Lievisse Adriaanse
Hello,

everytime I start /usr/X11R6/bin/xedit on my sparc64, it seg. faults.
Most of the time I get to see the window for less than a second, before
it disapears.
Here's the backtrace:

$ xeditSegmentation fault (core dumped)
$ gdb /usr/X11R6/bin/xedit xedit.core
GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain
conditions. Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "sparc64-unknown-openbsd3.9"...(no debugging
symbols found)

Core was generated by `xedit'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXp.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libXp.so.9.0
Reading symbols from /usr/X11R6/lib/libXaw.so.11.0...done.
Loaded symbols for /usr/X11R6/lib/libXaw.so.11.0
Reading symbols from /usr/X11R6/lib/libXmu.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libXmu.so.9.0
Reading symbols from /usr/X11R6/lib/libXt.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libXt.so.9.0
Reading symbols from /usr/X11R6/lib/libSM.so.8.0...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.8.0
Reading symbols from /usr/X11R6/lib/libICE.so.8.1...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.8.1
Reading symbols from /usr/X11R6/lib/libXpm.so.7.0...done.
Loaded symbols for /usr/X11R6/lib/libXpm.so.7.0
Reading symbols from /usr/X11R6/lib/libXext.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.9.0
Reading symbols from /usr/X11R6/lib/libX11.so.9.0...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.9.0
Reading symbols from /usr/lib/libm.so.2.2...done.
Loaded symbols for /usr/lib/libm.so.2.2
Reading symbols from /usr/lib/libc.so.39.0...done.
Loaded symbols for /usr/lib/libc.so.39.0
Reading symbols from /usr/libexec/ld.so...done.
Loaded symbols for /usr/libexec/ld.so
Reading symbols from /usr/X11R6/lib/libXcursor.so.3.0...done.
Loaded symbols for /usr/X11R6/lib/libXcursor.so.3.0
Reading symbols from /usr/X11R6/lib/libXrender.so.4.1...done.
Loaded symbols for /usr/X11R6/lib/libXrender.so.4.1
Reading symbols from /usr/X11R6/lib/libXfixes.so.4.0...done.
Loaded symbols for /usr/X11R6/lib/libXfixes.so.4.0
#0  0x000000004fdd73fc in InsertCursor (w=0x43cfbc00, x=2, y=16,
state=XawisOn) at MultiSink.c:512
512    c = ((wchar_t *)block.ptr)[0];
(gdb) bt
#0  0x000000004fdd73fc in InsertCursor (w=0x43cfbc00, x=2, y=16,
state=XawisOn) at MultiSink.c:512
#1  0x000000004fdfb0f8 in XawTextSinkInsertCursor (w=0x43cfbc00, x=2, y=16,
state=XawisOn) at TextSink.c:669
#2  0x000000004fdf09c4 in InsertCursor (w=0x40474400, state=XawisOn) at
Text.c:1056
#3  0x000000004fdf9524 in _XawTextExecuteUpdate (ctx=0x40474400) at
Text.c:3608
#4  0x000000004fdf8614 in XawTextExpose (w=0x40474400,
event=0xffffffffffff2360, region=0x0) at Text.c:3291
#5  0x0000000040730b74 in XtDispatchEventToWidget () from
/usr/X11R6/lib/libXt.so.9.0
#6  0x00000000407315b8 in _XtDefaultDispatcher () from
/usr/X11R6/lib/libXt.so.9.0
#7  0x00000000407318e8 in XtDispatchEvent () from /usr/X11R6/lib/libXt.so.9.0
#8  0x0000000040731ecc in XtAppMainLoop () from /usr/X11R6/lib/libXt.so.9.0
#9  0x0000000000105650 in ?? ()
#10 0x0000000000105650 in ?? ()
Previous frame identical to this frame (corrupt stack?)
(gdb) q


This is on a regular Sun Blade 100:

console is keyboard/display
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2006 OpenBSD. All rights reserved.
http://www.OpenBSD.org

OpenBSD 3.9-current (GENERIC) #0: Tue Apr  4 18:13:25 CEST 2006
    [hidden email]:/usr/src/sys/arch/sparc64/compile/GENERIC
total memory = 536870912
avail memory = 478650368
using 3276 buffers containing 26836992 bytes of memory
bootpath: /pci@1f,0/ide@d,0/disk@0,0
mainbus0 (root): Sun Blade 100 (UltraSPARC-IIe)
cpu0 at mainbus0: SUNW,UltraSPARC-IIe @ 502 MHz, version 0 FPU
cpu0: physical 32K instruction (32 b/l), 16K data (32 b/l), 1024K external
(64 b/l) psycho0 at mainbus0
pci108e,a001: impl 0, version 0: ign 7c0 bus range 0 to 1; PCI bus 0
DVMA map: c0000000 to e0000000
IOTDB: 26a8000 to 2728000
pci0 at psycho0
ebus0 at pci0 dev 12 function 0 "Sun PCIO Ebus2 (US III)" rev 0x01
"flashprom" at ebus0 addr 0-fffff not configured
clock1 at ebus0 addr 0-1fff: mk48t59: hostid 83080f9f
ebus_attach: idprom: incomplete
ebus1 at pci0 dev 7 function 0 "Acer Labs M1533 ISA" rev 0x00
"dma" at ebus1 addr 0-ffff ipl 42 not configured
"power" at ebus1 addr 800-82f ipl 32 not configured
com0 at ebus1 addr 3f8-3ff ipl 43: ns16550a, 16 byte fifo
com1 at ebus1 addr 2e8-2ef ipl 43: ns16550a, 16 byte fifo
gem0 at pci0 dev 12 function 1 "Sun ERI Ether" rev 0x01: ivec 3006, address
00:03:ba:08:0f:9f ukphy0 at gem0 phy 1: Generic IEEE 802.3u media
interface, rev. 1: OUI 0x0010dd, model 0x0002 "Sun FireWire" rev 0x01 at
pci0 dev 12 function 2 not configured ohci0 at pci0 dev 12 function 3 "Sun
USB" rev 0x01: ivec 24, version 1.0, legacy support usb0 at ohci0: USB
revision 1.0 uhub0 at usb0
uhub0: Sun OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
alipm0 at pci0 dev 3 function 0 "Acer Labs M7101 Power" rev 0x00: 223KHz
clock, disabling to avoid hardware failure autri0 at pci0 dev 8 function 0
"Acer Labs M5451 Audio" rev 0x01: ivec 23 ac97: codec id 0x41445348 (Analog
Devices AD1881A) ac97: codec features headphone, Analog Devices Phat Stereo
audio0 at autri0
midi0 at autri0: <4DWAVE MIDI UART>
pciide0 at pci0 dev 13 function 0 "Acer Labs M5229 UDMA IDE" rev 0xc3: DMA,
channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide0: using ivec 180c for native-PCI interrupt wd0 at pciide0 channel 0
drive 0: <ST340014A> wd0: 16-sector PIO, LBA, 38166MB, 78165360 sectors
atapiscsi0 at pciide0 channel 0 drive 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <COMPAQ, CRD-8322B, 1.03> SCSI0 5/cdrom
removable wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
cd0(pciide0:0:1): using PIO mode 4, DMA mode 2
pciide0: channel 1 disabled (no drives)
ppb0 at pci0 dev 5 function 0 "DEC 21152 PCI-PCI" rev 0x03
pci1 at ppb0 bus 1
vgafb0 at pci0 dev 19 function 0 "ATI Rage XL" rev 0x27
wsdisplay0 at vgafb0: console (std, sun emulation)
pcons at mainbus0 not configured
No counter-timer -- using %tick at 502MHz as system clock.
uhidev0 at uhub0 port 2 configuration 1 interface 0
uhidev0: Sun Microsystems Type 6 Mouse, rev 1.00/1.02, addr 2, iclass 3/1
ums0 at uhidev0: 3 buttons
wsmouse0 at ums0
uhidev1 at uhub0 port 4 configuration 1 interface 0
uhidev1: Sun Microsystems Type 6 Keyboard, rev 1.00/1.02, addr 3, iclass 3/1
ukbd0 at uhidev1: 8 modifier keys, 6 key codes
wskbd0 at ukbd0: console keyboard, using wsdisplay0
root on wd0a
rootdev=0xc00 rrootdev=0x1a00 rawdev=0x1a02


Cheers,
Jasper

[demime 1.01d removed an attachment of type application/pgp-signature]