x11/xfce4 - conflict between required modules.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

x11/xfce4 - conflict between required modules.

4625
xfce4$ make install
===> x11/xfce4/exo
===> x11/xfce4/gtk-xfce-engine
===> x11/xfce4/libxfce4menu
===> x11/xfce4/libxfce4util
===> x11/xfce4/libxfcegui4
===> x11/xfce4/mousepad
===> x11/xfce4/notification-daemon-xfce
===>  Installing notification-daemon-xfce-0.3.7p6 from /usr/ports/packages/i386/all/
Adding notification-daemon-xfce-0.3.7p6
===> x11/xfce4/orage
===> x11/xfce4/ristretto
===> x11/xfce4/terminal
===> x11/xfce4/thunar
===> x11/xfce4/thunar-media-tags
===> x11/xfce4/thunar-thumbnailers
===> x11/xfce4/xfce-utils
===> x11/xfce4/xfce4-appfinder
===> x11/xfce4/xfce4-battery
===> x11/xfce4/xfce4-clipman
===> x11/xfce4/xfce4-dict
===> x11/xfce4/xfce4-diskperf
===> x11/xfce4/xfce4-fsguard
===> x11/xfce4/xfce4-genmon
===> x11/xfce4/xfce4-icon-theme
===> x11/xfce4/xfce4-mailwatch
===> x11/xfce4/xfce4-mixer
===> x11/xfce4/xfce4-modemlights
===> x11/xfce4/xfce4-mpc
===> x11/xfce4/xfce4-netload
===> x11/xfce4/xfce4-notes
===> x11/xfce4/xfce4-notifyd
===>  Installing xfce4-notifyd-0.1.0 from /usr/ports/packages/i386/all/
/usr/sbin/pkg_add: xfce4-notifyd-0.1.0:Fatal error
Can't install xfce4-notifyd-0.1.0 because of conflicts (notification-daemon-xfce-0.3.7p6)
*** Error code 1

Stop in /usr/ports/x11/xfce4/xfce4-notifyd (line 1474 of /usr/ports/infrastructure/mk/bsd.port.mk).
===> Exiting x11/xfce4/xfce4-notifyd with an error
*** Error code 1

Stop in /usr/ports/x11/xfce4 (line 129 of /usr/ports/infrastructure/mk/bsd.port.subdir.mk).

OpenBSD 4.6 (200910240023) #0: Sat Oct 24 01:20:25 2009
    root@localhost:/sys/arch/i386/compile/200910240023

--
/Buzzer         () кампания ascii ribbon - против писем в html формате
                /\ www.asciiribbon.org   - против проприетарных вложений

Reply | Threaded
Open this post in threaded view
|

Re: x11/xfce4 - conflict between required modules.

Landry Breuil-3
On Wed, Dec 02, 2009 at 06:57:18PM -0800, Buzzer wrote:

> xfce4$ make install
> ===> x11/xfce4/exo
> ===> x11/xfce4/gtk-xfce-engine
> ===> x11/xfce4/libxfce4menu
> ===> x11/xfce4/libxfce4util
> ===> x11/xfce4/libxfcegui4
> ===> x11/xfce4/mousepad
> ===> x11/xfce4/notification-daemon-xfce
> ===>  Installing notification-daemon-xfce-0.3.7p6 from /usr/ports/packages/i386/all/
> Adding notification-daemon-xfce-0.3.7p6
> ===> x11/xfce4/orage
> ===> x11/xfce4/ristretto
> ===> x11/xfce4/terminal
> ===> x11/xfce4/thunar
> ===> x11/xfce4/thunar-media-tags
> ===> x11/xfce4/thunar-thumbnailers
> ===> x11/xfce4/xfce-utils
> ===> x11/xfce4/xfce4-appfinder
> ===> x11/xfce4/xfce4-battery
> ===> x11/xfce4/xfce4-clipman
> ===> x11/xfce4/xfce4-dict
> ===> x11/xfce4/xfce4-diskperf
> ===> x11/xfce4/xfce4-fsguard
> ===> x11/xfce4/xfce4-genmon
> ===> x11/xfce4/xfce4-icon-theme
> ===> x11/xfce4/xfce4-mailwatch
> ===> x11/xfce4/xfce4-mixer
> ===> x11/xfce4/xfce4-modemlights
> ===> x11/xfce4/xfce4-mpc
> ===> x11/xfce4/xfce4-netload
> ===> x11/xfce4/xfce4-notes
> ===> x11/xfce4/xfce4-notifyd
> ===>  Installing xfce4-notifyd-0.1.0 from /usr/ports/packages/i386/all/
> /usr/sbin/pkg_add: xfce4-notifyd-0.1.0:Fatal error
> Can't install xfce4-notifyd-0.1.0 because of conflicts (notification-daemon-xfce-0.3.7p6)

Where is the problem ? xfce4-notifyd and notification-daemon-xfce
provide the same functionality (and install same files, hence
@conflict), you just have to make a choice between both.

And no, they are not 'modules required by xfce' just because they're in
x11/xfce4.

Landry