x11/gtk+4: colord on aarch64

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

x11/gtk+4: colord on aarch64

Peter Hessler
Pretty straightforward addition to the dependency chain, as
x11/gtk+4,-cloudprint also depends on colord being installed.

if this is OK, then I'll sort the list before committing it

OK?

Index: x11/gtk+4/Makefile
===================================================================
RCS file: /cvs/ports/x11/gtk+4/Makefile,v
retrieving revision 1.14
diff -u -p -u -p -r1.14 Makefile
--- x11/gtk+4/Makefile 12 Jul 2019 20:51:12 -0000 1.14
+++ x11/gtk+4/Makefile 12 Aug 2019 21:28:53 -0000
@@ -128,7 +128,7 @@ CONFIGURE_ARGS= -Dwayland-backend=false
 .if ${MACHINE_ARCH} == "i386" || ${MACHINE_ARCH} == "amd64" || \
     ${MACHINE_ARCH} == "alpha" || ${MACHINE_ARCH} == "hppa" || \
     ${MACHINE_ARCH} == "powerpc" || ${MACHINE_ARCH} == "sparc64" || \
-    ${MACHINE_ARCH} == "mips64"
+    ${MACHINE_ARCH} == "mips64" || ${MACHINE_ARCH} == "aarch64"
 LIB_DEPENDS-cups += graphics/colord
 WANTLIB-cups += colord
 .else




--
It is easier to write an incorrect program than understand a correct one.

Reply | Threaded
Open this post in threaded view
|

Re: x11/gtk+4: colord on aarch64

Antoine Jacoutot-7
On Tue, Aug 13, 2019 at 08:11:50AM +0200, Peter Hessler wrote:
> Pretty straightforward addition to the dependency chain, as
> x11/gtk+4,-cloudprint also depends on colord being installed.

x11/gtk+4,-cloudprint does not depend at all on colord.
I assume you meant x11/gtk+4,-cups.

> if this is OK, then I'll sort the list before committing it
>
> OK?

Yes

> Index: x11/gtk+4/Makefile
> ===================================================================
> RCS file: /cvs/ports/x11/gtk+4/Makefile,v
> retrieving revision 1.14
> diff -u -p -u -p -r1.14 Makefile
> --- x11/gtk+4/Makefile 12 Jul 2019 20:51:12 -0000 1.14
> +++ x11/gtk+4/Makefile 12 Aug 2019 21:28:53 -0000
> @@ -128,7 +128,7 @@ CONFIGURE_ARGS= -Dwayland-backend=false
>  .if ${MACHINE_ARCH} == "i386" || ${MACHINE_ARCH} == "amd64" || \
>      ${MACHINE_ARCH} == "alpha" || ${MACHINE_ARCH} == "hppa" || \
>      ${MACHINE_ARCH} == "powerpc" || ${MACHINE_ARCH} == "sparc64" || \
> -    ${MACHINE_ARCH} == "mips64"
> +    ${MACHINE_ARCH} == "mips64" || ${MACHINE_ARCH} == "aarch64"
>  LIB_DEPENDS-cups += graphics/colord
>  WANTLIB-cups += colord
>  .else
>
>
>
>
> --
> It is easier to write an incorrect program than understand a correct one.
>

--
Antoine