wi problem on 3.8/sparc64

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

wi problem on 3.8/sparc64

Jim Faulkner
Hello,

I have a Sun Ultra-1 running 3.8/sparc64.  I have a Netgear MA401RA
plugged into an STP sbus PCMCIA bridge which is plugged into the machine.
I've attached the output of dmesg.

Here is my /etc/hostname.wi0 (its all one line in the file, and no
that's not my real nwkey):
!ifconfig wi0 inet 192.168.1.2 netmask 255.255.255.0 broadcast
192.168.1.255 nwid jimbo nwkey persist:0x92b0320d76101234da619ef5bc
mediaopt hostap

Everything works fine normally, however I'd like to disable encryption
occasionally so guests can use my wireless network easily.  When I run
this command:
/sbin/ifconfig wi0 -nwkey

OpenBSD hangs for 20 or 30 seconds, then finally gives me a shell prompt
again.  It will then alternate between hanging and responsiveness until it
is rebooted.  I get these errors in /var/log/messages:
Dec 16 10:03:11 leech /bsd: wi0: init failed
Dec 16 10:03:12 leech /bsd: wi0: failed to allocate 1594 bytes on NIC
Dec 16 10:03:12 leech /bsd: wi0: tx buffer allocation failed
Dec 16 10:03:12 leech /bsd: wi0: failed to allocate 1594 bytes on NIC
Dec 16 10:03:12 leech /bsd: wi0: mgmt. buffer allocation failed
Dec 16 10:04:13 leech /bsd: wi0: wi_cmd failed with 60
Dec 16 10:05:14 leech /bsd: wi0: wi_cmd failed with 60

The "wi_cmd failed with 60" messages will continue to appear every minute
or so until reboot.

I would have this problem under 3.7 once in a while, however it happens
every time under 3.8.

Please let me know if you need any other information.

thanks,
Jim Faulkner
console is keyboard/display

Copyright (c) 1982, 1986, 1989, 1991, 1993

        The Regents of the University of California.  All rights reserved.

Copyright (c) 1995-2005 OpenBSD. All rights reserved.  http://www.OpenBSD.org



OpenBSD 3.8 (GENERIC) #607: Sat Sep 10 16:03:59 MDT 2005

    [hidden email]:/usr/src/sys/arch/sparc64/compile/GENERIC

total memory = 469762048

avail memory = 418807808

using 2867 buffers containing 23486464 bytes of memory

bootpath: /sbus@1f,0/SUNW,hme@e,8c00000

mainbus0 (root): Sun Ultra 1 UPA/SBus (UltraSPARC 167MHz)

cpu0 at mainbus0: SUNW,UltraSPARC @ 166.996 MHz, version 0 FPU

cpu0: physical 32K instruction (32 b/l), 16K data (32 b/l), 512K external (64 b/l)

timer0 at mainbus0 addr 0xfffc7c00 irq vectors 7f0 and 7f1

sbus0 at mainbus0 addr 0xfffcc000: clock = 25 MHz

STC0 on /mainbus enabled

DVMA map: ff800000 to ffffe000

IOTDB: 21fa000 to 21fc000

audiocs0 at sbus0 slot 13 offset 0xc000000 vector 24 ipl 8

audio0 at audiocs0

auxio0 at sbus0 slot 15 offset 0x1900000

flashprom at sbus0 slot 15 offset 0x0 not configured

fdc0 at sbus0 slot 15 offset 0x1400000 vector 29 ipl 11: no drives attached

clock1 at sbus0 slot 15 offset 0x1200000: mk48t59: hostid 8088ebd5

zs0 at sbus0 slot 15 offset 0x1100000 vector 28 ipl 12 softpri 6

zstty0 at zs0 channel 0

zstty1 at zs0 channel 1

zs1 at sbus0 slot 15 offset 0x1000000 vector 28 ipl 12 softpri 6

zskbd0 at zs1 channel 0: layout 33

wskbd0 at zskbd0: console keyboard

zstty2 at zs1 channel 1: mouse

uperf0 at sbus0 slot 15 offset 0x1300000: model SUNW,sc-up (0/0) ports 3

SUNW,pll at sbus0 slot 15 offset 0x1304000 not configured

esp0 at sbus0 slot 14 offset 0x8800000 vector 20 ipl 3: dma rev fas

esp0: FAS366/HME, 40MHz, SCSI ID 7

scsibus0 at esp0: 8 targets

hme0 at sbus0 slot 14 offset 0x8c00000 vector 21 ipl 6: address 08:00:20:88:eb:d5

nsphy0 at hme0 phy 1: DP83840 10/100 PHY, rev. 0

SUNW,bpp at sbus0 slot 14 offset 0xc800000 vector 22 ipl 2 not configured

hme1 at sbus0 slot 0 offset 0x8c00000 vector 4 ipl 6: address 08:00:20:88:eb:d5

nsphy1 at hme1 phy 1: DP83840 10/100 PHY, rev. 1

stp0 at sbus0 slot 1 offset 0x0 vector 4 ipl 2 vector 7 ipl 2: rev 1

pcmcia0 at stp0 socket 0

pcmcia1 at stp0 socket 1

wi0 at pcmcia1 function 0 "NETGEAR MA401RA Wireless PC, Card, ISL37300P" port 0x0/64

wi0: PRISM2.5 ISL3873 (0x800c), Firmware 1.1.1 (primary), 1.8.0 (station), address 00:09:5b:0f:03:40

creator0 at mainbus0 addr 0xfec00000: Creator3D, model SUNW,501-2633, dac 10

wsdisplay0 at creator0: console (std, sun emulation), using wskbd0

pcons at mainbus0 not configured

nfs_boot: using network interface 'hme0'

nfs_boot: client_addr=192.168.0.2

nfs_boot: server_addr=192.168.0.83 hostname=leech

root on 192.168.0.83:/home/leech

WARNING: clock gained 36 days -- CHECK AND RESET THE DATE!

nfs_boot: bootparam get swap: 60

WARNING: no swap

swapmount: no device