uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) in unregister_acpi_notifier()

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) in unregister_acpi_notifier()

Sebastien Marie-3
Hi,

After upgrading to latest snapshot on amd64, I have uvm_fault().

initializing kernel modesetting (RV610 0x1002:0x94C3 0x1028:0x0402 0x00).
drm:pid0:r600_init *ERROR* Expecting atombios for R600 GPU
drm:pid0:radeondrm_attachhook *ERROR* Fatal error during GPU init
uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) -> e
fatal page fault in supervisor mode
trap type 6 code 0 rip ffffffff81663953 cs 8 rflags 10217 cr2  8 cpl 0 rsp ffffffff82291da0
gsbase 0xffffffff81f2fff0  kgsbase 0x0
panic: trap type 6, code=0, pc=ffffffff81663953
Starting stack trace...
panic() at panic+0x11b
kerntrap(ffffffff82291cf0) at kerntrap+0x114
alltraps_kern_meltdown(6,0,ffffffff81f2cbf8,0,0,ffff80000007f000) at alltraps_kern_meltdown+0x7b
unregister_acpi_notifier(ffff800000081b28) at unregister_acpi_notifier+0x23
radeondrm_detach_kms(ffff80000007f000,0) at radeondrm_detach_kms+0x3b
config_detach(ffff80000007f000,0) at config_detach+0x152
radeondrm_attachhook(ffff80000007f000) at radeondrm_attachhook+0x2ea
config_process_deferred_mountroot() at config_process_deferred_mountroot+0x6b
main(0) at main+0x745
end trace frame: 0x0, count: 248
End of stack trace.

I bisected the kernel to get the proper commit which introduced the problem.

It is 6a77e6ad1ad5d153b53aaa6987055f6163280aee (https://github.com/openbsd/src/commit/6a77e6ad1ad5d153b53aaa6987055f6163280aee)

        Implement a few Linux compat ACPI interfaces and enable the ACPI support
        code in radeon(4) and amdgpu(4).

        ok jsg@

Please note that the drm error is expected for this hardware, but
previously the fallback path worked well.

Disabling radeondrm* in UKC is a working workaround.

Full dmesg below.

Thanks.
--
Sebastien Marie


OpenBSD 6.6-beta (GENERIC.MP) #28: Tue Aug 27 09:35:21 CEST 2019
    [hidden email]:/sys/arch/amd64/compile/GENERIC.MP
real mem = 4141871104 (3949MB)
avail mem = 4003672064 (3818MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.5 @ 0xf0450 (80 entries)
bios0: vendor Dell Inc. version "A22" date 06/11/2012
bios0: Dell Inc. OptiPlex 755
acpi0 at bios0
acpi0: TCPA checksum error: ACPI 3.0
acpi0: sleep states S0 S1 S3 S4 S5
acpi0: tables DSDT FACP SSDT APIC BOOT ASF! MCFG HPET TCPA DMAR SLIC SSDT SSDT SSDT
acpi0: wakeup devices VBTN(S4) PCI0(S5) PCI4(S5) PCI2(S5) PCI3(S5) PCI1(S5) PCI5(S5) PCI6(S5) USB0(S3) USB1(S3) USB2(S3) USB3(S3) USB4(S3) USB5(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz, 2660.38 MHz, 06-0f-0b
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,NXE,LONG,LAHF,PERF,MELTDOWN
cpu0: 4MB 64b/line 16-way L2 cache
mtrr: Pentium Pro MTRR support, 7 var ranges, 88 fixed ranges
cpu0: apic clock running at 332MHz
cpu1 at mainbus0: apid 1 (application processor)
TSC skew=-8
cpu1: Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz, 2660.00 MHz, 06-0f-0b
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,NXE,LONG,LAHF,PERF,MELTDOWN
cpu1: 4MB 64b/line 16-way L2 cache
ioapic0 at mainbus0: apid 8 pa 0xfec00000, version 20, 24 pins, remapped
acpimcfg0 at acpi0
acpimcfg0: addr 0xe0000000, bus 0-255
acpimcfg0: addr 0xffffff0000000000, bus 255-255
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 3 (PCI4)
acpiprt2 at acpi0: bus 2 (PCI2)
acpiprt3 at acpi0: bus -1 (PCI3)
acpiprt4 at acpi0: bus 1 (PCI1)
acpiprt5 at acpi0: bus -1 (PCI5)
acpiprt6 at acpi0: bus -1 (PCI6)
acpicpu0 at acpi0: C1(@1 halt!), PSS
acpicpu1 at acpi0: C1(@1 halt!), PSS
acpibtn0 at acpi0: VBTN
acpipci0 at acpi0 PCI0: _OSC failed
acpicmos0 at acpi0
cpu0: Enhanced SpeedStep 2660 MHz: speeds: 2667, 2333, 2000 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel 82Q35 Host" rev 0x02
ppb0 at pci0 dev 1 function 0 "Intel 82Q35 PCIE" rev 0x02: msi
pci1 at ppb0 bus 1
radeondrm0 at pci1 dev 0 function 0 "ATI Radeon HD 2400 Pro" rev 0x00
drm0 at radeondrm0
radeondrm0: msi
"Intel 82Q35 HECI" rev 0x02 at pci0 dev 3 function 0 not configured
pciide0 at pci0 dev 3 function 2 "Intel 82Q35 PT IDER" rev 0x02: DMA (unsupported), channel 0 wired to native-PCI, channel 1 wired to native-PCI
pciide0: using apic 8 int 18 for native-PCI interrupt
pciide0: channel 0 ignored (not responding; disabled or no drives?)
pciide0: channel 1 ignored (not responding; disabled or no drives?)
puc0 at pci0 dev 3 function 3 "Intel 82Q35 KT" rev 0x02: ports: 16 com
com4 at puc0 port 0 apic 8 int 17: ns16550a, 16 byte fifo
com4: probed fifo depth: 0 bytes
em0 at pci0 dev 25 function 0 "Intel ICH9 IGP AMT" rev 0x02: msi, address 00:1e:4f:f4:e8:50
uhci0 at pci0 dev 26 function 0 "Intel 82801I USB" rev 0x02: apic 8 int 16
uhci1 at pci0 dev 26 function 1 "Intel 82801I USB" rev 0x02: apic 8 int 17
ehci0 at pci0 dev 26 function 7 "Intel 82801I USB" rev 0x02: apic 8 int 22
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 82801I HD Audio" rev 0x02: msi
azalia0: codecs: Analog Devices AD1984
audio0 at azalia0
ppb1 at pci0 dev 28 function 0 "Intel 82801I PCIE" rev 0x02: msi
pci2 at ppb1 bus 2
uhci2 at pci0 dev 29 function 0 "Intel 82801I USB" rev 0x02: apic 8 int 23
uhci3 at pci0 dev 29 function 1 "Intel 82801I USB" rev 0x02: apic 8 int 17
uhci4 at pci0 dev 29 function 2 "Intel 82801I USB" rev 0x02: apic 8 int 18
ehci1 at pci0 dev 29 function 7 "Intel 82801I USB" rev 0x02: apic 8 int 23
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb2 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0x92
pci3 at ppb2 bus 3
sis0 at pci3 dev 2 function 0 "NS DP83815" rev 0x00, DP83816A: apic 8 int 18, address 00:0f:b5:42:59:c0
nsphyter0 at sis0 phy 0: DP83815 10/100 PHY, rev. 1
pcib0 at pci0 dev 31 function 0 "Intel 82801IO LPC" rev 0x02
ahci0 at pci0 dev 31 function 2 "Intel 82801I AHCI" rev 0x02: msi, AHCI 1.2
ahci0: port 0: 3.0Gb/s
ahci0: port 1: 1.5Gb/s
ahci0: PHY offline on port 2
ahci0: PHY offline on port 3
ahci0: PHY offline on port 5
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, ST3160815AS, 3.AD> SCSI3 0/direct fixed t10.ATA_ST3160815AS_9RX7BKBD
sd0: 152587MB, 512 bytes/sector, 312500000 sectors
cd0 at scsibus1 targ 1 lun 0: <HL-DT-ST, DVD+-RW GSA-H73N, B103> ATAPI 5/cdrom removable
ichiic0 at pci0 dev 31 function 3 "Intel 82801I SMBus" rev 0x02: apic 8 int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 1GB DDR2 SDRAM non-parity PC2-5300CL5
spdmem1 at iic0 addr 0x51: 1GB DDR2 SDRAM non-parity PC2-5300CL5
spdmem2 at iic0 addr 0x52: 1GB DDR2 SDRAM non-parity PC2-5300CL5
spdmem3 at iic0 addr 0x53: 1GB DDR2 SDRAM non-parity PC2-5300CL5
usb2 at uhci0: USB revision 1.0
uhub2 at usb2 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci1: USB revision 1.0
uhub3 at usb3 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci2: USB revision 1.0
uhub4 at usb4 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb5 at uhci3: USB revision 1.0
uhub5 at usb5 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb6 at uhci4: USB revision 1.0
uhub6 at usb6 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
vmm0 at mainbus0: VMX (using slow L1TF mitigation)
uhidev0 at uhub2 port 1 configuration 1 interface 0 "Dell Dell USB Keyboard" rev 1.10/3.52 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
uhidev1 at uhub2 port 2 configuration 1 interface 0 "Dell Dell Premium USB Optical Mouse" rev 2.00/29.00 addr 3
uhidev1: iclass 3/1
ums0 at uhidev1: 5 buttons, Z and W dir
wsmouse0 at ums0 mux 0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (f1307242b412e6c8.a) swap on sd0b dump on sd0b
initializing kernel modesetting (RV610 0x1002:0x94C3 0x1028:0x0402 0x00).
drm:pid0:r600_init *ERROR* Expecting atombios for R600 GPU
drm:pid0:radeondrm_attachhook *ERROR* Fatal error during GPU init
uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) -> e
fatal page fault in supervisor mode
trap type 6 code 0 rip ffffffff81663953 cs 8 rflags 10217 cr2  8 cpl 0 rsp ffffffff82291da0
gsbase 0xffffffff81f2fff0  kgsbase 0x0
panic: trap type 6, code=0, pc=ffffffff81663953
Starting stack trace...
panic() at panic+0x11b
kerntrap(ffffffff82291cf0) at kerntrap+0x114
alltraps_kern_meltdown(6,0,ffffffff81f2cbf8,0,0,ffff80000007f000) at alltraps_kern_meltdown+0x7b
unregister_acpi_notifier(ffff800000081b28) at unregister_acpi_notifier+0x23
radeondrm_detach_kms(ffff80000007f000,0) at radeondrm_detach_kms+0x3b
config_detach(ffff80000007f000,0) at config_detach+0x152
radeondrm_attachhook(ffff80000007f000) at radeondrm_attachhook+0x2ea
config_process_deferred_mountroot() at config_process_deferred_mountroot+0x6b
main(0) at main+0x745
end trace frame: 0x0, count: 248
End of stack trace.
syncing disks... done

dumping to dev 4,1 offset 280707
dump ...

Reply | Threaded
Open this post in threaded view
|

Re: uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) in unregister_acpi_notifier()

Mark Kettenis
> Date: Tue, 27 Aug 2019 10:04:56 +0200
> From: Sebastien Marie <[hidden email]>
>
> Hi,
>
> After upgrading to latest snapshot on amd64, I have uvm_fault().
>
> initializing kernel modesetting (RV610 0x1002:0x94C3 0x1028:0x0402 0x00).
> drm:pid0:r600_init *ERROR* Expecting atombios for R600 GPU
> drm:pid0:radeondrm_attachhook *ERROR* Fatal error during GPU init
> uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) -> e
> fatal page fault in supervisor mode
> trap type 6 code 0 rip ffffffff81663953 cs 8 rflags 10217 cr2  8 cpl 0 rsp ffffffff82291da0
> gsbase 0xffffffff81f2fff0  kgsbase 0x0
> panic: trap type 6, code=0, pc=ffffffff81663953
> Starting stack trace...
> panic() at panic+0x11b
> kerntrap(ffffffff82291cf0) at kerntrap+0x114
> alltraps_kern_meltdown(6,0,ffffffff81f2cbf8,0,0,ffff80000007f000) at alltraps_kern_meltdown+0x7b
> unregister_acpi_notifier(ffff800000081b28) at unregister_acpi_notifier+0x23
> radeondrm_detach_kms(ffff80000007f000,0) at radeondrm_detach_kms+0x3b
> config_detach(ffff80000007f000,0) at config_detach+0x152
> radeondrm_attachhook(ffff80000007f000) at radeondrm_attachhook+0x2ea
> config_process_deferred_mountroot() at config_process_deferred_mountroot+0x6b
> main(0) at main+0x745
> end trace frame: 0x0, count: 248
> End of stack trace.
>
> I bisected the kernel to get the proper commit which introduced the problem.
>
> It is 6a77e6ad1ad5d153b53aaa6987055f6163280aee (https://github.com/openbsd/src/commit/6a77e6ad1ad5d153b53aaa6987055f6163280aee)
>
> Implement a few Linux compat ACPI interfaces and enable the ACPI support
> code in radeon(4) and amdgpu(4).
>
> ok jsg@
>
> Please note that the drm error is expected for this hardware, but
> previously the fallback path worked well.
>
> Disabling radeondrm* in UKC is a working workaround.

I'll have a look.  Obviously that error path wasn't tested...

> OpenBSD 6.6-beta (GENERIC.MP) #28: Tue Aug 27 09:35:21 CEST 2019
>     [hidden email]:/sys/arch/amd64/compile/GENERIC.MP
> real mem = 4141871104 (3949MB)
> avail mem = 4003672064 (3818MB)
> mpath0 at root
> scsibus0 at mpath0: 256 targets
> mainbus0 at root
> bios0 at mainbus0: SMBIOS rev. 2.5 @ 0xf0450 (80 entries)
> bios0: vendor Dell Inc. version "A22" date 06/11/2012
> bios0: Dell Inc. OptiPlex 755
> acpi0 at bios0
> acpi0: TCPA checksum error: ACPI 3.0
> acpi0: sleep states S0 S1 S3 S4 S5
> acpi0: tables DSDT FACP SSDT APIC BOOT ASF! MCFG HPET TCPA DMAR SLIC SSDT SSDT SSDT
> acpi0: wakeup devices VBTN(S4) PCI0(S5) PCI4(S5) PCI2(S5) PCI3(S5) PCI1(S5) PCI5(S5) PCI6(S5) USB0(S3) USB1(S3) USB2(S3) USB3(S3) USB4(S3) USB5(S3)
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz, 2660.38 MHz, 06-0f-0b
> cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,NXE,LONG,LAHF,PERF,MELTDOWN
> cpu0: 4MB 64b/line 16-way L2 cache
> mtrr: Pentium Pro MTRR support, 7 var ranges, 88 fixed ranges
> cpu0: apic clock running at 332MHz
> cpu1 at mainbus0: apid 1 (application processor)
> TSC skew=-8
> cpu1: Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz, 2660.00 MHz, 06-0f-0b
> cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,NXE,LONG,LAHF,PERF,MELTDOWN
> cpu1: 4MB 64b/line 16-way L2 cache
> ioapic0 at mainbus0: apid 8 pa 0xfec00000, version 20, 24 pins, remapped
> acpimcfg0 at acpi0
> acpimcfg0: addr 0xe0000000, bus 0-255
> acpimcfg0: addr 0xffffff0000000000, bus 255-255
> acpihpet0 at acpi0: 14318179 Hz
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus 3 (PCI4)
> acpiprt2 at acpi0: bus 2 (PCI2)
> acpiprt3 at acpi0: bus -1 (PCI3)
> acpiprt4 at acpi0: bus 1 (PCI1)
> acpiprt5 at acpi0: bus -1 (PCI5)
> acpiprt6 at acpi0: bus -1 (PCI6)
> acpicpu0 at acpi0: C1(@1 halt!), PSS
> acpicpu1 at acpi0: C1(@1 halt!), PSS
> acpibtn0 at acpi0: VBTN
> acpipci0 at acpi0 PCI0: _OSC failed
> acpicmos0 at acpi0
> cpu0: Enhanced SpeedStep 2660 MHz: speeds: 2667, 2333, 2000 MHz
> pci0 at mainbus0 bus 0
> pchb0 at pci0 dev 0 function 0 "Intel 82Q35 Host" rev 0x02
> ppb0 at pci0 dev 1 function 0 "Intel 82Q35 PCIE" rev 0x02: msi
> pci1 at ppb0 bus 1
> radeondrm0 at pci1 dev 0 function 0 "ATI Radeon HD 2400 Pro" rev 0x00
> drm0 at radeondrm0
> radeondrm0: msi
> "Intel 82Q35 HECI" rev 0x02 at pci0 dev 3 function 0 not configured
> pciide0 at pci0 dev 3 function 2 "Intel 82Q35 PT IDER" rev 0x02: DMA (unsupported), channel 0 wired to native-PCI, channel 1 wired to native-PCI
> pciide0: using apic 8 int 18 for native-PCI interrupt
> pciide0: channel 0 ignored (not responding; disabled or no drives?)
> pciide0: channel 1 ignored (not responding; disabled or no drives?)
> puc0 at pci0 dev 3 function 3 "Intel 82Q35 KT" rev 0x02: ports: 16 com
> com4 at puc0 port 0 apic 8 int 17: ns16550a, 16 byte fifo
> com4: probed fifo depth: 0 bytes
> em0 at pci0 dev 25 function 0 "Intel ICH9 IGP AMT" rev 0x02: msi, address 00:1e:4f:f4:e8:50
> uhci0 at pci0 dev 26 function 0 "Intel 82801I USB" rev 0x02: apic 8 int 16
> uhci1 at pci0 dev 26 function 1 "Intel 82801I USB" rev 0x02: apic 8 int 17
> ehci0 at pci0 dev 26 function 7 "Intel 82801I USB" rev 0x02: apic 8 int 22
> usb0 at ehci0: USB revision 2.0
> uhub0 at usb0 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
> azalia0 at pci0 dev 27 function 0 "Intel 82801I HD Audio" rev 0x02: msi
> azalia0: codecs: Analog Devices AD1984
> audio0 at azalia0
> ppb1 at pci0 dev 28 function 0 "Intel 82801I PCIE" rev 0x02: msi
> pci2 at ppb1 bus 2
> uhci2 at pci0 dev 29 function 0 "Intel 82801I USB" rev 0x02: apic 8 int 23
> uhci3 at pci0 dev 29 function 1 "Intel 82801I USB" rev 0x02: apic 8 int 17
> uhci4 at pci0 dev 29 function 2 "Intel 82801I USB" rev 0x02: apic 8 int 18
> ehci1 at pci0 dev 29 function 7 "Intel 82801I USB" rev 0x02: apic 8 int 23
> usb1 at ehci1: USB revision 2.0
> uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
> ppb2 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0x92
> pci3 at ppb2 bus 3
> sis0 at pci3 dev 2 function 0 "NS DP83815" rev 0x00, DP83816A: apic 8 int 18, address 00:0f:b5:42:59:c0
> nsphyter0 at sis0 phy 0: DP83815 10/100 PHY, rev. 1
> pcib0 at pci0 dev 31 function 0 "Intel 82801IO LPC" rev 0x02
> ahci0 at pci0 dev 31 function 2 "Intel 82801I AHCI" rev 0x02: msi, AHCI 1.2
> ahci0: port 0: 3.0Gb/s
> ahci0: port 1: 1.5Gb/s
> ahci0: PHY offline on port 2
> ahci0: PHY offline on port 3
> ahci0: PHY offline on port 5
> scsibus1 at ahci0: 32 targets
> sd0 at scsibus1 targ 0 lun 0: <ATA, ST3160815AS, 3.AD> SCSI3 0/direct fixed t10.ATA_ST3160815AS_9RX7BKBD
> sd0: 152587MB, 512 bytes/sector, 312500000 sectors
> cd0 at scsibus1 targ 1 lun 0: <HL-DT-ST, DVD+-RW GSA-H73N, B103> ATAPI 5/cdrom removable
> ichiic0 at pci0 dev 31 function 3 "Intel 82801I SMBus" rev 0x02: apic 8 int 18
> iic0 at ichiic0
> spdmem0 at iic0 addr 0x50: 1GB DDR2 SDRAM non-parity PC2-5300CL5
> spdmem1 at iic0 addr 0x51: 1GB DDR2 SDRAM non-parity PC2-5300CL5
> spdmem2 at iic0 addr 0x52: 1GB DDR2 SDRAM non-parity PC2-5300CL5
> spdmem3 at iic0 addr 0x53: 1GB DDR2 SDRAM non-parity PC2-5300CL5
> usb2 at uhci0: USB revision 1.0
> uhub2 at usb2 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb3 at uhci1: USB revision 1.0
> uhub3 at usb3 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb4 at uhci2: USB revision 1.0
> uhub4 at usb4 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb5 at uhci3: USB revision 1.0
> uhub5 at usb5 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb6 at uhci4: USB revision 1.0
> uhub6 at usb6 configuration 1 interface 0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> isa0 at pcib0
> isadma0 at isa0
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> pckbc0 at isa0 port 0x60/5 irq 1 irq 12
> pckbd0 at pckbc0 (kbd slot)
> wskbd0 at pckbd0: console keyboard
> pcppi0 at isa0 port 0x61
> spkr0 at pcppi0
> lpt0 at isa0 port 0x378/4 irq 7
> vmm0 at mainbus0: VMX (using slow L1TF mitigation)
> uhidev0 at uhub2 port 1 configuration 1 interface 0 "Dell Dell USB Keyboard" rev 1.10/3.52 addr 2
> uhidev0: iclass 3/1
> ukbd0 at uhidev0: 8 variable keys, 6 key codes
> wskbd1 at ukbd0 mux 1
> uhidev1 at uhub2 port 2 configuration 1 interface 0 "Dell Dell Premium USB Optical Mouse" rev 2.00/29.00 addr 3
> uhidev1: iclass 3/1
> ums0 at uhidev1: 5 buttons, Z and W dir
> wsmouse0 at ums0 mux 0
> vscsi0 at root
> scsibus2 at vscsi0: 256 targets
> softraid0 at root
> scsibus3 at softraid0: 256 targets
> root on sd0a (f1307242b412e6c8.a) swap on sd0b dump on sd0b
> initializing kernel modesetting (RV610 0x1002:0x94C3 0x1028:0x0402 0x00).
> drm:pid0:r600_init *ERROR* Expecting atombios for R600 GPU
> drm:pid0:radeondrm_attachhook *ERROR* Fatal error during GPU init
> uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) -> e
> fatal page fault in supervisor mode
> trap type 6 code 0 rip ffffffff81663953 cs 8 rflags 10217 cr2  8 cpl 0 rsp ffffffff82291da0
> gsbase 0xffffffff81f2fff0  kgsbase 0x0
> panic: trap type 6, code=0, pc=ffffffff81663953
> Starting stack trace...
> panic() at panic+0x11b
> kerntrap(ffffffff82291cf0) at kerntrap+0x114
> alltraps_kern_meltdown(6,0,ffffffff81f2cbf8,0,0,ffff80000007f000) at alltraps_kern_meltdown+0x7b
> unregister_acpi_notifier(ffff800000081b28) at unregister_acpi_notifier+0x23
> radeondrm_detach_kms(ffff80000007f000,0) at radeondrm_detach_kms+0x3b
> config_detach(ffff80000007f000,0) at config_detach+0x152
> radeondrm_attachhook(ffff80000007f000) at radeondrm_attachhook+0x2ea
> config_process_deferred_mountroot() at config_process_deferred_mountroot+0x6b
> main(0) at main+0x745
> end trace frame: 0x0, count: 248
> End of stack trace.
> syncing disks... done
>
> dumping to dev 4,1 offset 280707
> dump ...
>
>

Reply | Threaded
Open this post in threaded view
|

Re: uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) in unregister_acpi_notifier()

Mark Kettenis
In reply to this post by Sebastien Marie-3
Wonder if it is trying to remove a notifier that hasn't been
registered.  Seems the Linux code would allow that.

Can you try the diff below?


Index: dev/pci/drm/drm_linux.c
===================================================================
RCS file: /cvs/src/sys/dev/pci/drm/drm_linux.c,v
retrieving revision 1.48
diff -u -p -r1.48 drm_linux.c
--- dev/pci/drm/drm_linux.c 18 Aug 2019 13:11:47 -0000 1.48
+++ dev/pci/drm/drm_linux.c 27 Aug 2019 09:12:10 -0000
@@ -1120,8 +1120,17 @@ register_acpi_notifier(struct notifier_b
 int
 unregister_acpi_notifier(struct notifier_block *nb)
 {
- SLIST_REMOVE(&drm_linux_acpi_notify_list, nb, notifier_block, link);
- return 0;
+ struct notifier_block *tmp;
+
+ SLIST_FOREACH(tmp, &drm_linux_acpi_notify_list, link) {
+ if (tmp == nb) {
+ SLIST_REMOVE(&drm_linux_acpi_notify_list, nb,
+    notifier_block, link);
+ return 0;
+ }
+ }
+
+ return -ENOENT;
 }
 
 const char *

Reply | Threaded
Open this post in threaded view
|

Re: uvm_fault(0xffffffff81fb9030, 0x8, 0, 1) in unregister_acpi_notifier()

Sebastien Marie-3
On Tue, Aug 27, 2019 at 11:13:24AM +0200, Mark Kettenis wrote:
> Wonder if it is trying to remove a notifier that hasn't been
> registered.  Seems the Linux code would allow that.
>
> Can you try the diff below?

the host boot fine with it. the error path is taken, and the system
continues to boot.

the diff itself looks fine. so ok semarie@

Thanks.
--
Sebastien Marie

> Index: dev/pci/drm/drm_linux.c
> ===================================================================
> RCS file: /cvs/src/sys/dev/pci/drm/drm_linux.c,v
> retrieving revision 1.48
> diff -u -p -r1.48 drm_linux.c
> --- dev/pci/drm/drm_linux.c 18 Aug 2019 13:11:47 -0000 1.48
> +++ dev/pci/drm/drm_linux.c 27 Aug 2019 09:12:10 -0000
> @@ -1120,8 +1120,17 @@ register_acpi_notifier(struct notifier_b
>  int
>  unregister_acpi_notifier(struct notifier_block *nb)
>  {
> - SLIST_REMOVE(&drm_linux_acpi_notify_list, nb, notifier_block, link);
> - return 0;
> + struct notifier_block *tmp;
> +
> + SLIST_FOREACH(tmp, &drm_linux_acpi_notify_list, link) {
> + if (tmp == nb) {
> + SLIST_REMOVE(&drm_linux_acpi_notify_list, nb,
> +    notifier_block, link);
> + return 0;
> + }
> + }
> +
> + return -ENOENT;
>  }
>  
>  const char *