Quantcast

usb hdd странным образом "пропадает"...

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

usb hdd странным образом "пропадает"...

Anton Maksimenkov-2
Замечено такое вот поведение USB'шного HDD винта (он 3Q называется).

Есть железка, у неё есть только этот винт в качестве накопителя.
boot показывает что-то типа hd0+
Ядро грузиться с него, конфигурит устройства... и раз-на-раз бывает
что не находит сам винт (с которого он грузится, другого нету).
Загрузка соответственно останавливается на
root device:

Выкл-выкл, возможно неск-ко раз, и... находит и всё работает до выключения.
После выключения-включения опять лотерея.
Ставил винт на другие железки, эффект ровно тот же самый. Другой винт
не пробовал.

Может ктонить на эту тему что-то сказать?
--
antonvm
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: usb hdd странным образом "пропадает"...

Alexey Vatchenko-2

У меня тоже есть железка Soekris. Я подключал IDE диски и они на ней
винты тоже не живут. Через какое-то время винт начинает клацать и...
становится недоступным, а после перезагрузки не видится. Потом может на
какое-то время опять появиться. Вобщем, выживает только CF.
Поскольку USB HDD = это карман + IDE/SATA диск, то думаю, что корень
проблемы один ;)

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: usb hdd странным образом "пропадает"...

Dmitry Bogdan-4
In reply to this post by Anton Maksimenkov-2


2011/10/13 Anton Maksimenkov <[hidden email]>


Может ктонить на эту тему что-то сказать?
--
antonvm
у меня телепон филипс (платформа китайская) примерно так же отдаёт хранилище (встроенное и sd карту) по USB: диск как устройство появляется, после монтирования при чтении файлов read error (ls показывает пустой раздел), есть возможность даже заморозить систему при попытке сделать перезагрузку с подвисшим umount.
голову не грею - это китайское фуфло. хотя с линуксом проблем нет.

может юсб контроллеры в устройствах (телефоне и вашей коробочке с мостом sata-usb) такие дурные.
Loading...