upgrading FVWM to 2.4

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

upgrading FVWM to 2.4

badeguruji
Hello,

I figure that i will need to give some runtime arguments to following commands for upgrading my fvwm installation. as per README from fvwm package...

can someone tell me what is the right value for PREFIX and EPREFIX?

 Installation directories:
  --prefix=PREFIX         install architecture-independent files in PREFIX
                          [/usr/local]
  --exec-prefix=EPREFIX   install architecture-dependent files in EPREFIX
                          [PREFIX]

By default, `make install' will install all the files in
`/usr/local/bin', `/usr/local/lib' etc.  You can specify
an installation prefix other than `/usr/local' using `--prefix',
for instance `--prefix=$HOME'.

For better control, use the options below.

Fine tuning of the installation directories:
  --bindir=DIR           user executables [EPREFIX/bin]
  --sbindir=DIR          system admin executables [EPREFIX/sbin]
  --libexecdir=DIR       program executables [EPREFIX/libexec]
  --sysconfdir=DIR       read-only single-machine data [PREFIX/etc]
  --sharedstatedir=DIR   modifiable architecture-independent data [PREFIX/com]
  --localstatedir=DIR    modifiable single-machine data [PREFIX/var]
  --libdir=DIR           object code libraries [EPREFIX/lib]
  --includedir=DIR       C header files [PREFIX/include]
  --oldincludedir=DIR    C header files for non-gcc [/usr/include]
  --datarootdir=DIR      read-only arch.-independent data root [PREFIX/share]
  --datadir=DIR          read-only architecture-independent data [DATAROOTDIR]
  --infodir=DIR          info documentation [DATAROOTDIR/info]
  --localedir=DIR        locale-dependent data [DATAROOTDIR/locale]
  --mandir=DIR           man documentation [DATAROOTDIR/man]
  --docdir=DIR           documentation root [DATAROOTDIR/doc/PACKAGE]
  --htmldir=DIR          html documentation [DOCDIR]
  --dvidir=DIR           dvi documentation [DOCDIR]
  --pdfdir=DIR           pdf documentation [DOCDIR]
  --psdir=DIR            ps documentation [DOCDIR]

Since I did not do that (I do not knwo where is OpenBSD installing fvwm related stuff) I guess after running the following sequence, i have two versions installed on my system...

[host]/tmp # ./configure
# make
# make install

so that,

from an xterm window....

$ which fvwm
/usr/X11R6/bin/fvwm
$
$ fvwm -version
[FVWM][main]:  Fvwm Version 2.2.5 compiled on Aug  8 2007 at 23:03:41

[FVWM][main]: <<ERROR>> can't open display
$
$ /usr/local/bin/fvwm -version
FVWM version 2.4.20 compiled on Jan  7 2008 at 11:33:48
with support for: ReadLine, XPM, GNOME WM hints, Shape, SM, Xinerama
$

can someone tell the right values for PREFIX and EPREFIX?

thx,
-BG

________________________________
~~aapka kalyan ho~~

Reply | Threaded
Open this post in threaded view
|

Re: upgrading FVWM to 2.4

Johan Beisser
On Jan 7, 2008, at 9:55 AM, badeguruji wrote:

> Hello,
>
> I figure that i will need to give some runtime arguments to  
> following commands for upgrading my fvwm installation. as per README  
> from fvwm package...
>
> can someone tell me what is the right value for PREFIX and EPREFIX?

Since they are not part of the base install with X, I'd keep them in /
usr/local/bin. Or, better, build a package/port for it and submit it.

Reply | Threaded
Open this post in threaded view
|

Re: upgrading FVWM to 2.4

Ted Unangst-2
In reply to this post by badeguruji
On 1/7/08, badeguruji <[hidden email]> wrote:
> I figure that i will need to give some runtime arguments to following commands for upgrading my fvwm installation. as per README from fvwm package...

pkg_add fvwm2 is a lot easier...

Reply | Threaded
Open this post in threaded view
|

Re: upgrading FVWM to 2.4

badeguruji
In reply to this post by badeguruji
Ted / Johan,
thx. i downloaded 2.4.20 tar from fvwm site and ran ./configure --prefix /usr/X11r6 (otherwise default /usr/local)
and then
make
and then
make install

after that i was able to use the new fvwm version.

-BG.
________________________________
~~aapka kalyan ho~~

----- Original Message ----
From: Ted Unangst <[hidden email]>
To: badeguruji <[hidden email]>
Cc: [hidden email]
Sent: Monday, January 7, 2008 5:04:01 PM
Subject: Re: upgrading FVWM to 2.4


On 1/7/08, badeguruji <[hidden email]> wrote:
> I figure that i will need to give some runtime arguments to following
 commands for upgrading my fvwm installation. as per README from fvwm
 package...

pkg_add fvwm2 is a lot easier...