update: mail/claws-mail* 3.7.9

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

update: mail/claws-mail* 3.7.9

roberth-5
Hi,

attached is an update for claws-mail and its plugins.
Some more testing welcome. (Especially of the plugins by someone
who actually uses them regularly.)


claws-mail updated to 3.7.9
        included patch 3.7.9cvs2 from upstream
        http://www.colino.net/claws-mail/index.php?len=30&ver=3.7.9cvs2#3.7.9cvs2 
        fix for bug 2396, with gnome shell cm would start minimized.
        http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2396 

claws-mail-attremover bump
claws-mail-cachesaver -> attic
        retired upstream, not necessary anymore.
       
claws-mail-htmlviewer updated to 0.30
claws-mail-notification updated to 0.27
claws-mail-rssyl updated to 0.30
claws-mail-vcalendar updated to 2.0.10


Cheers,
        Robert

claws-mail-3.7.9.diff (11K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: update: mail/claws-mail* 3.7.9

Gabriel Guzman-2
On Sun, 17 Apr 2011 13:46:44 +0200
roberth <[hidden email]> wrote:

> Hi,
>
> attached is an update for claws-mail and its plugins.
> Some more testing welcome. (Especially of the plugins by someone
> who actually uses them regularly.)

make build is giving me the following errors:  

# make build
===>  Verifying specs: X11 Xau Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6 X11 Xau Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6 ICE SM c dbus-1 gmp hogweed nettle  pthread stdc++ tasn1 xcb-atom xcb-aux xcb-event  startup-notification-1 enchant gnutls gpgme dbus-glib-1 X11 X!
 au Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6 X11 Xau Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6
Missing library for hogweed>=0.0
Missing library for nettle>=0.0
Fatal error
*** Error code 1

Stop in /usr/ports/mail/claws-mail (line 1952 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/mail/claws-mail (line 2212 of /usr/ports/infrastructure/mk/bsd.port.mk).


Seemingly I'm missing the hogweed and nettle libraries, but...those don't appear available on my system.  I just updated to latest current as of Sat Apr 16 16:17:57 EDT.... kernel, userland, and ports.  

I'm sure I'm doing something wrong.


I use claws + the bogofilter plugin, so I'm happy to test this... just
need to figure out why I can't get it running.

gabe.

Reply | Threaded
Open this post in threaded view
|

Re: update: mail/claws-mail* 3.7.9

Antoine Jacoutot-7
On Sun, 17 Apr 2011, Gabriel Guzman wrote:

> On Sun, 17 Apr 2011 13:46:44 +0200
> roberth <[hidden email]> wrote:
>
> > Hi,
> >
> > attached is an update for claws-mail and its plugins.
> > Some more testing welcome. (Especially of the plugins by someone
> > who actually uses them regularly.)
>
> make build is giving me the following errors:  
>
> # make build
> ===>  Verifying specs: X11 Xau Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6 X11 Xau Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6 ICE SM c dbus-1 gmp hogweed nettle  pthread stdc++ tasn1 xcb-atom xcb-aux xcb-event  startup-notification-1 enchant gnutls gpgme dbus-glib-1 X11!
  X!

>  au Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6 X11 Xau Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6
> Missing library for hogweed>=0.0
> Missing library for nettle>=0.0
> Fatal error
> *** Error code 1
>
> Stop in /usr/ports/mail/claws-mail (line 1952 of /usr/ports/infrastructure/mk/bsd.port.mk).
> *** Error code 1
>
> Stop in /usr/ports/mail/claws-mail (line 2212 of /usr/ports/infrastructure/mk/bsd.port.mk).
>
>
> Seemingly I'm missing the hogweed and nettle libraries, but...those don't appear available on my system.  I just updated to latest current as of Sat Apr 16 16:17:57 EDT.... kernel, userland, and ports.  
>
> I'm sure I'm doing something wrong.
>
>
> I use claws + the bogofilter plugin, so I'm happy to test this... just
> need to figure out why I can't get it running.

Your ports aren't up to date, gnutls especially.

--
Antoine

Reply | Threaded
Open this post in threaded view
|

Re: update: mail/claws-mail* 3.7.9

Gabriel Guzman-2
On Sun, 17 Apr 2011 16:50:43 +0200 (CEST)
Antoine Jacoutot <[hidden email]> wrote:

> On Sun, 17 Apr 2011, Gabriel Guzman wrote:
>
> > On Sun, 17 Apr 2011 13:46:44 +0200
> > roberth <[hidden email]> wrote:
> >
> > > Hi,
> > >
> > > attached is an update for claws-mail and its plugins.
> > > Some more testing welcome. (Especially of the plugins by someone
> > > who actually uses them regularly.)
> >
> > make build is giving me the following errors:  
> >
> > # make build
> > ===>  Verifying specs: X11 Xau Xcomposite Xcursor Xdamage Xdmcp
> > Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo crypto curl
> > expat fontconfig freetype gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0
> > gobject-2.0 idn m pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre
> > pixman-1 png pthread-stubs ssl  gcrypt gpg-error xcb z
> > gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2
> > GL Xxf86vm drm xcb-render xcb-shm intl>=5 iconv>=6 X11 Xau
> > Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr
> > Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype
> > gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m
> > pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png
> > pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0
> > gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm
> > xcb-render xcb-shm intl>=5 iconv>=6 ICE SM c dbus-1 gmp hogweed
> > nettle  pthread stdc++ tasn1 xcb-atom xcb-aux xcb-event
> > startup-notification-1 enchant gnutls gpgme dbus-glib-1 X11!
>  
>   X!
> >  au Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes  Xi Xinerama
> > Xrandr Xrender atk-1.0 cairo crypto curl  expat fontconfig freetype
> > gio-2.0 glib-2.0 gthread-2.0  gmodule-2.0 gobject-2.0 idn m
> > pango-1.0 pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png
> > pthread-stubs ssl  gcrypt gpg-error xcb z gdk_pixbuf-2.0
> > gdk-x11-2.0 gtk-x11-2.0 execinfo etpan>=13 sasl2  GL Xxf86vm drm
> > xcb-render xcb-shm intl>=5 iconv>=6 X11 Xau Xcomposite Xcursor
> > Xdamage Xdmcp Xext Xfixes  Xi Xinerama Xrandr Xrender atk-1.0 cairo
> > crypto curl  expat fontconfig freetype gio-2.0 glib-2.0
> > gthread-2.0  gmodule-2.0 gobject-2.0 idn m pango-1.0
> > pangocairo-1.0  pangoft2-1.0 pcre pixman-1 png pthread-stubs ssl
> > gcrypt gpg-error xcb z gdk_pixbuf-2.0  gdk-x11-2.0 gtk-x11-2.0
> > execinfo etpan>=13 sasl2  GL Xxf86vm drm xcb-render xcb-shm intl>=5
> > iconv>=6 Missing library for hogweed>=0.0 Missing library for
> > iconv>nettle>=0.0 Fatal error *** Error code 1
> >
> > Stop in /usr/ports/mail/claws-mail (line 1952
> > of /usr/ports/infrastructure/mk/bsd.port.mk). *** Error code 1
> >
> > Stop in /usr/ports/mail/claws-mail (line 2212
> > of /usr/ports/infrastructure/mk/bsd.port.mk).
> >
> >
> > Seemingly I'm missing the hogweed and nettle libraries, but...those
> > don't appear available on my system.  I just updated to latest
> > current as of Sat Apr 16 16:17:57 EDT.... kernel, userland, and
> > ports.  
> >
> > I'm sure I'm doing something wrong.
> >
> >
> > I use claws + the bogofilter plugin, so I'm happy to test this...
> > just need to figure out why I can't get it running.
>
> Your ports aren't up to date, gnutls especially.

ok... that would explain it.  I'll update them and test.

thanks,
gabe.