update devel/py-attrs

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

update devel/py-attrs

Daniel Dickman
Here's an update for py-attrs. I have a port for airflow 1.10.14, and it
needs py-attrs to be at version 20.x (but not newer).

ok?

Index: Makefile
===================================================================
RCS file: /cvs/ports/devel/py-attrs/Makefile,v
retrieving revision 1.8
diff -u -p -u -r1.8 Makefile
--- Makefile 3 Jul 2020 21:12:40 -0000 1.8
+++ Makefile 15 Feb 2021 21:33:26 -0000
@@ -2,11 +2,10 @@
 
 COMMENT = classes without boilerplate
 
-MODPY_EGG_VERSION = 19.3.0
+MODPY_EGG_VERSION = 20.1.0
 
 DISTNAME = attrs-${MODPY_EGG_VERSION}
 PKGNAME = py-${DISTNAME}
-REVISION = 0
 
 CATEGORIES = devel
 
Index: distinfo
===================================================================
RCS file: /cvs/ports/devel/py-attrs/distinfo,v
retrieving revision 1.4
diff -u -p -u -r1.4 distinfo
--- distinfo 6 Jan 2020 18:12:09 -0000 1.4
+++ distinfo 15 Feb 2021 21:33:26 -0000
@@ -1,2 +1,2 @@
-SHA256 (attrs-19.3.0.tar.gz) = 97fOFlcP6ZZazW0wEBoo9i+0p/npJrO7ybYfiwQkfnI=
-SIZE (attrs-19.3.0.tar.gz) = 132477
+SHA256 (attrs-20.1.0.tar.gz) = DvlyOIVkMNz5Io4H8xau/Bfok5/IUH4YxlAbdh7xpCo=
+SIZE (attrs-20.1.0.tar.gz) = 160766
Index: pkg/PLIST
===================================================================
RCS file: /cvs/ports/devel/py-attrs/pkg/PLIST,v
retrieving revision 1.4
diff -u -p -u -r1.4 PLIST
--- pkg/PLIST 6 Jan 2020 18:12:09 -0000 1.4
+++ pkg/PLIST 15 Feb 2021 21:33:26 -0000
@@ -8,15 +8,18 @@ lib/python${MODPY_VERSION}/site-packages
 lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}_config.${MODPY_PYC_MAGIC_TAG}pyc
 lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}_funcs.${MODPY_PYC_MAGIC_TAG}pyc
 lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}_make.${MODPY_PYC_MAGIC_TAG}pyc
+${MODPY_COMMENT}lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}_next_gen.${MODPY_PYC_MAGIC_TAG}pyc
 lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}_version_info.${MODPY_PYC_MAGIC_TAG}pyc
 lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}converters.${MODPY_PYC_MAGIC_TAG}pyc
 lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}exceptions.${MODPY_PYC_MAGIC_TAG}pyc
 lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}filters.${MODPY_PYC_MAGIC_TAG}pyc
+lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}setters.${MODPY_PYC_MAGIC_TAG}pyc
 lib/python${MODPY_VERSION}/site-packages/attr/${MODPY_PYCACHE}validators.${MODPY_PYC_MAGIC_TAG}pyc
 lib/python${MODPY_VERSION}/site-packages/attr/_compat.py
 lib/python${MODPY_VERSION}/site-packages/attr/_config.py
 lib/python${MODPY_VERSION}/site-packages/attr/_funcs.py
 lib/python${MODPY_VERSION}/site-packages/attr/_make.py
+lib/python${MODPY_VERSION}/site-packages/attr/_next_gen.py
 lib/python${MODPY_VERSION}/site-packages/attr/_version_info.py
 lib/python${MODPY_VERSION}/site-packages/attr/_version_info.pyi
 lib/python${MODPY_VERSION}/site-packages/attr/converters.py
@@ -26,6 +29,8 @@ lib/python${MODPY_VERSION}/site-packages
 lib/python${MODPY_VERSION}/site-packages/attr/filters.py
 lib/python${MODPY_VERSION}/site-packages/attr/filters.pyi
 lib/python${MODPY_VERSION}/site-packages/attr/py.typed
+lib/python${MODPY_VERSION}/site-packages/attr/setters.py
+lib/python${MODPY_VERSION}/site-packages/attr/setters.pyi
 lib/python${MODPY_VERSION}/site-packages/attr/validators.py
 lib/python${MODPY_VERSION}/site-packages/attr/validators.pyi
 lib/python${MODPY_VERSION}/site-packages/attrs-${MODPY_EGG_VERSION}-py${MODPY_VERSION}.egg-info/