system/4994: trunk with ath doesn't work well

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

system/4994: trunk with ath doesn't work well

Angelos D. Keromytis-2
>Number:         4994
>Category:       system
>Synopsis:       trunk with ath doesn't work well
>Confidential:   yes
>Severity:       non-critical
>Priority:       low
>Responsible:    bugs
>State:          open
>Quarter:        
>Keywords:      
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jan 29 01:40:02 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Angelos D. Keromytis
>Release:        
>Organization:
net
>Environment:
       
        System      : OpenBSD 3.8
        Architecture: OpenBSD.i386
        Machine     : i386
>Description:
        Configured trunk to use em0 (master) and ath0 (in
        WEP). Failover worked when I unplugged the cable,
        but performance stinks --- ath loses the network
        every 1 second or so (despite sitting right next to the AP,
        which works well when I'm not using trunk). My guess is that
        the ieee80211 watchdog forces a scan at approximately that
        rate.

64 bytes from 128.59.19.55: icmp_seq=152 ttl=255 time=6616.971 ms
64 bytes from 128.59.19.55: icmp_seq=153 ttl=255 time=5625.780 ms
64 bytes from 128.59.19.55: icmp_seq=154 ttl=255 time=4657.537 ms
64 bytes from 128.59.19.55: icmp_seq=155 ttl=255 time=3662.015 ms
64 bytes from 128.59.19.55: icmp_seq=156 ttl=255 time=2667.543 ms
64 bytes from 128.59.19.55: icmp_seq=157 ttl=255 time=1673.123 ms
64 bytes from 128.59.19.55: icmp_seq=158 ttl=255 time=663.736 ms
64 bytes from 128.59.19.55: icmp_seq=159 ttl=255 time=8.859 ms
64 bytes from 128.59.19.55: icmp_seq=160 ttl=255 time=6555.205 ms
64 bytes from 128.59.19.55: icmp_seq=161 ttl=255 time=5569.394 ms
64 bytes from 128.59.19.55: icmp_seq=162 ttl=255 time=4574.145 ms
64 bytes from 128.59.19.55: icmp_seq=163 ttl=255 time=3575.993 ms
64 bytes from 128.59.19.55: icmp_seq=164 ttl=255 time=2579.121 ms
64 bytes from 128.59.19.55: icmp_seq=165 ttl=255 time=1581.576 ms
64 bytes from 128.59.19.55: icmp_seq=166 ttl=255 time=572.189 ms


>How-To-Repeat:
        Configure trunk with em0 and ath0, the latter using WEP. (I
        suspect the same happens when not using WEP too.)

>Fix:
        Don't scan?


>Release-Note:
>Audit-Trail:
>Unformatted: