system/4988: Mountings msdos fs fails

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

system/4988: Mountings msdos fs fails

Tilo Stritzky
>Number:         4988
>Category:       system
>Synopsis:       Mountings msdos fs fails
>Confidential:   yes
>Severity:       serious
>Priority:       medium
>Responsible:    bugs
>State:          open
>Quarter:        
>Keywords:      
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jan 23 20:10:01 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Tilo Stritzky
>Release:        -current
>Organization:
net
>Environment:
       
        System      : OpenBSD 3.8
        Architecture: OpenBSD.i386
        Machine     : i386
>Description:
        When trying to mount a msdos fs on an USB device the mount fails:
        # mount -tmsdos /dev/sd0i /mnt
        mount_msdos: /dev/sd0i on /mnt: Inappropriate file type or format

>How-To-Repeat:
        typescript:

# mount -tmsdos /dev/sd0i /mnt
mount_msdos: /dev/sd0i on /mnt: Inappropriate file type or format
# fdisk sd0
fdisk: sysctl(machdep.bios.diskinfo): Device not configured
Disk: sd0       geometry: 992/64/32 [2032128 Sectors]
Offset: 0       Signature: 0xAA55
         Starting       Ending       LBA Info:
 #: id    C   H  S -    C   H  S [       start:      size   ]
------------------------------------------------------------------------
*0: 0B    0   1 32 -  992  15 32 [          63:     2032065 ] Win95 FAT-32
 1: 00    0   0  0 -    0   0  0 [           0:           0 ] unused      
 2: 00    0   0  0 -    0   0  0 [           0:           0 ] unused      
 3: 00    0   0  0 -    0   0  0 [           0:           0 ] unused      
# disklabel sd0
disklabel: warning, DOS partition table with no valid OpenBSD partition
# /dev/rsd0c:
type: SCSI
disk: SCSI disk
label: iAUDIO G3      
flags:
bytes/sector: 512
sectors/track: 32
tracks/cylinder: 64
sectors/cylinder: 2048
cylinders: 992
total sectors: 2032128
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0           # microseconds
track-to-track seek: 0  # microseconds
drivedata: 0

16 partitions:
#             size        offset  fstype [fsize bsize  cpg]
  c:       2032128             0  unused      0     0      # Cyl     0 -   992*
  i:       2032065            63   MSDOS                   # Cyl     0*-   992*
# dmesg
OpenBSD 3.8 (GENERIC) #138: Sat Sep 10 15:41:37 MDT 2005
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: mobile AMD Athlon(tm) XP 2200+ ("AuthenticAMD" 686-class, 256KB L2 cache) 1.79 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
cpu0: AMD Powernow: FID VID TTP
real mem  = 468230144 (457256K)
avail mem = 420032512 (410188K)
using 4278 buffers containing 23515136 bytes (22964K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(81) BIOS, date 12/17/02, BIOS32 rev. 0 @ 0xfd730
pcibios0 at bios0: rev 2.1 @ 0xfd730/0x8d0
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdf10/208 (11 entries)
pcibios0: PCI Interrupt Router at 000:07:0 ("Acer Labs M1533 ISA" rev 0x00)
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0xf000 0xcf000/0x800 0xdf000/0x1000! 0xe0000/0x4000!
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "ATI RS100 AGP" rev 0x13
ppb0 at pci0 dev 1 function 0 "ATI RS100 PCI" rev 0x01
pci1 at ppb0 bus 1
vga1 at pci1 dev 5 function 0 "ATI Radeon IGP 320M" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ohci0 at pci0 dev 2 function 0 "Acer Labs M5237 USB" rev 0x03: irq 9, version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Acer Labs OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
autri0 at pci0 dev 6 function 0 "Acer Labs M5451 Audio" rev 0x02: irq 5
ac97: codec id 0x43585429 (Conexant CX20468 rev 1)
ac97: codec features reserved, headphone, 18 bit DAC, 18 bit ADC, No 3D Stereo
audio0 at autri0
midi0 at autri0: <4DWAVE MIDI UART>
pcib0 at pci0 dev 7 function 0 "Acer Labs M1533 ISA" rev 0x00
"Acer Labs M5457 Modem" rev 0x00 at pci0 dev 8 function 0 not configured
cbb0 at pci0 dev 10 function 0 "O2 Micro OZ69[17]2 CardBus" rev 0x00: irq 5
"Texas Instruments TSB43AB21 FireWire" rev 0x00 at pci0 dev 12 function 0 not configured
pciide0 at pci0 dev 16 function 0 "Acer Labs M5229 UDMA IDE" rev 0xc4: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <IC25N030ATCS04-0>
wd0: 16-sector PIO, LBA, 28615MB, 58605120 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TOSHIBA, DVD-ROM SD-R2312, 1905> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
"Acer Labs M7101 Power" rev 0x00 at pci0 dev 17 function 0 not configured
sis0 at pci0 dev 18 function 0 "NS DP83815 10/100" rev 0x00: DP83816A, irq 11, address 00:0b:cd:34:69:2f
nsphyter0 at sis0 phy 0: DP83815 10/100 PHY, rev. 1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi1 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
biomask e76d netmask ef6d ttymask ffef
pctr: user-level cycle counter enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
umass0 at uhub0 port 1 configuration 1 interface 0
umass0: COWON iAUDIO G3, rev 2.00/1.10, addr 2
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets
sd0 at scsibus1 targ 1 lun 0: <COWON, iAUDIO G3, 0100> SCSI4 0/direct removable
sd0: 992MB, 992 cyl, 64 head, 32 sec, 512 bytes/sec, 2032128 sec total
>Fix:
        None known


>Release-Note:
>Audit-Trail:
>Unformatted: