symbol ( - - - - ) size mismatch, relink your program

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

symbol ( - - - - ) size mismatch, relink your program

Mihai Popescu B.S.
Hello,

I did a snapshot install and I got many warnings like this one. What
could be this warning, is it about mismatch on .so files ?

Thanks.

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

roberth-5
On Sat, 11 Dec 2010 18:04:32 +0200
"Mihai Popescu B.S." <[hidden email]> wrote:

> Hello,
>
> I did a snapshot install and I got many warnings like this one. What
> could be this warning, is it about mismatch on .so files ?
>
> Thanks.
>

thats a very informative bug report. you sure did include a lot of
information. care to eleborate?

if i had to guess...
you are talking about updating packages and see mozilla related stuff
complaining about sqlite.
don't worry bout that one, it's an issue with sqlite from ports vs the
mozilla distributed version.

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

J Sisson
In reply to this post by Mihai Popescu B.S.
On Sat, Dec 11, 2010 at 10:04 AM, Mihai Popescu B.S. <[hidden email]>wrote:

> I did a snapshot install and I got many warnings like this one. What
> could be this warning, is it about mismatch on .so files ?
>
> Was it a clean install of a snapshot or an upgrade?

If upgrade, did you sysmerge and pkg_add -u after the upgrade?

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

Abel Abraham Camarillo Ojeda-2
In reply to this post by Mihai Popescu B.S.
On Sat, Dec 11, 2010 at 10:04 AM, Mihai Popescu B.S. <[hidden email]> wrote:
> Hello,
>
> I did a snapshot install and I got many warnings like this one. What
> could be this warning, is it about mismatch on .so files ?
>
> Thanks.
>
>

I think this is in the archives...

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

James A. Peltier
----- Original Message -----
| On Sat, Dec 11, 2010 at 10:04 AM, Mihai Popescu B.S.
| <[hidden email]> wrote:
| > Hello,
| >
| > I did a snapshot install and I got many warnings like this one. What
| > could be this warning, is it about mismatch on .so files ?
| >
| > Thanks.
| >
| >
|
| I think this is in the archives...

Yes it is because I created the most recent thread and it was because of packages.  PHP in my case.

--
James A. Peltier
Research Computing Group
Simon Fraser University - Burnaby Campus
Phone   : 778-782-6573
Fax     : 778-782-3045
E-Mail  : [hidden email]
Website : http://www.sfu.ca/itservices
          http://blogs.sfu.ca/people/jpeltier

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

Mihai Popescu B.S.
In reply to this post by Mihai Popescu B.S.
Sorry folks,

I was to quick in posting. Here are the details: I've installed from
what is (was) today on snapshots on ftp server. Then I used the same
ftp snapshot mirror for packages. That's all, no CVS, no compile, just
plain install from what is (was) on snapshots - base & packages.
This was after a long pause of using OpenBSD as a desktop, I was using
it only as a router. I had to do this to give a try to Ubuntu, but I
was disappointed with it and came back to old and stable stuff. I did
the same install like in the old times, get the snapshot and go.
First, my ATI HD4350 refused to startx, effectively putting my display
in some unusable state: I had to remove power from display to get it
back online. I searched the archive and found out that Xorg became a
"joke" since Intel put some code in it. Too sad.
Then I got the messages about symbol size mismatch. I've installed
empathy but got some strange messages like Cannot execute the script
... (not a manual?) and empathy refused to start being unable to load
some lib.so files. Now I replaced the ATI HD4350 with ATI X1650 and
managed to get X working.
Are there new things in snapshot which I don't know ? Should I wait
for another compile of packages, to have a date close to the base
compile time ?
If X is so crappy, is there another thing to use ?

Many thanks.

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

roberth-5
On Sat, 11 Dec 2010 23:07:02 +0200
"Mihai Popescu B.S." <[hidden email]> wrote:

> Sorry folks,
>
> I was to quick in posting. Here are the details: I've installed from
> what is (was) today on snapshots on ftp server. Then I used the same
> ftp snapshot mirror for packages. That's all, no CVS, no compile, just
> plain install from what is (was) on snapshots - base & packages.
> This was after a long pause of using OpenBSD as a desktop, I was using
> it only as a router. I had to do this to give a try to Ubuntu, but I
> was disappointed with it and came back to old and stable stuff. I did
> the same install like in the old times, get the snapshot and go.
> First, my ATI HD4350 refused to startx, effectively putting my display
> in some unusable state: I had to remove power from display to get it
> back online. I searched the archive and found out that Xorg became a
> "joke" since Intel put some code in it. Too sad.
> Then I got the messages about symbol size mismatch. I've installed
> empathy but got some strange messages like Cannot execute the script
> ... (not a manual?) and empathy refused to start being unable to load
> some lib.so files. Now I replaced the ATI HD4350 with ATI X1650 and
> managed to get X working.
> Are there new things in snapshot which I don't know ? Should I wait
> for another compile of packages, to have a date close to the base
> compile time ?
> If X is so crappy, is there another thing to use ?
>
> Many thanks.
>

something like
/regxpcom:/usr/local/lib/libsqlite3.so.14.0: /usr/local/mozilla-firefox/libsqlite3.so.22.1 : WARNING: symbol(sqlite3_version) size mismatch, relink your program
can be ignored atm.

i don't use empathy, so no idea if it is broken, the actual error
messages would help.
for ports/package related stuff there is ports@ which might get you a
quicker response.

"not a manual" might point to a "bad" manpage, related to the
mandoc/groff change; nothing to worry about either from a pure user
perspective. the package should have installed fine nevertheless.

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

patsy-10
In reply to this post by Mihai Popescu B.S.
On Sat, Dec 11, 2010 at 11:07:02PM +0200, Mihai Popescu B.S. wrote:

> Sorry folks,
>
> First, my ATI HD4350 refused to startx, effectively putting my display
> in some unusable state: I had to remove power from display to get it
> back online. I searched the archive and found out that Xorg became a
> "joke" since Intel put some code in it. Too sad.
> Then I got the messages about symbol size mismatch. I've installed
> empathy but got some strange messages like Cannot execute the script
> ... (not a manual?) and empathy refused to start being unable to load
> some lib.so files. Now I replaced the ATI HD4350 with ATI X1650 and
> managed to get X working.
> Are there new things in snapshot which I don't know ? Should I wait
> for another compile of packages, to have a date close to the base
> compile time ?
> If X is so crappy, is there another thing to use ?
>
> Many thanks.
>

I don't mean to brag, but my Radeon HD4350 works fine with X. Sending
a dmesg to the list is never a bad idea if hardware is misbehaving.
Are you using an xorg.conf?

Incidentally, if you are using a snapshot then you should use the
ports.tar.gz that comes with the snapshot, the packages that may be
available won't necessarily work (they usually do, but it's not by
design). There was a thread about it recently, I'm afraid I can't
recall the title though.

Patsy

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

Tomas Bodzar-4
In reply to this post by Mihai Popescu B.S.
On Sat, Dec 11, 2010 at 10:07 PM, Mihai Popescu B.S. <[hidden email]> wrote:
> Sorry folks,
>
> I was to quick in posting. Here are the details: I've installed from
> what is (was) today on snapshots on ftp server. Then I used the same
> ftp snapshot mirror for packages. That's all, no CVS, no compile, just
> plain install from what is (was) on snapshots - base & packages.

At least 'sysctl kern.version' will be fine

> This was after a long pause of using OpenBSD as a desktop, I was using
> it only as a router. I had to do this to give a try to Ubuntu, but I
> was disappointed with it and came back to old and stable stuff. I did
> the same install like in the old times, get the snapshot and go.
> First, my ATI HD4350 refused to startx, effectively putting my display
> in some unusable state: I had to remove power from display to get it
> back online. I searched the archive and found out that Xorg became a
> "joke" since Intel put some code in it. Too sad.

OpenBSD has its own version of X based on Xorg called Xenocara.
(www.xenocara.org)

man radeon (because there is RV710       Radeon HD 4350/4550).
So your card is supported, but you must send your dmesg, xorg.conf,
Xorg.0.log and probably 'pcidump -v' (because there will be details
about your card).

> Then I got the messages about symbol size mismatch. I've installed
> empathy but got some strange messages like Cannot execute the script
> ... (not a manual?) and empathy refused to start being unable to load
> some lib.so files. Now I replaced the ATI HD4350 with ATI X1650 and
> managed to get X working.
> Are there new things in snapshot which I don't know ? Should I wait
> for another compile of packages, to have a date close to the base
> compile time ?
> If X is so crappy, is there another thing to use ?
>
> Many thanks.

Reply | Threaded
Open this post in threaded view
|

Re: symbol ( - - - - ) size mismatch, relink your program

Stuart Henderson
In reply to this post by Mihai Popescu B.S.
On 2010-12-11, Mihai Popescu B.S. <[hidden email]> wrote:

> I've installed
> empathy but got some strange messages like Cannot execute the script
> ... (not a manual?)

many packages are now using manpages preformatted at build time.
makewhatis(8) doesn't handle these very well yet.

for the other things, e.g.

> Then I got the messages about symbol size mismatch.

and

> and empathy refused to start being unable to load
> some lib.so files.

you need to show the actual messages.