sunfire v120, serial io, boot net bsd.rd

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

sunfire v120, serial io, boot net bsd.rd

Chris B-6
Hi everyone,

I am trying to net boot a sunfire v120 in order to
procced with 3.8 installation.
Note that I am completely new to this type of machine.
(no keyboard, no screen, no floppy or cdrom)
I have connected to the sun's LOM port with serial
cable from a linux machine with kermit.
I have set tftpd, bootparamd and nfsd on the linux and
so i can issue an
 ok boot net bsd.rd

I have placed into the exported root only the bsd.rd
file.

The problem is that after the bsd kernel is booted,
things stop at:
rd0: fixed, 6144 blocks

I have no clue on what to do, is it an io problem
(have no more output on serial), or execution has
stopped cuz something is missing?

The only output i can include is the serial log:
(I replaced non printable with ......)

=================================================================
lom>poweron
lom>
LOM event: +0h6m19s host power on
?
Sun Fire V120 (UltraSPARC-IIe 648MHz), No Keyboard
OpenBoot 4.0, 1024 MB memory installed, Serial
#53825868.
Ethernet address 0:3:ba:35:51:4c, Host ID: 8335514c.


Initializing Memory - .....

ok boot net bsd.rd
Boot device: /pci@1f,0/pci@1,1/network@c,1  File and
args: bsd.rd
Timeout waiting for ARP/RARP packet
..... >> OpenBSD 3.8 (obj) #1: Thu Sep  1 17:32:43 MDT
2005
   
[hidden email]:/usr/src/sys/arch/sparc64/stand/ofwboot.net/obj
Using BOOTPARAMS protocol: ip address: 10.0.0.200,
hostname: sunny
root addr=10.0.0.118 path=/export
Booting /pci@1f,0/pci@1,1/network@c,1/bsd.rd
2325112@0x1000000.....+3256616@0x1800000.....+937688@0x1b1b128
.....symbols @ 0xfff44200 42/.... start=0x1000000
console is /pci@1f,0/pci@1,1/isa@7/serial@0,3f8
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All
rights reserved.
Copyright (c) 1995-2005 OpenBSD. All rights reserved.
http://www.OpenBSD.org

OpenBSD 3.8 (RAMDISK) #459: Sat Sep 10 16:41:34 MDT
2005
   
[hidden email]:/usr/src/sys/arch/sparc64/compile/RAMDISK
total memory = 1073741824
avail memory = 971956224
using 6553 buffers containing 53682176 bytes of memory
bootpath: /pci@1f,0/pci@1,1/network@c,1
mainbus0 (root): Sun Fire V120 (UltraSPARC-IIe 648MHz)
cpu0 at mainbus0: SUNW,UltraSPARC-IIe @ 648 MHz,
version 0 FPU
cpu0: physical 32K instruction (32 b/l), 16K data (32
b/l), 2048K external (64 b/l)
psycho0 at mainbus0
SUNW,sabre: impl 0, version 0: ign 7c0 bus range 0 to
3; PCI bus 0
DVMA map: c0000000 to e0000000
IOTDB: 4d02000 to 4d82000
pci0 at psycho0
ppb0 at pci0 dev 1 function 1 vendor 0x108e product
0x5000 rev 0x13
pci1 at ppb0 bus 1
ebus0 at pci1 dev 12 function 0 vendor 0x108e product
0x1100 rev 0x01
flashprom at ebus0 addr 0-fffff not configured
clock1 at ebus0 addr 0-1fff: mk48t59: hostid 8335514c
ebus_attach: idprom: incomplete
SUNW,lomh at ebus0 addr 200000-200003 ipl 42 not
configured
gem0 at pci1 dev 12 function 1 vendor 0x108e product
0x1101 rev 0x01: ivec 3006, address 00:03:ba:35:51:4c
ukphy0 at gem0 phy 1: Generic IEEE 802.3u media
interface
ukphy0: OUI 0x0010dd, model 0x0002, rev. 1
ohci0 at pci1 dev 12 function 3 vendor 0x108e product
0x1103 rev 0x01: ivec 24, version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x108e OHCI root hub, rev 1.00/1.00,
addr 1
uhub0: 4 ports with 4 removable, self powered
vendor 0x10b9 product 0x7101 (class prehistoric
subclass miscellaneous, rev 0x00) at pci1 dev 3
function 0 not configured
vendor 0x10b9 product 0x7101 (class prehistoric
subclass miscellaneous, rev 0x00) at pci1 dev 3
function 0 not configured
ebus1 at pci1 dev 7 function 0 vendor 0x10b9 product
0x1533 rev 0x00
power at ebus1 addr 2000-2007 ipl 37 not configured
com0 at ebus1 addr 3f8-3ff ipl 43: ns16550a, 16 byte
fifo
com0: console
com1 at ebus1 addr 2e8-2ef ipl 43: ns16550a, 16 byte
fifo
pciide0 at pci1 dev 13 function 0 vendor 0x10b9
product 0x5229 rev 0xc3: DMA, channel 0 configured to
native-PCI, channel 1 configured to native-PCI
pciide0: using ivec 180c for native-PCI interrupt
atapiscsi0 at pciide0 channel 0 drive 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <SAMSUNG, CD-ROM SN-124,
N102> SCSI0 5/cdrom removable
cd0(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 disabled (no drives)
gem1 at pci1 dev 5 function 1 vendor 0x108e product
0x1101 rev 0x01interrupt_vector: spurious vector 7df
at pil 13
: ivec 301c, address 00:03:ba:35:51:4d
ukphy1 at gem1 phy 1: Generic IEEE 802.3u media
interface
ukphy1: OUI 0x0010dd, model 0x0002, rev. 1
ohci1 at pci1 dev 5 function 3 vendor 0x108e product
0x1103 rev 0x01: ivec 26, version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: vendor 0x108e OHCI root hub, rev 1.00/1.00,
addr 1
uhub1: 4 ports with 4 removable, self powered
ppb1 at pci0 dev 1 function 0 vendor 0x108e product
0x5000 rev 0x13
pci2 at ppb1 bus 2
siop0 at pci2 dev 8 function 0 vendor 0x1000 product
0x000b rev 0x07: ivec 1820, using 8K of on-board RAM
scsibus1 at siop0: 16 targets
sd0 at scsibus1 targ 0 lun 0: <FUJITSU, MAP3367N
SUN36G, 0301> SCSI4 0/direct fixed
sd0: 34732MB, 24622 cyl, 27 head, 107 sec, 512
bytes/sec, 71132959 sec total
siop1 at pci2 dev 8 function 1 vendor 0x1000 product
0x000b rev 0x07: ivec 1820, using 8K of on-board RAM
scsibus2 at siop1: 16 targets
ppb2 at pci2 dev 5 function 0 vendor 0x8086 product
0xb154 rev 0x00
pci3 at ppb2 bus 3
vendor 0x108e product 0x1000 (class bridge subclass
miscellaneous, rev 0x01) at pci3 dev 0 function 0 not
configured
hme0 at pci3 dev 0 function 1 vendor 0x108e product
0x1001 rev 0x01: address 00:03:ba:34:82:58
luphy0 at hme0 phy 1: LU6612 10/100 PHY, rev. 1
hme0: using ivec 3005 for interrupt
vendor 0x108e product 0x1000 (class bridge subclass
miscellaneous, rev 0x01) at pci3 dev 1 function 0 not
configured
hme1 at pci3 dev 1 function 1 vendor 0x108e product
0x1001 rev 0x01: address 00:03:ba:34:82:59
luphy1 at hme1 phy 1: LU6612 10/100 PHY, rev. 1
hme1: using ivec 3014 for interrupt
vendor 0x108e product 0x1000 (class bridge subclass
miscellaneous, rev 0x01) at pci3 dev 2 function 0 not
configured
hme2 at pci3 dev 2 function 1 vendor 0x108e product
0x1001 rev 0x01: address 00:03:ba:34:82:5a
luphy2 at hme2 phy 1: LU6612 10/100 PHY, rev. 1
hme2: using ivec 3004 for interrupt
vendor 0x108e product 0x1000 (class bridge subclass
miscellaneous, rev 0x01) at pci3 dev 3 function 0 not
configured
hme3 at pci3 dev 3 function 1 vendor 0x108e product
0x1001 rev 0x01: address 00:03:ba:34:82:5b
luphy3 at hme3 phy 1: LU6612 10/100 PHY, rev. 1
hme3: using ivec 3015 for interrupt
pcons at mainbus0 not configured
No counter-timer -- using %tick at 648MHz as system
clock.
rd0: fixed, 6144 blocks
=================================================================

I have not idea on what to do next,

the above cd0, recognized by bsd, is not usable before
bsd is loaded, i.e. ok probe-ide shows all 4 devices
as "Not Present" and of cource
ok boot cdrom fails with "Can't open boot device"

Thank you all in advance.
 - chris
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com