strange SMTP interaction with mail.openbsd.org ?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

strange SMTP interaction with mail.openbsd.org ?

Leen Besselink-6
Hi,

Recently we've set up a Postfix mailserver with TLS (valid Let's Encrypt
certificate).

So I was checking the logs and I saw mail.openbsd.org connected and
disconnected but strange enough did not deliver any mail:

Sep  6 21:47:13 mx5 postfix/smtpd[938]: connect from
mail.openbsd.org[199.185.178.25]
Sep  6 21:47:14 mx5 postfix/smtpd[938]: Anonymous TLS connection
established from mail.openbsd.org[199.185.178.25]: TLSv1.2 with cipher
ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
Sep  6 21:47:15 mx5 postfix/smtpd[938]: disconnect from
mail.openbsd.org[199.185.178.25] ehlo=2 starttls=1 quit=1 commands=4

When I checked on the other server, it seems mail.openbsd.org probably
tried to deliver '[hidden email]'.

The name in the MX-record matches the forward and reverse DNS, the
HELO/EHLO name and certificate.

Any idea what could have happened ?(or maybe how to contact the
person(s) running mail.openbsd.org)

With kind regards,

  Leen.

Reply | Threaded
Open this post in threaded view
|

Re: strange SMTP interaction with mail.openbsd.org ?

Edgar Pettijohn III-2
On Sep 6, 2020 4:24 PM, Leen Besselink <[hidden email]> wrote:

  Hi,

  Recently we've set up a Postfix mailserver with TLS (valid Let's
  Encrypt
  certificate).

  So I was checking the logs and I saw mail.openbsd.org connected and
  disconnected but strange enough did not deliver any mail:

  Sep  6 21:47:13 mx5 postfix/smtpd[938]: connect from
  mail.openbsd.org[199.185.178.25]
  Sep  6 21:47:14 mx5 postfix/smtpd[938]: Anonymous TLS connection
  established from mail.openbsd.org[199.185.178.25]: TLSv1.2 with
  cipher
  ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
  Sep  6 21:47:15 mx5 postfix/smtpd[938]: disconnect from
  mail.openbsd.org[199.185.178.25] ehlo=2 starttls=1 quit=1 commands=4

  When I checked on the other server, it seems mail.openbsd.org
  probably
  tried to deliver '[hidden email]'.

  The name in the MX-record matches the forward and reverse DNS, the
  HELO/EHLO name and certificate.

  Any idea what could have happened ?(or maybe how to contact the
  person(s) running mail.openbsd.org)

  With kind regards,

   Leen.

Have you tried [hidden email]?
Reply | Threaded
Open this post in threaded view
|

Re: strange SMTP interaction with mail.openbsd.org ?

Claus Assmann-4
In reply to this post by Leen Besselink-6
On Sun, Sep 06, 2020, Leen Besselink wrote:

> So I was checking the logs and I saw mail.openbsd.org connected and
> disconnected but strange enough did not deliver any mail:

I noticed something similar and asked on misc at opensmtpd.org

  Date: Sat, 16 May 2020 12:20:35 +0200
  Subject: design or error: no transaction started by opensmtpd
  Message-ID: <[hidden email]>

but nobody replied.

--
Address is valid for this mailing list only, please do not reply
to it direcly, but to the list.

Reply | Threaded
Open this post in threaded view
|

Re: strange SMTP interaction with mail.openbsd.org ?

Leen Besselink-6

On 07-09-2020 06:53, Claus Assmann wrote:

> On Sun, Sep 06, 2020, Leen Besselink wrote:
>
>> So I was checking the logs and I saw mail.openbsd.org connected and
>> disconnected but strange enough did not deliver any mail:
> I noticed something similar and asked on misc at opensmtpd.org
>
>    Date: Sat, 16 May 2020 12:20:35 +0200
>    Subject: design or error: no transaction started by opensmtpd
>    Message-ID: <[hidden email]>
>
> but nobody replied.
>
Thanks for your reply ! Good to know I'm not the only one. :-)

Based on the Postfix logs, it looks to me like it does only does:

EHLO, STARTTLS, EHLO and QUIT.

I've enabled debug in Postfix for the IP of mail.openbsd.org but very
likely just show what I just mentioned.

So most likely their is something in the EHLO which scares off the
mail.openbsd.org

Only difference I see between the 2 mailservers I'm using for this
domain for the EHLO is the one that doesn't receive the mail announced
it supports CHUNKING

Which I've now turned off to be announced in the EHLO

Let's see what happens...


Reply | Threaded
Open this post in threaded view
|

Re: strange SMTP interaction with mail.openbsd.org ?

Leen Besselink-6

On 07-09-2020 09:41, Leen Besselink wrote:

>
> On 07-09-2020 06:53, Claus Assmann wrote:
>> On Sun, Sep 06, 2020, Leen Besselink wrote:
>>
>>> So I was checking the logs and I saw mail.openbsd.org connected and
>>> disconnected but strange enough did not deliver any mail:
>> I noticed something similar and asked on misc at opensmtpd.org
>>
>>    Date: Sat, 16 May 2020 12:20:35 +0200
>>    Subject: design or error: no transaction started by opensmtpd
>>    Message-ID: <[hidden email]>
>>
>> but nobody replied.
>>
> Thanks for your reply ! Good to know I'm not the only one. :-)
>
> Based on the Postfix logs, it looks to me like it does only does:
>
> EHLO, STARTTLS, EHLO and QUIT.
>
> I've enabled debug in Postfix for the IP of mail.openbsd.org but very
> likely just show what I just mentioned.
>
> So most likely their is something in the EHLO which scares off the
> mail.openbsd.org
>
> Only difference I see between the 2 mailservers I'm using for this
> domain for the EHLO is the one that doesn't receive the mail announced
> it supports CHUNKING
>
> Which I've now turned off to be announced in the EHLO
>
> Let's see what happens...
>
>
OK, with CHUNKING not mentioned in the EHLO mail did arrive, so I turned
it back on.


Reply | Threaded
Open this post in threaded view
|

Re: strange SMTP interaction with mail.openbsd.org ?

Leen Besselink-6

On 07-09-2020 09:48, Leen Besselink wrote:

>
> On 07-09-2020 09:41, Leen Besselink wrote:
>>
>> On 07-09-2020 06:53, Claus Assmann wrote:
>>> On Sun, Sep 06, 2020, Leen Besselink wrote:
>>>
>>>> So I was checking the logs and I saw mail.openbsd.org connected and
>>>> disconnected but strange enough did not deliver any mail:
>>> I noticed something similar and asked on misc at opensmtpd.org
>>>
>>>    Date: Sat, 16 May 2020 12:20:35 +0200
>>>    Subject: design or error: no transaction started by opensmtpd
>>>    Message-ID: <[hidden email]>
>>>
>>> but nobody replied.
>>>
>> Thanks for your reply ! Good to know I'm not the only one. :-)
>>
>> Based on the Postfix logs, it looks to me like it does only does:
>>
>> EHLO, STARTTLS, EHLO and QUIT.
>>
>> I've enabled debug in Postfix for the IP of mail.openbsd.org but very
>> likely just show what I just mentioned.
>>
>> So most likely their is something in the EHLO which scares off the
>> mail.openbsd.org
>>
>> Only difference I see between the 2 mailservers I'm using for this
>> domain for the EHLO is the one that doesn't receive the mail
>> announced it supports CHUNKING
>>
>> Which I've now turned off to be announced in the EHLO
>>
>> Let's see what happens...
>>
>>
> OK, with CHUNKING not mentioned in the EHLO mail did arrive, so I
> turned it back on.
>
>
So I just got confirmation, when CHUNKING is in the EHLO then it will do
STARTTLS, but after a second EHLO it will notice the CHUNKING and just QUIT.

My guess is this is a bug/misconfiguration.

I'll try to contact [hidden email] and see what happens.


Reply | Threaded
Open this post in threaded view
|

Re: strange SMTP interaction with mail.openbsd.org ?

Claus Assmann-4
On Mon, Sep 07, 2020, Leen Besselink wrote:

> So I just got confirmation, when CHUNKING is in the EHLO then it will do
> STARTTLS, but after a second EHLO it will notice the CHUNKING and just QUIT.

Interesting... but unfortunately that's not the problem I am seeing
- my server does not offer CHUNKING and the "drops" seem to be random
(maybe some artifact of the scheduling in smtpd?)

--
Address is valid for this mailing list only, please do not reply
to it direcly, but to the list.

Reply | Threaded
Open this post in threaded view
|

Re: strange SMTP interaction with mail.openbsd.org ?

Leen Besselink-6

On 08-09-2020 10:30, Claus Assmann wrote:
> On Mon, Sep 07, 2020, Leen Besselink wrote:
>
>> So I just got confirmation, when CHUNKING is in the EHLO then it will do
>> STARTTLS, but after a second EHLO it will notice the CHUNKING and just QUIT.
> Interesting... but unfortunately that's not the problem I am seeing
> - my server does not offer CHUNKING and the "drops" seem to be random
> (maybe some artifact of the scheduling in smtpd?)
>
Seems you are right.

I waited longer now and CHUNKING is not in the EHLO banner, but I do see
QUiT again without sending any emails.

So even though I had turned it off and on a couple of times, it was
probably just a coincidence.


Reply | Threaded
Open this post in threaded view
|

Re: strange SMTP interaction with mail.openbsd.org ?

Claus Assmann-4
On Fri, Sep 11, 2020, Leen Besselink wrote:

> I waited longer now and CHUNKING is not in the EHLO banner, but I do see
> QUiT again without sending any emails.

> So even though I had turned it off and on a couple of times, it was probably
> just a coincidence.

Did you get an answer from postmaster@?

It would be interesting to know what is going on.

--
Address is valid for this mailing list only, please do not reply
to it direcly, but to the list.