squid низкая скорость

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

squid низкая скорость

mitrofanzzz
Добрый день уважаемый All.
Подскажите пожалуйста, никак не могу понять почему так медленно работает
сквид.
Пробовал крутить настройки кеша, не влияет абсолютно, машина долго
думает перед запросом авторизации, и после него еще столько же.
Причем ближе к вечеру когда нагрузка на прокси падает, задержки
исчезают...
Дмесдж и конфиг сквида прилагаю. Подскажите куда смотреть. За ранее
благодарен...
дмесдж:
# dmesg
OpenBSD 4.4 (GENERIC) #1021: Tue Aug 12 17:16:55 MDT 2008
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: VIA Samuel 2 ("CentaurHauls" 686-class) 797 MHz
cpu0: FPU,DE,TSC,MSR,MTRR,PGE,MMX
real mem  = 502820864 (479MB)
avail mem = 477704192 (455MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 08/19/04, BIOS32 rev. 0 @ 0xfdad0,
SMBIOS rev. 2.3 @ 0xf0630 (24 entries)
bios0: vendor American Megatrends Inc. version "Version 07.00T" date
04/02/01
bios0: ECS M789CG
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
acpi at bios0 function 0x0 not configured
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xf79a0/144 (7 entries)
pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT8235 ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x7e00 0xc8000/0x3000!
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT8623 PCI" rev 0x00
ppb0 at pci0 dev 1 function 0 "VIA VT8633 AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "VIA CLE266" rev 0x03
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
agp0 at vga1: v2, aperture at 0xe0000000, size 0xe800000
drm at vga1 unsupported
wb0 at pci0 dev 9 function 0 "Compex RL100-ATX 10/100" rev 0x00: irq 10,
address 00:80:48:b6:bf:40
sqphy0 at wb0 phy 1: Seeq 80225 10/100 PHY, rev. 0
viapm0 at pci0 dev 17 function 0 "VIA VT8235 ISA" rev 0x00
iic0 at viapm0
spdmem0 at iic0 addr 0x50: 256MB DDR SDRAM non-parity PC2100CL2.5
spdmem1 at iic0 addr 0x51: 256MB DDR SDRAM non-parity PC3200CL3.0
pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA133,
channel 0 configured to compatibility, channel 1 configured to
compatibility
wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALLlct20 20>
wd0: 8-sector PIO, LBA, 19470MB, 39876480 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
pciide0: channel 1 disabled (no drives)
vr0 at pci0 dev 18 function 0 "VIA RhineII-2" rev 0x74: irq 11, address
00:16:ec:9c:68:1f
ukphy0 at vr0 phy 1: Generic IEEE 802.3u media interface, rev. 10: OUI
0x004063, model 0x0032
isa0 at mainbus0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
it0 at isa0 port 0x2e/2: IT8705F rev 0x03, EC port 0x290
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
biomask f3fd netmask fffd ttymask ffff
softraid0 at root
wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
0 tn 0 sn 0), retrying
wd0: transfer error, downgrading to Ultra-DMA mode 4
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
0 tn 0 sn 0), retrying
wd0: transfer error, downgrading to Ultra-DMA mode 3
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 3
wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
0 tn 0 sn 0), retrying
wd0: soft error (corrected)
root on wd0a swap on wd0b dump on wd0b
WARNING: / was not properly unmounted

конфиг сквида
auth_param basic program /usr/local/libexec/ncsa_auth
/etc/squid/squid.passwd
auth_param basic children 20
auth_param basic realm Squid proxy-caching web server
auth_param basic credentialsttl 12 hours
auth_param basic casesensitive off

acl all src all
acl manager proto cache_object
acl localhost src 127.0.0.1/8
acl to_localhost dst 127.0.0.0/8
acl localnet src 192.168.0.0/16 # RFC1918 possible internal
network
acl gendir src 192.168.200.156
acl AUTH proxy_auth REQUIRED
acl SSL_ports port 443
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow gendir
http_access allow AUTH localnet
http_access deny all

icp_access allow localnet
icp_access deny all
http_port 3128
hierarchy_stoplist cgi-bin ?
cache_dir ufs /var/squid/cache 16 4 16
access_log /var/squid/logs/access.log squid
cache_store_log none
url_rewrite_program /usr/local/bin/squidGuard
url_rewrite_children 20
url_rewrite_access deny localhost
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
refresh_pattern . 0 20% 4320
acl apache rep_header Server ^Apache
broken_vary_encoding allow apache
cache_mgr [hidden email]
cache_effective_user _squid
cache_effective_group _squid
dns_nameservers 62.213.7.190 192.168.200.3 62.213.0.2

Все ставилось как есть с офф. сервера. Никаких самосборок и
перекомпиляций...
Друзья, соратники... Спасите...
--
С уважением Сохин Никита Александрович...


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

Grigoriy Orlov
> cache_dir ufs /var/squid/cache 16 4 16

A для чего ты используешь squid, если у тебя размер дискового
кеш 16MB ? Такая конфигурация может быть полезна для одной машины
сидящей на модеме 28kbit.

        /gluk

On Fri, Jul 03, 2009 at 11:54:36AM +0400, mitrofanzzz wrote:

> Добрый день уважаемый All.
> Подскажите пожалуйста, никак не могу понять почему так медленно работает
> сквид.
> Пробовал крутить настройки кеша, не влияет абсолютно, машина долго
> думает перед запросом авторизации, и после него еще столько же.
> Причем ближе к вечеру когда нагрузка на прокси падает, задержки
> исчезают...
> Дмесдж и конфиг сквида прилагаю. Подскажите куда смотреть. За ранее
> благодарен...
> дмесдж:
> # dmesg
> OpenBSD 4.4 (GENERIC) #1021: Tue Aug 12 17:16:55 MDT 2008
>    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
> cpu0: VIA Samuel 2 ("CentaurHauls" 686-class) 797 MHz
> cpu0: FPU,DE,TSC,MSR,MTRR,PGE,MMX
> real mem  = 502820864 (479MB)
> avail mem = 477704192 (455MB)
> mainbus0 at root
> bios0 at mainbus0: AT/286+ BIOS, date 08/19/04, BIOS32 rev. 0 @ 0xfdad0,
> SMBIOS rev. 2.3 @ 0xf0630 (24 entries)
> bios0: vendor American Megatrends Inc. version "Version 07.00T" date
> 04/02/01
> bios0: ECS M789CG
> apm0 at bios0: Power Management spec V1.2
> apm0: AC on, battery charge unknown
> acpi at bios0 function 0x0 not configured
> pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
> pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xf79a0/144 (7 entries)
> pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT8235 ISA" rev 0x00)
> pcibios0: PCI bus #1 is the last bus
> bios0: ROM list: 0xc0000/0x7e00 0xc8000/0x3000!
> cpu0 at mainbus0
> pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
> pchb0 at pci0 dev 0 function 0 "VIA VT8623 PCI" rev 0x00
> ppb0 at pci0 dev 1 function 0 "VIA VT8633 AGP" rev 0x00
> pci1 at ppb0 bus 1
> vga1 at pci1 dev 0 function 0 "VIA CLE266" rev 0x03
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> agp0 at vga1: v2, aperture at 0xe0000000, size 0xe800000
> drm at vga1 unsupported
> wb0 at pci0 dev 9 function 0 "Compex RL100-ATX 10/100" rev 0x00: irq 10,
> address 00:80:48:b6:bf:40
> sqphy0 at wb0 phy 1: Seeq 80225 10/100 PHY, rev. 0
> viapm0 at pci0 dev 17 function 0 "VIA VT8235 ISA" rev 0x00
> iic0 at viapm0
> spdmem0 at iic0 addr 0x50: 256MB DDR SDRAM non-parity PC2100CL2.5
> spdmem1 at iic0 addr 0x51: 256MB DDR SDRAM non-parity PC3200CL3.0
> pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA133,
> channel 0 configured to compatibility, channel 1 configured to
> compatibility
> wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALLlct20 20>
> wd0: 8-sector PIO, LBA, 19470MB, 39876480 sectors
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
> pciide0: channel 1 disabled (no drives)
> vr0 at pci0 dev 18 function 0 "VIA RhineII-2" rev 0x74: irq 11, address
> 00:16:ec:9c:68:1f
> ukphy0 at vr0 phy 1: Generic IEEE 802.3u media interface, rev. 10: OUI
> 0x004063, model 0x0032
> isa0 at mainbus0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> it0 at isa0 port 0x2e/2: IT8705F rev 0x03, EC port 0x290
> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
> biomask f3fd netmask fffd ttymask ffff
> softraid0 at root
> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
> 0 tn 0 sn 0), retrying
> wd0: transfer error, downgrading to Ultra-DMA mode 4
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
> 0 tn 0 sn 0), retrying
> wd0: transfer error, downgrading to Ultra-DMA mode 3
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 3
> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
> 0 tn 0 sn 0), retrying
> wd0: soft error (corrected)
> root on wd0a swap on wd0b dump on wd0b
> WARNING: / was not properly unmounted
>
> конфиг сквида
> auth_param basic program /usr/local/libexec/ncsa_auth
> /etc/squid/squid.passwd
> auth_param basic children 20
> auth_param basic realm Squid proxy-caching web server
> auth_param basic credentialsttl 12 hours
> auth_param basic casesensitive off
>
> acl all src all
> acl manager proto cache_object
> acl localhost src 127.0.0.1/8
> acl to_localhost dst 127.0.0.0/8
> acl localnet src 192.168.0.0/16 # RFC1918 possible internal
> network
> acl gendir src 192.168.200.156
> acl AUTH proxy_auth REQUIRED
> acl SSL_ports port 443
> acl Safe_ports port 80 # http
> acl Safe_ports port 21 # ftp
> acl Safe_ports port 443 # https
> acl Safe_ports port 70 # gopher
> acl Safe_ports port 210 # wais
> acl Safe_ports port 1025-65535 # unregistered ports
> acl Safe_ports port 280 # http-mgmt
> acl Safe_ports port 488 # gss-http
> acl Safe_ports port 591 # filemaker
> acl Safe_ports port 777 # multiling http
> acl CONNECT method CONNECT
>
> http_access allow manager localhost
> http_access deny manager
> http_access deny !Safe_ports
> http_access deny CONNECT !SSL_ports
> http_access allow gendir
> http_access allow AUTH localnet
> http_access deny all
>
> icp_access allow localnet
> icp_access deny all
> http_port 3128
> hierarchy_stoplist cgi-bin ?
> cache_dir ufs /var/squid/cache 16 4 16
> access_log /var/squid/logs/access.log squid
> cache_store_log none
> url_rewrite_program /usr/local/bin/squidGuard
> url_rewrite_children 20
> url_rewrite_access deny localhost
> refresh_pattern ^ftp: 1440 20% 10080
> refresh_pattern ^gopher: 1440 0% 1440
> refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
> refresh_pattern . 0 20% 4320
> acl apache rep_header Server ^Apache
> broken_vary_encoding allow apache
> cache_mgr [hidden email]
> cache_effective_user _squid
> cache_effective_group _squid
> dns_nameservers 62.213.7.190 192.168.200.3 62.213.0.2
>
> Все ставилось как есть с офф. сервера. Никаких самосборок и
> перекомпиляций...
> Друзья, соратники... Спасите...
> --
> С уважением Сохин Никита Александрович...
>
>


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

Anton Maksimenkov-2
In reply to this post by mitrofanzzz
> Подскажите пожалуйста, никак не могу понять почему так медленно работает
> сквид.
Пробовал смотреть в top, systat vmstat, tcpdump, лог сквида и прочее?
--
antonvm
Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

irix
In reply to this post by mitrofanzzz
Hello mitrofanzzz,

Friday, July 3, 2009, 10:54:36 AM, you wrote:

m> Добрый день уважаемый All.
m> Подскажите пожалуйста, никак не могу понять почему так медленно работает
m> сквид.
m> Пробовал крутить настройки кеша, не влияет абсолютно, машина долго
m> думает перед запросом авторизации, и после него еще столько же.
m> Причем ближе к вечеру когда нагрузка на прокси падает, задержки
m> исчезают...
m> Дмесдж и конфиг сквида прилагаю. Подскажите куда смотреть. За ранее
m> благодарен...
m> дмесдж:
m> # dmesg
m> OpenBSD 4.4 (GENERIC) #1021: Tue Aug 12 17:16:55 MDT 2008
m>     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
m> cpu0: VIA Samuel 2 ("CentaurHauls" 686-class) 797 MHz
m> cpu0: FPU,DE,TSC,MSR,MTRR,PGE,MMX
m> real mem  = 502820864 (479MB)
m> avail mem = 477704192 (455MB)
m> mainbus0 at root
m> bios0 at mainbus0: AT/286+ BIOS, date 08/19/04, BIOS32 rev. 0 @ 0xfdad0,
m> SMBIOS rev. 2.3 @ 0xf0630 (24 entries)
m> bios0: vendor American Megatrends Inc. version "Version 07.00T" date
m> 04/02/01
m> bios0: ECS M789CG
m> apm0 at bios0: Power Management spec V1.2
m> apm0: AC on, battery charge unknown
m> acpi at bios0 function 0x0 not configured
m> pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
m> pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xf79a0/144 (7 entries)
m> pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT8235 ISA" rev 0x00)
m> pcibios0: PCI bus #1 is the last bus
m> bios0: ROM list: 0xc0000/0x7e00 0xc8000/0x3000!
m> cpu0 at mainbus0
m> pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
m> pchb0 at pci0 dev 0 function 0 "VIA VT8623 PCI" rev 0x00
m> ppb0 at pci0 dev 1 function 0 "VIA VT8633 AGP" rev 0x00
m> pci1 at ppb0 bus 1
m> vga1 at pci1 dev 0 function 0 "VIA CLE266" rev 0x03
m> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
m> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
m> agp0 at vga1: v2, aperture at 0xe0000000, size 0xe800000
m> drm at vga1 unsupported
m> wb0 at pci0 dev 9 function 0 "Compex RL100-ATX 10/100" rev 0x00: irq 10,
m> address 00:80:48:b6:bf:40
m> sqphy0 at wb0 phy 1: Seeq 80225 10/100 PHY, rev. 0
m> viapm0 at pci0 dev 17 function 0 "VIA VT8235 ISA" rev 0x00
m> iic0 at viapm0
m> spdmem0 at iic0 addr 0x50: 256MB DDR SDRAM non-parity PC2100CL2.5
m> spdmem1 at iic0 addr 0x51: 256MB DDR SDRAM non-parity PC3200CL3.0
m> pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA133,
m> channel 0 configured to compatibility, channel 1 configured to
m> compatibility
m> wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALLlct20 20>
m> wd0: 8-sector PIO, LBA, 19470MB, 39876480 sectors
m> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
m> pciide0: channel 1 disabled (no drives)
m> vr0 at pci0 dev 18 function 0 "VIA RhineII-2" rev 0x74: irq 11, address
m> 00:16:ec:9c:68:1f
m> ukphy0 at vr0 phy 1: Generic IEEE 802.3u media interface, rev. 10: OUI
m> 0x004063, model 0x0032
m> isa0 at mainbus0
m> isadma0 at isa0
m> pckbc0 at isa0 port 0x60/5
m> pckbd0 at pckbc0 (kbd slot)
m> pckbc0: using irq 1 for kbd slot
m> wskbd0 at pckbd0: console keyboard, using wsdisplay0
m> pcppi0 at isa0 port 0x61
m> midi0 at pcppi0: <PC speaker>
m> spkr0 at pcppi0
m> it0 at isa0 port 0x2e/2: IT8705F rev 0x03, EC port 0x290
m> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
m> biomask f3fd netmask fffd ttymask ffff
m> softraid0 at root
m> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
m> 0 tn 0 sn 0), retrying
m> wd0: transfer error, downgrading to Ultra-DMA mode 4
m> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
m> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
m> 0 tn 0 sn 0), retrying
m> wd0: transfer error, downgrading to Ultra-DMA mode 3
m> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 3
m> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
m> 0 tn 0 sn 0), retrying
m> wd0: soft error (corrected)
m> root on wd0a swap on wd0b dump on wd0b
m> WARNING: / was not properly unmounted

m> конфиг сквида
m> auth_param basic program /usr/local/libexec/ncsa_auth
m> /etc/squid/squid.passwd
m> auth_param basic children 20
m> auth_param basic realm Squid proxy-caching web server
m> auth_param basic credentialsttl 12 hours
m> auth_param basic casesensitive off

m> acl all src all
m> acl manager proto cache_object
m> acl localhost src 127.0.0.1/8
m> acl to_localhost dst 127.0.0.0/8
m> acl localnet src 192.168.0.0/16      # RFC1918 possible internal
m> network
m> acl gendir src 192.168.200.156
m> acl AUTH proxy_auth REQUIRED
m> acl SSL_ports port 443
m> acl Safe_ports port 80          # http
m> acl Safe_ports port 21          # ftp
m> acl Safe_ports port 443         # https
m> acl Safe_ports port 70          # gopher
m> acl Safe_ports port 210         # wais
m> acl Safe_ports port 1025-65535  # unregistered ports
m> acl Safe_ports port 280         # http-mgmt
m> acl Safe_ports port 488         # gss-http
m> acl Safe_ports port 591         # filemaker
m> acl Safe_ports port 777         # multiling http
m> acl CONNECT method CONNECT

m> http_access allow manager localhost
m> http_access deny manager
m> http_access deny !Safe_ports
m> http_access deny CONNECT !SSL_ports
m> http_access allow gendir
m> http_access allow AUTH localnet
m> http_access deny all

m> icp_access allow localnet
m> icp_access deny all
m> http_port 3128
m> hierarchy_stoplist cgi-bin ?
m> cache_dir ufs /var/squid/cache 16 4 16
m> access_log /var/squid/logs/access.log squid
m> cache_store_log none
m> url_rewrite_program /usr/local/bin/squidGuard
m> url_rewrite_children 20
m> url_rewrite_access deny localhost
m> refresh_pattern ^ftp:           1440    20%     10080
m> refresh_pattern ^gopher:        1440    0%      1440
m> refresh_pattern -i (/cgi-bin/|\?) 0     0%      0
m> refresh_pattern .               0       20%     4320
m> acl apache rep_header Server ^Apache
m> broken_vary_encoding allow apache
m> cache_mgr [hidden email]
m> cache_effective_user _squid
m> cache_effective_group _squid
m> dns_nameservers 62.213.7.190 192.168.200.3 62.213.0.2

m> Все ставилось как есть с офф. сервера. Никаких самосборок и
m> перекомпиляций...
m> Друзья, соратники... Спасите...
m> --
m> С уважением Сохин Никита Александрович...





Что-то мне подсказывает что у тебя винт скоро поломаеться :)
Пройдись по винту MHDD программой
Может у тебя уже винт сыпаться начал

Скорее всего из-за этого проблемы

wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
0 tn 0 sn 0), retrying
wd0: transfer error, downgrading to Ultra-DMA mode 4
 wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
 wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
0 tn 0 sn 0), retrying
wd0: transfer error, downgrading to Ultra-DMA mode 3
 wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 3
wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0; cn
 0 tn 0 sn 0), retrying
 wd0: soft error (corrected)

--
Best regards,
 irix                            mailto:[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

mitrofanzzz
In reply to this post by mitrofanzzz
> cache_dir ufs /var/squid/cache 16 4 16

A для чего ты используешь squid, если у тебя размер дискового
кеш 16MB ? Такая конфигурация может быть полезна для одной машины
сидящей на модеме 28kbit.

        /gluk

Изначально стояли умолчальные 100 мБ, потом задумался над кешем.
Машина древняя места на диске мало, не разгуляешься...

to irix
благодарю за наводку, проглядел сообщение из dmesg об ошибках...
хотя после загрузки на винчестер не ругается...
--
С уважением Сохин Никита Александрович...


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

Grigoriy Orlov
On Fri, Jul 03, 2009 at 03:48:57PM +0400, mitrofanzzz wrote:
> to irix
> благодарю за наводку, проглядел сообщение из dmesg об ошибках...
> хотя после загрузки на винчестер не ругается...

Система несколько раз сделала downgrade transfer mode, причем еще в
процессе загрузки. Потом как я понял ошибок не было. Это очень похоже
на использование 40-ка жильного кабеля для UDMA-33.  Еще могут
быть плохие контакты или плохой кабель. Ну и конечно сам винт уже
в пенсионном возрасте.

        /gluk


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

Kirill Bychkov-2
у меня такое было со старыми хардами вне зависимости от шлейфа.
подобные квантумы и их последователей в виде максторов я давно отпел.
с древними сигейтами, самсунгами и вестернами таких ошибок ни разу не видел.
смею предположить, что это некие "приколы" квантумов/максторов.

я бы рекомендовал сменить винт на что-нибудь свежее и живое.
перед сменой погонять что-нибудь на машине и определить её производительность.
глянуть хотя бы на тот же systat. ну и после смены посмотреть на
производительность.


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

mitrofanzzz
In reply to this post by mitrofanzzz
Согласен что диск следует заменить. Но в dmesg во время работы не падает
сообщений об ошибках.
Следовательно, ИМХО, дисковая подсистема работает стабильно.
Сегодня, максимум завтра пересажу систему на новый диск, возможно это
исправит ситуацию.
Если нет то вариантов больше придумать не могу...
Так же отмечу, что в top, systat  и логах машины ошибок и чрезмерных
нагрузок не наблюдается...

--
С уважением Сохин Никита Александрович...


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

irix
Hello mitrofanzzz,

Monday, July 6, 2009, 11:20:30 AM, you wrote:

m> Согласен что диск следует заменить. Но в dmesg во время работы не падает
m> сообщений об ошибках.
m> Следовательно, ИМХО, дисковая подсистема работает стабильно.
m> Сегодня, максимум завтра пересажу систему на новый диск, возможно это
m> исправит ситуацию.
m> Если нет то вариантов больше придумать не могу...
m> Так же отмечу, что в top, systat  и логах машины ошибок и чрезмерных
m> нагрузок не наблюдается...

m> --
m> С уважением Сохин Никита Александрович...



Попробуй  ещё  на  винте  при  монтировании  раздела  с  кэшем указать
softdep, может быть поможет :)



--
Best regards,
 irix                            mailto:[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

Anton Maksimenkov-2
> Попробуй  ещё  на  винте  при  монтировании  раздела  с  кэшем указать
> softdep, может быть поможет :)

тогда уж и noatime
--
antonvm
Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

Пальянов Иван Владимирович
In reply to this post by mitrofanzzz
mitrofanzzz пишет:

> Добрый день уважаемый All.
> Подскажите пожалуйста, никак не могу понять почему так медленно
> работает сквид.
> Пробовал крутить настройки кеша, не влияет абсолютно, машина долго
> думает перед запросом авторизации, и после него еще столько же.
> Причем ближе к вечеру когда нагрузка на прокси падает, задержки
> исчезают...
> Дмесдж и конфиг сквида прилагаю. Подскажите куда смотреть. За ранее
> благодарен...
> дмесдж:
> # dmesg
> OpenBSD 4.4 (GENERIC) #1021: Tue Aug 12 17:16:55 MDT 2008
>    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
> cpu0: VIA Samuel 2 ("CentaurHauls" 686-class) 797 MHz
> cpu0: FPU,DE,TSC,MSR,MTRR,PGE,MMX
> real mem  = 502820864 (479MB)
> avail mem = 477704192 (455MB)
> mainbus0 at root
> bios0 at mainbus0: AT/286+ BIOS, date 08/19/04, BIOS32 rev. 0 @
> 0xfdad0, SMBIOS rev. 2.3 @ 0xf0630 (24 entries)
> bios0: vendor American Megatrends Inc. version "Version 07.00T" date
> 04/02/01
> bios0: ECS M789CG
> apm0 at bios0: Power Management spec V1.2
> apm0: AC on, battery charge unknown
> acpi at bios0 function 0x0 not configured
> pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
> pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xf79a0/144 (7 entries)
> pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT8235 ISA" rev 0x00)
> pcibios0: PCI bus #1 is the last bus
> bios0: ROM list: 0xc0000/0x7e00 0xc8000/0x3000!
> cpu0 at mainbus0
> pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
> pchb0 at pci0 dev 0 function 0 "VIA VT8623 PCI" rev 0x00
> ppb0 at pci0 dev 1 function 0 "VIA VT8633 AGP" rev 0x00
> pci1 at ppb0 bus 1
> vga1 at pci1 dev 0 function 0 "VIA CLE266" rev 0x03
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> agp0 at vga1: v2, aperture at 0xe0000000, size 0xe800000
> drm at vga1 unsupported
> wb0 at pci0 dev 9 function 0 "Compex RL100-ATX 10/100" rev 0x00: irq
> 10, address 00:80:48:b6:bf:40
> sqphy0 at wb0 phy 1: Seeq 80225 10/100 PHY, rev. 0
> viapm0 at pci0 dev 17 function 0 "VIA VT8235 ISA" rev 0x00
> iic0 at viapm0
> spdmem0 at iic0 addr 0x50: 256MB DDR SDRAM non-parity PC2100CL2.5
> spdmem1 at iic0 addr 0x51: 256MB DDR SDRAM non-parity PC3200CL3.0
> pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA133,
> channel 0 configured to compatibility, channel 1 configured to
> compatibility
> wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALLlct20 20>
> wd0: 8-sector PIO, LBA, 19470MB, 39876480 sectors
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
> pciide0: channel 1 disabled (no drives)
> vr0 at pci0 dev 18 function 0 "VIA RhineII-2" rev 0x74: irq 11,
> address 00:16:ec:9c:68:1f
> ukphy0 at vr0 phy 1: Generic IEEE 802.3u media interface, rev. 10: OUI
> 0x004063, model 0x0032
> isa0 at mainbus0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> it0 at isa0 port 0x2e/2: IT8705F rev 0x03, EC port 0x290
> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
> biomask f3fd netmask fffd ttymask ffff
> softraid0 at root
> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0;
> cn 0 tn 0 sn 0), retrying
> wd0: transfer error, downgrading to Ultra-DMA mode 4
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0;
> cn 0 tn 0 sn 0), retrying
> wd0: transfer error, downgrading to Ultra-DMA mode 3
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 3
> wd0c: aborted command, interface CRC error reading fsbn 0 (wd0 bn 0;
> cn 0 tn 0 sn 0), retrying
> wd0: soft error (corrected)
> root on wd0a swap on wd0b dump on wd0b
> WARNING: / was not properly unmounted
>
> конфиг сквида
> auth_param basic program /usr/local/libexec/ncsa_auth
> /etc/squid/squid.passwd
> auth_param basic children 20
> auth_param basic realm Squid proxy-caching web server
> auth_param basic credentialsttl 12 hours
> auth_param basic casesensitive off
>
> acl all src all
> acl manager proto cache_object
> acl localhost src 127.0.0.1/8
> acl to_localhost dst 127.0.0.0/8
> acl localnet src 192.168.0.0/16    # RFC1918 possible internal network
> acl gendir src 192.168.200.156
> acl AUTH proxy_auth REQUIRED
> acl SSL_ports port 443
> acl Safe_ports port 80        # http
> acl Safe_ports port 21        # ftp
> acl Safe_ports port 443        # https
> acl Safe_ports port 70        # gopher
> acl Safe_ports port 210        # wais
> acl Safe_ports port 1025-65535    # unregistered ports
> acl Safe_ports port 280        # http-mgmt
> acl Safe_ports port 488        # gss-http
> acl Safe_ports port 591        # filemaker
> acl Safe_ports port 777        # multiling http
> acl CONNECT method CONNECT
>
> http_access allow manager localhost
> http_access deny manager
> http_access deny !Safe_ports
> http_access deny CONNECT !SSL_ports
> http_access allow gendir
> http_access allow AUTH localnet
> http_access deny all
>
> icp_access allow localnet
> icp_access deny all
> http_port 3128
> hierarchy_stoplist cgi-bin ?
> cache_dir ufs /var/squid/cache 16 4 16
> access_log /var/squid/logs/access.log squid
> cache_store_log none
> url_rewrite_program /usr/local/bin/squidGuard
> url_rewrite_children 20
> url_rewrite_access deny localhost
> refresh_pattern ^ftp:        1440    20%    10080
> refresh_pattern ^gopher:    1440    0%    1440
> refresh_pattern -i (/cgi-bin/|\?) 0    0%    0
> refresh_pattern .        0    20%    4320
> acl apache rep_header Server ^Apache
> broken_vary_encoding allow apache
> cache_mgr [hidden email]
> cache_effective_user _squid
> cache_effective_group _squid
> dns_nameservers 62.213.7.190 192.168.200.3 62.213.0.2
>
> Все ставилось как есть с офф. сервера. Никаких самосборок и
> перекомпиляций...
> Друзья, соратники... Спасите...
> --
> С уважением Сохин Никита Александрович...
>
>


покажи squid -v
--enable-delay-pools там есть ?
я так помню в OpenBSD опцию отдельно включал эту, между тем как раз без нее не зависимо будешь ты пулы настраивать или delay_parameters -1/-1 укажешь, происходит торможение при обращении хотя бы с двух клиентов.

попробуй собрать из портов с этой опцией.

 

а потом уже кеш крути можно diskd использовать например для ускорения.


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

mitrofanzzz
In reply to this post by mitrofanzzz
Хотите верьте, хотите нет. Но скорость загрузки сегодня целый день на
должном уровне. А я ничего не делал. Озадачен...
Но прокси на более новую машину пересажу...
--
С уважением Сохин Никита Александрович...


Reply | Threaded
Open this post in threaded view
|

Re: squid низкая скорость

Pavel Labushev-3
In reply to this post by Anton Maksimenkov-2
Anton Maksimenkov пишет:
>> Попробуй  ещё  на  винте  при  монтировании  раздела  с  кэшем указать
>> softdep, может быть поможет :)
>>    
>
> тогда уж и noatime
>  
Я бы еще проверил, как оно живёт с кэшем на рамдиске, чтобы не
устраивать преждевременных шаманств вокруг винта (вдруг дело не в нём).