snapshot kernel boot problem on laptop (Thinkpad 390X)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

snapshot kernel boot problem on laptop (Thinkpad 390X)

Joost-2
I could not use sendbug, so i will cut&paste the message

To: [hidden email]
Subject: snapshot kernel boot problem on laptop
From: [hidden email]
Cc:
Reply-To: [hidden email]
X-sendbug-version: 3.97


>Submitter-Id:  net
>Originator:    Joost Lammers
>Organization:  home
>Synopsis:      snapshot kernel not booting on laptop, iic problem
>Severity:      critical
>Priority:      high
>Category:      kernel
>Class:         sw-bug
>Release:       OpenBSD 3.8-current (GENERIC) #529: Thu Dec 29 13:39:24 MST 2005
>Environment:

        Machine     : IBM Thinkpad 390X (128MB)
        System      : OpenBSD 3.8
        Architecture: OpenBSD.i386
        Machine     : i386
>Description:
        Systemhang while booting the unchanged snapshot kernel.
        I also downloaded a newer kernel (GENERIC #532:Fri Dec 30
        20:57:40 MST 2005), which had the same problem.

<...last lines before system hang....>
piixpm0 at pci0 dev 2 function 3 "Intel 82371AB Power" rev 0x02: SMI
iic0 at piixpm0
admtemp0 at iic0 addr 0x4e: adm1021
 00=23 01=02 02=28 03=2d 04=2d 05=2d 06=2d 07=2d 08=2d 09=2d 0a=2d 0b=2d
 0c=2d 0d=2d 0e=2d 0f=2d 22=28 40=23 41=02_

after disabling iic I get the next dmesg:

OpenBSD 3.8-current (GENERIC) #529: Thu Dec 29 13:39:24 MST 2005
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Celeron ("GenuineIntel" 686-class, 256KB L2 cache) 398 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem  = 133734400 (130600K)
avail mem = 115343360 (112640K)
using 1658 buffers containing 6791168 bytes (6632K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(e5) BIOS, date 11/24/99, BIOS32 rev. 0 @
0xfd7a0
apm0 at bios0: Power Management spec V1.2
apm0: battery life expectancy 94%
apm0: AC on, battery charge high
apm0: flags 30102 dobusy 0 doidle 1
pcibios0 at bios0: rev 2.1 @ 0xfd7a0/0x860
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdf40/160 (8 entries)
pcibios0: PCI Interrupt Router at 000:02:0 ("Intel 82371FB ISA" rev
0x00)
pcibios0: PCI bus #3 is the last bus
bios0: ROM list: 0xc0000/0xc000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX AGP" rev 0x03
ppb0 at pci0 dev 1 function 0 "Intel 82443BX AGP" rev 0x03
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Neomagic Magicgraph NM2200" rev 0x12
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 2 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
pciide0 at pci0 dev 2 function 1 "Intel 82371AB IDE" rev 0x01: DMA,
channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <HITACHI_DK239A-65>
wd0: 16-sector PIO, LBA, 6194MB, 12685680 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <LG, CD-ROM CRN-8241B, 1.22> SCSI0 5/cdrom
removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
uhci0 at pci0 dev 2 function 2 "Intel 82371AB USB" rev 0x01: irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
piixpm0 at pci0 dev 2 function 3 "Intel 82371AB Power" rev 0x02: SMI
"iic" at piixpm0 not configured
cbb0 at pci0 dev 3 function 0 "Texas Instruments PCI1251B CardBus" rev
0x00: irq 11
cbb1 at pci0 dev 3 function 1 "Texas Instruments PCI1251B CardBus" rev
0x00: irq 11
"AT&T/Lucent LTMODEM" rev 0x01 at pci0 dev 6 function 0 not configured
eso0 at pci0 dev 7 function 0 "ESS SOLO-1 AudioDrive" rev 0x02: ES1946
rev E, irq 5
eso0: mapping Audio 1 DMA using VC I/O space at 0x10d0
audio0 at eso0
opl0 at eso0: model OPL3
midi0 at opl0: <ESO Yamaha OPL3>
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi1 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt2 at isa0 port 0x3bc/4: polled
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
cbb1: bad Vcc request. sock_ctrl 0x0, sock_status 0x30000b20
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 3 device 0 cacheline 0x0, lattimer 0x20
pcmcia1 at cardslot1
biomask efcd netmask efcd ttymask ffcf
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
cbb1: bad Vcc request. sock_ctrl 0x30, sock_status 0x30000b20
dc0 at cardbus1 dev 0 function 0 "Xircom, CardBus Ethernet 10/100 +
Modem 56, CBEM56G" irq 11 address 00:10:a4:e9:3d:97
tqphy0 at dc0 phy 0: 78Q2120 10/100 PHY, rev. 11
pccom3 at cardbus1 dev 0 function 1 "Xircom, CardBus Ethernet 10/100 +
Modem 56, CBEM56G": Xircom CardBus Ethernet 10/100 + Modem 56
pccom3: irq 11,: ns16550a, 16 byte fifo
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302


>How-To-Repeat:
        boot an unchanged snapshot kernel
>Fix:
        workaround: disable iic during boot process, reconfigure kernel
        with config