snapshot installs

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

snapshot installs

Theo de Raadt-2
I'm wondering if anyone doing an install/upgrade has noticed any
behaviour changes in the last week...

There's a secret diff being tested :-)

Reply | Threaded
Open this post in threaded view
|

Re: snapshot installs

Dimitris Papastamos
On Fri, Dec 30, 2016 at 11:30:10AM -0700, Theo de Raadt wrote:
> I'm wondering if anyone doing an install/upgrade has noticed any
> behaviour changes in the last week...
>
> There's a secret diff being tested :-)

i was building from source but just tried a snapshot

is it a scheduler or librthread change? :)

Reply | Threaded
Open this post in threaded view
|

Re: snapshot installs

Ville Valkonen
In reply to this post by Theo de Raadt-2
On Dec 30, 2016 20:32, "Theo de Raadt" <[hidden email]> wrote:

I'm wondering if anyone doing an install/upgrade has noticed any
behaviour changes in the last week...

There's a secret diff being tested :-)


Hello,

so far I haven't noticed anything peculiar. Two or three distinct machines,
two for surfing and one acting as a server.

Obviously quite well hidden and secret diff :)

--
Regards,
Ville
Reply | Threaded
Open this post in threaded view
|

Re: snapshot installs

Benjamin Baier
In reply to this post by Theo de Raadt-2
On Fri, 30 Dec 2016 11:30:10 -0700
Theo de Raadt <[hidden email]> wrote:

> I'm wondering if anyone doing an install/upgrade has noticed any
> behaviour changes in the last week...
Did an auto_upgrade with pre-downloaded sets today. Got curious and did one
normal/manual update again from a mirror. No regressions.

> There's a secret diff being tested :-)
Found it. It's in install.sub in bsd.rd's ramdisk.

Reply | Threaded
Open this post in threaded view
|

Re: snapshot installs

Remco
In reply to this post by Theo de Raadt-2
Op 12/30/16 om 19:30 schreef Theo de Raadt:
> I'm wondering if anyone doing an install/upgrade has noticed any
> behaviour changes in the last week...
>
> There's a secret diff being tested :-)
>
>

Tried an upgrade on a rarely used, roughly two months old, CURRENT system.

Is it related to "wxallowed" ? I noticed it missing on my /usr/local
mount, though I'm not sure it was there before. I think it was, but it
may be an configuration mistake on my CURRENT system.

Anyway my private ports failed to build in my home directory. (seems
like a permission error during "make obj") Building as root, using doas,
worked. Testing a Python script failed with a permission error on "env
/usr/local/bin/python3.4".

Enabled "wxallowed" on /usr/local and the permission problems went away.
(my guess is that this is not what you want to hear as a solution)

Reply | Threaded
Open this post in threaded view
|

Re: snapshot installs

temp+101
In reply to this post by Theo de Raadt-2
Theo de Raadt wrotes:
>
>I'm wondering if anyone doing an install/upgrade has noticed any
>behaviour changes in the last week...

Is it about ftp-ssl?

>
>There's a secret diff being tested :-)
>

Reply | Threaded
Open this post in threaded view
|

Re: snapshot installs

Ted Unangst-6
In reply to this post by Theo de Raadt-2
Theo de Raadt wrote:
> I'm wondering if anyone doing an install/upgrade has noticed any
> behaviour changes in the last week...

Small buglet:
grep /tmp/i/cgiinfo: No such file