Quantcast

security/py-crypto fails if COPTS & CXXOPTS are set in /etc/mk.conf

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

security/py-crypto fails if COPTS & CXXOPTS are set in /etc/mk.conf

Adam Jensen
5.8-stable

security/py-crypto fails to compile if COPTS & CXXOPTS are set in /etc/mk.conf

$ cat /etc/mk.conf                                            
SUDO=/usr/bin/doas
USE_SYSTRACE=No
COPTS="-march=native"
CXXOPTS="-march=native"

$ make
...
copying lib/Crypto/Signature/PKCS1_PSS.py -> /usr/ports/pobj/py-crypto-2.6.1/pycrypto-2.6.1/lib.openbsd-5.8-i386-2.7/Crypto/Signature
running build_ext
running build_configure
building 'Crypto.PublicKey._fastmath' extension
creating /usr/ports/pobj/py-crypto-2.6.1/pycrypto-2.6.1/temp.openbsd-5.8-i386-2.7
creating /usr/ports/pobj/py-crypto-2.6.1/pycrypto-2.6.1/temp.openbsd-5.8-i386-2.7/src
cc -pipe -march=native -fPIC -pipe -I/usr/local/include -march=native -fPIC -std=c99 -O2 -pipe -I/usr/local/include "-march=native" -Isrc/ -I/usr/include/ -I/usr/local/include/python2.7 -c src/_fastmath.c -o /usr/ports/pobj/py-crypto-2.6.1/pycrypto-2.6.1/temp.openbsd-5.8-i386-2.7/src/_fastmath.o
cc: "-march=native": No such file or directory
src/_fastmath.c:1113: warning: C99 inline functions are not supported; using GNU89
src/_fastmath.c:1113: warning: to disable this warning use -fgnu89-inline or the gnu_inline function attribute
error: command 'cc' failed with exit status 1
*** Error 1 in . (/usr/ports/lang/python/python.port.mk:172 'do-build': @: ;mkdir -p /usr/ports/pobj/py-crypto-2.6.1/lib/python2.7/site-pack...)
*** Error 1 in . (/usr/ports/infrastructure/mk/bsd.port.mk:2763 '/usr/ports/pobj/py-crypto-2.6.1/.build_done')
*** Error 1 in /usr/ports/security/py-crypto (/usr/ports/infrastructure/mk/bsd.port.mk:2488 'all')


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: security/py-crypto fails if COPTS & CXXOPTS are set in /etc/mk.conf

Stuart Henderson-6
On 2015/11/27 13:43, Adam Jensen wrote:
> 5.8-stable
>
> security/py-crypto fails to compile if COPTS & CXXOPTS are set in /etc/mk.conf
>
> $ cat /etc/mk.conf                                            
> SUDO=/usr/bin/doas
> USE_SYSTRACE=No
> COPTS="-march=native"
> CXXOPTS="-march=native"

That isn't expected to work.

Loading...