reboot after panic: pool_do_put

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

reboot after panic: pool_do_put

f.holop
>Synopsis: panic: pool_do_put
>Category: kernel
>Environment:
        System      : OpenBSD 5.3
        Details     : OpenBSD 5.3-beta (GENERIC.MP) #29: Thu Feb  7 19:53:06 MST 2013
                         [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP

        Architecture: OpenBSD.i386
        Machine     : i386
>Description:
        feb 7 snapshot, panic while browsing in opera 12.14.

        Feb  9 11:07:23 amaaq /bsd: WARNING: / was not properly unmounted
        Feb  9 11:07:24 amaaq savecore: reboot after panic: pool_do_put
        Feb  9 11:07:24 amaaq savecore: writing core to /var/crash/bsd.2.core
        Feb  9 11:08:10 amaaq savecore: writing kernel to /var/crash/bsd.2

        # gdb
        GNU gdb 6.3
        Copyright 2004 Free Software Foundation, Inc.
        GDB is free software, covered by the GNU General Public License, and you are
        welcome to change it and/or distribute copies of it under certain conditions.
        Type "show copying" to see the conditions.
        There is absolutely no warranty for GDB.  Type "show warranty" for details.
        This GDB was configured as "i386-unknown-openbsd5.3".
        (gdb) file /var/crash/bsd.2
        Reading symbols from /var/crash/bsd.2...(no debugging symbols found)...done.
        (gdb) target kvm /var/crash/bsd.2.core
        #0  0xd0581ce3 in boot ()
        (gdb) where
        #0  0xd0581ce3 in boot ()
        #1  0xd03b5762 in db_boot_crash_cmd ()
        #2  0xd03b5d44 in db_command ()
        #3  0xd03b5f7f in db_command_loop ()
        #4  0xd03b9780 in db_trap ()
        #5  0xd057d2e7 in kdb_trap ()
        #6  0xd058cd07 in trap ()
        #7  0xd0200b85 in alltraps ()
        #8  0xd057d024 in Debugger ()
        #9  0xd0401bfd in panic ()
        #10 0xd03ff44f in pool_do_put ()
        #11 0xd03ff4bf in pool_put ()
        #12 0xd078fd8f in linux_do_futex ()
        #13 0xd078fe42 in linux_sys_futex ()
        #14 0xd058c770 in syscall ()
        #15 0xd0200c47 in Xsyscall ()
        #16 0xf5afdfa8 in ?? ()
        #17 0x4c3a005b in ?? ()
        #18 0xcfbf0063 in ?? ()
        #19 0xcfbf0033 in ?? ()
        #20 0x003d0033 in ?? ()
        #21 0x00000055 in ?? ()
        #22 0x00000000 in ?? ()

>How-To-Repeat:
        use opera for browsing with linux emulation enabled.
>Fix:


dmesg:
OpenBSD 5.3-beta (GENERIC.MP) #29: Thu Feb  7 19:53:06 MST 2013
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Intel(R) Atom(TM) CPU N570 @ 1.66GHz ("GenuineIntel" 686-class) 1.67 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,LONG,SSE3,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,MOVBE,LAHF,PERF
real mem  = 1061818368 (1012MB)
avail mem = 1033461760 (985MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 03/31/10, SMBIOS rev. 2.6 @ 0xeb0f0 (53 entries)
bios0: vendor LENOVO version "50CN12WW" date 04/22/2011
bios0: LENOVO 20109
acpi0 at bios0: rev 3
acpi0: sleep states S0 S1 S3 S4 S5
acpi0: tables DSDT FACP APIC MCFG SLIC HPET
acpi0: wakeup devices P0P8(S4) PS2K(S3) PS2M(S3) EUSB(S3) P0PA(S4) P0PB(S4) P0PC(S4) P0P9(S3) USB0(S3) USB1(S3) USB2(S3) USB3(S3) PWRB(S3) SLPB(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 189MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Atom(TM) CPU N570 @ 1.66GHz ("GenuineIntel" 686-class) 1.90 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,LONG,SSE3,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,MOVBE,LAHF,PERF
cpu2 at mainbus0: apid 2 (application processor)
cpu2: Intel(R) Atom(TM) CPU N570 @ 1.66GHz ("GenuineIntel" 686-class) 1.90 GHz
cpu2: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,LONG,SSE3,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,MOVBE,LAHF,PERF
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Atom(TM) CPU N570 @ 1.66GHz ("GenuineIntel" 686-class) 1.90 GHz
cpu3: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,LONG,SSE3,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,MOVBE,LAHF,PERF
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0 addr 0xf0000000, bus 0-63
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 3 (P0P8)
acpiprt2 at acpi0: bus 2 (P0PA)
acpiprt3 at acpi0: bus -1 (P0PB)
acpiprt4 at acpi0: bus -1 (P0PC)
acpiprt5 at acpi0: bus 1 (P0P9)
acpiec0 at acpi0
acpicpu0 at acpi0:, C3, C2, C1, PSS
acpicpu1 at acpi0:, C3, C2, C1, PSS
acpicpu2 at acpi0:, C3, C2, C1, PSS
acpicpu3 at acpi0:, C3, C2, C1, PSS
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: SLPB
acpibtn2 at acpi0: LID_
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT1 model "LNV-L10C6Y12" serial 004706 type LiIon               oem "CPT-ES3"
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD02
bios0: ROM list: 0xc0000/0xda00! 0xce000/0x1000
cpu0: Enhanced SpeedStep 1896 MHz: speeds: 1667, 1334, 1000 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel Pineview DMI" rev 0x02
vga1 at pci0 dev 2 function 0 "Intel Pineview Video" rev 0x02
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp0 at vga1
agp0 at intagp0: aperture at 0xd0000000, size 0x10000000
inteldrm0 at vga1: apic 4 int 16
drm0 at inteldrm0
"Intel Pineview Video" rev 0x02 at pci0 dev 2 function 1 not configured
azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x02: msi
azalia0: codecs: Realtek ALC269
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x02: apic 4 int 16
pci1 at ppb0 bus 1
re0 at pci1 dev 0 function 0 "Realtek 8101E" rev 0x05: RTL8105E (0x4080), apic 4 int 16, address 50:af:73:14:da:b5
ukphy0 at re0 phy 7: Generic IEEE 802.3u media interface, rev. 2: OUI 0x000732, model 0x0008
ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x02: apic 4 int 17
pci2 at ppb1 bus 2
"Realtek 8188CE" rev 0x01 at pci2 dev 0 function 0 not configured
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x02: apic 4 int 23
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x02: apic 4 int 19
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x02: apic 4 int 18
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x02: apic 4 int 16
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x02: apic 4 int 23
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb2 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xe2
pci3 at ppb2 bus 3
pcib0 at pci0 dev 31 function 0 "Intel NM10 LPC" rev 0x02
ahci0 at pci0 dev 31 function 2 "Intel 82801GR AHCI" rev 0x02: msi, AHCI 1.1
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, HITACHI HTS54323, ES2Z> SCSI3 0/direct fixed naa.5000cca6c7d0d37f
sd0: 305245MB, 512 bytes/sector, 625142448 sectors
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x02: apic 4 int 19
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 1GB DDR3 SDRAM PC3-10600 SO-DIMM
usb1 at uhci0: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb2 at uhci1: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci2: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci3: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
umass0 at uhub0 port 1 configuration 1 interface 0 "Generic USB2.0-CRW" rev 2.00/19.81 addr 2
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd1 at scsibus1 targ 1 lun 0: <Generic-, SD/MMC, 1.00> SCSI0 0/direct removable serial.0bda0119815198100000
sd1: 15096MB, 512 bytes/sector, 30916608 sectors
urndis0 at uhub0 port 6 configuration 1 interface 0 "SEMC SEMC HSUSB Device" rev 2.00/2.26 addr 3
urndis0: using RNDIS, address 42:77:85:55:79:10
uvideo0 at uhub0 port 8 configuration 1 interface 0 "Lenovo Lenovo EasyCamera" rev 2.00/10.22 addr 4
video0 at uvideo0
uhidev0 at uhub1 port 2 configuration 1 interface 0 "Genius 2.4G Wireless Mouse" rev 2.00/5.19 addr 2
uhidev0: iclass 3/1, 5 report ids
ums0 at uhidev0 reportid 1: 3 buttons, Z dir
wsmouse1 at ums0 mux 0
uhid0 at uhidev0 reportid 2: input=1, output=0, feature=0
uhid1 at uhidev0 reportid 3: input=2, output=0, feature=0
uhid2 at uhidev0 reportid 5: input=0, output=0, feature=7
ugen0 at uhub2 port 2 "Cambridge Silicon Radio Bluetooth" rev 2.00/52.76 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (65714a12cd3919f3.a) swap on sd0b dump on sd0b
WARNING: / was not properly unmounted

usbdevs:
Controller /dev/usb0:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000), Intel(0x8086), rev 1.00
 port 1 addr 2: high speed, power 500 mA, config 1, USB2.0-CRW(0x0119), Generic(0x0bda), rev 19.81, iSerialNumber 20090815198100000
 port 2 powered
 port 3 powered
 port 4 powered
 port 5 powered
 port 6 addr 3: high speed, power 500 mA, config 1, SEMC HSUSB Device(0x7168), SEMC(0x0fce), rev 2.26, iSerialNumber 4342354131475A36564B
 port 7 powered
 port 8 addr 4: high speed, power 500 mA, config 1, Lenovo EasyCamera(0x2000), Lenovo(0x1bcf), rev 10.22
Controller /dev/usb1:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000), Intel(0x8086), rev 1.00
 port 1 powered
 port 2 addr 2: low speed, power 100 mA, config 1, 2.4G Wireless Mouse(0x00c8), Genius(0x0458), rev 5.19
Controller /dev/usb2:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000), Intel(0x8086), rev 1.00
 port 1 powered
 port 2 addr 2: full speed, self powered, config 1, Bluetooth(0x0001), Cambridge Silicon Radio(0x0a12), rev 52.76
Controller /dev/usb3:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000), Intel(0x8086), rev 1.00
 port 1 powered
 port 2 powered
Controller /dev/usb4:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000), Intel(0x8086), rev 1.00
 port 1 powered
 port 2 powered

Reply | Threaded
Open this post in threaded view
|

Re: reboot after panic: pool_do_put

Paul Irofti-4
Can you reproduce this consitently?

It would make it easier to debug for me.

Reply | Threaded
Open this post in threaded view
|

Re: reboot after panic: pool_do_put

f.holop
hmm, on Sun, Feb 10, 2013 at 12:04:37PM +0200, Paul Irofti said that
> Can you reproduce this consitently?

i wouldn't say consistently but oftenish.
it just happened again right after i started
up opera again.  but sometimes opera would
keep working long long time before panicing.

no other opera users seeing this?

i can run some more gdb commands on the crash
image if it helps and/or try patches.

-f
--
the cow is a machine which makes grass fit for us people.