re0 issue : system freeze

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

re0 issue : system freeze

Thuban
Hi,
I have an issue on my server : after a while, it seems down and freeze. I have no SSH access because it's offline, I only can reboot it.
Looking in /var/log/messages, I see "/bsd: re0: watchdog timeout".
Instead of replacing the network card, what can I do to solve this issue?

Below more information :

* OpenBSD 6.4 -stable amd64

* Last lines of /var/log/daemon before crash :
Dec 13 23:44:46 ledzep spamd[40106]: 198.71.246.20: disconnected after 433 seconds. lists: spamd-greytrap
Dec 13 23:45:47 ledzep spamd[40106]: 64.90.177.115: connected (1/0)
Dec 13 23:46:00 ledzep spamd[40106]: (GREY) 64.90.177.115: <[hidden email]> -> <[hidden email]>
Dec 13 23:46:00 ledzep spamd[40106]: 64.90.177.115: disconnected after 13 seconds.
Dec 13 23:47:30 ledzep spamd[40106]: 198.71.246.20: connected (1/1), lists: spamd-greytrap
Dec 13 23:47:38 ledzep spamd[40106]: 37.252.72.189: connected (2/2), lists: nixspam
Dec 13 23:47:41 ledzep spamd[40106]: 86.125.112.183: connected (3/3), lists: nixspam
Dec 13 23:47:42 ledzep spamd[40106]: 37.252.72.189: disconnected after 4 seconds. lists: nixspam
Dec 13 23:47:45 ledzep spamd[40106]: 86.125.112.183: disconnected after 4 seconds. lists: nixspam
Dec 13 23:51:41 ledzep spamd[40106]: (BLACK) 198.71.246.20: <[hidden email]> -> <[hidden email]>
Dec 13 23:53:36 ledzep spamd[40106]: 198.71.246.20: From: Matomo Analytics <[hidden email]>
Dec 13 23:53:36 ledzep spamd[40106]: 198.71.246.20: To: [hidden email]
Dec 13 23:53:36 ledzep spamd[40106]: 198.71.246.20: Subject: Matomo Tag Manager now available on Matomo 3.7.0 for free
Dec 13 23:54:48 ledzep spamd[40106]: 198.71.246.20: disconnected after 438 seconds. lists: spamd-greytrap

* Part of /var/log/message around crash time :
Dec 11 23:22:30 ledzep /bsd: re0: watchdog timeout
Dec 11 23:22:31 ledzep bgpd[70451]: neighbor 217.31.80.170: sending notification: HoldTimer expired
Dec 11 23:22:31 ledzep bgpd[70451]: neighbor 64.142.121.62: sending notification: HoldTimer expired
Dec 11 23:30:34 ledzep /bsd: re0: watchdog timeout
Dec 11 23:31:44 ledzep /bsd: re0: watchdog timeout
Dec 11 23:31:44 ledzep bgpd[70451]: neighbor 217.31.80.170: sending notification: HoldTimer expired
Dec 11 23:31:44 ledzep bgpd[70451]: neighbor 64.142.121.62: sending notification: HoldTimer expired
Dec 11 23:36:49 ledzep bgpd[70451]: neighbor 2a00:15a8:0:100:0:d91f:50aa:1: session_connect socket: No buffer space available
Dec 11 23:38:53 ledzep bgpd[70451]: neighbor 2a00:15a8:0:100:0:d91f:50aa:1: session_connect socket: No buffer space available
Dec 11 23:40:57 ledzep bgpd[70451]: neighbor 2a00:15a8:0:100:0:d91f:50aa:1: session_connect socket: No buffer space available
Dec 11 23:45:00 ledzep last message repeated 2 times
Dec 11 23:50:26 ledzep /bsd: re0: watchdog timeout
Dec 11 23:51:03 ledzep bgpd[70451]: neighbor 217.31.80.170: sending notification: HoldTimer expired
Dec 11 23:51:04 ledzep bgpd[70451]: neighbor 64.142.121.62: sending notification: HoldTimer expired
Dec 11 23:51:41 ledzep /bsd: re0: watchdog timeout
Dec 11 23:53:48 ledzep /bsd: re0: watchdog timeout
Dec 11 23:55:05 ledzep bgpd[70451]: neighbor 217.31.80.170: connect: No route to host
Dec 11 23:55:05 ledzep bgpd[70451]: neighbor 64.142.121.62: connect: No route to host
Dec 11 23:57:37 ledzep /bsd: re0: watchdog timeout
Dec 11 23:59:13 ledzep /bsd: re0: watchdog timeout
Dec 12 00:00:38 ledzep last message repeated 2 times
Dec 12 00:01:13 ledzep nsd[87909]: sendto 80.67.169.40 failed: No route to host
Dec 12 00:01:14 ledzep last message repeated 5 times
Dec 12 00:01:35 ledzep bgpd[70451]: neighbor 217.31.80.170: received notification: HoldTimer expired
Dec 12 00:01:36 ledzep bgpd[70451]: neighbor 64.142.121.62: received notification: HoldTimer expired
Dec 12 00:03:16 ledzep /bsd: re0: watchdog timeout
Dec 12 00:05:12 ledzep /bsd: re0: watchdog timeout
Dec 12 00:06:19 ledzep /bsd: re0: watchdog timeout
Dec 12 00:17:32 ledzep last message repeated 7 times
Dec 12 00:21:59 ledzep last message repeated 4 times

* dmesg :
OpenBSD 6.4 (GENERIC.MP) #1: Mon Nov 26 10:18:14 CET 2018
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 2019500032 (1925MB)
avail mem = 1949073408 (1858MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.8 @ 0xebf00 (51 entries)
bios0: vendor American Megatrends Inc. version "F4" date 07/15/2014
bios0: GIGABYTE GB-BXBT-2807
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC FPDT MCFG LPIT HPET SSDT SSDT SSDT UEFI
acpi0: wakeup devices XHC1(S4) PXSX(S4) PXSX(S4) PXSX(S4) PXSX(S4) PWRB(S0) BRCM(S0)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Celeron(R) CPU N2807 @ 1.58GHz, 1583.70 MHz, 06-37-08
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,SMEP,ERMS,SENSOR,ARAT,MELTDOWN
cpu0: 1MB 64b/line 16-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 83MHz
cpu0: mwait min=64, max=64, C-substates=0.2.0.0.0.0.3.3, IBE
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Celeron(R) CPU N2807 @ 1.58GHz, 1583.34 MHz, 06-37-08
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,SMEP,ERMS,SENSOR,ARAT,MELTDOWN
cpu1: 1MB 64b/line 16-way L2 cache
cpu1: smt 0, core 1, package 0
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 20, 87 pins
acpimcfg0 at acpi0
acpimcfg0: addr 0xe0000000, bus 0-255
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (RP01)
acpiprt2 at acpi0: bus 2 (RP02)
acpiprt3 at acpi0: bus 3 (RP03)
acpiprt4 at acpi0: bus 4 (RP04)
acpiec0 at acpi0: not present
acpicpu0 at acpi0: C3(10@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(10@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
acpipwrres0 at acpi0: PLPE
acpipwrres1 at acpi0: PLPE
acpipwrres2 at acpi0: USBC, resource for EHC1, OTG1
acpipwrres3 at acpi0: CLK0, resource for CAM1
acpipwrres4 at acpi0: CLK1, resource for CAM0, CAM2
acpipwrres5 at acpi0: FN00, resource for FAN0
acpitz0 at acpi0: critical temperature is 90 degC
"INT3396" at acpi0 not configured
acpicmos0 at acpi0
"DMA0F28" at acpi0 not configured
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: SLPB
"BCM2E1A" at acpi0 not configured
"BCM4752" at acpi0 not configured
"INTCF0B" at acpi0 not configured
"INTCF1A" at acpi0 not configured
"INTCF1C" at acpi0 not configured
"SMO91D0" at acpi0 not configured
"ATML1000" at acpi0 not configured
"INT33BD" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD1F
cpu0: Enhanced SpeedStep 1583 MHz: speeds: 1578, 1577, 1494, 1411, 1328, 1245, 1162, 1079, 996, 913, 830, 747, 664, 581, 498 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Bay Trail Host" rev 0x0e
inteldrm0 at pci0 dev 2 function 0 "Intel Bay Trail Video" rev 0x0e
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 1024x768, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
ahci0 at pci0 dev 19 function 0 "Intel Bay Trail AHCI" rev 0x0e: msi, AHCI 1.3
ahci0: port 0: 3.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, SAMSUNG HM321HI, 2AJ1> SCSI3 0/direct fixed naa.50024e9204e415d8
sd0: 305245MB, 512 bytes/sector, 625142448 sectors
xhci0 at pci0 dev 20 function 0 "Intel Bay Trail xHCI" rev 0x0e: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
"Intel Bay Trail TXE" rev 0x0e at pci0 dev 26 function 0 not configured
azalia0 at pci0 dev 27 function 0 "Intel Bay Trail HD Audio" rev 0x0e: msi
azalia0: codecs: Realtek/0x0283, 0x0000/0x0000, using Realtek/0x0283
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel Bay Trail PCIE" rev 0x0e: msi
pci1 at ppb0 bus 1
ppb1 at pci0 dev 28 function 1 "Intel Bay Trail PCIE" rev 0x0e: msi
pci2 at ppb1 bus 2
"Realtek 8191SE" rev 0x00 at pci2 dev 0 function 0 not configured
ppb2 at pci0 dev 28 function 2 "Intel Bay Trail PCIE" rev 0x0e: msi
pci3 at ppb2 bus 3
re0 at pci3 dev 0 function 0 "Realtek 8168" rev 0x0c: RTL8168G/8111G (0x4c00), msi, address fc:aa:14:65:5f:86
rgephy0 at re0 phy 7: RTL8251 PHY, rev. 0
ppb3 at pci0 dev 28 function 3 "Intel Bay Trail PCIE" rev 0x0e: msi
pci4 at ppb3 bus 4
pcib0 at pci0 dev 31 function 0 "Intel Bay Trail LPC" rev 0x0e
ichiic0 at pci0 dev 31 function 3 "Intel Bay Trail SMBus" rev 0x0e: apic 1 int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 2GB DDR3 SDRAM PC3-12800 SO-DIMM
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT (using slow L1TF mitigation)
umass0 at uhub0 port 1 configuration 1 interface 0 "Western Digital Ext HDD 1021" rev 2.00/20.21 addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets, initiator 0
sd1 at scsibus2 targ 1 lun 0: <WD, Ext HDD 1021, 2021> SCSI2 0/direct fixed serial.10581021383235373034
sd1: 1907727MB, 512 bytes/sector, 3907024896 sectors
ugen0 at uhub0 port 2 "Realtek Bluetooth Radio" rev 2.10/2.00 addr 3
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
scsibus4 at softraid0: 256 targets
root on sd0a (e0ca6b318b796701.a) swap on sd0b dump on sd0b