radeon driver bug?

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

radeon driver bug?

岡本健二
I'm using AMD HD6450 graphic card which I reported before, and faced a
curious thing
during running Jahshaka Studio (dev version 7.03a).
To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
temporally, which
is not the problem now.

After start to run 'Jahshaka Studio', I got start 3D animation sample
'Skeletal Animation' data to load, then
I got many errors included below which seems to come from radeon drm
driver's bug to me.
If you interested please check it.

Thanks in advance

Kenji

jahshaka (16K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
This errors come from
/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
The mesa version of OpenBSD6.4 is 13.0.6.
I'm running this Jahshaka on Ubutu 18.04, where the mesa version is 18.x.

So, it may be the mesa problem...

Kenji


2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:

> I'm using AMD HD6450 graphic card which I reported before, and faced a
> curious thing
> during running Jahshaka Studio (dev version 7.03a).
> To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
> temporally, which
> is not the problem now.
>
> After start to run 'Jahshaka Studio', I got start 3D animation sample
> 'Skeletal Animation' data to load, then
> I got many errors included below which seems to come from radeon drm
> driver's bug to me.
> If you interested please check it.
>
> Thanks in advance
>
> Kenji
>
>
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

Thomas Frohwein-2
On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]> wrote:

>This errors come from
>/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
>The mesa version of OpenBSD6.4 is 13.0.6.
>I'm running this Jahshaka on Ubutu 18.04, where the mesa version is
>18.x.
>
>So, it may be the mesa problem...
>
>Kenji
>
>
>2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
>
>> I'm using AMD HD6450 graphic card which I reported before, and faced
>a
>> curious thing
>> during running Jahshaka Studio (dev version 7.03a).
>> To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
>> temporally, which
>> is not the problem now.
>>
>> After start to run 'Jahshaka Studio', I got start 3D animation sample
>> 'Skeletal Animation' data to load, then
>> I got many errors included below which seems to come from radeon drm
>> driver's bug to me.
>> If you interested please check it.
>>
>> Thanks in advance
>>
>> Kenji
>>
>>

There's a known bug where the shader on r600 uses too many registers:

https://bugs.freedesktop.org/show_bug.cgi?id=99349

I encountered this bug with godot on a Radeon HD 7570, too, and it went away with the updated mesa that's in -current.

Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
in-current means stable 6.4?

Kenji

2018年12月5日(水) 23:58 [hidden email] <[hidden email]>:

> On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]> wrote:
> >This errors come from
> >/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
> >The mesa version of OpenBSD6.4 is 13.0.6.
> >I'm running this Jahshaka on Ubutu 18.04, where the mesa version is
> >18.x.
> >
> >So, it may be the mesa problem...
> >
> >Kenji
> >
> >
> >2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
> >
> >> I'm using AMD HD6450 graphic card which I reported before, and faced
> >a
> >> curious thing
> >> during running Jahshaka Studio (dev version 7.03a).
> >> To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
> >> temporally, which
> >> is not the problem now.
> >>
> >> After start to run 'Jahshaka Studio', I got start 3D animation sample
> >> 'Skeletal Animation' data to load, then
> >> I got many errors included below which seems to come from radeon drm
> >> driver's bug to me.
> >> If you interested please check it.
> >>
> >> Thanks in advance
> >>
> >> Kenji
> >>
> >>
>
> There's a known bug where the shader on r600 uses too many registers:
>
> https://bugs.freedesktop.org/show_bug.cgi?id=99349
>
> I encountered this bug with godot on a Radeon HD 7570, too, and it went
> away with the updated mesa that's in -current.
>
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
Sorry, I'm a novice to OpenBSD.
Yes, it's current branch of xenocara.
I updated my xenocara (stable) to that current, and build new xenocara here.

Wow, it makes the Jahshaka works!

However, it still has some bugs, because it moves and stop suddenly and then
move again.  Whine the animation stops, the system seems to halting...

Anyway it makes much advance, I included the screenshot of it.

Kenji

PS: sorry tfrohwein, this is doubled to you

2018年12月6日(木) 13:26 岡本健二 <[hidden email]>:

> in-current means stable 6.4?
>
> Kenji
>
> 2018年12月5日(水) 23:58 [hidden email] <[hidden email]>:
>
>> On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]> wrote:
>> >This errors come from
>> >/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
>> >The mesa version of OpenBSD6.4 is 13.0.6.
>> >I'm running this Jahshaka on Ubutu 18.04, where the mesa version is
>> >18.x.
>> >
>> >So, it may be the mesa problem...
>> >
>> >Kenji
>> >
>> >
>> >2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
>> >
>> >> I'm using AMD HD6450 graphic card which I reported before, and faced
>> >a
>> >> curious thing
>> >> during running Jahshaka Studio (dev version 7.03a).
>> >> To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
>> >> temporally, which
>> >> is not the problem now.
>> >>
>> >> After start to run 'Jahshaka Studio', I got start 3D animation sample
>> >> 'Skeletal Animation' data to load, then
>> >> I got many errors included below which seems to come from radeon drm
>> >> driver's bug to me.
>> >> If you interested please check it.
>> >>
>> >> Thanks in advance
>> >>
>> >> Kenji
>> >>
>> >>
>>
>> There's a known bug where the shader on r600 uses too many registers:
>>
>> https://bugs.freedesktop.org/show_bug.cgi?id=99349
>>
>> I encountered this bug with godot on a Radeon HD 7570, too, and it went
>> away with the updated mesa that's in -current.
>>
>

jahshaka.png (347K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
also, it stull has some bugs, because the colors of some
parts are different from those of original ones.

Kenji


2018年12月6日(木) 15:10 岡本健二 <[hidden email]>:

> Sorry, I'm a novice to OpenBSD.
> Yes, it's current branch of xenocara.
> I updated my xenocara (stable) to that current, and build new xenocara
> here.
>
> Wow, it makes the Jahshaka works!
>
> However, it still has some bugs, because it moves and stop suddenly and
> then
> move again.  Whine the animation stops, the system seems to halting...
>
> Anyway it makes much advance, I included the screenshot of it.
>
> Kenji
>
> PS: sorry tfrohwein, this is doubled to you
>
> 2018年12月6日(木) 13:26 岡本健二 <[hidden email]>:
>
>> in-current means stable 6.4?
>>
>> Kenji
>>
>> 2018年12月5日(水) 23:58 [hidden email] <[hidden email]>:
>>
>>> On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]> wrote:
>>> >This errors come from
>>> >/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
>>> >The mesa version of OpenBSD6.4 is 13.0.6.
>>> >I'm running this Jahshaka on Ubutu 18.04, where the mesa version is
>>> >18.x.
>>> >
>>> >So, it may be the mesa problem...
>>> >
>>> >Kenji
>>> >
>>> >
>>> >2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
>>> >
>>> >> I'm using AMD HD6450 graphic card which I reported before, and faced
>>> >a
>>> >> curious thing
>>> >> during running Jahshaka Studio (dev version 7.03a).
>>> >> To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
>>> >> temporally, which
>>> >> is not the problem now.
>>> >>
>>> >> After start to run 'Jahshaka Studio', I got start 3D animation sample
>>> >> 'Skeletal Animation' data to load, then
>>> >> I got many errors included below which seems to come from radeon drm
>>> >> driver's bug to me.
>>> >> If you interested please check it.
>>> >>
>>> >> Thanks in advance
>>> >>
>>> >> Kenji
>>> >>
>>> >>
>>>
>>> There's a known bug where the shader on r600 uses too many registers:
>>>
>>> https://bugs.freedesktop.org/show_bug.cgi?id=99349
>>>
>>> I encountered this bug with godot on a Radeon HD 7570, too, and it went
>>> away with the updated mesa that's in -current.
>>>
>>
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

Chris Bennett-4
In reply to this post by 岡本健二
On Thu, Dec 06, 2018 at 01:26:12PM +0900, 岡本健二 wrote:
> in-current means stable 6.4?
>

No. Look in the FAQ. Look at the running -current page
Look at what release -> stable is.

Run -current only if you need something new, are developing base/ports
or wish to help test the software/hardware being developed.
It is not always stable. It could have new security problems temporarily
before those changes are fixed or pulled out.

However, OpenBSD runs ports and base code as a unit. You cannot run
current without making your current up to date and using the latest
version of ports/packages. Unless you find a nice spot and just stay
there.

OpenBSD is not a jumbled mess of code all over the place. It's one of
many reasons that it has fewer bugs -> better security. Also, security
specific methods are always under active development.

Please read the entire FAQ and PF Guide. Please read all of the man
pages for any commands you need to use or are interested in.

Please learn what you can do with boot -s or boot -c. You will at some
point need to use them. Search the mailing list archives for interesting
topics. Figure out how to handle the filesystem when it gets hosed
during a power failure. Figure out how to arrange your disklabel at
install to let you use growfs.

I also suggest that you learn to use ed. It's not hard to use, but it's
really, really old. It's still actively maintained because it's 100%
worth having.

The command line is so powerful once you learn to use it. We don't want
GUI interfaces for this stuff because we expect you to truly learn what
to do and why.

Have a good day,
Chris Bennett


Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
I'm using acme also on OpenBSD.
I don't know any better editor than that.
Of course, where acme cannot use, such as cui only, I use ed.

Kenji

2018年12月6日(木) 21:38 Chris Bennett <[hidden email]>:

> On Thu, Dec 06, 2018 at 01:26:12PM +0900, 岡本健二 wrote:
> > in-current means stable 6.4?
> >
>
> No. Look in the FAQ. Look at the running -current page
> Look at what release -> stable is.
>
> Run -current only if you need something new, are developing base/ports
> or wish to help test the software/hardware being developed.
> It is not always stable. It could have new security problems temporarily
> before those changes are fixed or pulled out.
>
> However, OpenBSD runs ports and base code as a unit. You cannot run
> current without making your current up to date and using the latest
> version of ports/packages. Unless you find a nice spot and just stay
> there.
>
> OpenBSD is not a jumbled mess of code all over the place. It's one of
> many reasons that it has fewer bugs -> better security. Also, security
> specific methods are always under active development.
>
> Please read the entire FAQ and PF Guide. Please read all of the man
> pages for any commands you need to use or are interested in.
>
> Please learn what you can do with boot -s or boot -c. You will at some
> point need to use them. Search the mailing list archives for interesting
> topics. Figure out how to handle the filesystem when it gets hosed
> during a power failure. Figure out how to arrange your disklabel at
> install to let you use growfs.
>
> I also suggest that you learn to use ed. It's not hard to use, but it's
> really, really old. It's still actively maintained because it's 100%
> worth having.
>
> The command line is so powerful once you learn to use it. We don't want
> GUI interfaces for this stuff because we expect you to truly learn what
> to do and why.
>
> Have a good day,
> Chris Bennett
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
In reply to this post by 岡本健二
I checked mesa-18.3.0 sources under src/gallium/drivers/r600 and compared
with those
of xenocara.  File names are all same, however, individual sizes are very
different for
most of those, which would not permit me to copy those to xenocara...

Kenji


2018年12月6日(木) 15:14 岡本健二 <[hidden email]>:

> also, it stull has some bugs, because the colors of some
> parts are different from those of original ones.
>
> Kenji
>
>
> 2018年12月6日(木) 15:10 岡本健二 <[hidden email]>:
>
>> Sorry, I'm a novice to OpenBSD.
>> Yes, it's current branch of xenocara.
>> I updated my xenocara (stable) to that current, and build new xenocara
>> here.
>>
>> Wow, it makes the Jahshaka works!
>>
>> However, it still has some bugs, because it moves and stop suddenly and
>> then
>> move again.  Whine the animation stops, the system seems to halting...
>>
>> Anyway it makes much advance, I included the screenshot of it.
>>
>> Kenji
>>
>> PS: sorry tfrohwein, this is doubled to you
>>
>> 2018年12月6日(木) 13:26 岡本健二 <[hidden email]>:
>>
>>> in-current means stable 6.4?
>>>
>>> Kenji
>>>
>>> 2018年12月5日(水) 23:58 [hidden email] <[hidden email]>:
>>>
>>>> On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]> wrote:
>>>> >This errors come from
>>>> >/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
>>>> >The mesa version of OpenBSD6.4 is 13.0.6.
>>>> >I'm running this Jahshaka on Ubutu 18.04, where the mesa version is
>>>> >18.x.
>>>> >
>>>> >So, it may be the mesa problem...
>>>> >
>>>> >Kenji
>>>> >
>>>> >
>>>> >2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
>>>> >
>>>> >> I'm using AMD HD6450 graphic card which I reported before, and faced
>>>> >a
>>>> >> curious thing
>>>> >> during running Jahshaka Studio (dev version 7.03a).
>>>> >> To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
>>>> >> temporally, which
>>>> >> is not the problem now.
>>>> >>
>>>> >> After start to run 'Jahshaka Studio', I got start 3D animation sample
>>>> >> 'Skeletal Animation' data to load, then
>>>> >> I got many errors included below which seems to come from radeon drm
>>>> >> driver's bug to me.
>>>> >> If you interested please check it.
>>>> >>
>>>> >> Thanks in advance
>>>> >>
>>>> >> Kenji
>>>> >>
>>>> >>
>>>>
>>>> There's a known bug where the shader on r600 uses too many registers:
>>>>
>>>> https://bugs.freedesktop.org/show_bug.cgi?id=99349
>>>>
>>>> I encountered this bug with godot on a Radeon HD 7570, too, and it went
>>>> away with the updated mesa that's in -current.
>>>>
>>>
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
I installed Ubuntu 18.04 to a AMD 6450 graphic card, and played
Jahshaka.  It has mesa version 18.2, and runs Jahshaka very
smoothly.

The colors I reported before are same in this machine, so that
report was not correct.

Kenji

2018年12月7日(金) 11:09 岡本健二 <[hidden email]>:

> I checked mesa-18.3.0 sources under src/gallium/drivers/r600 and compared
> with those
> of xenocara.  File names are all same, however, individual sizes are very
> different for
> most of those, which would not permit me to copy those to xenocara...
>
> Kenji
>
>
> 2018年12月6日(木) 15:14 岡本健二 <[hidden email]>:
>
>> also, it stull has some bugs, because the colors of some
>> parts are different from those of original ones.
>>
>> Kenji
>>
>>
>> 2018年12月6日(木) 15:10 岡本健二 <[hidden email]>:
>>
>>> Sorry, I'm a novice to OpenBSD.
>>> Yes, it's current branch of xenocara.
>>> I updated my xenocara (stable) to that current, and build new xenocara
>>> here.
>>>
>>> Wow, it makes the Jahshaka works!
>>>
>>> However, it still has some bugs, because it moves and stop suddenly and
>>> then
>>> move again.  Whine the animation stops, the system seems to halting...
>>>
>>> Anyway it makes much advance, I included the screenshot of it.
>>>
>>> Kenji
>>>
>>> PS: sorry tfrohwein, this is doubled to you
>>>
>>> 2018年12月6日(木) 13:26 岡本健二 <[hidden email]>:
>>>
>>>> in-current means stable 6.4?
>>>>
>>>> Kenji
>>>>
>>>> 2018年12月5日(水) 23:58 [hidden email] <[hidden email]>:
>>>>
>>>>> On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]> wrote:
>>>>> >This errors come from
>>>>> >/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
>>>>> >The mesa version of OpenBSD6.4 is 13.0.6.
>>>>> >I'm running this Jahshaka on Ubutu 18.04, where the mesa version is
>>>>> >18.x.
>>>>> >
>>>>> >So, it may be the mesa problem...
>>>>> >
>>>>> >Kenji
>>>>> >
>>>>> >
>>>>> >2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
>>>>> >
>>>>> >> I'm using AMD HD6450 graphic card which I reported before, and faced
>>>>> >a
>>>>> >> curious thing
>>>>> >> during running Jahshaka Studio (dev version 7.03a).
>>>>> >> To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
>>>>> >> temporally, which
>>>>> >> is not the problem now.
>>>>> >>
>>>>> >> After start to run 'Jahshaka Studio', I got start 3D animation
>>>>> sample
>>>>> >> 'Skeletal Animation' data to load, then
>>>>> >> I got many errors included below which seems to come from radeon drm
>>>>> >> driver's bug to me.
>>>>> >> If you interested please check it.
>>>>> >>
>>>>> >> Thanks in advance
>>>>> >>
>>>>> >> Kenji
>>>>> >>
>>>>> >>
>>>>>
>>>>> There's a known bug where the shader on r600 uses too many registers:
>>>>>
>>>>> https://bugs.freedesktop.org/show_bug.cgi?id=99349
>>>>>
>>>>> I encountered this bug with godot on a Radeon HD 7570, too, and it
>>>>> went away with the updated mesa that's in -current.
>>>>>
>>>>
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
I found mesa-libs-18.1.9 for FreeBSD ports.
How can I get it without FreeBSD system?

Kenji


2018年12月8日(土) 14:48 岡本健二 <[hidden email]>:

> I installed Ubuntu 18.04 to a AMD 6450 graphic card, and played
> Jahshaka.  It has mesa version 18.2, and runs Jahshaka very
> smoothly.
>
> The colors I reported before are same in this machine, so that
> report was not correct.
>
> Kenji
>
> 2018年12月7日(金) 11:09 岡本健二 <[hidden email]>:
>
>> I checked mesa-18.3.0 sources under src/gallium/drivers/r600 and compared
>> with those
>> of xenocara.  File names are all same, however, individual sizes are very
>> different for
>> most of those, which would not permit me to copy those to xenocara...
>>
>> Kenji
>>
>>
>> 2018年12月6日(木) 15:14 岡本健二 <[hidden email]>:
>>
>>> also, it stull has some bugs, because the colors of some
>>> parts are different from those of original ones.
>>>
>>> Kenji
>>>
>>>
>>> 2018年12月6日(木) 15:10 岡本健二 <[hidden email]>:
>>>
>>>> Sorry, I'm a novice to OpenBSD.
>>>> Yes, it's current branch of xenocara.
>>>> I updated my xenocara (stable) to that current, and build new xenocara
>>>> here.
>>>>
>>>> Wow, it makes the Jahshaka works!
>>>>
>>>> However, it still has some bugs, because it moves and stop suddenly and
>>>> then
>>>> move again.  Whine the animation stops, the system seems to halting...
>>>>
>>>> Anyway it makes much advance, I included the screenshot of it.
>>>>
>>>> Kenji
>>>>
>>>> PS: sorry tfrohwein, this is doubled to you
>>>>
>>>> 2018年12月6日(木) 13:26 岡本健二 <[hidden email]>:
>>>>
>>>>> in-current means stable 6.4?
>>>>>
>>>>> Kenji
>>>>>
>>>>> 2018年12月5日(水) 23:58 [hidden email] <[hidden email]>:
>>>>>
>>>>>> On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]>
>>>>>> wrote:
>>>>>> >This errors come from
>>>>>> >/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
>>>>>> >The mesa version of OpenBSD6.4 is 13.0.6.
>>>>>> >I'm running this Jahshaka on Ubutu 18.04, where the mesa version is
>>>>>> >18.x.
>>>>>> >
>>>>>> >So, it may be the mesa problem...
>>>>>> >
>>>>>> >Kenji
>>>>>> >
>>>>>> >
>>>>>> >2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
>>>>>> >
>>>>>> >> I'm using AMD HD6450 graphic card which I reported before, and
>>>>>> faced
>>>>>> >a
>>>>>> >> curious thing
>>>>>> >> during running Jahshaka Studio (dev version 7.03a).
>>>>>> >> To run Jahshaka on OpenBSD 6.4 I needed to delete google breakpad
>>>>>> >> temporally, which
>>>>>> >> is not the problem now.
>>>>>> >>
>>>>>> >> After start to run 'Jahshaka Studio', I got start 3D animation
>>>>>> sample
>>>>>> >> 'Skeletal Animation' data to load, then
>>>>>> >> I got many errors included below which seems to come from radeon
>>>>>> drm
>>>>>> >> driver's bug to me.
>>>>>> >> If you interested please check it.
>>>>>> >>
>>>>>> >> Thanks in advance
>>>>>> >>
>>>>>> >> Kenji
>>>>>> >>
>>>>>> >>
>>>>>>
>>>>>> There's a known bug where the shader on r600 uses too many registers:
>>>>>>
>>>>>> https://bugs.freedesktop.org/show_bug.cgi?id=99349
>>>>>>
>>>>>> I encountered this bug with godot on a Radeon HD 7570, too, and it
>>>>>> went away with the updated mesa that's in -current.
>>>>>>
>>>>>
Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

Thomas Frohwein-2
On December 9, 2018 1:22:42 AM UTC, "岡本健二" <[hidden email]> wrote:

>I found mesa-libs-18.1.9 for FreeBSD ports.
>How can I get it without FreeBSD system?
>
>Kenji
>
>
>2018年12月8日(土) 14:48 岡本健二 <[hidden email]>:
>
>> I installed Ubuntu 18.04 to a AMD 6450 graphic card, and played
>> Jahshaka.  It has mesa version 18.2, and runs Jahshaka very
>> smoothly.
>>
>> The colors I reported before are same in this machine, so that
>> report was not correct.
>>
>> Kenji
>>
>> 2018年12月7日(金) 11:09 岡本健二 <[hidden email]>:
>>
>>> I checked mesa-18.3.0 sources under src/gallium/drivers/r600 and
>compared
>>> with those
>>> of xenocara.  File names are all same, however, individual sizes are
>very
>>> different for
>>> most of those, which would not permit me to copy those to
>xenocara...
>>>
>>> Kenji
>>>
>>>
>>> 2018年12月6日(木) 15:14 岡本健二 <[hidden email]>:
>>>
>>>> also, it stull has some bugs, because the colors of some
>>>> parts are different from those of original ones.
>>>>
>>>> Kenji
>>>>
>>>>
>>>> 2018年12月6日(木) 15:10 岡本健二 <[hidden email]>:
>>>>
>>>>> Sorry, I'm a novice to OpenBSD.
>>>>> Yes, it's current branch of xenocara.
>>>>> I updated my xenocara (stable) to that current, and build new
>xenocara
>>>>> here.
>>>>>
>>>>> Wow, it makes the Jahshaka works!
>>>>>
>>>>> However, it still has some bugs, because it moves and stop
>suddenly and
>>>>> then
>>>>> move again.  Whine the animation stops, the system seems to
>halting...
>>>>>
>>>>> Anyway it makes much advance, I included the screenshot of it.
>>>>>
>>>>> Kenji
>>>>>
>>>>> PS: sorry tfrohwein, this is doubled to you
>>>>>
>>>>> 2018年12月6日(木) 13:26 岡本健二 <[hidden email]>:
>>>>>
>>>>>> in-current means stable 6.4?
>>>>>>
>>>>>> Kenji
>>>>>>
>>>>>> 2018年12月5日(水) 23:58 [hidden email]
><[hidden email]>:
>>>>>>
>>>>>>> On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]>
>>>>>>> wrote:
>>>>>>> >This errors come from
>>>>>>>
>>/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
>>>>>>> >The mesa version of OpenBSD6.4 is 13.0.6.
>>>>>>> >I'm running this Jahshaka on Ubutu 18.04, where the mesa
>version is
>>>>>>> >18.x.
>>>>>>> >
>>>>>>> >So, it may be the mesa problem...
>>>>>>> >
>>>>>>> >Kenji
>>>>>>> >
>>>>>>> >
>>>>>>> >2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
>>>>>>> >
>>>>>>> >> I'm using AMD HD6450 graphic card which I reported before,
>and
>>>>>>> faced
>>>>>>> >a
>>>>>>> >> curious thing
>>>>>>> >> during running Jahshaka Studio (dev version 7.03a).
>>>>>>> >> To run Jahshaka on OpenBSD 6.4 I needed to delete google
>breakpad
>>>>>>> >> temporally, which
>>>>>>> >> is not the problem now.
>>>>>>> >>
>>>>>>> >> After start to run 'Jahshaka Studio', I got start 3D
>animation
>>>>>>> sample
>>>>>>> >> 'Skeletal Animation' data to load, then
>>>>>>> >> I got many errors included below which seems to come from
>radeon
>>>>>>> drm
>>>>>>> >> driver's bug to me.
>>>>>>> >> If you interested please check it.
>>>>>>> >>
>>>>>>> >> Thanks in advance
>>>>>>> >>
>>>>>>> >> Kenji
>>>>>>> >>
>>>>>>> >>
>>>>>>>
>>>>>>> There's a known bug where the shader on r600 uses too many
>registers:
>>>>>>>
>>>>>>> https://bugs.freedesktop.org/show_bug.cgi?id=99349
>>>>>>>
>>>>>>> I encountered this bug with godot on a Radeon HD 7570, too, and
>it
>>>>>>> went away with the updated mesa that's in -current.
>>>>>>>
>>>>>>

I think you are asking for way more than you (or most misc@ readers) can handle. Porting low-level libraries from FreeBSD is far from trivial.

My advice remains: if you want working graphics, you should run OpenBSD-current, not 6.4-release. What you did is try to plug in stuff from -current into 6.4 which is huge gamble and I'm not surprised if the result is weird.

Just read the OpenBSD FAQ again for how to install -current. I would stop experimenting like you've one until you understand the system much better than now.

Reply | Threaded
Open this post in threaded view
|

Re: radeon driver bug?

岡本健二
Ok, I upgraded my OpenBSD system to -current, and rebuild the Jahshaka.
After all, the results are same as before.

 Skeletal Animations runs for less than 1 second, and halt for about 35
seconds,
and then runs for less than 1 second, and halt for about 35 second(yes,
it's same)...
Above cycle continues eternally.

Kenji


2018年12月10日(月) 1:23 [hidden email] <[hidden email]>:

> On December 9, 2018 1:22:42 AM UTC, "岡本健二" <[hidden email]> wrote:
> >I found mesa-libs-18.1.9 for FreeBSD ports.
> >How can I get it without FreeBSD system?
> >
> >Kenji
> >
> >
> >2018年12月8日(土) 14:48 岡本健二 <[hidden email]>:
> >
> >> I installed Ubuntu 18.04 to a AMD 6450 graphic card, and played
> >> Jahshaka.  It has mesa version 18.2, and runs Jahshaka very
> >> smoothly.
> >>
> >> The colors I reported before are same in this machine, so that
> >> report was not correct.
> >>
> >> Kenji
> >>
> >> 2018年12月7日(金) 11:09 岡本健二 <[hidden email]>:
> >>
> >>> I checked mesa-18.3.0 sources under src/gallium/drivers/r600 and
> >compared
> >>> with those
> >>> of xenocara.  File names are all same, however, individual sizes are
> >very
> >>> different for
> >>> most of those, which would not permit me to copy those to
> >xenocara...
> >>>
> >>> Kenji
> >>>
> >>>
> >>> 2018年12月6日(木) 15:14 岡本健二 <[hidden email]>:
> >>>
> >>>> also, it stull has some bugs, because the colors of some
> >>>> parts are different from those of original ones.
> >>>>
> >>>> Kenji
> >>>>
> >>>>
> >>>> 2018年12月6日(木) 15:10 岡本健二 <[hidden email]>:
> >>>>
> >>>>> Sorry, I'm a novice to OpenBSD.
> >>>>> Yes, it's current branch of xenocara.
> >>>>> I updated my xenocara (stable) to that current, and build new
> >xenocara
> >>>>> here.
> >>>>>
> >>>>> Wow, it makes the Jahshaka works!
> >>>>>
> >>>>> However, it still has some bugs, because it moves and stop
> >suddenly and
> >>>>> then
> >>>>> move again.  Whine the animation stops, the system seems to
> >halting...
> >>>>>
> >>>>> Anyway it makes much advance, I included the screenshot of it.
> >>>>>
> >>>>> Kenji
> >>>>>
> >>>>> PS: sorry tfrohwein, this is doubled to you
> >>>>>
> >>>>> 2018年12月6日(木) 13:26 岡本健二 <[hidden email]>:
> >>>>>
> >>>>>> in-current means stable 6.4?
> >>>>>>
> >>>>>> Kenji
> >>>>>>
> >>>>>> 2018年12月5日(水) 23:58 [hidden email]
> ><[hidden email]>:
> >>>>>>
> >>>>>>> On December 5, 2018 9:41:44 AM UTC, "岡本健二" <[hidden email]>
> >>>>>>> wrote:
> >>>>>>> >This errors come from
> >>>>>>>
> >>/usr/xenocara/lib/mesa/src/gallium/drivers/r600/r600_state_common.c.
> >>>>>>> >The mesa version of OpenBSD6.4 is 13.0.6.
> >>>>>>> >I'm running this Jahshaka on Ubutu 18.04, where the mesa
> >version is
> >>>>>>> >18.x.
> >>>>>>> >
> >>>>>>> >So, it may be the mesa problem...
> >>>>>>> >
> >>>>>>> >Kenji
> >>>>>>> >
> >>>>>>> >
> >>>>>>> >2018年12月4日(火) 16:19 岡本健二 <[hidden email]>:
> >>>>>>> >
> >>>>>>> >> I'm using AMD HD6450 graphic card which I reported before,
> >and
> >>>>>>> faced
> >>>>>>> >a
> >>>>>>> >> curious thing
> >>>>>>> >> during running Jahshaka Studio (dev version 7.03a).
> >>>>>>> >> To run Jahshaka on OpenBSD 6.4 I needed to delete google
> >breakpad
> >>>>>>> >> temporally, which
> >>>>>>> >> is not the problem now.
> >>>>>>> >>
> >>>>>>> >> After start to run 'Jahshaka Studio', I got start 3D
> >animation
> >>>>>>> sample
> >>>>>>> >> 'Skeletal Animation' data to load, then
> >>>>>>> >> I got many errors included below which seems to come from
> >radeon
> >>>>>>> drm
> >>>>>>> >> driver's bug to me.
> >>>>>>> >> If you interested please check it.
> >>>>>>> >>
> >>>>>>> >> Thanks in advance
> >>>>>>> >>
> >>>>>>> >> Kenji
> >>>>>>> >>
> >>>>>>> >>
> >>>>>>>
> >>>>>>> There's a known bug where the shader on r600 uses too many
> >registers:
> >>>>>>>
> >>>>>>> https://bugs.freedesktop.org/show_bug.cgi?id=99349
> >>>>>>>
> >>>>>>> I encountered this bug with godot on a Radeon HD 7570, too, and
> >it
> >>>>>>> went away with the updated mesa that's in -current.
> >>>>>>>
> >>>>>>
>
> I think you are asking for way more than you (or most misc@ readers) can
> handle. Porting low-level libraries from FreeBSD is far from trivial.
>
> My advice remains: if you want working graphics, you should run
> OpenBSD-current, not 6.4-release. What you did is try to plug in stuff from
> -current into 6.4 which is huge gamble and I'm not surprised if the result
> is weird.
>
> Just read the OpenBSD FAQ again for how to install -current. I would stop
> experimenting like you've one until you understand the system much better
> than now.
>