problem to install OpenBSD 5.7 on iMAC G5 (1.6Ghz)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

problem to install OpenBSD 5.7 on iMAC G5 (1.6Ghz)

Laurent Masson
Hello,

I can't install OpenBSD on iMac G5, when I booted on cd with the
command :

boot cd:,ofwboot \5.7\macppc\bsd.rd

The boot started and stopped quickly with the message :

Loading ELF
 >> OpenBSD/macppc BOOT 1.3
boot
cannot open /ht/pci@5/ata-6/disk@0:/etc/random.seed: No such file or
directory
booting /ht/pci@5/ata-6/disk@0:\5.7\macppc\bsd.rd: open
/ht/pci@5/ata-6/disk@0:\5.7\macppc\bsd.rd: No such file or directory
failed(2). will  try /bsd
Turning timeout off.
boot>

The acces path is invalid, the correct access path is
/ht/pci@5/ata-6/disk@0:2,

I tried an USB install and had the same problem.
I tried to boot with "boot /ht/pci@5/ata-6/disk@0:2,ofwboot
\5.7\macppc\bsd.rd" command, and the result was the same.

Do you have a solution, please ?

Thanks.

Laurent Masson



Reply | Threaded
Open this post in threaded view
|

Re: problem to install OpenBSD 5.7 on iMAC G5 (1.6Ghz)

Matthew Martin-2
I have an old slot loader imac I had a problem installing to eons ago,
not the same machine but it's also macppc. I chalked it up to lack of
sufficient RTFM and buried it in a closet somewhere. I don't at all
remember what the issue was and I don't believe it'll even attempt to
boot off USB but I can crank out a 5.7 CD and give that install a go
again tomorrowish.

On 8/1/15, Laurent Masson <[hidden email]> wrote:

> Hello,
>
> I can't install OpenBSD on iMac G5, when I booted on cd with the
> command :
>
> boot cd:,ofwboot \5.7\macppc\bsd.rd
>
> The boot started and stopped quickly with the message :
>
> Loading ELF
>  >> OpenBSD/macppc BOOT 1.3
> boot
> cannot open /ht/pci@5/ata-6/disk@0:/etc/random.seed: No such file or
> directory
> booting /ht/pci@5/ata-6/disk@0:\5.7\macppc\bsd.rd: open
> /ht/pci@5/ata-6/disk@0:\5.7\macppc\bsd.rd: No such file or directory
> failed(2). will  try /bsd
> Turning timeout off.
> boot>
>
> The acces path is invalid, the correct access path is
> /ht/pci@5/ata-6/disk@0:2,
>
> I tried an USB install and had the same problem.
> I tried to boot with "boot /ht/pci@5/ata-6/disk@0:2,ofwboot
> \5.7\macppc\bsd.rd" command, and the result was the same.
>
> Do you have a solution, please ?
>
> Thanks.
>
> Laurent Masson
>
>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: problem to install OpenBSD 5.7 on iMAC G5 (1.6Ghz)

Stefan Sperling-5
In reply to this post by Laurent Masson
On Sat, Aug 01, 2015 at 08:35:58PM +0002, Laurent Masson wrote:

> Hello,
>
> I can't install OpenBSD on iMac G5, when I booted on cd with the command :
>
> boot cd:,ofwboot \5.7\macppc\bsd.rd
>
> The boot started and stopped quickly with the message :
>
> Loading ELF
> >> OpenBSD/macppc BOOT 1.3
> boot
> cannot open /ht/pci@5/ata-6/disk@0:/etc/random.seed: No such file or
> directory
> booting /ht/pci@5/ata-6/disk@0:\5.7\macppc\bsd.rd: open
> /ht/pci@5/ata-6/disk@0:\5.7\macppc\bsd.rd: No such file or directory
> failed(2). will  try /bsd
> Turning timeout off.
> boot>
>
> The acces path is invalid, the correct access path is
> /ht/pci@5/ata-6/disk@0:2,
>
> I tried an USB install and had the same problem.
> I tried to boot with "boot /ht/pci@5/ata-6/disk@0:2,ofwboot
> \5.7\macppc\bsd.rd" command, and the result was the same.
>
> Do you have a solution, please ?
>
> Thanks.
>
> Laurent Masson
>

I've just tested CD install with -current (5.8) on a powerbook G4
where OpenBSD booted just fine. cd5.7.iso boots fine as well, however
device paths on this machine do not contain a colon.

cdrom (5.7): /pci@f2000000/mac-io@17/ata-3@20000/disk@0:/5.7/macppc/bsd.rd
disk (5.8): /pci@f2000000/mac-io@17/ata-4@1f000/disk@0:/bsd

I suspect the bug that prevents your machine from booting is in parsename()
in /usr/src/sys/arch/macppc/stand/ofdev.c

Can you please provide the output of the 'devalias' command at the OF prompt?

[ using 549788 bytes of bsd ELF symbol table ]
console out [ATY,Crown_A] console in [keyboard], using ADB
using parent ATY,CrownParent:: memaddr b8000000, size 8000000 : consaddr bc008000 : ioaddr b0020000, size 20000: width 1152 linebytes 1280 height 768 depth 8
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2015 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 5.8 (GENERIC) #641: Fri Jul 31 17:54:32 MDT 2015
    [hidden email]:/usr/src/sys/arch/macppc/compile/GENERIC
real mem = 1073741824 (1024MB)
avail mem = 1031081984 (983MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root: model PowerBook3,4
cpu0 at mainbus0: 7455 (Revision 0x201): 667 MHz: 256KB L2 cache, 1MB L3 cache
mem0 at mainbus0
spdmem0 at mem0: 512MB SDRAM non-parity PC133CL2
spdmem1 at mem0: 512MB SDRAM non-parity PC133CL2
memc0 at mainbus0: uni-n rev 0x11
kiic0 at memc0 offset 0xf8001000
iic0 at kiic0
mpcpcibr0 at mainbus0 pci: uni-north
pci0 at mpcpcibr0 bus 0
pchb0 at pci0 dev 11 function 0 "Apple Uni-N2 AGP" rev 0x00
radeondrm0 at pci0 dev 16 function 0 "ATI Radeon Mobility M7" rev 0x00
drm0 at radeondrm0
radeondrm0: irq 48
mpcpcibr1 at mainbus0 pci: uni-north
pci1 at mpcpcibr1 bus 0
macobio0 at pci1 dev 23 function 0 "Apple Keylargo" rev 0x03
openpic0 at macobio0 offset 0x40000: version 0x4614 feature 3f0302 LE
macgpio0 at macobio0 offset 0x50
macgpio1 at macgpio0 offset 0x59: irq 47
pgs0 at macgpio0 offset 0x61: irq 55
"firewire-linkon" at macgpio0 offset 0x5f not configured
"gpio5" at macgpio0 offset 0x6f not configured
"gpio6" at macgpio0 offset 0x70 not configured
"extint-gpio4" at macgpio0 offset 0x5c not configured
"gpio11" at macgpio0 offset 0x75 not configured
"extint-gpio15" at macgpio0 offset 0x67 not configured
"escc-legacy" at macobio0 offset 0x12000 not configured
zsc0 at macobio0 offset 0x13000: irq 22,23
zstty0 at zsc0 channel 0
zstty1 at zsc0 channel 1
snapper0 at macobio0 offset 0x10000: irq 30,1,2
"timer" at macobio0 offset 0x15000 not configured
adb0 at macobio0 offset 0x16000: irq 25, via-pmu, 3 targets
apm0 at adb0: battery flags 0xD, 57% charged
akbd0 at adb0 addr 2: iBook keyboard with inverted T (ISO layout)
wskbd0 at akbd0: console keyboard
ams0 at adb0 addr 3: EMP trackpad <tpad> 2-button, 400 dpi
wsmouse0 at ams0 mux 0
abtn0 at adb0 addr 7: brightness/volume/eject buttons
"battery" at macobio0 offset 0x0 not configured
"backlight" at macobio0 offset 0xf300 not configured
kiic1 at macobio0 offset 0x18000
iic1 at kiic1
wdc0 at macobio0 offset 0x1f000 irq 19: DMA
wd0 at wdc0 channel 0 drive 0: <IBM-IC25N030ATCS04-0>
wd0: 16-sector PIO, LBA, 28615MB, 58605120 sectors
wd0(wdc0:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 4
wdc1 at macobio0 offset 0x20000 irq 20: DMA
atapiscsi0 at wdc1 channel 0 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <MATSHITA, CD-RW CW-8121, AA20> ATAPI 5/cdrom removable
cd0(wdc1:0:0): using BIOS timings, DMA mode 2
wdc2 at macobio0 offset 0x21000 irq 21: DMA
wi0 at macobio0 offset 0x30000 irq 57:
wi0: Firmware 8.70 variant 1, address 00:30:65:17:bc:b8
audio0 at snapper0
ohci0 at pci1 dev 24 function 0 "Apple USB" rev 0x00: irq 27, version 1.0
ohci1 at pci1 dev 25 function 0 "Apple USB" rev 0x00: irq 28, version 1.0
cbb0 at pci1 dev 26 function 0 "TI PCI1410 CardBus" rev 0x02: irq 58
usb0 at ohci0: USB revision 1.0
uhub0 at usb0 "Apple OHCI root hub" rev 1.00/1.00 addr 1
usb1 at ohci1: USB revision 1.0
uhub1 at usb1 "Apple OHCI root hub" rev 1.00/1.00 addr 1
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 1 device 0 cacheline 0x8, lattimer 0x20
pcmcia0 at cardslot0
mpcpcibr2 at mainbus0 pci: uni-north
pci2 at mpcpcibr2 bus 0
"AT&T/Lucent FW322 1394" rev 0x00 at pci2 dev 14 function 0 not configured
gem0 at pci2 dev 15 function 0 "Apple Uni-N GMAC" rev 0x01: irq 41, address 00:03:93:b6:3c:f2
brgphy0 at gem0 phy 0: BCM5421 10/100/1000baseT PHY, rev. 1
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
bootpath: /pci@f2000000/mac-io@17/ata-4@1f000/disk@0:/bsd
root on wd0a (bdddd31d84d82816.a) swap on wd0b dump on wd0b
error: [drm:pid0:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
trying to bind memory to uninitialized GART !
error: [drm:pid0:radeon_ttm_backend_bind] *ERROR* failed to bind 1 pages at 0x00000000
drm:pid0:radeon_wb_init *WARNING* (-22) create WB bo failed
drm:pid0:r100_init *ERROR* Disabling GPU acceleration
ttm_pool_mm_shrink_fini stub
error: [drm:pid0:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
radeondrm0: 1152x768
wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)

Reply | Threaded
Open this post in threaded view
|

Re: problem to install OpenBSD 5.7 on iMAC G5 (1.6Ghz)

Stefan Sperling-5
On Sun, Aug 02, 2015 at 02:50:18PM +0002, Laurent Masson wrote:
> 0> devalias
> cd /ht/pci@5/ata-6/disk@0

I don't understand where your assertion comes from that the correct
device path was "/ht/pci@5/ata-6/disk@0:2".

I'll note that you are using \ instead of / as path separator in
your commands to ofwboot. Try forward slashes instead:
  boot cd:,ofwboot /5.7/macppc/bsd.rd