problem running sharity-light at system startup

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

problem running sharity-light at system startup

Valerio G. Romano
Hello all,

I am having a problem running sharity-light at startup.
I am running:

-bash-3.00$ uname -a
OpenBSD my.hostname 3.8 GENERIC#425 macppc
(dmesg appended at bottom of this email)

I added this line to rc.local:

/usr/local/sbin/shlight //fileserver-host/public /mnt/myshare -U
myusername -P mypasswd -w

I reboot and the windows drive is not mounted.  I run the exact same
command as root (with sudo) from a bash shell and it is mounted and I
can do an ls in /mnt/myshare/ or browse it with a samba share, and my
files are there.

I searched all the archives, and found one answer here:
(I also found a few other people with the same problem)

http://openbsd.toybed.com/archive/2003/msg13352.html

but I am embarrassed to admit that I do not see how the output of that
diff solves my problem.

Following another suggestion I read, I made an external script which is
very similar and call that script in rc.local.  That script is
executable.  It still does not work.

My question is this: how do I execute the shlight command at startup
without having to log in after the machine starts and run it myself?

-The rest of this email is simply further explanation to make sure I
covered my basis, my apologies for my longwindedness.-


Unfortunately, it has been years since my sysadmin days (law
school...yadda yadda).  Nonetheless, just playing around recently I
installed OpenBSD 3.8 on an old G4 I had never turned on, the install
worked effortlessly, OpenBSD kicks butt! OpenVPN went on and runs with
only slightly more effort, ditto on Samba.  I convinced the windows
admin to forward a couple ports to the pretty G4 in my cluttered office
(that cost me a bottle of scotch)...

then I put on sharity-light:

-bash-3.00$ shlight -v
shlight: Version 1.1 (1998-11-16)

which interestingly is the version that installs with a pkg_add -rv on
the following link:

ftp://ftp.openbsd.org/pub/OpenBSD/3.8/packages/powerpc/sharity-light-1.2.tgz

I mounted my windows drive without too much problem.  The VPN works
great from my laptop anywhere.  I can get all my other processes
starting with rc.local or inetd.conf.   As explained above, I can not
get the windows drive mounted on my OpenBSD machine with sharity-light
(or otherwise) on system startup.  It seems silly that simply getting
this final process to run on start up is keeping this project from
completion.

I welcome any ideas or help, including suggestions on another package or
method to mount windows machines on my OpenBSD machine, on the same
subnet, with no special networking considerations. Sharity-light has
worked thus far without much problem (except for the aforementioned
problems at system startup, and /usr/local/sbin/unshlight -a never
actually works), but the lack of documentation, including man pages and
mailing lists, and the negative feedback in some of what I read makes me
think there must be a better alternative.  I would simply use OpenVPN as
a bridge to the windows network, but I do not have access to the DHCP
server to break off a chunk of our subnet, I can't afford that much scotch.


Thanks very much,


Valerio


p.s I have appended my dmesg:

9 headphones
audio0 at awacs0
adb0 at macobio0 irq 18: via-cuda , 0 targets
aed0 at adb0 addr 0: ADB Event device
wdc0 at macobio0 irq 13: DMA
atapiscsi0 at wdc0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, DVD-ROM SR-8583, D54A> SCSI0
5/cdrom removable
atapiscsi1 at wdc0 channel 0 drive 1
scsibus1 at atapiscsi1: 2 targets
sd0 at scsibus1 targ 0 lun 0: <IOMEGA, ZIP 100, 14.A> SCSI0 0/direct
removable
sd0: drive offline
cd0(wdc0:0:0): using BIOS timings, DMA mode 2
sd0(wdc0:0:1): using BIOS timings
bm0 at macobio0 irq 42,33: address 00:50:e4:59:20:49
lxtphy0 at bm0 phy 0: LXT970 10/100 PHY, rev. 3
ohci0 at pci1 dev 6 function 0 "Opti 82C861" rev 0x10: irq 28, version
1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Opti OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
vgafb0 at pci0 dev 16 function 0 "ATI Rage 128 GL" rev 0x00, mmio
wsdisplay0 at vgafb0 mux 1: console (std, vt100 emulation)
uhub1 at uhub0 port 1
uhub1: Mitsumi Electric Hub in Apple USB Keyboard, rev 1.10/2.11, addr 2
uhub1: 3 ports with 2 removable, bus powered
uhidev0 at uhub1 port 1 configuration 1 interface 0
uhidev0: Mitsumi Electric Apple USB Keyboard, rev 1.00/1.03, addr 3,
iclass 3/1
ukbd0 at uhidev0: 8 modifier keys, 6 key codes
wskbd0 at ukbd0: console keyboard, using wsdisplay0
bootpath: '/pci/@d/pci-ata@1/ata-4@0/disk@0/bsd'
boot device: wd0.
root on wd0a
rootdev=0x0 rrootdev=0xb00 rawdev=0xb02
9 headphones
audi
[ using 323864 bytes of bsd ELF symbol table ]
console out [ATY,Rage128y]console in [keyboard] USB and ADB found, using USB
: memaddr 84000000 size 4000000, : consaddr 84000000, : ioaddr 80b20000,
size 20000: memtag 8000, iotag 8000: width 640 linebytes 640 height 480
depth 8
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2005 OpenBSD. All rights reserved.
http://www.OpenBSD.org

OpenBSD 3.8 (GENERIC) #425: Sat Sep 10 15:49:26 MDT 2005
    [hidden email]:/usr/src/sys/arch/macppc/compile/GENERIC
real mem = 402653184 (393216K)
avail mem = 360906752 (352448K)
using 1254 buffers containing 20131840 bytes of memory
mainbus0 (root)
cpu0 at mainbus0: 7400 (Revision 0x206): 400 MHz: 1MB backside cache
mpcpcibr0 at mainbus0: grackle, Revision 0x40
pci0 at mpcpcibr0 bus 0
pchb0 at pci0 dev 0 function 0 "Motorola MPC106 PCI" rev 0x40
ppb0 at pci0 dev 13 function 0 "DEC 21154 PCI-PCI" rev 0x02
pci1 at ppb0 bus 1
"Texas Instruments TSB12LV21 FireWire" rev 0x04 at pci1 dev 0 function 0
not configured
pciide0 at pci1 dev 1 function 0 "CMD Technology PCI0646" rev 0x07: DMA,
channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide0: using irq 26 for native-PCI interrupt
wd0 at pciide0 channel 0 drive 0: <IC35L040AVVA07-0>
wd0: 16-sector PIO, LBA, 38166MB, 78165360 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 ignored (disabled)
fxp0 at pci1 dev 3 function 0 "Intel 82557" rev 0x08, i82559: irq 24,
address 00:d0:b7:ba:68:8d
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
macobio0 at pci1 dev 5 function 0 "Apple Paddington" rev 0x00
macintr0 at macobio0
zsc0 at macobio0: irq 15,16
zstty0 at zsc0 channel 0
zstty1 at zsc0 channel 1
awacs0 at macobio0: irq 17,8,9 headphones
audio0 at awacs0
adb0 at macobio0 irq 18: via-cuda , 0 targets
aed0 at adb0 addr 0: ADB Event device
wdc0 at macobio0 irq 13: DMA
atapiscsi0 at wdc0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, DVD-ROM SR-8583, D54A> SCSI0
5/cdrom removable
atapiscsi1 at wdc0 channel 0 drive 1
scsibus1 at atapiscsi1: 2 targets
sd0 at scsibus1 targ 0 lun 0: <IOMEGA, ZIP 100, 14.A> SCSI0 0/direct
removable
sd0: drive offline
cd0(wdc0:0:0): using BIOS timings, DMA mode 2
sd0(wdc0:0:1): using BIOS timings
bm0 at macobio0 irq 42,33: address 00:50:e4:59:20:49
lxtphy0 at bm0 phy 0: LXT970 10/100 PHY, rev. 3
ohci0 at pci1 dev 6 function 0 "Opti 82C861" rev 0x10: irq 28, version
1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Opti OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
vgafb0 at pci0 dev 16 function 0 "ATI Rage 128 GL" rev 0x00, mmio
wsdisplay0 at vgafb0 mux 1: console (std, vt100 emulation)
uhub1 at uhub0 port 1
uhub1: Mitsumi Electric Hub in Apple USB Keyboard, rev 1.10/2.11, addr 2
uhub1: 3 ports with 2 removable, bus powered
uhidev0 at uhub1 port 1 configuration 1 interface 0
uhidev0: Mitsumi Electric Apple USB Keyboard, rev 1.00/1.03, addr 3,
iclass 3/1
ukbd0 at uhidev0: 8 modifier keys, 6 key codes
wskbd0 at ukbd0: console keyboard, using wsdisplay0
bootpath: '/pci/@d/pci-ata@1/ata-4@0/disk@0/bsd'
boot device: wd0.
root on wd0a
rootdev=0x0 rrootdev=0xb00 rawdev=0xb02
syncing disks...
[ using 323864 bytes of bsd ELF symbol table ]
console out [ATY,Rage128y]console in [keyboard] USB and ADB found, using USB
: memaddr 84000000 size 4000000, : consaddr 84000000, : ioaddr 80b20000,
size 20000: memtag 8000, iotag 8000: width 640 linebytes 640 height 480
depth 8
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2005 OpenBSD. All rights reserved.
http://www.OpenBSD.org

OpenBSD 3.8 (GENERIC) #425: Sat Sep 10 15:49:26 MDT 2005
    [hidden email]:/usr/src/sys/arch/macppc/compile/GENERIC
real mem = 402653184 (393216K)
avail mem = 360906752 (352448K)
using 1254 buffers containing 20131840 bytes of memory
mainbus0 (root)
cpu0 at mainbus0: 7400 (Revision 0x206): 400 MHz: 1MB backside cache
mpcpcibr0 at mainbus0: grackle, Revision 0x40
pci0 at mpcpcibr0 bus 0
pchb0 at pci0 dev 0 function 0 "Motorola MPC106 PCI" rev 0x40
ppb0 at pci0 dev 13 function 0 "DEC 21154 PCI-PCI" rev 0x02
pci1 at ppb0 bus 1
"Texas Instruments TSB12LV21 FireWire" rev 0x04 at pci1 dev 0 function 0
not configured
pciide0 at pci1 dev 1 function 0 "CMD Technology PCI0646" rev 0x07: DMA,
channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide0: using irq 26 for native-PCI interrupt
wd0 at pciide0 channel 0 drive 0: <IC35L040AVVA07-0>
wd0: 16-sector PIO, LBA, 38166MB, 78165360 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 ignored (disabled)
fxp0 at pci1 dev 3 function 0 "Intel 82557" rev 0x08, i82559: irq 24,
address 00:d0:b7:ba:68:8d
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
macobio0 at pci1 dev 5 function 0 "Apple Paddington" rev 0x00
macintr0 at macobio0
zsc0 at macobio0: irq 15,16
zstty0 at zsc0 channel 0
zstty1 at zsc0 channel 1
awacs0 at macobio0: irq 17,8,9 headphones
audio0 at awacs0
adb0 at macobio0 irq 18: via-cuda , 0 targets
aed0 at adb0 addr 0: ADB Event device
wdc0 at macobio0 irq 13: DMA
atapiscsi0 at wdc0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, DVD-ROM SR-8583, D54A> SCSI0
5/cdrom removable
atapiscsi1 at wdc0 channel 0 drive 1
scsibus1 at atapiscsi1: 2 targets
sd0 at scsibus1 targ 0 lun 0: <IOMEGA, ZIP 100, 14.A> SCSI0 0/direct
removable
sd0: drive offline
cd0(wdc0:0:0): using BIOS timings, DMA mode 2
sd0(wdc0:0:1): using BIOS timings
bm0 at macobio0 irq 42,33: address 00:50:e4:59:20:49
lxtphy0 at bm0 phy 0: LXT970 10/100 PHY, rev. 3
ohci0 at pci1 dev 6 function 0 "Opti 82C861" rev 0x10: irq 28, version
1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Opti OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
vgafb0 at pci0 dev 16 function 0 "ATI Rage 128 GL" rev 0x00, mmio
wsdisplay0 at vgafb0 mux 1: console (std, vt100 emulation)
uhub1 at uhub0 port 1
uhub1: Mitsumi Electric Hub in Apple USB Keyboard, rev 1.10/2.11, addr 2
uhub1: 3 ports with 2 removable, bus powered
uhidev0 at uhub1 port 1 configuration 1 interface 0
uhidev0: Mitsumi Electric Apple USB Keyboard, rev 1.00/1.03, addr 3,
iclass 3/1
ukbd0 at uhidev0: 8 modifier keys, 6 key codes
wskbd0 at ukbd0: console keyboard, using wsdisplay0
bootpath: '/pci/@d/pci-ata@1/ata-4@0/disk@0/bsd'
boot device: wd0.
root on wd0a
rootdev=0x0 rrootdev=0xb00 rawdev=0xb02