pppoe

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

pppoe

Vasily Ivanov-4

привет.

есть проблема у товарища на домашнем шлюзе после того как перевели на pppoe
Фактически машина захлёбывается про "большом" количестве запросов.
Например, рыскание по (google|yandex).map
Пинги сериями возрастают в тысячи раз (до тысяч и десятков тысяч ms)

Машина не очень хилая --- http://dev-null.ru/tmp/dmesg.nordvik.htm
хотя и не метеор.

1. pfctl -F all не помогает, всё в точности также с самого шлюза.
2. сетевуху он менял --- не помогает
3. ipv6 (есть канал) --- без разницы
4. если напрямую включить win-тачку --- всё летает
5. до перехода на pppoe также проблем со шлюзом не было
6. настройки pppoe стандартные (ниже)
7. может быть что-то на подкрутить в kern.some_param ?

   default:
     set log Phase Chat LCP IPCP CCP tun command

   pppoe:
     set device "!/usr/sbin/pppoe -i epic0"
     set mtu max 1492
     set mru max 1492
     set speed sync
     disable acfcomp protocomp
     deny acfcomp
     set authname "йййй"
     set authkey  "ёёёё"
     add! default HISADDR

Reply | Threaded
Open this post in threaded view
|

Re: pppoe

Anton Maksimenkov-2
Попробуйте "ядерный" pppoe(4)
И до кучи посмотрите в сторону mtu.

--
antonvm
Reply | Threaded
Open this post in threaded view
|

Re: pppoe

Gregory Edigarov-2
In reply to this post by Vasily Ivanov-4

acpi попробуй выключить.

# config -o /bsd -e /bsd
>disable acpi
>quit

On Thu, 08 Sep 2011 13:01:31 +0400
Vasily Ivanov <[hidden email]> wrote:

>
> привет.
>
> есть проблема у товарища на домашнем шлюзе после того как перевели на
> pppoe Фактически машина захлёбывается про "большом" количестве
> запросов. Например, рыскание по (google|yandex).map
> Пинги сериями возрастают в тысячи раз (до тысяч и десятков тысяч ms)
>
> Машина не очень хилая --- http://dev-null.ru/tmp/dmesg.nordvik.htm
> хотя и не метеор.
>
> 1. pfctl -F all не помогает, всё в точности также с самого шлюза.
> 2. сетевуху он менял --- не помогает
> 3. ipv6 (есть канал) --- без разницы
> 4. если напрямую включить win-тачку --- всё летает
> 5. до перехода на pppoe также проблем со шлюзом не было
> 6. настройки pppoe стандартные (ниже)
> 7. может быть что-то на подкрутить в kern.some_param ?
>
>    default:
>      set log Phase Chat LCP IPCP CCP tun command
>
>    pppoe:
>      set device "!/usr/sbin/pppoe -i epic0"
>      set mtu max 1492
>      set mru max 1492
>      set speed sync
>      disable acfcomp protocomp
>      deny acfcomp
>      set authname "йййй"
>      set authkey  "ёёёё"
>      add! default HISADDR
>

Reply | Threaded
Open this post in threaded view
|

Re: pppoe

irix

А acpi тут причём ?

08.09.2011 14:19, Gregory Edigarov пишет:

> acpi попробуй выключить.
>
> # config -o /bsd -e /bsd
>> disable acpi
>> quit
> On Thu, 08 Sep 2011 13:01:31 +0400
> Vasily Ivanov<[hidden email]>  wrote:
>
>> привет.
>>
>> есть проблема у товарища на домашнем шлюзе после того как перевели на
>> pppoe Фактически машина захлёбывается про "большом" количестве
>> запросов. Например, рыскание по (google|yandex).map
>> Пинги сериями возрастают в тысячи раз (до тысяч и десятков тысяч ms)
>>
>> Машина не очень хилая --- http://dev-null.ru/tmp/dmesg.nordvik.htm
>> хотя и не метеор.
>>
>> 1. pfctl -F all не помогает, всё в точности также с самого шлюза.
>> 2. сетевуху он менял --- не помогает
>> 3. ipv6 (есть канал) --- без разницы
>> 4. если напрямую включить win-тачку --- всё летает
>> 5. до перехода на pppoe также проблем со шлюзом не было
>> 6. настройки pppoe стандартные (ниже)
>> 7. может быть что-то на подкрутить в kern.some_param ?
>>
>>     default:
>>       set log Phase Chat LCP IPCP CCP tun command
>>
>>     pppoe:
>>       set device "!/usr/sbin/pppoe -i epic0"
>>       set mtu max 1492
>>       set mru max 1492
>>       set speed sync
>>       disable acfcomp protocomp
>>       deny acfcomp
>>       set authname "йййй"
>>       set authkey  "ёёёё"
>>       add! default HISADDR
>>
>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: pppoe

Alexander Sheiko
In reply to this post by Vasily Ivanov-4

Hello Vasily,

Thursday, September 8, 2011, 12:01:31 PM, you wrote:


VI> есть проблема у товарища на домашнем шлюзе после того как перевели на pppoe
VI> Фактически машина захлёбывается про "большом" количестве запросов.

В опёнке очень хороший родной ядерный PPPoE. Сижу на нём много лет -
загрузка P-III-900 на 20 мбит от прокачки клиентского торрент трафика
до 10%.

Вот здесь есть хороший пример настроек:

http://www.benjaminheckmann.de/howto/


--
WBR, Alexander Sheiko

Reply | Threaded
Open this post in threaded view
|

Re: pppoe

Vasily Ivanov-4
In reply to this post by Anton Maksimenkov-2

On 09/08/11 15:15, Anton Maksimenkov wrote:
> Попробуйте "ядерный" pppoe(4)

Помогло, однако.
Летает!
Спасибо.


Приволок для начала ноут помощнее (на феноме втором), pppoe (через tun)
всё равно захлёбывается.

> И до кучи посмотрите в сторону mtu.
>

Reply | Threaded
Open this post in threaded view
|

Re: pppoe

Gregory Edigarov-2
In reply to this post by irix

On Thu, 08 Sep 2011 17:51:24 +0300
irix <[hidden email]> wrote:

>
> А acpi тут причём ?
влияет на распределение прерываний. некоторые контроллеры вообще имеют
тенденцию вешать все железки на одну линию. поэтому - если есть тормоза
на малозагруженной тачке - надо первым делом вырубить acpi и
посмотреть не полегчает ли. в 90% случаев таки легчает.

> 08.09.2011 14:19, Gregory Edigarov пишет:
> > acpi попробуй выключить.
> >
> > # config -o /bsd -e /bsd
> >> disable acpi
> >> quit
> > On Thu, 08 Sep 2011 13:01:31 +0400
> > Vasily Ivanov<[hidden email]>  wrote:
> >
> >> привет.
> >>
> >> есть проблема у товарища на домашнем шлюзе после того как перевели
> >> на pppoe Фактически машина захлёбывается про "большом" количестве
> >> запросов. Например, рыскание по (google|yandex).map
> >> Пинги сериями возрастают в тысячи раз (до тысяч и десятков тысяч
> >> ms)
> >>
> >> Машина не очень хилая --- http://dev-null.ru/tmp/dmesg.nordvik.htm
> >> хотя и не метеор.
> >>
> >> 1. pfctl -F all не помогает, всё в точности также с самого шлюза.
> >> 2. сетевуху он менял --- не помогает
> >> 3. ipv6 (есть канал) --- без разницы
> >> 4. если напрямую включить win-тачку --- всё летает
> >> 5. до перехода на pppoe также проблем со шлюзом не было
> >> 6. настройки pppoe стандартные (ниже)
> >> 7. может быть что-то на подкрутить в kern.some_param ?
> >>
> >>     default:
> >>       set log Phase Chat LCP IPCP CCP tun command
> >>
> >>     pppoe:
> >>       set device "!/usr/sbin/pppoe -i epic0"
> >>       set mtu max 1492
> >>       set mru max 1492
> >>       set speed sync
> >>       disable acfcomp protocomp
> >>       deny acfcomp
> >>       set authname "йййй"
> >>       set authkey  "ёёёё"
> >>       add! default HISADDR
> >>
> >
> >
> >
>