port/libintl pthread issue on 4.3/mac68k release?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

port/libintl pthread issue on 4.3/mac68k release?

Hugo Villeneuve-2
I upgraded from 3.7 to 4.3 on my Quadra 640 yesterday. Downloaded
from ftp5.usa, but also checked against the MD5 on the main site.
By the way, no x* tar ball love in that mac68k MD5 file. (Neither
for vax.) Also did a proper etc merge.

I installed the mutt stable package from ftp (same result when I
compiled it from an OPENBSD_4_3 port tree) and it gives this error
when running the binary:

"/usr/libexec/ld.so: Undefined symbol "_pthread_rwlock_unlock" in mutt:/usr/local/lib/libintl.so.4.0"

I didn't go further than that in trying to resolve the problem.

Just wanted to know if it was a known issue. That I just miss the
announcement. Or somehow missed the port cvs update for this.

I'll look later for relevent cvs update in the src/port -stable and
head tree. I doubt I could manage src recompile this week though.
(NFS server has terrible network performance right now.)


--
Hugo Villeneuve <[hidden email]>
http://EINTR.net/ 

Reply | Threaded
Open this post in threaded view
|

Re: port/libintl pthread issue on 4.3/mac68k release?

Martin Reindl-3
Hugo Villeneuve <[hidden email]> wrote:

> I upgraded from 3.7 to 4.3 on my Quadra 640 yesterday. Downloaded
> from ftp5.usa, but also checked against the MD5 on the main site.
> By the way, no x* tar ball love in that mac68k MD5 file. (Neither
> for vax.) Also did a proper etc merge.
>
> I installed the mutt stable package from ftp (same result when I
> compiled it from an OPENBSD_4_3 port tree) and it gives this error
> when running the binary:
>
> "/usr/libexec/ld.so: Undefined symbol "_pthread_rwlock_unlock" in mutt:/usr/local/lib/libintl.so.4.0"
>
> I didn't go further than that in trying to resolve the problem.
>
> Just wanted to know if it was a known issue. That I just miss the
> announcement. Or somehow missed the port cvs update for this.
>
> I'll look later for relevent cvs update in the src/port -stable and
> head tree. I doubt I could manage src recompile this week though.
> (NFS server has terrible network performance right now.)

Sigh, this is due to gettext being broken for 4.3/m68k. I hope I'm
wrong but the only real solution would be moving to binutils.