pkg_add: fatal error when updating packages

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pkg_add: fatal error when updating packages

Michael Reed-2
$ sysctl -n kern.version
OpenBSD 6.2-current (GENERIC.MP) #193: Wed Nov  1 12:24:15 MDT 2017
     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP


Recently I ran pkg_add -u and it bailed out with an ultra-long error
message.
This is what happened:

$ doas pkg_add -u
doas ([hidden email]) password:
quirks-2.376 signed on 2017-11-04T14:04:05Z
quirks-2.373->2.376: ok
adwaita-icon-theme-3.26.0:python-2.7.14->2.7.14p0: ok
adwaita-icon-theme-3.26.0:glib2-2.54.2->2.54.2p0: ok
adwaita-icon-theme-3.26.0:shared-mime-info-1.9->1.9p0: ok
adwaita-icon-theme-3.26.0:gdk-pixbuf-2.36.11->2.36.11: ok
adwaita-icon-theme-3.26.0:gtk-update-icon-cache-3.22.25->3.22.25p0: ok
adwaita-icon-theme-3.26.0->3.26.0: ok
at-spi2-core-2.26.2->2.26.2: ok
atk-2.26.1->2.26.1: ok
avahi-0.7p0->0.7p0: ok
cairo-1.14.10p0->1.14.10p0: ok
calibre-2.85.1p3:iodbc-3.52.10->3.52.10p0: ok
calibre-2.85.1p3:gpsd-2.95p9->2.95p9: ok
calibre-2.85.1p3:dbus-glib-0.108v0->0.108v0: ok
calibre-2.85.1p3:dconf-0.26.1->0.26.1: ok
calibre-2.85.1p3:python-3.6.3->3.6.3p0: ok
calibre-2.85.1p3:libproxy-0.4.15p0->0.4.15p0: ok
calibre-2.85.1p3:gsettings-desktop-schemas-3.24.1->3.24.1: ok
calibre-2.85.1p3:glib2-networking-2.54.1->2.54.1: ok
calibre-2.85.1p3:libsoup-2.60.2->2.60.2: ok
calibre-2.85.1p3:geoclue-0.12.99p5->0.12.99p5: ok
cups-libs-2.2.5->2.2.6 forward dependencies:
| Dependency of cups-2.2.5p0 on cups-libs-=2.2.5 doesn't match
Merging cups-2.2.5p0->2.2.6 (ok)
Detected loop, merging sets ok
| cups-filters-1.17.9p0->1.17.9p0
| cups-2.2.5p0+cups-libs-2.2.5->cups-2.2.6+cups-libs-2.2.6
Detected loop, merging sets ok
|
cups-2.2.5p0+cups-filters-1.17.9p0+cups-libs-2.2.5->cups-2.2.6+cups-filters-1.17.9p0+cups-libs-2.2.6
| ghostscript-9.07p6->9.07p7
calibre-2.85.1p3:openjp2-2.2.0->2.3.0: ok
calibre-2.85.1p3:poppler-0.57.0p2->0.57.0p2: ok
calibre-2.85.1p3:poppler-utils-0.57.0p1->0.57.0p1: ok
calibre-2.85.1p3:desktop-file-utils-0.23->0.23p0: ok
calibre-2.85.1p3:mupdf-1.11p2->1.11p2: ok
calibre-2.85.1p3:cups-2.2.5p0+cups-filters-1.17.9p0+cups-libs-2.2.5+ghostscript-9.07p6->cups-2.2.6+cups-filters-1.17.9p0+cups-libs-2.2.6+ghostscript-9.07p7:
ok
to_install:
         harfbuzz-1.6.3 => //harfbuzz-1.6.3/
         libffi-3.2.1p2 => //libffi-3.2.1p2/
         libdaemon-0.14p1 => //libdaemon-0.14p1/
         png-1.6.34 => //png-1.6.34/
         calibre-2.85.1p3 => calibre-2.85.1p3/calibre-2.85.1p3//
         jasper-1.900.1p5 => //jasper-1.900.1p5/
         qtbase-5.9.2 => qtbase-5.9.2/qtbase-5.9.2//
         lzo2-2.10 => //lzo2-2.10/
         libusb1-1.0.21 => //libusb1-1.0.21/
         tiff-4.0.8p1 => //tiff-4.0.8p1/
         ghostscript-9.07p7 =>
cups-filters-1.17.9p0,cups-libs-2.2.6,ghostscript-9.07p7,cups-2.2.6/cups-2.2.5p0,cups-libs-2.2.5,cups-filters-1.17.9p0,ghostscript-9.07p6//
         lcms2-2.7 => //lcms2-2.7/
         gettext-0.19.8.1p1 => //gettext-0.19.8.1p1/
         libxml-2.9.5 => //libxml-2.9.5/
         jpeg-1.5.1p0v0 => //jpeg-1.5.1p0v0/
         hicolor-icon-theme-0.17 => //hicolor-icon-theme-0.17/
         xz-5.2.3p0 => //xz-5.2.3p0/
         libexecinfo-0.3p0v0 => //libexecinfo-0.3p0v0/
         gnutls-3.5.16 => //gnutls-3.5.16/
         bzip2-1.0.6p8 => //bzip2-1.0.6p8/
         xdg-utils-1.1.2p0 => //xdg-utils-1.1.2p0/
         poppler-data-0.4.8 => //poppler-data-0.4.8/
         glfw-3.2.1p0 => //glfw-3.2.1p0/
         dbus-1.12.0v0 => //dbus-1.12.0v0/
         dbus-daemon-launch-helper-1.12.0 =>
//dbus-daemon-launch-helper-1.12.0/
         at-spi2-atk-2.26.1 => //at-spi2-atk-2.26.1/
         sqlite3-3.20.1 => //sqlite3-3.20.1/
         jbig2dec-0.11 => //jbig2dec-0.11/
         gdbm-1.13 => //gdbm-1.13/
         cups-filters-1.17.9p0 =>
cups-filters-1.17.9p0,cups-libs-2.2.6,ghostscript-9.07p7,cups-2.2.6/cups-2.2.5p0,cups-libs-2.2.5,cups-filters-1.17.9p0,ghostscript-9.07p6//
         pcre-8.41 => //pcre-8.41/
         cups-2.2.6 =>
cups-filters-1.17.9p0,cups-libs-2.2.6,ghostscript-9.07p7,cups-2.2.6/cups-2.2.5p0,cups-libs-2.2.5,cups-filters-1.17.9p0,ghostscript-9.07p6//
         cups-libs-2.2.6 =>
cups-filters-1.17.9p0,cups-libs-2.2.6,ghostscript-9.07p7,cups-2.2.6/cups-2.2.5p0,cups-libs-2.2.5,cups-filters-1.17.9p0,ghostscript-9.07p6//
         ijs-0.35p2 => //ijs-0.35p2/
         ghostscript-fonts-8.11p3 => //ghostscript-fonts-8.11p3/
         libxkbcommon-0.7.2p0 => //libxkbcommon-0.7.2p0/
         librsvg-2.40.19p2 => //librsvg-2.40.19p2/
         libelf-0.8.13p4 => //libelf-0.8.13p4/
         libiconv-1.14p3 => //libiconv-1.14p3/
         curl-7.56.1 => //curl-7.56.1/
         foomatic-db-engine-4.0.12p1 => //foomatic-db-engine-4.0.12p1/
         qpdf-7.0beta1 => //qpdf-7.0beta1/
to_update:
         p5-HTTP-Negotiate-6.01 => /p5-HTTP-Negotiate-6.01//
         p5-DateTime-Locale-0.46 => /p5-DateTime-Locale-0.46//
         libvpx-1.6.1p0 => /libvpx-1.6.1p0//
         get_flash_videos-1.25.94 => /get_flash_videos-1.25.94//
         libv4l-1.12.5 => /libv4l-1.12.5//
         p5-XML-SAX-0.99 => /p5-XML-SAX-0.99//
         p5-LWP-MediaTypes-6.02 => /p5-LWP-MediaTypes-6.02//
         p5-Params-Validate-1.26 => /p5-Params-Validate-1.26//
         p5-Net-SSLeay-1.82 => /p5-Net-SSLeay-1.82//
         p5-XML-SAX-Base-1.09 => /p5-XML-SAX-Base-1.09//
         libvorbis-1.3.5 => /libvorbis-1.3.5//
         py-dbus-1.2.4p0 => /py-dbus-1.2.4p0//
         p5-HTML-Parser-3.72 => /p5-HTML-Parser-3.72//
         libunistring-0.9.7 => /libunistring-0.9.7//
         p5-Math-Base-Convert-0.08p0 => /p5-Math-Base-Convert-0.08p0//
         py3-pexpect-4.2.1p0 => /py3-pexpect-4.2.1p0//
         py-crypto-2.6.1p4 => /py-crypto-2.6.1p4//
         libgcrypt-1.8.1p2 => /libgcrypt-1.8.1p2//
         sysclean-2.5 => /sysclean-2.5//
         py-Pillow-3.4.2p1 => /py-Pillow-3.4.2p1//
         npth-1.5 => /npth-1.5//
         firefox-56.0.2 => /firefox-56.0.2//
         vte3-0.50.2 => /vte3-0.50.2//
         p5-MLDBM-2.05 => /p5-MLDBM-2.05//
         libyajl-2.1.0 => /libyajl-2.1.0//
         geany-1.29p1 => /geany-1.29p1//
         nghttp2-1.27.0 => /nghttp2-1.27.0//
         orc-0.4.24p0 => /orc-0.4.24p0//
         py3-cairo-1.15.3 => /py3-cairo-1.15.3//
         gstreamer1-plugins-bad-1.12.3p1 =>
/gstreamer1-plugins-bad-1.12.3p1//
         p5-XML-Parser-2.44 => /p5-XML-Parser-2.44//
         ghostscript-9.07p6 =>
cups-filters-1.17.9p0,cups-libs-2.2.6,ghostscript-9.07p7,cups-2.2.6/cups-2.2.5p0,cups-libs-2.2.5,cups-filters-1.17.9p0,ghostscript-9.07p6//
         p5-List-MoreUtils-0.426 => /p5-List-MoreUtils-0.426//
         py-lxml-3.7.0p0 => /py-lxml-3.7.0p0//
         p5-WWW-Mechanize-1.86 => /p5-WWW-Mechanize-1.86//
         qtsensors-5.9.2 => /qtsensors-5.9.2//
         qtmultimedia-5.9.2 => /qtmultimedia-5.9.2//
         gtk+3-3.22.25p0 => /gtk+3-3.22.25p0//
         lua-5.1.5p6 => /lua-5.1.5p6//
         libksba-1.3.5p0 => /libksba-1.3.5p0//
         py-mako-0.9.1p3 => /py-mako-0.9.1p3//
         lz4-1.8.0p0 => /lz4-1.8.0p0//
         json-glib-1.4.2 => /json-glib-1.4.2//
         p5-HTTP-Date-6.02 => /p5-HTTP-Date-6.02//
         speex-1.2.0 => /speex-1.2.0//
         qtserialport-5.9.2 => /qtserialport-5.9.2//
         p5-Universal-require-0.18 => /p5-Universal-require-0.18//
         p5-Net-HTTP-6.17 => /p5-Net-HTTP-6.17//
         py3-gobject3-3.26.1 => /py3-gobject3-3.26.1//
         p5-Class-MethodMaker-2.24 => /p5-Class-MethodMaker-2.24//
         gconf2-3.2.6p8 => /gconf2-3.2.6p8//
         libbluray-1.0.0p0 => /libbluray-1.0.0p0//
         p5-Crypt-Rijndael-1.13 => /p5-Crypt-Rijndael-1.13//
         flac-1.3.2p1 => /flac-1.3.2p1//
         py-qt5-5.9p1 => /py-qt5-5.9p1//
         py-dateutil-2.6.0p0 => /py-dateutil-2.6.0p0//
         postgresql-client-9.6.5 => /postgresql-client-9.6.5//
         p5-URI-1.71 => /p5-URI-1.71//
         gtk+2-cups-2.24.31p3 => /gtk+2-cups-2.24.31p3//
         p5-XML-LibXML-2.0132v0 => /p5-XML-LibXML-2.0132v0//
         gmp-6.1.2p1 => /gmp-6.1.2p1//
         libsigc++-2.10.0p1 => /libsigc++-2.10.0p1//
         youtube-dl-2017.10.07 => /youtube-dl-2017.10.07//
         py-mechanize-0.3.5 => /py-mechanize-0.3.5//
         qtsvg-5.9.2 => /qtsvg-5.9.2//
         qtwebkit-5.9.0p2 => /qtwebkit-5.9.0p2//
         gnome-icon-theme-symbolic-3.12.0p2 =>
/gnome-icon-theme-symbolic-3.12.0p2//
         mpv-0.22.0p1 => /mpv-0.22.0p1//
         py-CherryPy-3.2.2p0 => /py-CherryPy-3.2.2p0//
         p5-XML-SAX-Expat-0.51 => /p5-XML-SAX-Expat-0.51//
         p5-libwww-6.15 => /p5-libwww-6.15//
         openldap-client-2.4.45p4 => /openldap-client-2.4.45p4//
         p5-File-Listing-6.04 => /p5-File-Listing-6.04//
         libass-0.13.7p0 => /libass-0.13.7p0//
         libxslt-1.1.30p0 => /libxslt-1.1.30p0//
         p5-LWP-Protocol-https-6.07 => /p5-LWP-Protocol-https-6.07//
         libidn2-2.0.0p0 => /libidn2-2.0.0p0//
         py3-yaml-3.12p0 => /py3-yaml-3.12p0//
         nspr-4.17 => /nspr-4.17//
         vmm-firmware-1.10.2p4 => /vmm-firmware-1.10.2p4//
         py-sip-4.19.3p1 => /py-sip-4.19.3p1//
         clucene-core-2.3.3.4p2 => /clucene-core-2.3.3.4p2//
         qtbase-5.9.2 => qtbase-5.9.2/qtbase-5.9.2//
         p5-Data-OptList-0.110 => /p5-Data-OptList-0.110//
         gstreamer1mm-1.10.0 => /gstreamer1mm-1.10.0//
         noto-cjk-1.004p0 => /noto-cjk-1.004p0//
         mpfr-3.1.5.2 => /mpfr-3.1.5.2//
         openal-1.16.0p1v0 => /openal-1.16.0p1v0//
         unzip-6.0p11 => /unzip-6.0p11//
         gvfs-1.34.1 => /gvfs-1.34.1//
         p5-Package-Stash-XS-0.28 => /p5-Package-Stash-XS-0.28//
         py-MarkupSafe-1.0 => /py-MarkupSafe-1.0//
         soundtouch-1.9.2p2 => /soundtouch-1.9.2p2//
         cyrus-sasl-2.1.26p24 => /cyrus-sasl-2.1.26p24//
         p5-Clone-0.38 => /p5-Clone-0.38//
         poppler-qt5-0.57.0p1 => /poppler-qt5-0.57.0p1//
         sxiv-1.3.2p0 => /sxiv-1.3.2p0//
         p5-HTTP-Daemon-6.01 => /p5-HTTP-Daemon-6.01//
         jdk-1.8.0.144v0 => /jdk-1.8.0.144v0//
         qtwebchannel-5.9.2 => /qtwebchannel-5.9.2//
         sdl-1.2.15p8 => /sdl-1.2.15p8//
         p5-Crypt-Blowfish_PP-1.12p0 => /p5-Crypt-Blowfish_PP-1.12p0//
         libsecret-0.18.5p0 => /libsecret-0.18.5p0//
         noto-emoji-20150929p0 => /noto-emoji-20150929p0//
         gnupg-2.1.23 => /gnupg-2.1.23//
         pcre2-10.23 => /pcre2-10.23//
         menu-cache-1.0.2 => /menu-cache-1.0.2//
         p11-kit-0.23.2p0 => /p11-kit-0.23.2p0//
         p5-HTTP-Message-6.13 => /p5-HTTP-Message-6.13//
         p5-HTML-Tagset-3.20p1 => /p5-HTML-Tagset-3.20p1//
         sdl2-2.0.5p2 => /sdl2-2.0.5p2//
         cdparanoia-3.a9.8p3 => /cdparanoia-3.a9.8p3//
         pinentry-1.0.0 => /pinentry-1.0.0//
         tarsnap-1.0.39 => /tarsnap-1.0.39//
         consolekit2-1.2.0p0 => /consolekit2-1.2.0p0//
         pango-1.40.13 => /pango-1.40.13//
         evince-3.24.1p1-light => /evince-3.24.1p1-light//
         libexif-0.6.21p0 => /libexif-0.6.21p0//
         fribidi-0.19.7 => /fribidi-0.19.7//
         p5-Mozilla-CA-Fake-20140330 => /p5-Mozilla-CA-Fake-20140330//
         libogg-1.3.2p0 => /libogg-1.3.2p0//
         p5-Module-Runtime-0.014 => /p5-Module-Runtime-0.014//
         mozilla-dicts-en-GB-1.3p1 => /mozilla-dicts-en-GB-1.3p1//
         opensp-1.5.2p1 => /opensp-1.5.2p1//
         tcl-8.5.19p0 => /tcl-8.5.19p0//
         podofo-0.9.5p0 => /podofo-0.9.5p0//
         py-netifaces-0.10.5p0 => /py-netifaces-0.10.5p0//
         libdvdcss-1.4.0 => /libdvdcss-1.4.0//
         py-beaker-1.6.2p5 => /py-beaker-1.6.2p5//
         py3-xdg-0.25p3 => /py3-xdg-0.25p3//
         gnome-icon-theme-3.12.0p3 => /gnome-icon-theme-3.12.0p3//
         rtorrent-0.9.6p3v0 => /rtorrent-0.9.6p3v0//
         speexdsp-1.2rc3 => /speexdsp-1.2rc3//
         tremor-20120410p1 => /tremor-20120410p1//
         p5-Net-Daemon-0.48p0 => /p5-Net-Daemon-0.48p0//
         libltdl-2.4.2p1 => /libltdl-2.4.2p1//
         libnettle-3.3p0 => /libnettle-3.3p0//
         iso-codes-3.76 => /iso-codes-3.76//
         p5-IO-Socket-Socks-0.74 => /p5-IO-Socket-Socks-0.74//
         graphite2-1.3.10p1 => /graphite2-1.3.10p1//
         py3-dateutil-2.6.0p0 => /py3-dateutil-2.6.0p0//
         pcmanfm-1.2.5 => /pcmanfm-1.2.5//
         libcroco-0.6.12 => /libcroco-0.6.12//
         p5-IO-Socket-SSL-2.052 => /p5-IO-Socket-SSL-2.052//
         gobject-introspection-1.54.1 => /gobject-introspection-1.54.1//
         libtasn1-4.12 => /libtasn1-4.12//
         libtorrent-0.13.6p2v0 => /libtorrent-0.13.6p2v0//
         x265-2.5p0 => /x265-2.5p0//
         p5-Try-Tiny-0.22 => /p5-Try-Tiny-0.22//
         p5-Digest-SHA1-2.13p4 => /p5-Digest-SHA1-2.13p4//
         tdb-1.3.12 => /tdb-1.3.12//
         qtxmlpatterns-5.9.2 => /qtxmlpatterns-5.9.2//
         p5-XML-NamespaceSupport-1.12 => /p5-XML-NamespaceSupport-1.12//
         libgnome-keyring-3.12.0p4 => /libgnome-keyring-3.12.0p4//
         p5-Module-Implementation-0.09 =>
/p5-Module-Implementation-0.09//
         libofx-0.9.12 => /libofx-0.9.12//
         polkit-0.113p4 => /polkit-0.113p4//
         p5-SQL-Statement-1.407 => /p5-SQL-Statement-1.407//
         libassuan-2.4.3p0 => /libassuan-2.4.3p0//
         glib2mm-2.54.1 => /glib2mm-2.54.1//
         gtk+3-cups-3.22.25p0 => /gtk+3-cups-3.22.25p0//
         py-beautifulsoup-3.2.1 => /py-beautifulsoup-3.2.1//
         py-apsw-3.9.2 => /py-apsw-3.9.2//
         cups-libs-2.2.5 =>
cups-filters-1.17.9p0,cups-libs-2.2.6,ghostscript-9.07p7,cups-2.2.6/cups-2.2.5p0,cups-libs-2.2.5,cups-filters-1.17.9p0,ghostscript-9.07p6//
         py-cssutils-1.0.1p0 => /py-cssutils-1.0.1p0//
         pulseaudio-11.1 => /pulseaudio-11.1//
         p5-Params-Util-1.07p1 => /p5-Params-Util-1.07p1//
         gstreamer1-plugins-base-1.12.3p0 =>
/gstreamer1-plugins-base-1.12.3p0//
         nss-3.33 => /nss-3.33//
         qttools-5.9.2 => /qttools-5.9.2//
         p5-Data-AMF-0.09p0 => /p5-Data-AMF-0.09p0//
         gcr-3.20.0p0 => /gcr-3.20.0p0//
         p5-HTTP-Cookies-6.04 => /p5-HTTP-Cookies-6.04//
         e2fsprogs-1.42.12p4 => /e2fsprogs-1.42.12p4//
         foomatic-db-4.0.20170503 => /foomatic-db-4.0.20170503//
         py3-ptyprocess-0.5.1p0 => /py3-ptyprocess-0.5.1p0//
         p5-PlRPC-0.2020 => /p5-PlRPC-0.2020//
         colord-1.3.5 => /colord-1.3.5//
         redshift-1.11p1 => /redshift-1.11p1//
         hunspell-1.6.1p1 => /hunspell-1.6.1p1//
         py-dnspython-1.15.0 => /py-dnspython-1.15.0//
         ddclient-3.8.3p0 => /ddclient-3.8.3p0//
         py-gobject3-common-3.26.1 => /py-gobject3-common-3.26.1//
         py3-six-1.10.0p0 => /py3-six-1.10.0p0//
         libbs2b-3.1.0p2 => /libbs2b-3.1.0p2//
         p5-Sub-Install-0.928 => /p5-Sub-Install-0.928//
         giflib-5.1.4 => /giflib-5.1.4//
         libid3tag-0.15.1bp4 => /libid3tag-0.15.1bp4//
         chmlib-0.40p2 => /chmlib-0.40p2//
         calibre-2.85.1p3 => calibre-2.85.1p3/calibre-2.85.1p3//
         py-xml-0.8.4p13 => /py-xml-0.8.4p13//
         p5-Exporter-Tiny-1.000000 => /p5-Exporter-Tiny-1.000000//
         redland-1.0.17p4 => /redland-1.0.17p4//
         p5-Class-Singleton-1.5 => /p5-Class-Singleton-1.5//
         raptor-2.0.15p1 => /raptor-2.0.15p1//
         geoclue2-2.4.7 => /geoclue2-2.4.7//
         libmms-0.6.2p3 => /libmms-0.6.2p3//
         p5-Any-Moose-0.18 => /p5-Any-Moose-0.18//
         gsm-1.0.17 => /gsm-1.0.17//
         harfbuzz-icu-1.6.3 => /harfbuzz-icu-1.6.3//
         sakura-3.4.0 => /sakura-3.4.0//
         p5-Term-ProgressBar-2.17p0 => /p5-Term-ProgressBar-2.17p0//
         qtconnectivity-5.9.2 => /qtconnectivity-5.9.2//
         p5-IO-HTML-1.001 => /p5-IO-HTML-1.001//
         x264-20170717 => /x264-20170717//
         py3-setuptools-28.6.1p0v0 => /py3-setuptools-28.6.1p0v0//
         libgpg-error-1.27p0 => /libgpg-error-1.27p0//
         libarchive-3.3.2 => /libarchive-3.3.2//
         p5-List-MoreUtils-XS-0.426 => /p5-List-MoreUtils-XS-0.426//
         p5-FreezeThaw-0.5001 => /p5-FreezeThaw-0.5001//
         p5-Dist-CheckConflicts-0.11 => /p5-Dist-CheckConflicts-0.11//
         p5-Digest-HMAC-1.03p0 => /p5-Digest-HMAC-1.03p0//
         libspectre-0.2.8p2 => /libspectre-0.2.8p2//
         wordnet-3.1p0 => /wordnet-3.1p0//
         qtdeclarative-5.9.2p0 => /qtdeclarative-5.9.2p0//
         p5-WWW-RobotRules-6.02 => /p5-WWW-RobotRules-6.02//
         qtwebsockets-5.9.2 => /qtwebsockets-5.9.2//
         gtk+2-2.24.31p2 => /gtk+2-2.24.31p2//
         chromium-62.0.3202.62p0 => /chromium-62.0.3202.62p0//
         glew-2.0.0 => /glew-2.0.0//
         tarsnapper-0.4.0p0 => /tarsnapper-0.4.0p0//
         unrar-5.50v1 => /unrar-5.50v1//
         qtlocation-5.9.2 => /qtlocation-5.9.2//
         mozjs17-17.0p4 => /mozjs17-17.0p4//
         homebank-5.1.5 => /homebank-5.1.5//
         libcddb-1.3.2p0 => /libcddb-1.3.2p0//
         libwmf-0.2.8.4p5 => /libwmf-0.2.8.4p5//
         p5-Package-Stash-0.37 => /p5-Package-Stash-0.37//
         xvidcore-1.3.4 => /xvidcore-1.3.4//
         libdvdnav-5.0.3v0 => /libdvdnav-5.0.3v0//
         libfm-extra-1.2.5 => /libfm-extra-1.2.5//
         lame-3.99.5p1 => /lame-3.99.5p1//
         opus-1.2.1 => /opus-1.2.1//
         p5-Storable-AMF-1.23 => /p5-Storable-AMF-1.23//
         libtheora-1.1.1p3 => /libtheora-1.1.1p3//
         p5-Class-Load-0.24 => /p5-Class-Load-0.24//
         p5-HTML-Form-6.03 => /p5-HTML-Form-6.03//
         tk-8.5.19p0 => /tk-8.5.19p0//
         p5-HTML-Tree-5.06 => /p5-HTML-Tree-5.06//
         cups-2.2.5p0 =>
cups-filters-1.17.9p0,cups-libs-2.2.6,ghostscript-9.07p7,cups-2.2.6/cups-2.2.5p0,cups-libs-2.2.5,cups-filters-1.17.9p0,ghostscript-9.07p6//
         icu4c-58.2p5 => /icu4c-58.2p5//
         scrot-0.8p3 => /scrot-0.8p3//
         rtmpdump-2.4.20151223 => /rtmpdump-2.4.20151223//
         giblib-1.2.4p7 => /giblib-1.2.4p7//
         qtx11extras-5.9.2 => /qtx11extras-5.9.2//
         libdvdread-5.0.3p0 => /libdvdread-5.0.3p0//
         neon-0.30.2p0 => /neon-0.30.2p0//
         p5-DateTime-1.07p2v0 => /p5-DateTime-1.07p2v0//
         libsndfile-1.0.27 => /libsndfile-1.0.27//
         p5-Encode-Locale-1.05 => /p5-Encode-Locale-1.05//
         py-dbus-common-1.2.4 => /py-dbus-common-1.2.4//
         py-setuptools-28.6.1p0v0 => /py-setuptools-28.6.1p0v0//
         gstreamer1-1.12.3 => /gstreamer1-1.12.3//
         p5-DateTime-TimeZone-1.64p1 => /p5-DateTime-TimeZone-1.64p1//
         imlib2-1.4.10 => /imlib2-1.4.10//
         py-six-1.10.0p0 => /py-six-1.10.0p0//
         p5-Module-Find-0.13 => /p5-Module-Find-0.13//
         par2cmdline-0.6.14p2 => /par2cmdline-0.6.14p2//
         libreoffice-5.2.7.2p6v0 => /libreoffice-5.2.7.2p6v0//
         py-cssselect-1.0.0p0 => /py-cssselect-1.0.0p0//
         libwebp-0.6.0 => /libwebp-0.6.0//
         p5-DBI-1.633 => /p5-DBI-1.633//
         rasqal-0.9.33p1 => /rasqal-0.9.33p1//
         p5-Mouse-2.4.2p0 => /p5-Mouse-2.4.2p0//
         noto-fonts-20150929p2 => /noto-fonts-20150929p2//
         keepassxc-2.2.1 => /keepassxc-2.2.1//
         libfm-1.2.5p0 => /libfm-1.2.5p0//
         p5-LWP-Protocol-socks-1.7 => /p5-LWP-Protocol-socks-1.7//
         jre-1.8.0.144v0 => /jre-1.8.0.144v0//
         p5-XML-Simple-2.24 => /p5-XML-Simple-2.24//
         cups-filters-1.17.9p0 =>
cups-filters-1.17.9p0,cups-libs-2.2.6,ghostscript-9.07p7,cups-2.2.6/cups-2.2.5p0,cups-libs-2.2.5,cups-filters-1.17.9p0,ghostscript-9.07p6//
         libcdio-0.80p9 => /libcdio-0.80p9//
         ffmpeg-20170825p2 => /ffmpeg-20170825p2//
         libidn-1.33p0 => /libidn-1.33p0//
         libyaml-0.1.7 => /libyaml-0.1.7//
uptodate: libusb1-1.0.21 python-2.7.14p0 tiff-4.0.8p1 lcms2-2.7
atk-2.26.1 lzo2-2.10 libffi-3.2.1p2 at-spi2-core-2.26.2
poppler-utils-0.57.0p1 png-1.6.34 libdaemon-0.14p1 gdk-pixbuf-2.36.11
jasper-1.900.1p5 glib2-networking-2.54.1 iodbc-3.52.10p0 harfbuzz-1.6.3
gpsd-2.95p9 xdg-utils-1.1.2p0 glfw-3.2.1p0 poppler-data-0.4.8
glib2-2.54.2p0 dbus-daemon-launch-helper-1.12.0 at-spi2-atk-2.26.1
dbus-1.12.0v0 bzip2-1.0.6p8 xz-5.2.3p0 athn-firmware-1.1p2
libexecinfo-0.3p0v0 gnutls-3.5.16 gettext-0.19.8.1p1 libxml-2.9.5
poppler-0.57.0p2 jpeg-1.5.1p0v0 libproxy-0.4.15p0
hicolor-icon-theme-0.17 gsettings-desktop-schemas-3.24.1 avahi-0.7p0
gtk-update-icon-cache-3.22.25p0 sqlite3-3.20.1 jbig2dec-0.11
openjp2-2.3.0 shared-mime-info-1.9p0 cairo-1.14.10p0 gdbm-1.13
qpdf-7.0beta1 dconf-0.26.1 libelf-0.8.13p4 libiconv-1.14p3
foomatic-db-engine-4.0.12p1 mupdf-1.11p2 curl-7.56.1 ijs-0.35p2
adwaita-icon-theme-3.26.0 ghostscript-fonts-8.11p3 quirks-2.376
libxkbcommon-0.7.2p0 librsvg-2.40.19p2 python-3.6.3p0 pcre-8.41
desktop-file-utils-0.23p0 dbus-glib-0.108v0 geoclue-0.12.99p5
libsoup-2.60.2
cant_update:
Read shared items: ok
Look in /usr/local/share/doc/pkg-readmes for extra documentation.
--- -cups-2.2.5p0 -------------------
You should also run rm -rf /etc/cups/*.conf.O /var/log/cups
You should also check /etc/cups/classes.conf (which was modified)
You should also check /etc/cups/printers.conf (which was modified)
You should also run rm -rf /var/cache/cups
You should also run rm -rf /var/spool/cups
--- -dconf-0.26.1 -------------------
You should also run rm -rf /etc/dconf/db/*
You should also run rm -rf /etc/dconf/profile/*
--- -iodbc-3.52.10 -------------------
You should also run rm -rf /etc/iodbc/ODBCDataSources/*
Fatal error: can't parse OpenBSD::RequiredBy: writing
/var/db/pkg/cups-libs-2.2.5/+REQUIRED_BY: No such file or directory at
/usr/libdata/perl5/OpenBSD/RequiredBy.pm line 30.
         
OpenBSD::RequirementList::fatal_error(OpenBSD::RequiredBy=HASH(0xb5791d52760),
"writing") called at /usr/libdata/perl5/OpenBSD/RequiredBy.pm line 67
         
OpenBSD::RequirementList::synch(OpenBSD::RequiredBy=HASH(0xb5791d52760))
called at /usr/libdata/perl5/OpenBSD/RequiredBy.pm line 122
         
OpenBSD::RequirementList::add(OpenBSD::RequiredBy=HASH(0xb5791d52760),
"cups-filters-1.17.9p0") called at
/usr/libdata/perl5/OpenBSD/Dependencies.pm line 713
         
OpenBSD::Dependencies::Solver::register_dependencies(OpenBSD::Dependencies::Solver=HASH(0xb573dba09d0),
OpenBSD::PkgAdd::State=HASH(0xb5716a19f58)) called at
/usr/libdata/perl5/OpenBSD/PkgAdd.pm line 839
         
OpenBSD::PkgAdd::really_add(OpenBSD::UpdateSet=HASH(0xb56fd766880),
OpenBSD::PkgAdd::State=HASH(0xb5716a19f58)) called at
/usr/libdata/perl5/OpenBSD/PkgAdd.pm line 1033
         OpenBSD::PkgAdd::process_set("OpenBSD::PkgAdd",
OpenBSD::UpdateSet=HASH(0xb56fd766880),
OpenBSD::PkgAdd::State=HASH(0xb5716a19f58)) called at
/usr/libdata/perl5/OpenBSD/AddDelete.pm line 150
         OpenBSD::AddDelete::process_setlist("OpenBSD::PkgAdd",
OpenBSD::PkgAdd::State=HASH(0xb5716a19f58)) called at
/usr/libdata/perl5/OpenBSD/PkgAdd.pm line 1170
         OpenBSD::PkgAdd::main("OpenBSD::PkgAdd",
OpenBSD::PkgAdd::State=HASH(0xb5716a19f58)) called at
/usr/libdata/perl5/OpenBSD/AddDelete.pm line 50
         eval {...} called at /usr/libdata/perl5/OpenBSD/AddDelete.pm
line 50
         OpenBSD::AddDelete::do_the_main_work("OpenBSD::PkgAdd",
OpenBSD::PkgAdd::State=HASH(0xb5716a19f58)) called at
/usr/libdata/perl5/OpenBSD/AddDelete.pm line 64
         OpenBSD::AddDelete::__ANON__ called at
/usr/libdata/perl5/OpenBSD/AddDelete.pm line 87
         OpenBSD::AddDelete::__ANON__ called at
/usr/libdata/perl5/OpenBSD/Error.pm line 175
         eval {...} called at /usr/libdata/perl5/OpenBSD/Error.pm line
175
         OpenBSD::Error::try(CODE(0xb569ee801f0),
OpenBSD::Error::catch=CODE(0xb569ee80238)) called at
/usr/libdata/perl5/OpenBSD/AddDelete.pm line 95
         OpenBSD::AddDelete::framework("OpenBSD::PkgAdd",
OpenBSD::PkgAdd::State=HASH(0xb5716a19f58)) called at
/usr/libdata/perl5/OpenBSD/AddDelete.pm line 126
         OpenBSD::AddDelete::parse_and_run("OpenBSD::PkgAdd", "pkg_add")
called at /usr/sbin/pkg_add line 30
         main::run("pkg_add", "PkgAdd") called at /usr/sbin/pkg_add line
46


Reply | Threaded
Open this post in threaded view
|

Re: pkg_add: fatal error when updating packages

Marc Espie-2
On Sat, Nov 04, 2017 at 05:47:46PM -0400, Michael Reed wrote:
> $ sysctl -n kern.version
> OpenBSD 6.2-current (GENERIC.MP) #193: Wed Nov  1 12:24:15 MDT 2017
>     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>
>
> Recently I ran pkg_add -u and it bailed out with an ultra-long error
> message.
> This is what happened:

Congrats, you ran into the elusive cups update bug.

I'd love to fix that one, but I haven't figured it out yet.

The vomit you're seeing is indeed a dump with lots of information.
I'm still clueless though. :(

As for fixing your machine, run pkg_check, then pkg_add -u will work
again.


Reply | Threaded
Open this post in threaded view
|

Re: pkg_add: fatal error when updating packages

Landry Breuil-5
In reply to this post by Michael Reed-2
On Sat, Nov 04, 2017 at 05:47:46PM -0400, Michael Reed wrote:
> $ sysctl -n kern.version
> OpenBSD 6.2-current (GENERIC.MP) #193: Wed Nov  1 12:24:15 MDT 2017
>     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>
>
> Recently I ran pkg_add -u and it bailed out with an ultra-long error
> message.

Welcome to the large club of people who had this error. Take a seat,
have a cocktail, you're here for a while as we sail on the
faiilbooaaatt..