pkg_add errors on current

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pkg_add errors on current

jungle Boogie
Hi All,

Running openBSD snapshot on amd64 from today, but I think this has been an issue since
perl 5.28 was added.


# pkg_add -u
perl:/usr/local/libdata/perl5/site_perl/amd64-openbsd/auto/List/Util/Util.so: undefined symbol 'PL_sv_no'                                                                      
perl:/usr/local/libdata/perl5/site_perl/amd64-openbsd/auto/List/Util/Util.so: undefined symbol 'PL_sv_undef'                                                                    
perl:/usr/local/libdata/perl5/site_perl/amd64-openbsd/auto/List/Util/Util.so: undefined symbol 'PL_sv_yes'                                                                      
Fatal error: can't parse Attempt to reload Scalar/Util.pm aborted.
Compilation failed in require at /usr/libdata/perl5/amd64-openbsd/IO/Compress/Base/Common.pm line 8.                                                                            
BEGIN failed--compilation aborted at /usr/libdata/perl5/amd64-openbsd/IO/Compress/Base/Common.pm line 8.                                                                        
Compilation failed in require at /usr/libdata/perl5/amd64-openbsd/IO/Uncompress/RawInflate.pm line 9.
BEGIN failed--compilation aborted at /usr/libdata/perl5/amd64-openbsd/IO/Uncompress/RawInflate.pm line 9.
Compilation failed in require at /usr/libdata/perl5/amd64-openbsd/IO/Uncompress/Gunzip.pm line 12.
BEGIN failed--compilation aborted at /usr/libdata/perl5/amd64-openbsd/IO/Uncompress/Gunzip.pm line 12.
Compilation failed in require at /usr/libdata/perl5/OpenBSD/PackageRepository.pm line 434.

Is this something I've done wrong with perl or an issue at the moment?

Thanks!

Reply | Threaded
Open this post in threaded view
|

Re: pkg_add errors on current

Stuart Henderson
On 2019-02-16, Jungle Boogie <[hidden email]> wrote:
> Hi All,
>
> Running openBSD snapshot on amd64 from today, but I think this has been an issue since
> perl 5.28 was added.

Where did .../perl5/site_perl/amd64-openbsd/auto/List/Util/Util.so come from?
It isn't in ports.

However you installed it, you either need to rebuild it or remove it.


Reply | Threaded
Open this post in threaded view
|

Re: pkg_add errors on current

jungle Boogie
On Sun 17 Feb 2019 12:25 PM, Stuart Henderson wrote:

> On 2019-02-16, Jungle Boogie <[hidden email]> wrote:
> > Hi All,
> >
> > Running openBSD snapshot on amd64 from today, but I think this has been an issue since
> > perl 5.28 was added.
>
> Where did .../perl5/site_perl/amd64-openbsd/auto/List/Util/Util.so come from?
> It isn't in ports.
>
> However you installed it, you either need to rebuild it or remove it.

Thanks for the hint! After removing, pkg_add works as normal.

>
>