pinebook 11" 1080p Xorg crashing with tcsetattr: Inappropriate ioctl for device

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

pinebook 11" 1080p Xorg crashing with tcsetattr: Inappropriate ioctl for device

Mikolaj Kucharski-3
>Synopsis: Xorg crash with can't switch keyboard to raw mode. Enable support for it in the kernel
>Category: arm kernel
>Environment:
        System      : OpenBSD 6.6
        Details     : OpenBSD 6.6-current (GENERIC.MP) #522: Wed Mar 25 14:03:43 MDT 2020
                         [hidden email]:/usr/src/sys/arch/arm64/compile/GENERIC.MP

        Architecture: OpenBSD.arm64
        Machine     : arm64
>Description:
        Unable to start X11. Problem started after upgrade to recent snapshot, I forgot to note when
        I had last time working X11 on this Pinebook. This machine is following -current, so upgrade
        was from a snapshot to more recent snapshot. I'm inlining Xorg.log at the end of the email.
        I don't have anything special in /etc/X11/xorg.conf(.d):

        # find /etc/X11/xorg.conf* -type f -exec cat '{}' +
        # /etc/X11/xorg.conf.d/75-fonts.conf

        Section "Files"
                FontPath "/usr/local/share/fonts/spleen"
        EndSection

>How-To-Repeat:
        Enable xenodm on boot up, upgrade system as usual, boot up system, Xorg crashes:

        [    77.562] (II) XINPUT: Adding extended input device "/dev/wskbd" (type: KEYBOARD, id 6)
        [    77.564] (EE) KbdOn: tcsetattr: Inappropriate ioctl for device
        [    77.564] (EE)
        Fatal server error:
        [    77.564] (EE) can't switch keyboard to raw mode. Enable support for it in the kernel

>Fix:
        Unknown


dmesg:
OpenBSD 6.6-current (GENERIC.MP) #522: Wed Mar 25 14:03:43 MDT 2020
    [hidden email]:/usr/src/sys/arch/arm64/compile/GENERIC.MP
real mem  = 2015850496 (1922MB)
avail mem = 1923846144 (1834MB)
mainbus0 at root: Pinebook
cpu0 at mainbus0 mpidr 0: ARM Cortex-A53 r0p4
cpu0: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
cpu0: 512KB 64b/line 16-way L2 cache
efi0 at mainbus0: UEFI 2.7
efi0: Das U-Boot rev 0x20190400
apm0 at mainbus0
psci0 at mainbus0: PSCI 0.2
"osc24M_clk" at mainbus0 not configured
"osc32k_clk" at mainbus0 not configured
"internal-osc-clk" at mainbus0 not configured
"sound_spdif" at mainbus0 not configured
"spdif-out" at mainbus0 not configured
agtimer0 at mainbus0: tick rate 24000 KHz
simplebus0 at mainbus0: "soc"
sxisyscon0 at simplebus0
sxisid0 at simplebus0
sxiccmu0 at simplebus0
sxipio0 at simplebus0: 103 pins
ampintc0 at simplebus0 nirq 224, ncpu 4 ipi: 0, 1: "interrupt-controller"
sxirtc0 at simplebus0
sxiccmu1 at simplebus0
sxipio1 at simplebus0: 13 pins
sxirsb0 at simplebus0
axppmic0 at sxirsb0 addr 0x3a3: AXP803
"de2" at simplebus0 not configured
"dma-controller" at simplebus0 not configured
"lcd-controller" at simplebus0 not configured
"lcd-controller" at simplebus0 not configured
sximmc0 at simplebus0
sdmmc0 at sximmc0: 4-bit, sd high-speed, mmc high-speed, dma
sximmc1 at simplebus0
sdmmc1 at sximmc1: 4-bit, sd high-speed, mmc high-speed, dma
sximmc2 at simplebus0
sdmmc2 at sximmc2: 8-bit, sd high-speed, mmc high-speed, dma
"phy" at simplebus0 not configured
ehci0 at simplebus0
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "Generic EHCI root hub" rev 2.00/1.00 addr 1
ohci0 at simplebus0: version 1.0
ehci1 at simplebus0
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Generic EHCI root hub" rev 2.00/1.00 addr 1
ohci1 at simplebus0: version 1.0
com0 at simplebus0sxiccmu_ccu_reset: 0x0000002e
: ns16550, no working fifo
sxipwm0 at simplebus0
"hdmi-phy" at simplebus0 not configured
"interrupt-controller" at simplebus0 not configured
sxitwi0 at simplebus0
iic0 at sxitwi0
"analogix,anx6345" at iic0 addr 0x38 not configured
sxidog0 at simplebus0
gpio0 at sxipio0: 32 pins
gpio1 at sxipio0: 32 pins
gpio2 at sxipio0: 32 pins
gpio3 at sxipio0: 32 pins
gpio4 at sxipio0: 32 pins
gpio5 at sxipio0: 32 pins
gpio6 at sxipio0: 32 pins
gpio7 at sxipio0: 32 pins
gpio8 at sxipio1: 32 pins
usb2 at ohci0: USB revision 1.0
uhub2 at usb2 configuration 1 interface 0 "Generic OHCI root hub" rev 1.00/1.00 addr 1
usb3 at ohci1: USB revision 1.0
uhub3 at usb3 configuration 1 interface 0 "Generic OHCI root hub" rev 1.00/1.00 addr 1
"regulator" at mainbus0 not configured
pwmbl0 at mainbus0
"gpio_keys" at mainbus0 not configured
"vcc3v3" at mainbus0 not configured
"wifi_pwrseq" at mainbus0 not configured
"binman" at mainbus0 not configured
simplefb0 at mainbus0: 1920x1080, 32bpp
wsdisplay0 at simplefb0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
cpu1 at mainbus0 mpidr 1: ARM Cortex-A53 r0p4
cpu1: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
cpu1: 512KB 64b/line 16-way L2 cache
cpu2 at mainbus0 mpidr 2: ARM Cortex-A53 r0p4
cpu2: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
cpu2: 512KB 64b/line 16-way L2 cache
cpu3 at mainbus0 mpidr 3: ARM Cortex-A53 r0p4
cpu3: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
cpu3: 512KB 64b/line 16-way L2 cache
manufacturer 0x024c, product 0xb703 at sdmmc1 function 1 not configured
scsibus0 at sdmmc0: 2 targets, initiator 0
sd0 at scsibus0 targ 1 lun 0: <SD/MMC, SR256, 0080> removable
sd0: 244016MB, 512 bytes/sector, 499744768 sectors
scsibus1 at sdmmc2: 2 targets, initiator 0
sd1 at scsibus1 targ 1 lun 0: <Samsung, AJTD4R, 0000> removable
sd1: 14910MB, 512 bytes/sector, 30535680 sectors
uhub4 at uhub1 port 1 configuration 1 interface 0 "Genesys Logic USB2.0 Hub" rev 2.00/88.32 addr 2
uhidev0 at uhub4 port 1 configuration 1 interface 0 "HAILUCK CO.,LTD USB KEYBOARD" rev 1.10/1.00 addr 3
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 variable keys, 6 key codes
wskbd0 at ukbd0: console keyboard, using wsdisplay0
uhidev1 at uhub4 port 1 configuration 1 interface 1 "HAILUCK CO.,LTD USB KEYBOARD" rev 1.10/1.00 addr 3
uhidev1: iclass 3/0, 9 report ids
ums0 at uhidev1 reportid 1: 5 buttons, Z and W dir
wsmouse0 at ums0 mux 0
uhid0 at uhidev1 reportid 2: input=1, output=0, feature=0
uhid1 at uhidev1 reportid 3: input=3, output=0, feature=0
uhid2 at uhidev1 reportid 5: input=0, output=0, feature=5
uhid3 at uhidev1 reportid 6: input=0, output=0, feature=255
uhid4 at uhidev1 reportid 9: input=1, output=0, feature=0
urtwn0 at uhub4 port 2 configuration 1 interface 0 "Realtek 802.11n WLAN Adapter" rev 2.00/2.00 addr 4
urtwn0: MAC/BB RTL8188CUS, RF 6052 1T1R, address 80:1f:02:4b:6a:6b
uvideo0 at uhub4 port 3 configuration 1 interface 0 "Generic USB2.0 PC CAMERA" rev 2.00/1.00 addr 5
video0 at uvideo0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
bootfile: sd0a:/bsd
boot device: sd0
root on sd1a (1440dafaca0ef42a.a) swap on sd1b dump on sd1b
urtwn0: INIT -> SCAN
urtwn0: begin active scan
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 2 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 3 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 4 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 5 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 6 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 7 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 8 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 9 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 10 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 11 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 12 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 13 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 14 mode auto
urtwn0: SCAN -> SCAN
urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 1 mode auto
urtwn0: end active scan
urtwn0: - 00:1d:7e:ec:23:c8   11  +174 54M   ess       no!  rsn! "linksys"!
urtwn0: + 04:f0:21:34:e4:23   13  +198 54M   ess  privacy   rsn  "net_092382"
urtwn0: - 4c:ed:fb:d2:44:7c   12  +182 54M   ess  privacy   rsn  "b242"!
urtwn0: - 68:d4:82:79:02:2d   11  +174 54M   ess  privacy   rsn  "INEA-2D3B"!
urtwn0: - 80:3e:48:c6:fd:81    6  +162 54M   ess  privacy   rsn  "INEA-D4C9_2.4G"!
urtwn0: - ec:08:6b:ce:09:5c    5  +166 54M   ess  privacy   rsn  "TP-LINK_CE095D"!
urtwn0: - fc:f5:28:f8:6b:1a    1  +166 54M   ess  privacy   rsn! "ZyXEL"!
urtwn0: SCAN -> AUTH
urtwn0: sending auth to 04:f0:21:34:e4:23 on channel 13 mode 11g
urtwn0: AUTH -> ASSOC
urtwn0: sending assoc_req to 04:f0:21:34:e4:23 on channel 13 mode 11g
urtwn0: ASSOC -> RUN
urtwn0: associated with 04:f0:21:34:e4:23 ssid "net_092382" channel 13 start 54Mb short preamble short slot time
urtwn0: missed beacon threshold set to 30 beacons, beacon interval is 100 TU
urtwn0: received msg 1/4 of the 4-way handshake from 04:f0:21:34:e4:23
urtwn0: sending msg 2/4 of the 4-way handshake to 04:f0:21:34:e4:23
urtwn0: received msg 1/4 of the 4-way handshake from 04:f0:21:34:e4:23
urtwn0: sending msg 2/4 of the 4-way handshake to 04:f0:21:34:e4:23
urtwn0: received msg 1/4 of the 4-way handshake from 04:f0:21:34:e4:23
urtwn0: sending msg 2/4 of the 4-way handshake to 04:f0:21:34:e4:23
urtwn0: RUN -> AUTH
urtwn0: sending auth to 04:f0:21:34:e4:23 on channel 13 mode 11g
urtwn0: AUTH -> ASSOC
urtwn0: sending assoc_req to 04:f0:21:34:e4:23 on channel 13 mode 11g
urtwn0: ASSOC -> RUN
urtwn0: associated with 04:f0:21:34:e4:23 ssid "net_092382" channel 13 start 54Mb short preamble short slot time
urtwn0: missed beacon threshold set to 30 beacons, beacon interval is 100 TU
urtwn0: received msg 1/4 of the 4-way handshake from 04:f0:21:34:e4:23
urtwn0: sending msg 2/4 of the 4-way handshake to 04:f0:21:34:e4:23
urtwn0: received msg 3/4 of the 4-way handshake from 04:f0:21:34:e4:23
urtwn0: sending msg 4/4 of the 4-way handshake to 04:f0:21:34:e4:23

usbdevs:
Controller /dev/usb0:
addr 01: 0000:0000 Generic, EHCI root hub
         high speed, self powered, config 1, rev 1.00
         driver: uhub0
Controller /dev/usb1:
addr 01: 0000:0000 Generic, EHCI root hub
         high speed, self powered, config 1, rev 1.00
         driver: uhub1
addr 02: 05e3:0608 Genesys Logic, USB2.0 Hub
         high speed, self powered, config 1, rev 88.32
         driver: uhub4
addr 03: 258a:000c HAILUCK CO.,LTD, USB KEYBOARD
         low speed, power 100 mA, config 1, rev 1.00
         driver: uhidev0
         driver: uhidev1
addr 04: 7392:7811 Realtek, 802.11n WLAN Adapter
         high speed, power 500 mA, config 1, rev 2.00, iSerial 00e04c000001
         driver: urtwn0
addr 05: 1908:2311 Generic, USB2.0 PC CAMERA
         high speed, power 256 mA, config 1, rev 1.00
         driver: uvideo0
Controller /dev/usb2:
addr 01: 0000:0000 Generic, OHCI root hub
         full speed, self powered, config 1, rev 1.00
         driver: uhub2
Controller /dev/usb3:
addr 01: 0000:0000 Generic, OHCI root hub
         full speed, self powered, config 1, rev 1.00
         driver: uhub3

pcidump:

acpidump:

Xorg.log:
[    73.344] (--) Using wscons driver on /dev/ttyC1
[    73.434]
X.Org X Server 1.20.7
X Protocol Version 11, Revision 0
[    73.435] Build Operating System: OpenBSD 6.6 arm64
[    73.435] Current Operating System: OpenBSD pinebook-0011.home.local 6.6 GENERIC.MP#522 arm64
[    73.436] Build Date: 25 March 2020  03:19:41PM
[    73.436]  
[    73.436] Current version of pixman: 0.38.4
[    73.436] Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    73.436] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    73.437] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 26 19:35:39 2020
[    73.447] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    73.448] (==) Using system config directory "/usr/X11R6/share/X11/xorg.conf.d"
[    73.461] (==) No Layout section.  Using the first Screen section.
[    73.461] (==) No screen section available. Using defaults.
[    73.461] (**) |-->Screen "Default Screen Section" (0)
[    73.461] (**) |   |-->Monitor "<default monitor>"
[    73.468] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    73.469] (==) Automatically adding devices
[    73.469] (==) Automatically enabling devices
[    73.469] (==) Not automatically adding GPU devices
[    73.470] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    73.477] (**) FontPath set to:
        /usr/local/share/fonts/spleen,
        /usr/X11R6/lib/X11/fonts/misc/,
        /usr/X11R6/lib/X11/fonts/TTF/,
        /usr/X11R6/lib/X11/fonts/OTF/,
        /usr/X11R6/lib/X11/fonts/Type1/,
        /usr/X11R6/lib/X11/fonts/100dpi/,
        /usr/X11R6/lib/X11/fonts/75dpi/
[    73.477] (==) ModulePath set to "/usr/X11R6/lib/modules"
[    73.477] (II) The server relies on wscons to provide the list of input devices.
        If no devices become available, reconfigure wscons or disable AutoAddDevices.
[    73.478] (II) Loader magic: 0x156840000
[    73.478] (II) Module ABI versions:
[    73.478] X.Org ANSI C Emulation: 0.4
[    73.478] X.Org Video Driver: 24.1
[    73.478] X.Org XInput driver : 24.1
[    73.478] X.Org Server Extension : 10.0
[    73.484] (II) LoadModule: "glx"
[    73.488] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
[    73.864] (II) Module glx: vendor="X.Org Foundation"
[    73.864] compiled for 1.20.7, module version = 1.0.0
[    73.864] ABI class: X.Org Server Extension, version 10.0
[    73.867] (==) Matched wsfb as autoconfigured driver 0
[    73.867] (==) Assigned the driver to the xf86ConfigLayout
[    73.867] (II) LoadModule: "wsfb"
[    73.869] (II) Loading /usr/X11R6/lib/modules/drivers/wsfb_drv.so
[    73.879] (II) Module wsfb: vendor="X.Org Foundation"
[    73.879] compiled for 1.20.7, module version = 0.4.1
[    73.879] ABI class: X.Org Video Driver, version 24.1
[    74.396] (II) wsfb: driver for wsdisplay framebuffer: wsfb
[    74.397] (WW) Falling back to old probe method for wsfb
[    74.400] (II) wsfb(0): using default device
[    74.413] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    74.418] (II) wsfb(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    74.419] (==) wsfb(0): Depth 24, (--) framebuffer bpp 32
[    74.419] (==) wsfb(0): RGB weight 888
[    74.419] (==) wsfb(0): Default visual is TrueColor
[    74.420] (==) wsfb(0): Using gamma correction (1.0, 1.0, 1.0)
[    74.420] (II) wsfb(0): Vidmem: 8100k
[    74.421] (==) wsfb(0): DPI set to (96, 96)
[    74.421] (**) wsfb(0): Using "Shadow Framebuffer"
[    74.421] (II) Loading sub module "shadow"
[    74.421] (II) LoadModule: "shadow"
[    74.430] (II) Loading /usr/X11R6/lib/modules/libshadow.so
[    74.447] (II) Module shadow: vendor="X.Org Foundation"
[    74.447] compiled for 1.20.7, module version = 1.1.0
[    74.447] ABI class: X.Org ANSI C Emulation, version 0.4
[    74.447] (II) Loading sub module "fb"
[    74.447] (II) LoadModule: "fb"
[    74.452] (II) Loading /usr/X11R6/lib/modules/libfb.so
[    74.477] (II) Module fb: vendor="X.Org Foundation"
[    74.477] compiled for 1.20.7, module version = 1.0.0
[    74.477] ABI class: X.Org ANSI C Emulation, version 0.4
[    74.521] (==) wsfb(0): Backing store enabled
[    74.537] (II) Initializing extension Generic Event Extension
[    74.541] (II) Initializing extension SHAPE
[    74.543] (II) Initializing extension MIT-SHM
[    74.546] (II) Initializing extension XInputExtension
[    74.554] (II) Initializing extension XTEST
[    74.556] (II) Initializing extension BIG-REQUESTS
[    74.558] (II) Initializing extension SYNC
[    74.563] (II) Initializing extension XKEYBOARD
[    74.568] (II) Initializing extension XC-MISC
[    74.571] (II) Initializing extension SECURITY
[    74.575] (II) Initializing extension XFIXES
[    74.578] (II) Initializing extension RENDER
[    74.581] (II) Initializing extension RANDR
[    74.586] (II) Initializing extension COMPOSITE
[    74.595] (II) Initializing extension DAMAGE
[    74.597] (II) Initializing extension MIT-SCREEN-SAVER
[    74.602] (II) Initializing extension DOUBLE-BUFFER
[    74.609] (II) Initializing extension RECORD
[    74.612] (II) Initializing extension DPMS
[    74.612] (II) Initializing extension Present
[    74.614] (II) Initializing extension DRI3
[    74.616] (II) Initializing extension X-Resource
[    74.626] (II) Initializing extension XVideo
[    74.629] (II) Initializing extension XVideo-MotionCompensation
[    74.629] (II) Initializing extension GLX
[    74.634] (II) AIGLX: Screen 0 is not DRI2 capable
[    76.392] (II) IGLX: Loaded and initialized swrast
[    76.392] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[    76.392] (II) Initializing extension XFree86-VidModeExtension
[    76.396] (II) Initializing extension XFree86-DGA
[    76.400] (II) Initializing extension XFree86-DRI
[    76.402] (II) Initializing extension DRI2
[    77.547] (II) config/wscons: checking input device /dev/wskbd
[    77.548] (II) wskbd: using layout us
[    77.549] (II) LoadModule: "kbd"
[    77.552] (II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so
[    77.561] (II) Module kbd: vendor="X.Org Foundation"
[    77.561] compiled for 1.20.7, module version = 1.9.0
[    77.561] Module class: X.Org XInput Driver
[    77.561] ABI class: X.Org XInput driver, version 24.1
[    77.561] (II) Using input driver 'kbd' for '/dev/wskbd'
[    77.561] (**) /dev/wskbd: always reports core events
[    77.562] (**) /dev/wskbd: always reports core events
[    77.562] (**) Option "Protocol" "standard"
[    77.562] (**) Option "XkbRules" "base"
[    77.562] (**) Option "XkbModel" "pc105"
[    77.562] (**) Option "XkbLayout" "us"
[    77.562] (II) XINPUT: Adding extended input device "/dev/wskbd" (type: KEYBOARD, id 6)
[    77.564] (EE) KbdOn: tcsetattr: Inappropriate ioctl for device
[    77.564] (EE)
Fatal server error:
[    77.564] (EE) can't switch keyboard to raw mode. Enable support for it in the kernel
or use for example:

Option "Protocol" "wskbd"
Option "Device" "/dev/wskbd0"

in your xorg.conf(5) file
[    77.564] (EE)
[    77.565] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    77.565] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    77.565] (EE)
[    77.599] (EE) Server terminated with error (1). Closing log file.

--
Regards,
 Mikolaj

Reply | Threaded
Open this post in threaded view
|

Re: pinebook 11" 1080p Xorg crashing with tcsetattr: Inappropriate ioctl for device

Marcus MERIGHI
Good Morning Mikolaj,

I have the same message in Xorg.0.log on my Pinebook Pro, ever since I
have it. It's a known bug for the Pinebook Pro.

A second attempt at starting xenodm(1) succeeds for me.

Marcus

[hidden email] (Mikolaj Kucharski), 2020.03.26 (Thu) 21:05 (CET):

> >Synopsis: Xorg crash with can't switch keyboard to raw mode. Enable support for it in the kernel
> >Category: arm kernel
> >Environment:
> System      : OpenBSD 6.6
> Details     : OpenBSD 6.6-current (GENERIC.MP) #522: Wed Mar 25 14:03:43 MDT 2020
> [hidden email]:/usr/src/sys/arch/arm64/compile/GENERIC.MP
>
> Architecture: OpenBSD.arm64
> Machine     : arm64
> >Description:
> Unable to start X11. Problem started after upgrade to recent snapshot, I forgot to note when
> I had last time working X11 on this Pinebook. This machine is following -current, so upgrade
> was from a snapshot to more recent snapshot. I'm inlining Xorg.log at the end of the email.
> I don't have anything special in /etc/X11/xorg.conf(.d):
>
> # find /etc/X11/xorg.conf* -type f -exec cat '{}' +
> # /etc/X11/xorg.conf.d/75-fonts.conf
>
> Section "Files"
> FontPath "/usr/local/share/fonts/spleen"
> EndSection
>
> >How-To-Repeat:
> Enable xenodm on boot up, upgrade system as usual, boot up system, Xorg crashes:
>
> [    77.562] (II) XINPUT: Adding extended input device "/dev/wskbd" (type: KEYBOARD, id 6)
> [    77.564] (EE) KbdOn: tcsetattr: Inappropriate ioctl for device
> [    77.564] (EE)
> Fatal server error:
> [    77.564] (EE) can't switch keyboard to raw mode. Enable support for it in the kernel
>
> >Fix:
> Unknown
>
>
> dmesg:
> OpenBSD 6.6-current (GENERIC.MP) #522: Wed Mar 25 14:03:43 MDT 2020
>     [hidden email]:/usr/src/sys/arch/arm64/compile/GENERIC.MP
> real mem  = 2015850496 (1922MB)
> avail mem = 1923846144 (1834MB)
> mainbus0 at root: Pinebook
> cpu0 at mainbus0 mpidr 0: ARM Cortex-A53 r0p4
> cpu0: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
> cpu0: 512KB 64b/line 16-way L2 cache
> efi0 at mainbus0: UEFI 2.7
> efi0: Das U-Boot rev 0x20190400
> apm0 at mainbus0
> psci0 at mainbus0: PSCI 0.2
> "osc24M_clk" at mainbus0 not configured
> "osc32k_clk" at mainbus0 not configured
> "internal-osc-clk" at mainbus0 not configured
> "sound_spdif" at mainbus0 not configured
> "spdif-out" at mainbus0 not configured
> agtimer0 at mainbus0: tick rate 24000 KHz
> simplebus0 at mainbus0: "soc"
> sxisyscon0 at simplebus0
> sxisid0 at simplebus0
> sxiccmu0 at simplebus0
> sxipio0 at simplebus0: 103 pins
> ampintc0 at simplebus0 nirq 224, ncpu 4 ipi: 0, 1: "interrupt-controller"
> sxirtc0 at simplebus0
> sxiccmu1 at simplebus0
> sxipio1 at simplebus0: 13 pins
> sxirsb0 at simplebus0
> axppmic0 at sxirsb0 addr 0x3a3: AXP803
> "de2" at simplebus0 not configured
> "dma-controller" at simplebus0 not configured
> "lcd-controller" at simplebus0 not configured
> "lcd-controller" at simplebus0 not configured
> sximmc0 at simplebus0
> sdmmc0 at sximmc0: 4-bit, sd high-speed, mmc high-speed, dma
> sximmc1 at simplebus0
> sdmmc1 at sximmc1: 4-bit, sd high-speed, mmc high-speed, dma
> sximmc2 at simplebus0
> sdmmc2 at sximmc2: 8-bit, sd high-speed, mmc high-speed, dma
> "phy" at simplebus0 not configured
> ehci0 at simplebus0
> usb0 at ehci0: USB revision 2.0
> uhub0 at usb0 configuration 1 interface 0 "Generic EHCI root hub" rev 2.00/1.00 addr 1
> ohci0 at simplebus0: version 1.0
> ehci1 at simplebus0
> usb1 at ehci1: USB revision 2.0
> uhub1 at usb1 configuration 1 interface 0 "Generic EHCI root hub" rev 2.00/1.00 addr 1
> ohci1 at simplebus0: version 1.0
> com0 at simplebus0sxiccmu_ccu_reset: 0x0000002e
> : ns16550, no working fifo
> sxipwm0 at simplebus0
> "hdmi-phy" at simplebus0 not configured
> "interrupt-controller" at simplebus0 not configured
> sxitwi0 at simplebus0
> iic0 at sxitwi0
> "analogix,anx6345" at iic0 addr 0x38 not configured
> sxidog0 at simplebus0
> gpio0 at sxipio0: 32 pins
> gpio1 at sxipio0: 32 pins
> gpio2 at sxipio0: 32 pins
> gpio3 at sxipio0: 32 pins
> gpio4 at sxipio0: 32 pins
> gpio5 at sxipio0: 32 pins
> gpio6 at sxipio0: 32 pins
> gpio7 at sxipio0: 32 pins
> gpio8 at sxipio1: 32 pins
> usb2 at ohci0: USB revision 1.0
> uhub2 at usb2 configuration 1 interface 0 "Generic OHCI root hub" rev 1.00/1.00 addr 1
> usb3 at ohci1: USB revision 1.0
> uhub3 at usb3 configuration 1 interface 0 "Generic OHCI root hub" rev 1.00/1.00 addr 1
> "regulator" at mainbus0 not configured
> pwmbl0 at mainbus0
> "gpio_keys" at mainbus0 not configured
> "vcc3v3" at mainbus0 not configured
> "wifi_pwrseq" at mainbus0 not configured
> "binman" at mainbus0 not configured
> simplefb0 at mainbus0: 1920x1080, 32bpp
> wsdisplay0 at simplefb0 mux 1: console (std, vt100 emulation)
> wsdisplay0: screen 1-5 added (std, vt100 emulation)
> cpu1 at mainbus0 mpidr 1: ARM Cortex-A53 r0p4
> cpu1: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
> cpu1: 512KB 64b/line 16-way L2 cache
> cpu2 at mainbus0 mpidr 2: ARM Cortex-A53 r0p4
> cpu2: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
> cpu2: 512KB 64b/line 16-way L2 cache
> cpu3 at mainbus0 mpidr 3: ARM Cortex-A53 r0p4
> cpu3: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
> cpu3: 512KB 64b/line 16-way L2 cache
> manufacturer 0x024c, product 0xb703 at sdmmc1 function 1 not configured
> scsibus0 at sdmmc0: 2 targets, initiator 0
> sd0 at scsibus0 targ 1 lun 0: <SD/MMC, SR256, 0080> removable
> sd0: 244016MB, 512 bytes/sector, 499744768 sectors
> scsibus1 at sdmmc2: 2 targets, initiator 0
> sd1 at scsibus1 targ 1 lun 0: <Samsung, AJTD4R, 0000> removable
> sd1: 14910MB, 512 bytes/sector, 30535680 sectors
> uhub4 at uhub1 port 1 configuration 1 interface 0 "Genesys Logic USB2.0 Hub" rev 2.00/88.32 addr 2
> uhidev0 at uhub4 port 1 configuration 1 interface 0 "HAILUCK CO.,LTD USB KEYBOARD" rev 1.10/1.00 addr 3
> uhidev0: iclass 3/1
> ukbd0 at uhidev0: 8 variable keys, 6 key codes
> wskbd0 at ukbd0: console keyboard, using wsdisplay0
> uhidev1 at uhub4 port 1 configuration 1 interface 1 "HAILUCK CO.,LTD USB KEYBOARD" rev 1.10/1.00 addr 3
> uhidev1: iclass 3/0, 9 report ids
> ums0 at uhidev1 reportid 1: 5 buttons, Z and W dir
> wsmouse0 at ums0 mux 0
> uhid0 at uhidev1 reportid 2: input=1, output=0, feature=0
> uhid1 at uhidev1 reportid 3: input=3, output=0, feature=0
> uhid2 at uhidev1 reportid 5: input=0, output=0, feature=5
> uhid3 at uhidev1 reportid 6: input=0, output=0, feature=255
> uhid4 at uhidev1 reportid 9: input=1, output=0, feature=0
> urtwn0 at uhub4 port 2 configuration 1 interface 0 "Realtek 802.11n WLAN Adapter" rev 2.00/2.00 addr 4
> urtwn0: MAC/BB RTL8188CUS, RF 6052 1T1R, address 80:1f:02:4b:6a:6b
> uvideo0 at uhub4 port 3 configuration 1 interface 0 "Generic USB2.0 PC CAMERA" rev 2.00/1.00 addr 5
> video0 at uvideo0
> vscsi0 at root
> scsibus2 at vscsi0: 256 targets
> softraid0 at root
> scsibus3 at softraid0: 256 targets
> bootfile: sd0a:/bsd
> boot device: sd0
> root on sd1a (1440dafaca0ef42a.a) swap on sd1b dump on sd1b
> urtwn0: INIT -> SCAN
> urtwn0: begin active scan
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 2 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 3 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 4 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 5 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 6 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 7 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 8 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 9 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 10 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 11 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 12 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 13 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 14 mode auto
> urtwn0: SCAN -> SCAN
> urtwn0: sending probe_req to ff:ff:ff:ff:ff:ff on channel 1 mode auto
> urtwn0: end active scan
> urtwn0: - 00:1d:7e:ec:23:c8   11  +174 54M   ess       no!  rsn! "linksys"!
> urtwn0: + 04:f0:21:34:e4:23   13  +198 54M   ess  privacy   rsn  "net_092382"
> urtwn0: - 4c:ed:fb:d2:44:7c   12  +182 54M   ess  privacy   rsn  "b242"!
> urtwn0: - 68:d4:82:79:02:2d   11  +174 54M   ess  privacy   rsn  "INEA-2D3B"!
> urtwn0: - 80:3e:48:c6:fd:81    6  +162 54M   ess  privacy   rsn  "INEA-D4C9_2.4G"!
> urtwn0: - ec:08:6b:ce:09:5c    5  +166 54M   ess  privacy   rsn  "TP-LINK_CE095D"!
> urtwn0: - fc:f5:28:f8:6b:1a    1  +166 54M   ess  privacy   rsn! "ZyXEL"!
> urtwn0: SCAN -> AUTH
> urtwn0: sending auth to 04:f0:21:34:e4:23 on channel 13 mode 11g
> urtwn0: AUTH -> ASSOC
> urtwn0: sending assoc_req to 04:f0:21:34:e4:23 on channel 13 mode 11g
> urtwn0: ASSOC -> RUN
> urtwn0: associated with 04:f0:21:34:e4:23 ssid "net_092382" channel 13 start 54Mb short preamble short slot time
> urtwn0: missed beacon threshold set to 30 beacons, beacon interval is 100 TU
> urtwn0: received msg 1/4 of the 4-way handshake from 04:f0:21:34:e4:23
> urtwn0: sending msg 2/4 of the 4-way handshake to 04:f0:21:34:e4:23
> urtwn0: received msg 1/4 of the 4-way handshake from 04:f0:21:34:e4:23
> urtwn0: sending msg 2/4 of the 4-way handshake to 04:f0:21:34:e4:23
> urtwn0: received msg 1/4 of the 4-way handshake from 04:f0:21:34:e4:23
> urtwn0: sending msg 2/4 of the 4-way handshake to 04:f0:21:34:e4:23
> urtwn0: RUN -> AUTH
> urtwn0: sending auth to 04:f0:21:34:e4:23 on channel 13 mode 11g
> urtwn0: AUTH -> ASSOC
> urtwn0: sending assoc_req to 04:f0:21:34:e4:23 on channel 13 mode 11g
> urtwn0: ASSOC -> RUN
> urtwn0: associated with 04:f0:21:34:e4:23 ssid "net_092382" channel 13 start 54Mb short preamble short slot time
> urtwn0: missed beacon threshold set to 30 beacons, beacon interval is 100 TU
> urtwn0: received msg 1/4 of the 4-way handshake from 04:f0:21:34:e4:23
> urtwn0: sending msg 2/4 of the 4-way handshake to 04:f0:21:34:e4:23
> urtwn0: received msg 3/4 of the 4-way handshake from 04:f0:21:34:e4:23
> urtwn0: sending msg 4/4 of the 4-way handshake to 04:f0:21:34:e4:23
>
> usbdevs:
> Controller /dev/usb0:
> addr 01: 0000:0000 Generic, EHCI root hub
> high speed, self powered, config 1, rev 1.00
> driver: uhub0
> Controller /dev/usb1:
> addr 01: 0000:0000 Generic, EHCI root hub
> high speed, self powered, config 1, rev 1.00
> driver: uhub1
> addr 02: 05e3:0608 Genesys Logic, USB2.0 Hub
> high speed, self powered, config 1, rev 88.32
> driver: uhub4
> addr 03: 258a:000c HAILUCK CO.,LTD, USB KEYBOARD
> low speed, power 100 mA, config 1, rev 1.00
> driver: uhidev0
> driver: uhidev1
> addr 04: 7392:7811 Realtek, 802.11n WLAN Adapter
> high speed, power 500 mA, config 1, rev 2.00, iSerial 00e04c000001
> driver: urtwn0
> addr 05: 1908:2311 Generic, USB2.0 PC CAMERA
> high speed, power 256 mA, config 1, rev 1.00
> driver: uvideo0
> Controller /dev/usb2:
> addr 01: 0000:0000 Generic, OHCI root hub
> full speed, self powered, config 1, rev 1.00
> driver: uhub2
> Controller /dev/usb3:
> addr 01: 0000:0000 Generic, OHCI root hub
> full speed, self powered, config 1, rev 1.00
> driver: uhub3
>
> pcidump:
>
> acpidump:
>
> Xorg.log:
> [    73.344] (--) Using wscons driver on /dev/ttyC1
> [    73.434]
> X.Org X Server 1.20.7
> X Protocol Version 11, Revision 0
> [    73.435] Build Operating System: OpenBSD 6.6 arm64
> [    73.435] Current Operating System: OpenBSD pinebook-0011.home.local 6.6 GENERIC.MP#522 arm64
> [    73.436] Build Date: 25 March 2020  03:19:41PM
> [    73.436]  
> [    73.436] Current version of pixman: 0.38.4
> [    73.436] Before reporting problems, check http://wiki.x.org
> to make sure that you have the latest version.
> [    73.436] Markers: (--) probed, (**) from config file, (==) default setting,
> (++) from command line, (!!) notice, (II) informational,
> (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> [    73.437] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 26 19:35:39 2020
> [    73.447] (==) Using config directory: "/etc/X11/xorg.conf.d"
> [    73.448] (==) Using system config directory "/usr/X11R6/share/X11/xorg.conf.d"
> [    73.461] (==) No Layout section.  Using the first Screen section.
> [    73.461] (==) No screen section available. Using defaults.
> [    73.461] (**) |-->Screen "Default Screen Section" (0)
> [    73.461] (**) |   |-->Monitor "<default monitor>"
> [    73.468] (==) No monitor specified for screen "Default Screen Section".
> Using a default monitor configuration.
> [    73.469] (==) Automatically adding devices
> [    73.469] (==) Automatically enabling devices
> [    73.469] (==) Not automatically adding GPU devices
> [    73.470] (==) Max clients allowed: 256, resource mask: 0x1fffff
> [    73.477] (**) FontPath set to:
> /usr/local/share/fonts/spleen,
> /usr/X11R6/lib/X11/fonts/misc/,
> /usr/X11R6/lib/X11/fonts/TTF/,
> /usr/X11R6/lib/X11/fonts/OTF/,
> /usr/X11R6/lib/X11/fonts/Type1/,
> /usr/X11R6/lib/X11/fonts/100dpi/,
> /usr/X11R6/lib/X11/fonts/75dpi/
> [    73.477] (==) ModulePath set to "/usr/X11R6/lib/modules"
> [    73.477] (II) The server relies on wscons to provide the list of input devices.
> If no devices become available, reconfigure wscons or disable AutoAddDevices.
> [    73.478] (II) Loader magic: 0x156840000
> [    73.478] (II) Module ABI versions:
> [    73.478] X.Org ANSI C Emulation: 0.4
> [    73.478] X.Org Video Driver: 24.1
> [    73.478] X.Org XInput driver : 24.1
> [    73.478] X.Org Server Extension : 10.0
> [    73.484] (II) LoadModule: "glx"
> [    73.488] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
> [    73.864] (II) Module glx: vendor="X.Org Foundation"
> [    73.864] compiled for 1.20.7, module version = 1.0.0
> [    73.864] ABI class: X.Org Server Extension, version 10.0
> [    73.867] (==) Matched wsfb as autoconfigured driver 0
> [    73.867] (==) Assigned the driver to the xf86ConfigLayout
> [    73.867] (II) LoadModule: "wsfb"
> [    73.869] (II) Loading /usr/X11R6/lib/modules/drivers/wsfb_drv.so
> [    73.879] (II) Module wsfb: vendor="X.Org Foundation"
> [    73.879] compiled for 1.20.7, module version = 0.4.1
> [    73.879] ABI class: X.Org Video Driver, version 24.1
> [    74.396] (II) wsfb: driver for wsdisplay framebuffer: wsfb
> [    74.397] (WW) Falling back to old probe method for wsfb
> [    74.400] (II) wsfb(0): using default device
> [    74.413] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
> [    74.418] (II) wsfb(0): Creating default Display subsection in Screen section
> "Default Screen Section" for depth/fbbpp 24/32
> [    74.419] (==) wsfb(0): Depth 24, (--) framebuffer bpp 32
> [    74.419] (==) wsfb(0): RGB weight 888
> [    74.419] (==) wsfb(0): Default visual is TrueColor
> [    74.420] (==) wsfb(0): Using gamma correction (1.0, 1.0, 1.0)
> [    74.420] (II) wsfb(0): Vidmem: 8100k
> [    74.421] (==) wsfb(0): DPI set to (96, 96)
> [    74.421] (**) wsfb(0): Using "Shadow Framebuffer"
> [    74.421] (II) Loading sub module "shadow"
> [    74.421] (II) LoadModule: "shadow"
> [    74.430] (II) Loading /usr/X11R6/lib/modules/libshadow.so
> [    74.447] (II) Module shadow: vendor="X.Org Foundation"
> [    74.447] compiled for 1.20.7, module version = 1.1.0
> [    74.447] ABI class: X.Org ANSI C Emulation, version 0.4
> [    74.447] (II) Loading sub module "fb"
> [    74.447] (II) LoadModule: "fb"
> [    74.452] (II) Loading /usr/X11R6/lib/modules/libfb.so
> [    74.477] (II) Module fb: vendor="X.Org Foundation"
> [    74.477] compiled for 1.20.7, module version = 1.0.0
> [    74.477] ABI class: X.Org ANSI C Emulation, version 0.4
> [    74.521] (==) wsfb(0): Backing store enabled
> [    74.537] (II) Initializing extension Generic Event Extension
> [    74.541] (II) Initializing extension SHAPE
> [    74.543] (II) Initializing extension MIT-SHM
> [    74.546] (II) Initializing extension XInputExtension
> [    74.554] (II) Initializing extension XTEST
> [    74.556] (II) Initializing extension BIG-REQUESTS
> [    74.558] (II) Initializing extension SYNC
> [    74.563] (II) Initializing extension XKEYBOARD
> [    74.568] (II) Initializing extension XC-MISC
> [    74.571] (II) Initializing extension SECURITY
> [    74.575] (II) Initializing extension XFIXES
> [    74.578] (II) Initializing extension RENDER
> [    74.581] (II) Initializing extension RANDR
> [    74.586] (II) Initializing extension COMPOSITE
> [    74.595] (II) Initializing extension DAMAGE
> [    74.597] (II) Initializing extension MIT-SCREEN-SAVER
> [    74.602] (II) Initializing extension DOUBLE-BUFFER
> [    74.609] (II) Initializing extension RECORD
> [    74.612] (II) Initializing extension DPMS
> [    74.612] (II) Initializing extension Present
> [    74.614] (II) Initializing extension DRI3
> [    74.616] (II) Initializing extension X-Resource
> [    74.626] (II) Initializing extension XVideo
> [    74.629] (II) Initializing extension XVideo-MotionCompensation
> [    74.629] (II) Initializing extension GLX
> [    74.634] (II) AIGLX: Screen 0 is not DRI2 capable
> [    76.392] (II) IGLX: Loaded and initialized swrast
> [    76.392] (II) GLX: Initialized DRISWRAST GL provider for screen 0
> [    76.392] (II) Initializing extension XFree86-VidModeExtension
> [    76.396] (II) Initializing extension XFree86-DGA
> [    76.400] (II) Initializing extension XFree86-DRI
> [    76.402] (II) Initializing extension DRI2
> [    77.547] (II) config/wscons: checking input device /dev/wskbd
> [    77.548] (II) wskbd: using layout us
> [    77.549] (II) LoadModule: "kbd"
> [    77.552] (II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so
> [    77.561] (II) Module kbd: vendor="X.Org Foundation"
> [    77.561] compiled for 1.20.7, module version = 1.9.0
> [    77.561] Module class: X.Org XInput Driver
> [    77.561] ABI class: X.Org XInput driver, version 24.1
> [    77.561] (II) Using input driver 'kbd' for '/dev/wskbd'
> [    77.561] (**) /dev/wskbd: always reports core events
> [    77.562] (**) /dev/wskbd: always reports core events
> [    77.562] (**) Option "Protocol" "standard"
> [    77.562] (**) Option "XkbRules" "base"
> [    77.562] (**) Option "XkbModel" "pc105"
> [    77.562] (**) Option "XkbLayout" "us"
> [    77.562] (II) XINPUT: Adding extended input device "/dev/wskbd" (type: KEYBOARD, id 6)
> [    77.564] (EE) KbdOn: tcsetattr: Inappropriate ioctl for device
> [    77.564] (EE)
> Fatal server error:
> [    77.564] (EE) can't switch keyboard to raw mode. Enable support for it in the kernel
> or use for example:
>
> Option "Protocol" "wskbd"
> Option "Device" "/dev/wskbd0"
>
> in your xorg.conf(5) file
> [    77.564] (EE)
> [    77.565] (EE)
> Please consult the The X.Org Foundation support
> at http://wiki.x.org
>  for help.
> [    77.565] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
> [    77.565] (EE)
> [    77.599] (EE) Server terminated with error (1). Closing log file.
>
> --
> Regards,
>  Mikolaj
>