pidgin SIGTRAPs/(threads?)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pidgin SIGTRAPs/(threads?)

ramrunner
Hello list ;) hope you'r all ok!

Pidgin receives SIGTRAP when messaging to invisible/offline contacts
(all ~current)

from my gdb:Program received signal SIGTRAP, Trace/breakpoint trap.
0x06289bbf in fork () from /usr/lib/libc.so.56.0
(gdb) backtrace full
#0  0x06289bbf in fork () from /usr/lib/libc.so.56.0
No symbol table info available.
#1  0x07a095f5 in _dofork (vfork=0)
    at /usr/src/lib/libpthread/uthread/uthread_fork.c:99
        curthread = (struct pthread *) 0x81b20400
        i = Variable "i" is not available.



versions and dmesg
inst:pidgin-2.7.2
OpenBSD vector 4.8 GENERIC.MP#0 i386

OpenBSD 4.8-current (GENERIC.MP) #0: Tue Aug 17 22:37:59 EEST 2010
    root@vector:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Intel(R) Pentium(R) 4 CPU 3.00GHz ("GenuineIntel" 686-class) 3 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,S
SE3,MWAIT,DS-CPL,EST,CNXT-ID,CX16,xTPR
real mem  = 525103104 (500MB)
avail mem = 506531840 (483MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 12/16/05, BIOS32 rev. 0 @
0xfd61a, SMBIOS rev. 2.34 @ 0xf0320 (59 entries)
bios0: vendor IBM version "2EKT32AIT" date 12/16/2005
bios0: IBM 8114D1G
acpi0 at bios0: rev 0
acpi0: sleep states S0 S1 S3 S4 S5
acpi0: tables DSDT FACP TCPA MCFG APIC BOOT ASF! SSDT
acpi0: wakeup devices AZAL(S3) EXP0(S5) EXP1(S5) USB1(S3) USB2(S3)
USB3(S3) USB4(S3) USBE(S3) SLOT(S5) KBC_(S3) PSM_(S3) COMA(
S5) COMB(S5)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 199MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Pentium(R) 4 CPU 3.00GHz ("GenuineIntel" 686-class) 3 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,S
SE3,MWAIT,DS-CPL,EST,CNXT-ID,CX16,xTPR
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEG_)
acpiprt2 at acpi0: bus 2 (EXP0)
acpiprt3 at acpi0: bus 4 (EXP1)
acpiprt4 at acpi0: bus 10 (SLOT)
acpicpu0 at acpi0
acpicpu1 at acpi0
acpitz0 at acpi0: critical temperature 255 degC
acpibtn0 at acpi0: PWRB
bios0: ROM list: 0xc0000/0xac00! 0xcb000/0x1000 0xcc000/0x1000 0xe0000/0x1800!
cpu0: Enhanced SpeedStep disabled by BIOS
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82945G Host" rev 0x02
vga1 at pci0 dev 2 function 0 "Intel 82945G Video" rev 0x02
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp0 at vga1inteldrm0 at vga1: apic 2 int 16 (irq 5)
drm0 at inteldrm0
"Intel 82945G Video" rev 0x02 at pci0 dev 2 function 1 not configured
azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x01:
apic 2 int 22 (irq 3)
azalia0: codecs: Analog Devices AD1981HD
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x01: apic 2
int 17 (irq 9)
pci1 at ppb0 bus 2
em0 at pci1 dev 0 function 0 "Intel PRO/1000MT (82573E)" rev 0x03:
apic 2 int 16 (irq 5), address 00:14:85:aa:97:bc
ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x01: apic 2
int 16 (irq 5)
pci2 at ppb1 bus 4
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x01: apic 2
int 23 (irq 11)
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x01: apic 2
int 19 (irq 9)
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x01: apic 2
int 18 (irq 10)
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x01: apic 2
int 16 (irq 5)
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x01: apic 2
int 23 (irq 11)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb2 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0xe1
pci3 at ppb2 bus 10
ichpcib0 at pci0 dev 31 function 0 "Intel 82801GB LPC" rev 0x01: PM disabled
pciide0 at pci0 dev 31 function 2 "Intel 82801GB SATA" rev 0x01: DMA,
channel 0 wired to compatibility, channel 1 wired to com
patibility
wd0 at pciide0 channel 0 drive 0: <WDC WD800JD-08LSA0>
wd0: 16-sector PIO, LBA48, 76324MB, 156312576 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 6
atapiscsi0 at pciide0 channel 1 drive 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVDRAM GSA-H10A, JL02> ATAPI
5/cdrom removable
cd0(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x01: apic
2 int 19 (irq 9)
iic0 at ichiic0
adt0 at iic0 addr 0x2e: lm96000 rev 0x68
spdmem0 at iic0 addr 0x50: 512MB DDR2 SDRAM non-parity PC2-4200CL5
usb1 at uhci0: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb2 at uhci1: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci2: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci3: USB revision 1.0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
mtrr: Pentium Pro MTRR support
softraid0 at root
root on wd0a swap on wd0b dump on wd0b

Reply | Threaded
Open this post in threaded view
|

Re: pidgin SIGTRAPs/(threads?)

Stuart Henderson
for threaded apps, use 'thread apply all bt'
you probably also want to build with debug symbols


On 2010/09/01 12:00, ramrunner wrote:

> Hello list ;) hope you'r all ok!
>
> Pidgin receives SIGTRAP when messaging to invisible/offline contacts
> (all ~current)
>
> from my gdb:Program received signal SIGTRAP, Trace/breakpoint trap.
> 0x06289bbf in fork () from /usr/lib/libc.so.56.0
> (gdb) backtrace full
> #0  0x06289bbf in fork () from /usr/lib/libc.so.56.0
> No symbol table info available.
> #1  0x07a095f5 in _dofork (vfork=0)
>     at /usr/src/lib/libpthread/uthread/uthread_fork.c:99
>         curthread = (struct pthread *) 0x81b20400
>         i = Variable "i" is not available.
>
>
>
> versions and dmesg
> inst:pidgin-2.7.2
> OpenBSD vector 4.8 GENERIC.MP#0 i386
>
> OpenBSD 4.8-current (GENERIC.MP) #0: Tue Aug 17 22:37:59 EEST 2010
>     root@vector:/usr/src/sys/arch/i386/compile/GENERIC.MP
> cpu0: Intel(R) Pentium(R) 4 CPU 3.00GHz ("GenuineIntel" 686-class) 3 GHz
> cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,S
> SE3,MWAIT,DS-CPL,EST,CNXT-ID,CX16,xTPR
> real mem  = 525103104 (500MB)
> avail mem = 506531840 (483MB)
> mainbus0 at root
> bios0 at mainbus0: AT/286+ BIOS, date 12/16/05, BIOS32 rev. 0 @
> 0xfd61a, SMBIOS rev. 2.34 @ 0xf0320 (59 entries)
> bios0: vendor IBM version "2EKT32AIT" date 12/16/2005
> bios0: IBM 8114D1G
> acpi0 at bios0: rev 0
> acpi0: sleep states S0 S1 S3 S4 S5
> acpi0: tables DSDT FACP TCPA MCFG APIC BOOT ASF! SSDT
> acpi0: wakeup devices AZAL(S3) EXP0(S5) EXP1(S5) USB1(S3) USB2(S3)
> USB3(S3) USB4(S3) USBE(S3) SLOT(S5) KBC_(S3) PSM_(S3) COMA(
> S5) COMB(S5)
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: apic clock running at 199MHz
> cpu1 at mainbus0: apid 1 (application processor)
> cpu1: Intel(R) Pentium(R) 4 CPU 3.00GHz ("GenuineIntel" 686-class) 3 GHz
> cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,S
> SE3,MWAIT,DS-CPL,EST,CNXT-ID,CX16,xTPR
> ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus -1 (PEG_)
> acpiprt2 at acpi0: bus 2 (EXP0)
> acpiprt3 at acpi0: bus 4 (EXP1)
> acpiprt4 at acpi0: bus 10 (SLOT)
> acpicpu0 at acpi0
> acpicpu1 at acpi0
> acpitz0 at acpi0: critical temperature 255 degC
> acpibtn0 at acpi0: PWRB
> bios0: ROM list: 0xc0000/0xac00! 0xcb000/0x1000 0xcc000/0x1000 0xe0000/0x1800!
> cpu0: Enhanced SpeedStep disabled by BIOS
> pci0 at mainbus0 bus 0: configuration mode 1 (bios)
> pchb0 at pci0 dev 0 function 0 "Intel 82945G Host" rev 0x02
> vga1 at pci0 dev 2 function 0 "Intel 82945G Video" rev 0x02
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> intagp0 at vga1inteldrm0 at vga1: apic 2 int 16 (irq 5)
> drm0 at inteldrm0
> "Intel 82945G Video" rev 0x02 at pci0 dev 2 function 1 not configured
> azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x01:
> apic 2 int 22 (irq 3)
> azalia0: codecs: Analog Devices AD1981HD
> audio0 at azalia0
> ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x01: apic 2
> int 17 (irq 9)
> pci1 at ppb0 bus 2
> em0 at pci1 dev 0 function 0 "Intel PRO/1000MT (82573E)" rev 0x03:
> apic 2 int 16 (irq 5), address 00:14:85:aa:97:bc
> ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x01: apic 2
> int 16 (irq 5)
> pci2 at ppb1 bus 4
> uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x01: apic 2
> int 23 (irq 11)
> uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x01: apic 2
> int 19 (irq 9)
> uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x01: apic 2
> int 18 (irq 10)
> uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x01: apic 2
> int 16 (irq 5)
> ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x01: apic 2
> int 23 (irq 11)
> usb0 at ehci0: USB revision 2.0
> uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
> ppb2 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0xe1
> pci3 at ppb2 bus 10
> ichpcib0 at pci0 dev 31 function 0 "Intel 82801GB LPC" rev 0x01: PM disabled
> pciide0 at pci0 dev 31 function 2 "Intel 82801GB SATA" rev 0x01: DMA,
> channel 0 wired to compatibility, channel 1 wired to com
> patibility
> wd0 at pciide0 channel 0 drive 0: <WDC WD800JD-08LSA0>
> wd0: 16-sector PIO, LBA48, 76324MB, 156312576 sectors
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 6
> atapiscsi0 at pciide0 channel 1 drive 1
> scsibus0 at atapiscsi0: 2 targets
> cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVDRAM GSA-H10A, JL02> ATAPI
> 5/cdrom removable
> cd0(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
> ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x01: apic
> 2 int 19 (irq 9)
> iic0 at ichiic0
> adt0 at iic0 addr 0x2e: lm96000 rev 0x68
> spdmem0 at iic0 addr 0x50: 512MB DDR2 SDRAM non-parity PC2-4200CL5
> usb1 at uhci0: USB revision 1.0
> uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb2 at uhci1: USB revision 1.0
> uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb3 at uhci2: USB revision 1.0
> uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb4 at uhci3: USB revision 1.0
> isadma0 at isa0
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pmsi0 at pckbc0 (aux slot)
> pckbc0: using irq 12 for aux slot
> wsmouse0 at pmsi0 mux 0
> pcppi0 at isa0 port 0x61
> spkr0 at pcppi0
> lpt0 at isa0 port 0x378/4 irq 7
> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
> fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
> fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
> mtrr: Pentium Pro MTRR support
> softraid0 at root
> root on wd0a swap on wd0b dump on wd0b
>

Reply | Threaded
Open this post in threaded view
|

Re: pidgin SIGTRAPs/(threads?)

ramrunner
thanks a lot for the info sthen.
this is what i managed to get out of it.
it happened by trying to message a contact gone offline
can anyone reproduce?

DsP

Starting program: /usr/local/bin/pidgin
pidgin in free(): error: chunk is already free

Program received signal SIGABRT, Aborted.
[Switching to process 9828, thread 0x87c78400]
0x0a291f3d in kill () from /usr/lib/libc.so.56.0
(gdb) backtrace full
#0  0x0a291f3d in kill () from /usr/lib/libc.so.56.0
No symbol table info available.
#1  0x0a2eba95 in abort () at /usr/src/lib/libc/stdlib/abort.c:68
        p = (struct atexit *) 0x88f7f000
        mask = 4294967263
        cleanup_called = 1
#2  0x0a2ca7ce in wrterror (p=Variable "p" is not available.
) at /usr/src/lib/libc/stdlib/malloc.c:380
        iov = Could not find the frame base for "wrterror".

(gdb) info registers
eax            0x0      0
ecx            0x0      0
edx            0x83e    2110
ebx            0x2a262004       707141636
esp            0xcfbd972c       0xcfbd972c
ebp            0xcfbd9758       0xcfbd9758
esi            0x88f7f000       -1997017088
edi            0xcfbd9748       -809658552
eip            0xa291f3d        0xa291f3d
eflags         0x200286 2097798
cs             0x2b     43
ss             0x33     51
ds             0x33     51
es             0x33     51
fs             0x33     51
gs             0x33     51
(gdb) x/16i $pc
0xa291f3d <kill+7>:     jb     0xa291f20 <fhopen+10>
0xa291f3f <kill+9>:     ret
0xa291f40 <pclose>:     push   %ebp
0xa291f41 <pclose+1>:   mov    %esp,%ebp
0xa291f43 <pclose+3>:   push   %edi
0xa291f44 <pclose+4>:   push   %esi
0xa291f45 <pclose+5>:   push   %ebx
0xa291f46 <pclose+6>:   call   0xa269bd1 <__i686.get_pc_thunk.bx>
0xa291f4b <pclose+11>:  add    $0x1ffd00b9,%ebx
0xa291f51 <pclose+17>:  sub    $0x1c,%esp
0xa291f54 <pclose+20>:  mov    0x8(%ebp),%edi
0xa291f57 <pclose+23>:  mov    0xcf4(%ebx),%eax
0xa291f5d <pclose+29>:  mov    (%eax),%ecx
0xa291f5f <pclose+31>:  test   %ecx,%ecx
0xa291f61 <pclose+33>:  jne    0xa29200b <pclose+203>
0xa291f67 <pclose+39>:  mov    0x17780(%ebx),%esi

(gdb) continue\

Continuing.

Program terminated with signal SIGABRT, Aborted.
The program no longer exists.




On Wed, Sep 1, 2010 at 12:05 PM, Stuart Henderson <[hidden email]> wrote:

> for threaded apps, use 'thread apply all bt'
> you probably also want to build with debug symbols
>
>
> On 2010/09/01 12:00, ramrunner wrote:
>> Hello list ;) hope you'r all ok!
>>
>> Pidgin receives SIGTRAP when messaging to invisible/offline contacts
>> (all ~current)
>>
>> from my gdb:Program received signal SIGTRAP, Trace/breakpoint trap.
>> 0x06289bbf in fork () from /usr/lib/libc.so.56.0
>> (gdb) backtrace full
>> #0  0x06289bbf in fork () from /usr/lib/libc.so.56.0
>> No symbol table info available.
>> #1  0x07a095f5 in _dofork (vfork=0)
>>     at /usr/src/lib/libpthread/uthread/uthread_fork.c:99
>>         curthread = (struct pthread *) 0x81b20400
>>         i = Variable "i" is not available.
>>
>>
>>
>> versions and dmesg
>> inst:pidgin-2.7.2
>> OpenBSD vector 4.8 GENERIC.MP#0 i386
>>
>> OpenBSD 4.8-current (GENERIC.MP) #0: Tue Aug 17 22:37:59 EEST 2010
>>     root@vector:/usr/src/sys/arch/i386/compile/GENERIC.MP
>> cpu0: Intel(R) Pentium(R) 4 CPU 3.00GHz ("GenuineIntel" 686-class) 3 GHz
>> cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,S
>> SE3,MWAIT,DS-CPL,EST,CNXT-ID,CX16,xTPR
>> real mem  = 525103104 (500MB)
>> avail mem = 506531840 (483MB)
>> mainbus0 at root
>> bios0 at mainbus0: AT/286+ BIOS, date 12/16/05, BIOS32 rev. 0 @
>> 0xfd61a, SMBIOS rev. 2.34 @ 0xf0320 (59 entries)
>> bios0: vendor IBM version "2EKT32AIT" date 12/16/2005
>> bios0: IBM 8114D1G
>> acpi0 at bios0: rev 0
>> acpi0: sleep states S0 S1 S3 S4 S5
>> acpi0: tables DSDT FACP TCPA MCFG APIC BOOT ASF! SSDT
>> acpi0: wakeup devices AZAL(S3) EXP0(S5) EXP1(S5) USB1(S3) USB2(S3)
>> USB3(S3) USB4(S3) USBE(S3) SLOT(S5) KBC_(S3) PSM_(S3) COMA(
>> S5) COMB(S5)
>> acpitimer0 at acpi0: 3579545 Hz, 24 bits
>> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
>> cpu0 at mainbus0: apid 0 (boot processor)
>> cpu0: apic clock running at 199MHz
>> cpu1 at mainbus0: apid 1 (application processor)
>> cpu1: Intel(R) Pentium(R) 4 CPU 3.00GHz ("GenuineIntel" 686-class) 3 GHz
>> cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,S
>> SE3,MWAIT,DS-CPL,EST,CNXT-ID,CX16,xTPR
>> ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
>> acpiprt0 at acpi0: bus 0 (PCI0)
>> acpiprt1 at acpi0: bus -1 (PEG_)
>> acpiprt2 at acpi0: bus 2 (EXP0)
>> acpiprt3 at acpi0: bus 4 (EXP1)
>> acpiprt4 at acpi0: bus 10 (SLOT)
>> acpicpu0 at acpi0
>> acpicpu1 at acpi0
>> acpitz0 at acpi0: critical temperature 255 degC
>> acpibtn0 at acpi0: PWRB
>> bios0: ROM list: 0xc0000/0xac00! 0xcb000/0x1000 0xcc000/0x1000 0xe0000/0x1800!
>> cpu0: Enhanced SpeedStep disabled by BIOS
>> pci0 at mainbus0 bus 0: configuration mode 1 (bios)
>> pchb0 at pci0 dev 0 function 0 "Intel 82945G Host" rev 0x02
>> vga1 at pci0 dev 2 function 0 "Intel 82945G Video" rev 0x02
>> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
>> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
>> intagp0 at vga1inteldrm0 at vga1: apic 2 int 16 (irq 5)
>> drm0 at inteldrm0
>> "Intel 82945G Video" rev 0x02 at pci0 dev 2 function 1 not configured
>> azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x01:
>> apic 2 int 22 (irq 3)
>> azalia0: codecs: Analog Devices AD1981HD
>> audio0 at azalia0
>> ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x01: apic 2
>> int 17 (irq 9)
>> pci1 at ppb0 bus 2
>> em0 at pci1 dev 0 function 0 "Intel PRO/1000MT (82573E)" rev 0x03:
>> apic 2 int 16 (irq 5), address 00:14:85:aa:97:bc
>> ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x01: apic 2
>> int 16 (irq 5)
>> pci2 at ppb1 bus 4
>> uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x01: apic 2
>> int 23 (irq 11)
>> uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x01: apic 2
>> int 19 (irq 9)
>> uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x01: apic 2
>> int 18 (irq 10)
>> uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x01: apic 2
>> int 16 (irq 5)
>> ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x01: apic 2
>> int 23 (irq 11)
>> usb0 at ehci0: USB revision 2.0
>> uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
>> ppb2 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0xe1
>> pci3 at ppb2 bus 10
>> ichpcib0 at pci0 dev 31 function 0 "Intel 82801GB LPC" rev 0x01: PM disabled
>> pciide0 at pci0 dev 31 function 2 "Intel 82801GB SATA" rev 0x01: DMA,
>> channel 0 wired to compatibility, channel 1 wired to com
>> patibility
>> wd0 at pciide0 channel 0 drive 0: <WDC WD800JD-08LSA0>
>> wd0: 16-sector PIO, LBA48, 76324MB, 156312576 sectors
>> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 6
>> atapiscsi0 at pciide0 channel 1 drive 1
>> scsibus0 at atapiscsi0: 2 targets
>> cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVDRAM GSA-H10A, JL02> ATAPI
>> 5/cdrom removable
>> cd0(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
>> ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x01: apic
>> 2 int 19 (irq 9)
>> iic0 at ichiic0
>> adt0 at iic0 addr 0x2e: lm96000 rev 0x68
>> spdmem0 at iic0 addr 0x50: 512MB DDR2 SDRAM non-parity PC2-4200CL5
>> usb1 at uhci0: USB revision 1.0
>> uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
>> usb2 at uhci1: USB revision 1.0
>> uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
>> usb3 at uhci2: USB revision 1.0
>> uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
>> usb4 at uhci3: USB revision 1.0
>> isadma0 at isa0
>> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
>> pckbc0 at isa0 port 0x60/5
>> pckbd0 at pckbc0 (kbd slot)
>> pckbc0: using irq 1 for kbd slot
>> wskbd0 at pckbd0: console keyboard, using wsdisplay0
>> pmsi0 at pckbc0 (aux slot)
>> pckbc0: using irq 12 for aux slot
>> wsmouse0 at pmsi0 mux 0
>> pcppi0 at isa0 port 0x61
>> spkr0 at pcppi0
>> lpt0 at isa0 port 0x378/4 irq 7
>> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
>> fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
>> fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
>> mtrr: Pentium Pro MTRR support
>> softraid0 at root
>> root on wd0a swap on wd0b dump on wd0b
>>
>