php5-core and apache2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

php5-core and apache2

Sebastiano Pomata-3
Hi all,

for various reasons I need to abandon the perfect chrooted solution of
apache-httpd and move to apache2 (I'm planning to run knowledgetree, a
DMS that only works with apache2).

I'm having troubles with php5-core official package, since if I try to
add the LoadModule line in apache2 configuration (regarding libphp5.so
installed by the module), I get some unresolved symbol error and it exits.

Is there a solution, or do I need to build from scratch?

Reply | Threaded
Open this post in threaded view
|

Re: php5-core and apache2

Robert Nagy
Hi

Those packages are built for our in tree apache.

You can try to modify core/Makefile and extensions/Makefile
to point to apache2's apxs and not to /usr/sbin/apxs.

But then you will have to do other hacks to make it work.
It's not that trivial.

On (2010-01-18 13:34), Sebastiano wrote:

> Hi all,
>
> for various reasons I need to abandon the perfect chrooted solution of
> apache-httpd and move to apache2 (I'm planning to run knowledgetree, a
> DMS that only works with apache2).
>
> I'm having troubles with php5-core official package, since if I try to
> add the LoadModule line in apache2 configuration (regarding libphp5.so
> installed by the module), I get some unresolved symbol error and it exits.
>
> Is there a solution, or do I need to build from scratch?

Reply | Threaded
Open this post in threaded view
|

Re: php5-core and apache2

Sebastiano Pomata-3
Til now, I managed to build php5-core and php5-extensions and they
seem to work.

Thank you

Il 18/01/2010 15.47, Robert Nagy ha scritto:

> Hi
>
> Those packages are built for our in tree apache.
>
> You can try to modify core/Makefile and extensions/Makefile
> to point to apache2's apxs and not to /usr/sbin/apxs.
>
> But then you will have to do other hacks to make it work.
> It's not that trivial.
>
> On (2010-01-18 13:34), Sebastiano wrote:
>> Hi all,
>>
>> for various reasons I need to abandon the perfect chrooted solution of
>> apache-httpd and move to apache2 (I'm planning to run knowledgetree, a
>> DMS that only works with apache2).
>>
>> I'm having troubles with php5-core official package, since if I try to
>> add the LoadModule line in apache2 configuration (regarding libphp5.so
>> installed by the module), I get some unresolved symbol error and it exits.
>>
>> Is there a solution, or do I need to build from scratch?