pfstat package dependencies missing on 6.3 amd64

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pfstat package dependencies missing on 6.3 amd64

mabi
Hello,

It looks like some package dependencies are missing on the package repository of 6.3 amd64 or pfstat dependencies is broken. See below:

$ doas pkg_add -v pfstat
quirks-2.414 signed on 2018-03-28T14:24:37Z
quirks-2.414: ok
pfstat-2.5p2:libiconv-1.14p3: ok
pfstat-2.5p2:png-1.6.34: ok
pfstat-2.5p2:jpeg-1.5.3v0: ok
pfstat-2.5p2:tiff-4.0.9: ok
pfstat-2.5p2:giflib-5.1.4: ok
pfstat-2.5p2:libwebp-0.6.1p0: ok
Can't install gd-2.2.5p0 because of libraries
|library fontconfig.11.0 not found
| not found anywhere
|library freetype.28.2 not found
| not found anywhere
Direct dependencies for gd-2.2.5p0 resolve to png-1.6.34 jpeg-1.5.3v0 tiff-4.0.9 libiconv-1.14p3 libwebp-0.6.1p0
Full dependency tree is tiff-4.0.9 giflib-5.1.4 libwebp-0.6.1p0 libiconv-1.14p3 png-1.6.34 jpeg-1.5.3v0
Can't install pfstat-2.5p2: can't resolve gd-2.2.5p0
Extracted 12048693 from 12052934

Best regards,
Mabi

Reply | Threaded
Open this post in threaded view
|

Re: pfstat package dependencies missing on 6.3 amd64

mabi
Sorry my bad these are actually system libraries and not packages missing. Indeed I do not have X tgz packages installed yet.
​​

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On April 16, 2018 3:48 PM, mabi <[hidden email]> wrote:

> ​​
>
> Hello,
>
> It looks like some package dependencies are missing on the package repository of 6.3 amd64 or pfstat dependencies is broken. See below:
>
> $ doas pkg_add -v pfstat
>
> quirks-2.414 signed on 2018-03-28T14:24:37Z
>
> quirks-2.414: ok
>
> pfstat-2.5p2:libiconv-1.14p3: ok
>
> pfstat-2.5p2:png-1.6.34: ok
>
> pfstat-2.5p2:jpeg-1.5.3v0: ok
>
> pfstat-2.5p2:tiff-4.0.9: ok
>
> pfstat-2.5p2:giflib-5.1.4: ok
>
> pfstat-2.5p2:libwebp-0.6.1p0: ok
>
> Can't install gd-2.2.5p0 because of libraries
>
> |library fontconfig.11.0 not found
>
> | not found anywhere
>
> |library freetype.28.2 not found
>
> | not found anywhere
>
> Direct dependencies for gd-2.2.5p0 resolve to png-1.6.34 jpeg-1.5.3v0 tiff-4.0.9 libiconv-1.14p3 libwebp-0.6.1p0
>
> Full dependency tree is tiff-4.0.9 giflib-5.1.4 libwebp-0.6.1p0 libiconv-1.14p3 png-1.6.34 jpeg-1.5.3v0
>
> Can't install pfstat-2.5p2: can't resolve gd-2.2.5p0
>
> Extracted 12048693 from 12052934
>
> Best regards,
>
> Mabi


Reply | Threaded
Open this post in threaded view
|

Re: pfstat package dependencies missing on 6.3 amd64

Edgar Pettijohn III-2
In reply to this post by mabi
Do you have the X sets installed? I'm not at my computer but fontconfig sounds like something that would be in the base x install.
On Apr 16, 2018 8:48 AM, mabi <[hidden email]> wrote:

>
> Hello,
>
> It looks like some package dependencies are missing on the package repository of 6.3 amd64 or pfstat dependencies is broken. See below:
>
> $ doas pkg_add -v pfstat
> quirks-2.414 signed on 2018-03-28T14:24:37Z
> quirks-2.414: ok
> pfstat-2.5p2:libiconv-1.14p3: ok
> pfstat-2.5p2:png-1.6.34: ok
> pfstat-2.5p2:jpeg-1.5.3v0: ok
> pfstat-2.5p2:tiff-4.0.9: ok
> pfstat-2.5p2:giflib-5.1.4: ok
> pfstat-2.5p2:libwebp-0.6.1p0: ok
> Can't install gd-2.2.5p0 because of libraries
> |library fontconfig.11.0 not found
> | not found anywhere
> |library freetype.28.2 not found
> | not found anywhere
> Direct dependencies for gd-2.2.5p0 resolve to png-1.6.34 jpeg-1.5.3v0 tiff-4.0.9 libiconv-1.14p3 libwebp-0.6.1p0
> Full dependency tree is tiff-4.0.9 giflib-5.1.4 libwebp-0.6.1p0 libiconv-1.14p3 png-1.6.34 jpeg-1.5.3v0
> Can't install pfstat-2.5p2: can't resolve gd-2.2.5p0
> Extracted 12048693 from 12052934
>
> Best regards,
> Mabi
>