pending/4962: GENERIC Oxford OX16PCI954 does not work, this chip is borked

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

pending/4962: GENERIC Oxford OX16PCI954 does not work, this chip is borked

Henrik Lund Kramshøj
>Number:         4962
>Category:       pending
>Synopsis:       SIIG 4-port serial PCI card does not work
>Confidential:   yes
>Severity:       non-critical
>Priority:       low
>Responsible:    bugs
>State:          open
>Quarter:        
>Keywords:      
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jan 02 14:30:02 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Henrik Kramshoej
>Release:        3.8 with own patch and -current as of 2. january 2005
>Organization:
Security6.net
net
>Environment:
       
        System      : OpenBSD 3.8
        Architecture: OpenBSD.i386
        Machine     : i386
>Description:
       
Installed SIIG Inc. 16550 4-port RS232 Serial I/O card part no LP-P40011
- tried this card this summer without problems!

This card has got a new chip - being the Oxford OX16PCI954

dmesg output:
OpenBSD 3.8-current (GENERIC) #0: Mon Jan  2 12:38:51 CET 2006
    [hidden email]:/sys/arch/i386/compile/GENERIC
cpu0: VIA Nehemiah ("CentaurHauls" 686-class) 1.01 GHz
cpu0: FPU,DE,TSC,MSR,MTRR,PGE,CMOV,MMX,FXSR,SSE
real mem  = 502833152 (491048K)
avail mem = 451801088 (441212K)
using 4278 buffers containing 25243648 bytes (24652K) of memory
mainbus0 (root)
...
puc0 at pci0 dev 20 function 0 "Oxford OX16PCI954" rev 0x00: com, com, com, com
pccom3 at puc0 port 0 irq 7: st16650, 32 byte fifo
pccom4 at puc0 port 1 irq 7: st16650, 32 byte fifo
pccom5 at puc0 port 2 irq 7: st16650, 32 byte fifo
pccom6 at puc0 port 3 irq 7: st16650, 32 byte fifo
vendor "Oxford", unknown product 0x9510 (class bridge subclass miscellaneous, re
v 0x00) at pci0 dev 20 function 1 not configured


Tried this card in multiple systems, also a soekris 4801

This chip apparently have some problems as discussed by:
http://unix.derkeiler.com/Mailing-Lists/FreeBSD/stable/2005-03/0674.html

quoting Kirk McKusick:
"I am able to tip from one port on the SIIG card to another quite
happily, and I can change the baud information (at least to the
extent that I have to set it to the same baud rate on both ports
for them to be able to communicate with each other). But I am unable
to communicate from an SIIG port to any other RS-232 port (whether
native sio port or external such as a modem).

To try and get an understanding of what is going on, I attached my
dual trace scope to the send and receive lines. I observed the
following anomolies:

1) The SIIG port is outputting a signal at +/- 3v as compared to every
   other RS-232 which is at +/- 5v.

2) The SIIG appears to have a badly skewed clock, running at
   approximately 10x what it should be. That is when it is set at
   1800 baud, it is putting out characters that are about the same
   width as a normal port running at 19200 baud.

3) With no output, it has about a 0.2v jitter (high frequency hum)
   in its output.

4) It appears to be missing its final framing bit when it sends characters.

I tried finding a set of baud rates that would match character widths,
but even at 1800/19200 it is not quite right, and definitely is not
effective at transmitting characters between SIIG and non-SIIG ports.
"

I can confirm that communication between two ports on the SIIG card
works.

>How-To-Repeat:
       
Install the new model card

communicate between two ports on this card - works fine

try communicating between SIIG card and another serial port - does not
work, only some random characters can be seen.

I used both conserver and minicom for my tests.

>Fix:
       
Get information from SIIG Inc. or some bit to turn on/off?
The datasheets for this chip mention some multipliers

Btw. The card was verified to work in W2K


>Release-Note:
>Audit-Trail:
>Unformatted: