panic: uhci_abort_xfer: not in process context

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

panic: uhci_abort_xfer: not in process context

Lars Weste
OpenBSD 3.8 dmesg with the upl-2302 interface:

OpenBSD 3.8 (GENERIC) #138: Sat Sep 10 15:41:37 MDT 2005
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) 4 CPU 3.00GHz ("GenuineIntel" 686-class) 3 GHz
cpu0:

FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,EST,CNXT-ID
cpu0: Enhanced SpeedStep 1500 MHz (1420 mV): unknown EST cpu, no changes
possible
real mem  = 1063755776 (1038824K)
avail mem = 964022272 (941428K)
using 4278 buffers containing 53288960 bytes (52040K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(d6) BIOS, date 10/07/05, BIOS32 rev. 0 @
0xfa000
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
apm0: flags 70102 dobusy 1 doidle 1
pcibios0 at bios0: rev 3.0 @ 0xf0000/0xcb84
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfca20/336 (19 entries)
pcibios0: PCI Exclusive IRQs: 5 9 10 12
pcibios0: no compatible PCI ICU found: ICU vendor 0x8086 product 0x2640
pcibios0: Warning, unable to fix up PCI interrupt routing
pcibios0: PCI bus #5 is the last bus
bios0: ROM list: 0xc0000/0x9400! 0xcc000/0x1000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel E7221 MCH Host" rev 0x05
ppb0 at pci0 dev 1 function 0 "Intel E7221 PCIE" rev 0x05
pci1 at ppb0 bus 1
ppb1 at pci1 dev 0 function 0 "Intel PCIE-PCIE" rev 0x09
pci2 at ppb1 bus 2
em0 at pci2 dev 1 function 0 "Intel PRO/1000GT (82541GI)" rev 0x05: irq
12, address: 00:0e:0c:a8:86:3e
vendor "Intel", unknown product 0x0326 (class system subclass interrupt,
rev 0x09) at pci1 dev 0 function 1 not configured
vga1 at pci0 dev 2 function 0 "Intel E7221 Video" rev 0x05: aperture at
0xd0400000, size 0x8000000
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ppb2 at pci0 dev 28 function 0 "Intel 82801FB PCIE" rev 0x03
pci3 at ppb2 bus 3
bge0 at pci3 dev 0 function 0 "Broadcom BCM5721" rev 0x11, BCM5750 B1
(0x4101): irq 12 address 00:30:48:87:68:08
brgphy0 at bge0 phy 1: BCM5750 10/100/1000baseT PHY, rev. 0
ppb3 at pci0 dev 28 function 1 "Intel 82801FB PCIE" rev 0x03
pci4 at ppb3 bus 4
bge1 at pci4 dev 0 function 0 "Broadcom BCM5721" rev 0x11, BCM5750 B1
(0x4101): irq 5 address 00:30:48:87:68:09
brgphy1 at bge1 phy 1: BCM5750 10/100/1000baseT PHY, rev. 0
uhci0 at pci0 dev 29 function 0 "Intel 82801FB USB" rev 0x03: irq 9
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 1 "Intel 82801FB USB" rev 0x03: irq 10
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 29 function 2 "Intel 82801FB USB" rev 0x03: irq 10
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3 at pci0 dev 29 function 3 "Intel 82801FB USB" rev 0x03: irq 12
usb3 at uhci3: USB revision 1.0
uhub3 at usb3
uhub3: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 29 function 7 "Intel 82801FB USB" rev 0x03: irq 9
usb4 at ehci0: USB revision 2.0
uhub4 at usb4
uhub4: Intel EHCI root hub, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
ppb4 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0xd3
pci5 at ppb4 bus 5
ichpcib0 at pci0 dev 31 function 0 "Intel 82801FB LPC" rev 0x03: PM
disabled
pciide0 at pci0 dev 31 function 1 "Intel 82801FB IDE" rev 0x03: DMA,
channel 0 configured to compatibility, channel 1 configured to
compatibility
atapiscsi0 at pciide0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TEAC, CD-224E-N, 1.AA> SCSI0 5/cdrom
removable
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 disabled (no drives)
pciide1 at pci0 dev 31 function 2 "Intel 82801FR SATA" rev 0x03: DMA,
channel 0 wired to native-PCI, channel 1 wired to compatibility
pciide1: using irq 10 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0: <WDC WD800JD-00LSA0>
wd0: 16-sector PIO, LBA48, 76319MB, 156301488 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
pciide1: couldn't map channel 1 cmd regs
"Intel 82801FB SMBus" rev 0x03 at pci0 dev 31 function 3 not configured
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ff45 netmask ff65 ttymask ffe7
pctr: user-level cycle counter enabled
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
WARNING: / was not properly unmounted
upl0 at uhub0 port 2
upl0: Prolific Technology Inc. PL2302 Host-Host interface, rev 1.00/0.02,
addr 2



# ifconfig upl0 inet 10.200.200.1 10.200.200.2 netmask 255.255.255.252 up
# route add default 10.200.200.2
# netstat -rn | head -n 6
Routing tables

Internet:
Destination       Gateway Flags Refs Use Mtu
Interface
default 10.200.200.2 UGS 0 0 -
upl0
10.200.200.2 10.200.200.1 UH 1 0 -
upl0
localhost routes follwing here...

# ifconfig upl0
upl0: flags=8d1<UP,POINTTOPINT,RUNNING,NOARP,SIMPLEX> mtu 1024
        groups: egress
        inet 10.200.200.200.1 --> 10.200.200.2 netmask 0xfffffffc
# ping 10.200.200.1

PANIC!!!!

on a serial console i saw the following:
upl0: watchdog timeout
panic: uhci_abort_xfer: not in process context
Stopped at Debugger+0x4: leave
RUN AT LEAST....

ddb> trace
Debugger(d06f1e9c,d06f1d40,d044294e,d181fc00,0) at Debugger+0x4
panic(d04ecf20,d06f1d60,d0442a88,0,d1772000) at panic+0x63
uhci_abort_xfer(d181fc00,6,d06f0010,d0210010,d7cb0010) at
uhci_abort_xfer+0x55
uhci_device_bulk_abort(d181fc00,8,d057fa84,0,d1838080) at
uhci_device_bulk_abor
t+0x10
usbd_ar_pipe(d1838080,d06f1e9c,1,17,d1789000) at usbd_ar_pipe+0x22
usbd_abort_pipe(d1838080,1,d06f1de4,d0220025) at usbd_abort_pipe+0x20
upl_stop(d1789000,d1789014,d057f950,d06f0000,d1789030) at upl_stop+0x1c9
upl_watchdog(d1789030,d0209a5e,d1776580,d06f1e24) at upl_watchdog+0x38
if_slowtimo(d0595cb0,0,0,5305,0) at if_slowtimo+0x6e
softclock(d0470058,10,380010,d06f0010,d06f1e9c) at softclock+0x22c
Bad frame pointer: 0xd06f1e44
ddb> ps
   PID   PPID   PGRP    UID  S       FLAGS  WAIT       COMMAND
 27893  13928  27893      0  3     0x44186  netio      ping
 23403      1  23403      0  3      0x4086  ttyin      getty
  3552      1   3552      0  3      0x4086  ttyin      getty
 23262      1  23262      0  3      0x4086  ttyin      getty
 14277      1  14277      0  3      0x4086  ttyin      getty
 13928      1  13928      0  3      0x4086  pause      ksh
 18358      1  18358      0  3        0x84  select     cron
 12060      1  12060      0  3     0x40184  select     sendmail
 11071      1  11071      0  3        0x84  select     sshd
 22166      1  22166      0  3       0x184  select     inetd
 19512  17748  17748     83  3       0x184  poll       ntpd
 17748      1  17748      0  3        0x84  poll       ntpd
 10435   9733   9733     73  2       0x184             syslogd
  9733      1   9733      0  3        0x84  netio      syslogd
    16      0      0      0  3    0x100204  crypto_wa  crypto
    15      0      0      0  3    0x100204  aiodoned   aiodoned
    14      0      0      0  3    0x100204  syncer     update
    13      0      0      0  3    0x100204  cleaner    cleaner
    12      0      0      0  3    0x100204  reaper     reaper
    11      0      0      0  3    0x100204  pgdaemon   pagedaemon
    10      0      0      0  3    0x100204  pftm       pfpurge
     9      0      0      0  3    0x100204  usbevt     usb4
     8      0      0      0  3    0x100204  usbevt     usb3
     7      0      0      0  3    0x100204  usbevt     usb2
     6      0      0      0  3    0x100204  usbevt     usb1
     5      0      0      0  3    0x100204  usbtsk     usbtask
     4      0      0      0  3    0x100204  usbevt     usb0
     3      0      0      0  3    0x100204  apmev      apm0
     2      0      0      0  3    0x100204  kmalloc    kmthread
     1      0      1      0  3      0x4084  wait       init
     0     -1      0      0  3     0x80204  scheduler  swapper

if I can help debugging this issue or providing any further information,
then please let me know.

greetings
lars

--
Bis zu 70% Ihrer Onlinekosten sparen: GMX SmartSurfer!
Kostenlos downloaden: http://www.gmx.net/de/go/smartsurfer