panic: bad dir

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

panic: bad dir

Federico Giannici
A panic occurred to one of our servers. I never experienced this panic
before, but I have to say that we recently upgraded that server from
OpenBSD 4.4 to 4.7.

The error was:

/var: bad dir ino 3 at offset 81920: mangled entry
panic: bad dir

I have done two photos of the panic and of the trace command:

http://www.neomedia.it/tmp/crash-1.jpg
http://www.neomedia.it/tmp/crash-2.jpg

The dmesg, df, mount and disklabel commands outputs are below.

Is anything more needed?

Bye.



arwen:/home/giannici# dmesg
OpenBSD 4.7 (GENERIC.MP) #130: Wed Mar 17 20:48:50 MDT 2010
     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 3488284672 (3326MB)
avail mem = 3388477440 (3231MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.5 @ 0x9f400 (71 entries)
bios0: vendor American Megatrends Inc. version "0801" date 01/05/2009
bios0: ASUSTeK Computer INC. M3A78 PRO
acpi0 at bios0: rev 0
acpi0: tables DSDT FACP APIC MCFG OEMB HPET
acpi0: wakeup devices PCE2(S4) PCE3(S4) PCE4(S4) PCE5(S4) PCE6(S4)
PCE7(S4) PCE9(S4) PCEA(S4) SBAZ(S4) PS2K(S3) PS2M(S3) UAR1(S4) P0PC(S4)
UHC1(S4) UHC2(S4) UHC3(S4) USB4(S4) UHC5(S4) UHC6(S4) UHC7(S4) PWRB(S3)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD Phenom(tm) 9650 Quad-Core Processor, 2306.35 MHz
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB
64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 16 4MB entries fully
associative
cpu0: DTLB 48 4KB entries fully associative, 48 4MB entries fully
associative
cpu0: apic clock running at 200MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: AMD Phenom(tm) 9650 Quad-Core Processor, 2306.00 MHz
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB
64b/line 16-way L2 cache
cpu1: ITLB 32 4KB entries fully associative, 16 4MB entries fully
associative
cpu1: DTLB 48 4KB entries fully associative, 48 4MB entries fully
associative
cpu2 at mainbus0: apid 2 (application processor)
cpu2: AMD Phenom(tm) 9650 Quad-Core Processor, 2306.00 MHz
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu2: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB
64b/line 16-way L2 cache
cpu2: ITLB 32 4KB entries fully associative, 16 4MB entries fully
associative
cpu2: DTLB 48 4KB entries fully associative, 48 4MB entries fully
associative
cpu3 at mainbus0: apid 3 (application processor)
cpu3: AMD Phenom(tm) 9650 Quad-Core Processor, 2306.00 MHz
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu3: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB
64b/line 16-way L2 cache
cpu3: ITLB 32 4KB entries fully associative, 16 4MB entries fully
associative
cpu3: DTLB 48 4KB entries fully associative, 48 4MB entries fully
associative
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 21, 24 pins
acpihpet0 at acpi0: 14318180 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (P0P1)
acpiprt2 at acpi0: bus -1 (PCE2)
acpiprt3 at acpi0: bus -1 (PCE3)
acpiprt4 at acpi0: bus -1 (PCE4)
acpiprt5 at acpi0: bus -1 (PCE5)
acpiprt6 at acpi0: bus 2 (PCE6)
acpiprt7 at acpi0: bus 3 (P0PC)
acpicpu0 at acpi0
acpicpu1 at acpi0
acpicpu2 at acpi0
acpicpu3 at acpi0
aibs0 at acpi0
aibs0: TSIF not found
aibs0: FSIF not found
aibs0: VSIF not found
aibs0: no sensors found
acpibtn0 at acpi0: PWRB
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "AMD RS780 Host" rev 0x00
ppb0 at pci0 dev 1 function 0 "AMD RS780 PCIE" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 5 function 0 "ATI Radeon HD 3200" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
azalia0 at pci1 dev 5 function 1 "ATI RS780 HD Audio" rev 0x00: apic 4
int 19 (irq 11)
azalia0: no supported codecs
azalia0: initialization failure, detaching
ppb1 at pci0 dev 6 function 0 "AMD RS780 PCIE" rev 0x00: apic 4 int 18
(irq 10)
pci2 at ppb1 bus 2
re0 at pci2 dev 0 function 0 "Realtek 8168" rev 0x02: RTL8168C/8111C
(0x3c00), apic 4 int 18 (irq 10), address 00:23:54:51:bc:11
rgephy0 at re0 phy 7: RTL8169S/8110S PHY, rev. 2
ahci0 at pci0 dev 17 function 0 "ATI SBx00 SATA" rev 0x00: apic 4 int 22
(irq 11), AHCI 1.1
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, WDC WD2500AAKS-0, 12.0> SCSI3
0/direct fixed
sd0: 238475MB, 512 bytes/sec, 488397168 sec total
sd1 at scsibus0 targ 1 lun 0: <ATA, Maxtor 6V250F0, VA11> SCSI3 0/direct
fixed
sd1: 239372MB, 512 bytes/sec, 490234752 sec total
ohci0 at pci0 dev 18 function 0 "ATI SB700 USB" rev 0x00: apic 4 int 16
(irq 7), version 1.0, legacy support
ohci1 at pci0 dev 18 function 1 "ATI SB700 USB" rev 0x00: apic 4 int 16
(irq 7), version 1.0, legacy support
ehci0 at pci0 dev 18 function 2 "ATI SB700 USB2" rev 0x00: apic 4 int 17
(irq 10)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "ATI EHCI root hub" rev 2.00/1.00 addr 1
ohci2 at pci0 dev 19 function 0 "ATI SB700 USB" rev 0x00: apic 4 int 18
(irq 10), version 1.0, legacy support
ohci3 at pci0 dev 19 function 1 "ATI SB700 USB" rev 0x00: apic 4 int 18
(irq 10), version 1.0, legacy support
ehci1 at pci0 dev 19 function 2 "ATI SB700 USB2" rev 0x00: apic 4 int 19
(irq 11)
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "ATI EHCI root hub" rev 2.00/1.00 addr 1
piixpm0 at pci0 dev 20 function 0 "ATI SBx00 SMBus" rev 0x3a: SMI
iic0 at piixpm0
spdmem0 at iic0 addr 0x50: 2GB DDR2 SDRAM non-parity PC2-6400CL5
spdmem1 at iic0 addr 0x51: 2GB DDR2 SDRAM non-parity PC2-6400CL5
pciide0 at pci0 dev 20 function 1 "ATI SB700 IDE" rev 0x00: DMA, channel
0 configured to compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide0 channel 0 drive 1
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <HL-DT-ST, DVD-ROM GDR8164B, 0L06> ATAPI
5/cdrom removable
cd0(pciide0:0:1): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
azalia1 at pci0 dev 20 function 2 "ATI SBx00 HD Audio" rev 0x00: apic 4
int 16 (irq 7)
azalia1: codecs: Realtek ALC888
audio0 at azalia1
pcib0 at pci0 dev 20 function 3 "ATI SB700 ISA" rev 0x00
ppb2 at pci0 dev 20 function 4 "ATI SB600 PCI" rev 0x00
pci3 at ppb2 bus 3
ohci4 at pci0 dev 20 function 5 "ATI SB700 USB" rev 0x00: apic 4 int 18
(irq 10), version 1.0, legacy support
pchb1 at pci0 dev 24 function 0 "AMD AMD64 10h HyperTransport" rev 0x00
pchb2 at pci0 dev 24 function 1 "AMD AMD64 10h Address Map" rev 0x00
pchb3 at pci0 dev 24 function 2 "AMD AMD64 10h DRAM Cfg" rev 0x00
km0 at pci0 dev 24 function 3 "AMD AMD64 10h Misc Cfg" rev 0x00
pchb4 at pci0 dev 24 function 4 "AMD AMD64 10h Link Cfg" rev 0x00
usb2 at ohci0: USB revision 1.0
uhub2 at usb2 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb3 at ohci1: USB revision 1.0
uhub3 at usb3 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb4 at ohci2: USB revision 1.0
uhub4 at usb4 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb5 at ohci3: USB revision 1.0
uhub5 at usb5 "ATI OHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
it0 at isa0 port 0x2e/2: IT8716F rev 3, EC port 0xe80
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
usb6 at ohci4: USB revision 1.0
uhub6 at usb6 "ATI OHCI root hub" rev 1.00/1.00 addr 1
mtrr: Pentium Pro MTRR support
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
root on sd0a swap on sd0b dump on sd0b

arwen:/home/giannici# df
Filesystem          1K-blocks      Used     Avail Capacity  Mounted on
/dev/sd0a            51606268   2927294  46098662     6%    /
/dev/sd0e           178399396   1531342 167948086     1%    /var
mfs:30101              967503         4    919124     0%    /tmp
195.103.207.9:/mail 2664997942 213100062 2318647984     8%    /mail

arwen:/home/giannici# mount
/dev/sd0a on / type ffs (local, softdep)
/dev/sd0e on /var type ffs (local, nodev, nosuid, softdep)
mfs:30101 on /tmp type mfs (asynchronous, local, nodev, nosuid,
size=1000000 1K-blocks)
195.103.207.9:/mail on /mail type nfs (noatime, nodev, noexec, nosuid,
v3, udp, soft, intr, timeo=100, retrans=3)

arwen:/home/giannici# disklabel sd0
# /dev/rsd0c:
type: ESDI
disk: ESDI/IDE disk
label: WDC WD2500AAKS-0
flags:
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 255
sectors/cylinder: 16065
cylinders: 30401
total sectors: 488397168
rpm: 3600
interleave: 1
boundstart: 63
boundend: 488392065
drivedata: 0

16 partitions:
#                size           offset  fstype [fsize bsize  cpg]
   a:        104872257               63  4.2BSD   2048 16384    1 # /
   b:         10490445        104872320    swap
   c:        488397168                0  unused
   d:         10490445        115362765  4.2BSD   2048 16384    1
   e:        362538855        125853210  4.2BSD   2048 16384    1 # /var



--
___________________________________________________
     __
    |-                      [hidden email]
    |ederico Giannici      http://www.neomedia.it
___________________________________________________

Reply | Threaded
Open this post in threaded view
|

Re: panic: bad dir

Chris Cappuccio
this is likely to be a result of a corrupted filesstem...

reboot in single user mode, bsd -s at the boot> prompt, and run fsck -fy all of your filesystems

Federico Giannici [[hidden email]] wrote:

> A panic occurred to one of our servers. I never experienced this
> panic before, but I have to say that we recently upgraded that
> server from OpenBSD 4.4 to 4.7.
>
> The error was:
>
> /var: bad dir ino 3 at offset 81920: mangled entry
> panic: bad dir
>
> I have done two photos of the panic and of the trace command:
>
> http://www.neomedia.it/tmp/crash-1.jpg
> http://www.neomedia.it/tmp/crash-2.jpg
>
> The dmesg, df, mount and disklabel commands outputs are below.
>
> Is anything more needed?
>
> Bye.
>
>
>
> arwen:/home/giannici# dmesg
> OpenBSD 4.7 (GENERIC.MP) #130: Wed Mar 17 20:48:50 MDT 2010
>     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> real mem = 3488284672 (3326MB)
> avail mem = 3388477440 (3231MB)
> mainbus0 at root
> bios0 at mainbus0: SMBIOS rev. 2.5 @ 0x9f400 (71 entries)
> bios0: vendor American Megatrends Inc. version "0801" date 01/05/2009
> bios0: ASUSTeK Computer INC. M3A78 PRO
> acpi0 at bios0: rev 0
> acpi0: tables DSDT FACP APIC MCFG OEMB HPET
> acpi0: wakeup devices PCE2(S4) PCE3(S4) PCE4(S4) PCE5(S4) PCE6(S4)
> PCE7(S4) PCE9(S4) PCEA(S4) SBAZ(S4) PS2K(S3) PS2M(S3) UAR1(S4)
> P0PC(S4) UHC1(S4) UHC2(S4) UHC3(S4) USB4(S4) UHC5(S4) UHC6(S4)
> UHC7(S4) PWRB(S3)
> acpitimer0 at acpi0: 3579545 Hz, 32 bits
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: AMD Phenom(tm) 9650 Quad-Core Processor, 2306.35 MHz
> cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
> cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache,
> 512KB 64b/line 16-way L2 cache
> cpu0: ITLB 32 4KB entries fully associative, 16 4MB entries fully
> associative
> cpu0: DTLB 48 4KB entries fully associative, 48 4MB entries fully
> associative
> cpu0: apic clock running at 200MHz
> cpu1 at mainbus0: apid 1 (application processor)
> cpu1: AMD Phenom(tm) 9650 Quad-Core Processor, 2306.00 MHz
> cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
> cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache,
> 512KB 64b/line 16-way L2 cache
> cpu1: ITLB 32 4KB entries fully associative, 16 4MB entries fully
> associative
> cpu1: DTLB 48 4KB entries fully associative, 48 4MB entries fully
> associative
> cpu2 at mainbus0: apid 2 (application processor)
> cpu2: AMD Phenom(tm) 9650 Quad-Core Processor, 2306.00 MHz
> cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
> cpu2: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache,
> 512KB 64b/line 16-way L2 cache
> cpu2: ITLB 32 4KB entries fully associative, 16 4MB entries fully
> associative
> cpu2: DTLB 48 4KB entries fully associative, 48 4MB entries fully
> associative
> cpu3 at mainbus0: apid 3 (application processor)
> cpu3: AMD Phenom(tm) 9650 Quad-Core Processor, 2306.00 MHz
> cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
> cpu3: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache,
> 512KB 64b/line 16-way L2 cache
> cpu3: ITLB 32 4KB entries fully associative, 16 4MB entries fully
> associative
> cpu3: DTLB 48 4KB entries fully associative, 48 4MB entries fully
> associative
> ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 21, 24 pins
> acpihpet0 at acpi0: 14318180 Hz
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus 1 (P0P1)
> acpiprt2 at acpi0: bus -1 (PCE2)
> acpiprt3 at acpi0: bus -1 (PCE3)
> acpiprt4 at acpi0: bus -1 (PCE4)
> acpiprt5 at acpi0: bus -1 (PCE5)
> acpiprt6 at acpi0: bus 2 (PCE6)
> acpiprt7 at acpi0: bus 3 (P0PC)
> acpicpu0 at acpi0
> acpicpu1 at acpi0
> acpicpu2 at acpi0
> acpicpu3 at acpi0
> aibs0 at acpi0
> aibs0: TSIF not found
> aibs0: FSIF not found
> aibs0: VSIF not found
> aibs0: no sensors found
> acpibtn0 at acpi0: PWRB
> pci0 at mainbus0 bus 0
> pchb0 at pci0 dev 0 function 0 "AMD RS780 Host" rev 0x00
> ppb0 at pci0 dev 1 function 0 "AMD RS780 PCIE" rev 0x00
> pci1 at ppb0 bus 1
> vga1 at pci1 dev 5 function 0 "ATI Radeon HD 3200" rev 0x00
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> azalia0 at pci1 dev 5 function 1 "ATI RS780 HD Audio" rev 0x00: apic
> 4 int 19 (irq 11)
> azalia0: no supported codecs
> azalia0: initialization failure, detaching
> ppb1 at pci0 dev 6 function 0 "AMD RS780 PCIE" rev 0x00: apic 4 int
> 18 (irq 10)
> pci2 at ppb1 bus 2
> re0 at pci2 dev 0 function 0 "Realtek 8168" rev 0x02: RTL8168C/8111C
> (0x3c00), apic 4 int 18 (irq 10), address 00:23:54:51:bc:11
> rgephy0 at re0 phy 7: RTL8169S/8110S PHY, rev. 2
> ahci0 at pci0 dev 17 function 0 "ATI SBx00 SATA" rev 0x00: apic 4
> int 22 (irq 11), AHCI 1.1
> scsibus0 at ahci0: 32 targets
> sd0 at scsibus0 targ 0 lun 0: <ATA, WDC WD2500AAKS-0, 12.0> SCSI3
> 0/direct fixed
> sd0: 238475MB, 512 bytes/sec, 488397168 sec total
> sd1 at scsibus0 targ 1 lun 0: <ATA, Maxtor 6V250F0, VA11> SCSI3
> 0/direct fixed
> sd1: 239372MB, 512 bytes/sec, 490234752 sec total
> ohci0 at pci0 dev 18 function 0 "ATI SB700 USB" rev 0x00: apic 4 int
> 16 (irq 7), version 1.0, legacy support
> ohci1 at pci0 dev 18 function 1 "ATI SB700 USB" rev 0x00: apic 4 int
> 16 (irq 7), version 1.0, legacy support
> ehci0 at pci0 dev 18 function 2 "ATI SB700 USB2" rev 0x00: apic 4
> int 17 (irq 10)
> usb0 at ehci0: USB revision 2.0
> uhub0 at usb0 "ATI EHCI root hub" rev 2.00/1.00 addr 1
> ohci2 at pci0 dev 19 function 0 "ATI SB700 USB" rev 0x00: apic 4 int
> 18 (irq 10), version 1.0, legacy support
> ohci3 at pci0 dev 19 function 1 "ATI SB700 USB" rev 0x00: apic 4 int
> 18 (irq 10), version 1.0, legacy support
> ehci1 at pci0 dev 19 function 2 "ATI SB700 USB2" rev 0x00: apic 4
> int 19 (irq 11)
> usb1 at ehci1: USB revision 2.0
> uhub1 at usb1 "ATI EHCI root hub" rev 2.00/1.00 addr 1
> piixpm0 at pci0 dev 20 function 0 "ATI SBx00 SMBus" rev 0x3a: SMI
> iic0 at piixpm0
> spdmem0 at iic0 addr 0x50: 2GB DDR2 SDRAM non-parity PC2-6400CL5
> spdmem1 at iic0 addr 0x51: 2GB DDR2 SDRAM non-parity PC2-6400CL5
> pciide0 at pci0 dev 20 function 1 "ATI SB700 IDE" rev 0x00: DMA,
> channel 0 configured to compatibility, channel 1 configured to
> compatibility
> atapiscsi0 at pciide0 channel 0 drive 1
> scsibus1 at atapiscsi0: 2 targets
> cd0 at scsibus1 targ 0 lun 0: <HL-DT-ST, DVD-ROM GDR8164B, 0L06>
> ATAPI 5/cdrom removable
> cd0(pciide0:0:1): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
> azalia1 at pci0 dev 20 function 2 "ATI SBx00 HD Audio" rev 0x00:
> apic 4 int 16 (irq 7)
> azalia1: codecs: Realtek ALC888
> audio0 at azalia1
> pcib0 at pci0 dev 20 function 3 "ATI SB700 ISA" rev 0x00
> ppb2 at pci0 dev 20 function 4 "ATI SB600 PCI" rev 0x00
> pci3 at ppb2 bus 3
> ohci4 at pci0 dev 20 function 5 "ATI SB700 USB" rev 0x00: apic 4 int
> 18 (irq 10), version 1.0, legacy support
> pchb1 at pci0 dev 24 function 0 "AMD AMD64 10h HyperTransport" rev 0x00
> pchb2 at pci0 dev 24 function 1 "AMD AMD64 10h Address Map" rev 0x00
> pchb3 at pci0 dev 24 function 2 "AMD AMD64 10h DRAM Cfg" rev 0x00
> km0 at pci0 dev 24 function 3 "AMD AMD64 10h Misc Cfg" rev 0x00
> pchb4 at pci0 dev 24 function 4 "AMD AMD64 10h Link Cfg" rev 0x00
> usb2 at ohci0: USB revision 1.0
> uhub2 at usb2 "ATI OHCI root hub" rev 1.00/1.00 addr 1
> usb3 at ohci1: USB revision 1.0
> uhub3 at usb3 "ATI OHCI root hub" rev 1.00/1.00 addr 1
> usb4 at ohci2: USB revision 1.0
> uhub4 at usb4 "ATI OHCI root hub" rev 1.00/1.00 addr 1
> usb5 at ohci3: USB revision 1.0
> uhub5 at usb5 "ATI OHCI root hub" rev 1.00/1.00 addr 1
> isa0 at pcib0
> isadma0 at isa0
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pmsi0 at pckbc0 (aux slot)
> pckbc0: using irq 12 for aux slot
> wsmouse0 at pmsi0 mux 0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> it0 at isa0 port 0x2e/2: IT8716F rev 3, EC port 0xe80
> fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
> usb6 at ohci4: USB revision 1.0
> uhub6 at usb6 "ATI OHCI root hub" rev 1.00/1.00 addr 1
> mtrr: Pentium Pro MTRR support
> vscsi0 at root
> scsibus2 at vscsi0: 256 targets
> softraid0 at root
> root on sd0a swap on sd0b dump on sd0b
>
> arwen:/home/giannici# df
> Filesystem          1K-blocks      Used     Avail Capacity  Mounted on
> /dev/sd0a            51606268   2927294  46098662     6%    /
> /dev/sd0e           178399396   1531342 167948086     1%    /var
> mfs:30101              967503         4    919124     0%    /tmp
> 195.103.207.9:/mail 2664997942 213100062 2318647984     8%    /mail
>
> arwen:/home/giannici# mount
> /dev/sd0a on / type ffs (local, softdep)
> /dev/sd0e on /var type ffs (local, nodev, nosuid, softdep)
> mfs:30101 on /tmp type mfs (asynchronous, local, nodev, nosuid,
> size=1000000 1K-blocks)
> 195.103.207.9:/mail on /mail type nfs (noatime, nodev, noexec,
> nosuid, v3, udp, soft, intr, timeo=100, retrans=3)
>
> arwen:/home/giannici# disklabel sd0
> # /dev/rsd0c:
> type: ESDI
> disk: ESDI/IDE disk
> label: WDC WD2500AAKS-0
> flags:
> bytes/sector: 512
> sectors/track: 63
> tracks/cylinder: 255
> sectors/cylinder: 16065
> cylinders: 30401
> total sectors: 488397168
> rpm: 3600
> interleave: 1
> boundstart: 63
> boundend: 488392065
> drivedata: 0
>
> 16 partitions:
> #                size           offset  fstype [fsize bsize  cpg]
>   a:        104872257               63  4.2BSD   2048 16384    1 # /
>   b:         10490445        104872320    swap
>   c:        488397168                0  unused
>   d:         10490445        115362765  4.2BSD   2048 16384    1
>   e:        362538855        125853210  4.2BSD   2048 16384    1 # /var
>
>
>
> --
> ___________________________________________________
>     __
>    |-                      [hidden email]
>    |ederico Giannici      http://www.neomedia.it
> ___________________________________________________

--
I know nothing except the fact of my ignorance -Socrates