page fault in iwn_tx_done

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

page fault in iwn_tx_done

Scott Walters-3
>Synopsis: page fault in iwn_tx_done
>Category: kernel
>Environment:
        System      : OpenBSD 6.1
        Details     : OpenBSD 6.1-current (GENERIC.MP) #23: Thu Apr 27 04:59:17 MDT 2017
                         [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP

        Architecture: OpenBSD.amd64
        Machine     : amd64
>Description:

Random.

[Typing in text from cameraphone pics:]

kernel: page fault trap, code=0
Stepped at      iwn_tx_done+0x65:  textb $0x4,hib_hlt_real+0xcf0(%rsi)
ddb{0}> trace
iwn_tx_done() at iwn_tx_done+0x65
iwn_notif_intr() at iwn_notif_intr+0x1c7
iwn_intr() at iwn_intr+0x201
intr_handler() at intr_handler+0x67
end of kernel
end trace frame: 0x83cc4885310, count: -4
ddb{0}> boot reboot
splassert: if_down: want 5 have 7
splassert: if_linkstate: want 5 have 7
splassert: pool_do_get: want 4 have 7
splassert: pool_do_get: want 4 have 7
splassert: if_down: want 5 have 5
splassert: if_linkstate: want 5 have 5
splassert: if_down: want 5 have 5
splassert: if_linkstate: want 5 have 7
splassert: pool_do_get: want 4 have 7
splassert: pool_do_get: want 5 have 7
splassert: assertwaitok: want 0 have 7

(then didn't reboot and I vulcan death pinched it.)

No `ps` or `show registers`; next time.  Hope this is helpful anyway.

>How-To-Repeat:

Sorry... not easily reproducible.  Wasn't in middle of suspend or anything, just dogging the system with Firefox.

April 27 "current" snapshot of 6.1.

ifconfig iwn0
iwn0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 18:3d:a2:4c:5d:78
        index 2 priority 4 llprio 3
        groups: wlan egress
        media: IEEE802.11 autoselect (HT-MCS2 mode 11n)
        status: active
        ieee80211: nwid PCMoney chan 11 bssid 18:d6:c7:6d:55:dc -53dBm wpakey <not displayed> wpaprotos wpa2 wpaakms psk wpaciphers ccmp wpagroupcipher ccmp
        inet 192.168.0.104 netmask 0xffffff00 broadcast 192.168.0.255

OpenVPN was up:

client
dev tap1
dev-type tap
proto udp
float
auth-user-pass
nobind
persist-key
persist-tun
ca ca.crt
cert client.crt
key client.key
comp-lzo
verb 3
mute 20
# just causes disconnects on shitty connections
# keepalive 10 60
# ifconfig 10.8.1.234
# route 10.8.1.0 255.255.255.0 10.8.1.1
route-delay 2
# stop quitting as soon as you can't ping for one damn second
ping 3600
ping-exit 7200
script-security 2
up go.sh

>Fix:

This WiFi card is garbage, but OpenBSD has been handling it far better than Linux so far.


dmesg:
OpenBSD 6.1-current (GENERIC.MP) #23: Thu Apr 27 04:59:17 MDT 2017
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 6214848512 (5926MB)
avail mem = 6021808128 (5742MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.6 @ 0xeb060 (49 entries)
bios0: vendor American Megatrends Inc. version "V1.00L18" date 12/15/2010
bios0: Panasonic Corporation CF-C1ADAJZ1M
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC MCFG HPET ASF! SLIC SSDT SSDT SSDT TCPA SSDT
acpi0: wakeup devices P0P2(S4) PEGP(S4) P0P1(S4) EHC1(S3) EHC2(S3) HDEF(S3) PXSX(S4) RP01(S4) PXSX(S4) RP05(S4) PXSX(S4) RP07(S4) PXSX(S4) RP08(S4) GLAN(S4) PEG3(S4) [...]
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz, 2394.37 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,POPCNT,AES,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,SENSOR,ARAT
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: TSC frequency 2394367950 Hz
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 133MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.1, IBE
cpu1 at mainbus0: apid 4 (application processor)
cpu1: Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz, 2394.01 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,POPCNT,AES,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,SENSOR,ARAT
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 0, core 2, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (P0P2)
acpiprt2 at acpi0: bus 20 (P0P1)
acpiprt3 at acpi0: bus 1 (RP01)
acpiprt4 at acpi0: bus -1 (RP05)
acpiprt5 at acpi0: bus -1 (RP07)
acpiprt6 at acpi0: bus -1 (RP08)
acpiprt7 at acpi0: bus -1 (PEG3)
acpiprt8 at acpi0: bus -1 (PEG5)
acpiprt9 at acpi0: bus 10 (RP03)
acpiprt10 at acpi0: bus 11 (RP04)
acpiprt11 at acpi0: bus 2 (RP02)
acpiec0 at acpi0
acpicpu0 at acpi0: C2(350@245 mwait.3@0x20), C1(1000@3 mwait.1), PSS
acpicpu1 at acpi0: C2(350@245 mwait.3@0x20), C1(1000@3 mwait.1), PSS
acpitz0 at acpi0: critical temperature is 106 degC
acpitz1 at acpi0: critical temperature is 130 degC
"PNP0303" at acpi0 not configured
"SYN0502" at acpi0 not configured
"INT3404" at acpi0 not configured
"INT3403" at acpi0 not configured
"INT3403" at acpi0 not configured
"INT3403" at acpi0 not configured
"INT3403" at acpi0 not configured
"INT3403" at acpi0 not configured
tpm0 at acpi0: TPM_ addr 0xfed40000/0x5000: Infineon SLB9635 1.2 rev 0x10
"INT3402" at acpi0 not configured
"MAT0021" at acpi0 not configured
"MAT0019" at acpi0 not configured
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT1 model "CF-VZSU66" serial 00626 type LION oem "Panasonic"
acpibat1 at acpi0: BAT2 model "CF-VZSU66" serial 00626 type LION oem "Panasonic"
"INT3405" at acpi0 not configured
"INT3400" at acpi0 not configured
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: PWRB
"MAT001F" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD02
cpu0: Enhanced SpeedStep 2394 MHz: speeds: 2400, 2399, 2266, 2133, 1999, 1866, 1733, 1599, 1466, 1333, 1199 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core Host" rev 0x02
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x02
drm0 at inteldrm0
intagp0 at inteldrm0
agp0 at intagp0: aperture at 0xe0000000, size 0x10000000
inteldrm0: msi
inteldrm0: 1280x800, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
em0 at pci0 dev 25 function 0 "Intel 82577LM" rev 0x06: msi, address 70:58:12:26:52:0c
ehci0 at pci0 dev 26 function 0 "Intel 3400 USB" rev 0x06: apic 2 int 16
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 3400 HD Audio" rev 0x06: msi
azalia0: codecs: Conexant/0x5068, Intel/0x2804, using Conexant/0x5068
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 3400 PCIE" rev 0x06: msi
pci1 at ppb0 bus 1
ppb1 at pci0 dev 28 function 1 "Intel 3400 PCIE" rev 0x06: msi
pci2 at ppb1 bus 2
ppb2 at pci0 dev 28 function 2 "Intel 3400 PCIE" rev 0x06: msi
pci3 at ppb2 bus 10
iwn0 at pci3 dev 0 function 0 "Intel Centrino Advanced-N 6200" rev 0x35: msi, MIMO 2T2R, MoW, address 18:3d:a2:4c:5d:78
ppb3 at pci0 dev 28 function 3 "Intel 3400 PCIE" rev 0x06: msi
pci4 at ppb3 bus 11
cbb0 at pci4 dev 0 function 0 vendor "Ricoh", unknown product 0xe476 rev 0x00: apic 2 int 19
sdhc0 at pci4 dev 0 function 1 "Ricoh 5U822 SD/MMC" rev 0x02: apic 2 int 16
sdhc0: SDHC 1.0, 50 MHz base clock
sdmmc0 at sdhc0: 4-bit, sd high-speed, mmc high-speed
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 12 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
ehci1 at pci0 dev 29 function 0 "Intel 3400 USB" rev 0x06: apic 2 int 23
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb4 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xa6
pci5 at ppb4 bus 20
pcib0 at pci0 dev 31 function 0 "Intel QM57 LPC" rev 0x06
ahci0 at pci0 dev 31 function 2 "Intel 3400 AHCI" rev 0x06: msi, AHCI 1.3
ahci0: port 0: 3.0Gb/s
ahci0: PHY offline on port 1
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, WDC WD10JPVX-22J, 01.0> SCSI3 0/direct fixed naa.50014ee2611e32f9
sd0: 953869MB, 512 bytes/sector, 1953525168 sectors
ichiic0 at pci0 dev 31 function 3 "Intel 3400 SMBus" rev 0x06: apic 2 int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 2GB DDR3 SDRAM PC3-10600 SO-DIMM
spdmem1 at iic0 addr 0x52: 4GB DDR3 SDRAM PC3-12800 SO-DIMM
itherm0 at pci0 dev 31 function 6 "Intel 3400 Thermal" rev 0x06
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pms0: Synaptics touchpad, firmware 6.2
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
pci6 at mainbus0 bus 63
pchb1 at pci6 dev 0 function 0 "Intel QuickPath" rev 0x02
pchb2 at pci6 dev 0 function 1 "Intel QuickPath" rev 0x02
pchb3 at pci6 dev 2 function 0 "Intel QPI Link" rev 0x02
pchb4 at pci6 dev 2 function 1 "Intel QPI Physical" rev 0x02
pchb5 at pci6 dev 2 function 2 "Intel Reserved" rev 0x02
pchb6 at pci6 dev 2 function 3 "Intel Reserved" rev 0x02
vmm0 at mainbus0: VMX/EPT
uhub2 at uhub0 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uhidev0 at uhub2 port 4 configuration 1 interface 0 "Tablet ISD-V4" rev 1.10/0.11 addr 3
uhidev0: iclass 3/0, 17 report ids
ums0 at uhidev0 reportid 2: 3 buttons, tip, barrel, eraser
wsmouse1 at ums0 mux 0
uhid0 at uhidev0 reportid 17: input=7, output=0, feature=3
uhidev1 at uhub2 port 4 configuration 1 interface 1 "Tablet ISD-V4" rev 1.10/0.11 addr 3
uhidev1: iclass 3/0, 16 report ids
uhid1 at uhidev1 reportid 2: input=0, output=0, feature=1
uhid2 at uhidev1 reportid 3: input=0, output=0, feature=3
uhid3 at uhidev1 reportid 5: input=0, output=0, feature=8
uhid4 at uhidev1 reportid 6: input=0, output=0, feature=8
ums1 at uhidev1 reportid 12: 1 button, tip
wsmouse2 at ums1 mux 0
uhid5 at uhidev1 reportid 13: input=13, output=0, feature=0
uhid6 at uhidev1 reportid 14: input=0, output=0, feature=2
ums2 at uhidev1 reportid 15: 2 buttons
wsmouse3 at ums2 mux 0
ums3 at uhidev1 reportid 16: 1 button, tip
wsmouse4 at ums3 mux 0
uvideo0 at uhub2 port 5 configuration 1 interface 0 "AVEO Technology Corp. USB2.0 Camera" rev 2.00/8.24 addr 4
video0 at uvideo0
uhub3 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uhidev2 at uhub3 port 2 configuration 1 interface 0 "vendor 0x0581 product 0x0101" rev 1.10/0.01 addr 3
uhidev2: iclass 3/1, 1 report id
ums4 at uhidev2 reportid 1: 5 buttons, Z dir
wsmouse5 at ums4 mux 0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
softraid0: sd1 was not shutdown properly
sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2 0/direct fixed
sd1: 921603MB, 512 bytes/sector, 1887444128 sectors
root on sd1a (6beb8c665f87a835.a) swap on sd1b dump on sd1b
WARNING: / was not properly unmounted

usbdevs:
Controller /dev/usb0:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000), Intel(0x8086), rev 1.00
 port 1 addr 2: high speed, self powered, config 1, Rate Matching Hub(0x0020), Intel(0x8087), rev 0.00
  port 1 powered
  port 2 powered
  port 3 powered
  port 4 addr 3: full speed, self powered, config 1, ISD-V4(0x00e3), Tablet(0x056a), rev 0.11
  port 5 addr 4: high speed, power 500 mA, config 1, USB2.0 Camera(0x7690), AVEO Technology Corp.(0x1871), rev 8.24
  port 6 powered
 port 2 powered
Controller /dev/usb1:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000), Intel(0x8086), rev 1.00
 port 1 addr 2: high speed, self powered, config 1, Rate Matching Hub(0x0020), Intel(0x8087), rev 0.00
  port 1 addr 4: high speed, power 500 mA, config 1, KYOCERA USB Modem(0x0923), Kyocera Corporation(0x0482), rev 2.28, iSerialNumber 014030000161084
  port 2 addr 3: low speed, power 100 mA, config 1, product 0x0101(0x0101), vendor 0x0581(0x0581), rev 0.01
  port 3 powered
  port 4 powered
  port 5 powered
  port 6 powered
  port 7 powered
  port 8 powered
 port 2 powered