ntpd terminates after a few seconds of running

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

ntpd terminates after a few seconds of running

Andreas Kusalananda Kähäri-3
Hi,

Running -current on amd64, I noticed that the ntpd daemon wasn't
responding:

$ ntpctl -s all
ntpctl: connect: /var/run/ntpd.sock: Connection refused

So I restarted it and tried again:

$ doas rcctl start ntpd
ntpd(ok)
$ ntpctl -s all
0/4 peers valid, constraint offset -1s, clock unsynced

peer
   wt tl st  next  poll          offset       delay      jitter
192.168.56.1 vboxhost
    2  3  3    4s    8s             ---- peer not valid ----
130.238.4.133 ntp1.uu.se
    1  3  2    2s    6s             ---- peer not valid ----
130.238.7.10 ntp2.uu.se
    1  3  2    5s    9s             ---- peer not valid ----
130.238.164.6 ntp3.uu.se
    1  3  2    3s    7s             ---- peer not valid ----
$ ntpctl -s all
ntpctl: connect: /var/run/ntpd.sock: Connection refused

I then tried running it in the foregrond and saw this:

$ doas ntpd -ds
ntp engine ready
constraint request to 64.233.161.147
constraint request to 64.233.161.103
constraint request to 64.233.161.99
constraint request to 64.233.161.104
constraint request to 64.233.161.106
constraint request to 2a00:1450:4010:c01::6a
constraint request to 64.233.161.105
constraint reply from 64.233.161.104: offset -0.462054
reply from 192.168.56.1: offset 0.000103 delay 0.000444, next query 9s
set local clock to Thu Oct 20 14:14:05 CEST 2016 (offset 0.000103s)
reply from 130.238.4.133: offset -0.000103 delay 0.001609, next query 9s
reply from 130.238.7.10: offset 0.000059 delay 0.001552, next query 6s
reply from 130.238.164.6: offset -0.000588 delay 0.001528, next query 6s
constraint reply from 64.233.161.103: offset -0.467928
no constraint reply from 64.233.161.104 received in time, next query 900s
constraint reply from 64.233.161.99: offset -0.474557
no constraint reply from 64.233.161.103 received in time, next query 900s
no constraint reply from 64.233.161.99 received in time, next query 900s
constraint reply from 64.233.161.147: offset -0.502529
no constraint reply from 64.233.161.147 received in time, next query 900s
constraint reply from 64.233.161.105: offset -0.517673
no constraint reply from 64.233.161.105 received in time, next query 900s
constraint reply from 64.233.161.106: offset -0.526446
no constraint reply from 64.233.161.106 received in time, next query 900s
reply from 130.238.7.10: offset -0.000060 delay 0.000973, next query 6s
reply from 130.238.164.6: offset -0.000814 delay 0.000908, next query 7s
reply from 192.168.56.1: offset -0.000161 delay 0.000796, next query 9s
ntp engine exiting
Terminating


Why is it terminating?

This is my ntpd.conf:

# $OpenBSD: ntpd.conf,v 1.14 2015/07/15 20:28:37 ajacoutot Exp $
#
# See ntpd.conf(5) and /etc/examples/ntpd.conf

server  vboxhost        weight 2
server  ntp1.uu.se      weight 1
server  ntp2.uu.se      weight 1
server  ntp3.uu.se      weight 1
#servers        pool.ntp.org    weight 1
sensor *
constraints from "https://www.google.com"


Cheers,
Andreas


--
Andreas Kusalananda Kähäri
Bioinformatics Developer
NBIS, Uppsala University
http://www.nbis.se/

[demime 1.01d removed an attachment of type application/pgp-signature which had a name of signature.asc]

Reply | Threaded
Open this post in threaded view
|

Re: ntpd terminates after a few seconds of running

Rafael Zalamena-2
On Thu, Oct 20, 2016 at 02:18:27PM +0200, Andreas Kusalananda K?h?ri wrote:

> Hi,
>
> Running -current on amd64, I noticed that the ntpd daemon wasn't
> responding:
>
> $ ntpctl -s all
> ntpctl: connect: /var/run/ntpd.sock: Connection refused
>
> So I restarted it and tried again:
>
> ---snip---

Hello,

How old is the snapshot you are using?

I just made 2 commits to fix ntpd(8) closings yesterday, so if you get
one snapshot from today and on or get the newer ntpd sources you can
try to reproduce this again.

For more information you can look at the thread
"ntpd failing during runtime without indication why" in the [hidden email]
mailing list.

Reply | Threaded
Open this post in threaded view
|

Re: ntpd terminates after a few seconds of running

Andreas Kusalananda Kähäri-3
On Thu, Oct 20, 2016 at 02:44:56PM +0200, Rafael Zalamena wrote:

> On Thu, Oct 20, 2016 at 02:18:27PM +0200, Andreas Kusalananda K?h?ri wrote:
> > Hi,
> >
> > Running -current on amd64, I noticed that the ntpd daemon wasn't
> > responding:
> >
> > $ ntpctl -s all
> > ntpctl: connect: /var/run/ntpd.sock: Connection refused
> >
> > So I restarted it and tried again:
> >
> > ---snip---
>
> Hello,
>
> How old is the snapshot you are using?
>
> I just made 2 commits to fix ntpd(8) closings yesterday, so if you get
> one snapshot from today and on or get the newer ntpd sources you can
> try to reproduce this again.
>
> For more information you can look at the thread
> "ntpd failing during runtime without indication why" in the
[hidden email]
> mailing list.
>

I'm using sources from the 15th (last Saturday).  I will rebuild when
I get time to do so (probably during the weekend). Thanks for the
response!  I'll get back to you if this is still an issue later.

Andreas

--
Andreas Kusalananda Kähäri
Bioinformatics Developer
NBIS, Uppsala University
http://www.nbis.se/

[demime 1.01d removed an attachment of type application/pgp-signature which had a name of signature.asc]

Reply | Threaded
Open this post in threaded view
|

Re: ntpd terminates after a few seconds of running

Andreas Kusalananda Kähäri-3
On Thu, Oct 20, 2016 at 03:46:42PM +0200, Andreas Kusalananda Kähäri wrote:
> On Thu, Oct 20, 2016 at 02:44:56PM +0200, Rafael Zalamena wrote:
> > On Thu, Oct 20, 2016 at 02:18:27PM +0200, Andreas Kusalananda K?h?ri
wrote:

> > > Hi,
> > >
> > > Running -current on amd64, I noticed that the ntpd daemon wasn't
> > > responding:
> > >
> > > $ ntpctl -s all
> > > ntpctl: connect: /var/run/ntpd.sock: Connection refused
> > >
> > > So I restarted it and tried again:
> > >
> > > ---snip---
> >
> > Hello,
> >
> > How old is the snapshot you are using?
> >
> > I just made 2 commits to fix ntpd(8) closings yesterday, so if you get
> > one snapshot from today and on or get the newer ntpd sources you can
> > try to reproduce this again.
> >
> > For more information you can look at the thread
> > "ntpd failing during runtime without indication why" in the
> [hidden email]
> > mailing list.
> >
>
> I'm using sources from the 15th (last Saturday).  I will rebuild when
> I get time to do so (probably during the weekend). Thanks for the
> response!  I'll get back to you if this is still an issue later.
>

Just to say that this issue went away after a rebuild of my system with
newer sources.  Thanks!


Andreas


--
Andreas Kusalananda Kähäri
Bioinformatics Developer
NBIS, Uppsala University
http://www.nbis.se/

[demime 1.01d removed an attachment of type application/pgp-signature which had a name of signature.asc]