Quantcast

npm in lang/node is outdated

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

npm in lang/node is outdated

Leo Unglaub-2
Hey friends,
i noticed that npm (gets shiped with lang/node) is very outdated.
Currently version 3.10.10 is shipped, but 4.1.2 should be included.

I looked at the Makefile but I don't see a reason for node containing
this old version of npm. Is that on purpose? Or is this a bug?

Thanks and greetings
Leo

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: npm in lang/node is outdated

Aaron Bieber-3
On Thu, Feb 09, 2017 at 06:09:47PM +0100, Leo Unglaub wrote:
> Hey friends,
> i noticed that npm (gets shiped with lang/node) is very outdated.
> Currently version 3.10.10 is shipped, but 4.1.2 should be included.

It's not outdated. That's the version that ships with this version of
node. Upstream development keeps happening on npm, so there are new
versions.

https://github.com/nodejs/node/tree/f098f8295c407e5a5126b501ed5f1aa80bd86106/deps

^ That is the commit from the node v6.9.4 tag.

>
> I looked at the Makefile but I don't see a reason for node containing
> this old version of npm. Is that on purpose? Or is this a bug?

You can install it yourself, currently 4.3.0 is the latest version.

>
> Thanks and greetings
> Leo
>

--
PGP: 0x1F81112D62A9ADCE / 3586 3350 BFEA C101 DB1A  4AF0 1F81 112D 62A9 ADCE

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: npm in lang/node is outdated

Oriol Demaria-3
In stable we have 4.4.5 and it segfaults for me. Also I can't compile it from ports. Anyone else with this problem?

Regards,
--
Oriol Demaria
0x1FEF5D72
10 de febrero del 2017 15:38, "Aaron Bieber" <[hidden email]> escribió:

> On Thu, Feb 09, 2017 at 06:09:47PM +0100, Leo Unglaub wrote:
>
>> Hey friends,
>> i noticed that npm (gets shiped with lang/node) is very outdated.
>> Currently version 3.10.10 is shipped, but 4.1.2 should be included.
>
> It's not outdated. That's the version that ships with this version of
> node. Upstream development keeps happening on npm, so there are new
> versions.
>
> https://github.com/nodejs/node/tree/f098f8295c407e5a5126b501ed5f1aa80bd86106/deps
>
> ^ That is the commit from the node v6.9.4 tag.
>
>> I looked at the Makefile but I don't see a reason for node containing
>> this old version of npm. Is that on purpose? Or is this a bug?
>
> You can install it yourself, currently 4.3.0 is the latest version.
>
>> Thanks and greetings
>> Leo
>
> --
> PGP: 0x1F81112D62A9ADCE / 3586 3350 BFEA C101 DB1A 4AF0 1F81 112D 62A9 ADCE

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: npm in lang/node is outdated

Juan Francisco Cantero Hurtado
On Mon, Mar 20, 2017 at 05:18:24PM +0000, Oriol Demaria wrote:
> In stable we have 4.4.5 and it segfaults for me. Also I can't compile it from ports. Anyone else with this problem?

Did you mount the partitions with the option wxallowed?

>
> Regards,
> --
> Oriol Demaria
> 0x1FEF5D72
> 10 de febrero del 2017 15:38, "Aaron Bieber" <[hidden email]> escribió:
> > On Thu, Feb 09, 2017 at 06:09:47PM +0100, Leo Unglaub wrote:
> >
> >> Hey friends,
> >> i noticed that npm (gets shiped with lang/node) is very outdated.
> >> Currently version 3.10.10 is shipped, but 4.1.2 should be included.
> >
> > It's not outdated. That's the version that ships with this version of
> > node. Upstream development keeps happening on npm, so there are new
> > versions.
> >
> > https://github.com/nodejs/node/tree/f098f8295c407e5a5126b501ed5f1aa80bd86106/deps
> >
> > ^ That is the commit from the node v6.9.4 tag.
> >
> >> I looked at the Makefile but I don't see a reason for node containing
> >> this old version of npm. Is that on purpose? Or is this a bug?
> >
> > You can install it yourself, currently 4.3.0 is the latest version.
> >
> >> Thanks and greetings
> >> Leo
> >
> > --
> > PGP: 0x1F81112D62A9ADCE / 3586 3350 BFEA C101 DB1A 4AF0 1F81 112D 62A9 ADCE
>

--
Juan Francisco Cantero Hurtado http://juanfra.info

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: npm in lang/node is outdated

Oriol Demaria-3
Facepalm!

For some reason I thought to update this for 6.1 not 6.0 Stable. It's working now.

Regards,
--
Oriol Demaria
0x1FEF5D72
20 de marzo del 2017 18:21, "Juan Francisco Cantero Hurtado" <[hidden email]> escribió:

> On Mon, Mar 20, 2017 at 05:18:24PM +0000, Oriol Demaria wrote:
>
>> In stable we have 4.4.5 and it segfaults for me. Also I can't compile it from ports. Anyone else
>> with this problem?
>
> Did you mount the partitions with the option wxallowed?
>
>> Regards,
>> --
>> Oriol Demaria
>> 0x1FEF5D72
>> 10 de febrero del 2017 15:38, "Aaron Bieber" <[hidden email]> escribió:
>>> On Thu, Feb 09, 2017 at 06:09:47PM +0100, Leo Unglaub wrote:
>>>
>>>> Hey friends,
>>>> i noticed that npm (gets shiped with lang/node) is very outdated.
>>>> Currently version 3.10.10 is shipped, but 4.1.2 should be included.
>>>
>>> It's not outdated. That's the version that ships with this version of
>>> node. Upstream development keeps happening on npm, so there are new
>>> versions.
>>>
>>> https://github.com/nodejs/node/tree/f098f8295c407e5a5126b501ed5f1aa80bd86106/deps
>>>
>>> ^ That is the commit from the node v6.9.4 tag.
>>>
>>>> I looked at the Makefile but I don't see a reason for node containing
>>>> this old version of npm. Is that on purpose? Or is this a bug?
>>>
>>> You can install it yourself, currently 4.3.0 is the latest version.
>>>
>>>> Thanks and greetings
>>>> Leo
>>>
>>> --
>>> PGP: 0x1F81112D62A9ADCE / 3586 3350 BFEA C101 DB1A 4AF0 1F81 112D 62A9 ADCE
>
> --
> Juan Francisco Cantero Hurtado http://juanfra.info

Loading...