no network in bsd.rd when wifi card is present

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

no network in bsd.rd when wifi card is present

jordon-7
My main OpenBSD system is a Shuttle SH81R4 with a 4th Gen i5.  I run the latest snapshot on it and once or twice a week I will boot into bsd.rd and run update.  A week or two ago I put a mini-pcie wifi card in it (athn0) and after getting some help from this mailing list, I got this system running as an Access Point.  I have since noticed a strange issue.

Now, when I boot into bsd.rd, I have no network.  When i try to upgrade, I will see the DHCPDISCOVER, DHCPOFFER, etc go by and it is all right, but when get to the “lets upgrade the sets” part, i get the (Unable to get list from ftp.openbsd.org, but that is OK) message and any attempt to actually download the updated packages fails.

If I ctrl+c to a prompt, i can run ‘dhclient re0’ and it looks like it succeeds, but when I run ‘ifconfig’, re0 does not have an ip address.  I can’t even ping the ip address of my router.
If I actually remove the wifi adapter (as in, open the case and physically remove the mini-pcie card from its slot) and try it, it works fine (though entering a number for a different mirror doesn’t seem to work).

Removing the pcie card every time I want to install the latest build is very inconvenient.  Is there a workaround for this?

Jordon

Loading...