nexcloud 16.0.0 on OPENBSD_6_4 Re: CVS: cvs.openbsd.org: ports

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

nexcloud 16.0.0 on OPENBSD_6_4 Re: CVS: cvs.openbsd.org: ports

Matthieu Herrb-3
On Tue, Apr 30, 2019 at 01:54:06AM -0600, Gonzalo L. Rodriguez wrote:

> CVSROOT: /cvs
> Module name: ports
> Changes by: [hidden email] 2019/04/30 01:54:06
>
> Modified files:
> www/nextcloud  : Tag: OPENBSD_6_4 Makefile distinfo
> www/nextcloud/pkg: Tag: OPENBSD_6_4 PLIST
>
> Log message:
> Update for Nextcloud to 16.0.0:
>
> https://nextcloud.com/changelog/
>
> Fart cloud all the things!

Hmm, MODPHP_VERSION is 7.0 on 6.4. Thus this update fails to run with

This version of Nextcloud requires at least PHP 7.1
You are currently running 7.0.33. Please update your PHP version.

How do I fix that (other than upgrading to 6.5) ?
--
Matthieu Herrb

Reply | Threaded
Open this post in threaded view
|

Re: nexcloud 16.0.0 on OPENBSD_6_4 Re: CVS: cvs.openbsd.org: ports

Stuart Henderson
On 2019/05/18 19:12, Matthieu Herrb wrote:

> On Tue, Apr 30, 2019 at 01:54:06AM -0600, Gonzalo L. Rodriguez wrote:
> > CVSROOT: /cvs
> > Module name: ports
> > Changes by: [hidden email] 2019/04/30 01:54:06
> >
> > Modified files:
> > www/nextcloud  : Tag: OPENBSD_6_4 Makefile distinfo
> > www/nextcloud/pkg: Tag: OPENBSD_6_4 PLIST
> >
> > Log message:
> > Update for Nextcloud to 16.0.0:
> >
> > https://nextcloud.com/changelog/
> >
> > Fart cloud all the things!
>
> Hmm, MODPHP_VERSION is 7.0 on 6.4. Thus this update fails to run with
>
> This version of Nextcloud requires at least PHP 7.1
> You are currently running 7.0.33. Please update your PHP version.
>
> How do I fix that (other than upgrading to 6.5) ?
> --
> Matthieu Herrb
>

6.4 does have php 7.1.x (and 7.2.x), you could work around this by
pkg_add'ing them and do the usual changeover steps (add symlinks in
/etc/php-7.2 to ../php-7.2.sample, change php70_fpm to php72_fpm in
pkg_scripts) and ignore the 7.0 packages.

It's not ideal though.

Reply | Threaded
Open this post in threaded view
|

Re: nexcloud 16.0.0 on OPENBSD_6_4 Re: CVS: cvs.openbsd.org: ports

Gonzalo L. Rodriguez-2


> On 18. May 2019, at 21:44, Stuart Henderson <[hidden email]> wrote:
>
>> On 2019/05/18 19:12, Matthieu Herrb wrote:
>>> On Tue, Apr 30, 2019 at 01:54:06AM -0600, Gonzalo L. Rodriguez wrote:
>>> CVSROOT:    /cvs
>>> Module name:    ports
>>> Changes by:    [hidden email]    2019/04/30 01:54:06
>>>
>>> Modified files:
>>>    www/nextcloud  : Tag: OPENBSD_6_4 Makefile distinfo
>>>    www/nextcloud/pkg: Tag: OPENBSD_6_4 PLIST
>>>
>>> Log message:
>>> Update for Nextcloud to 16.0.0:
>>>
>>> https://nextcloud.com/changelog/
>>>
>>> Fart cloud all the things!
>>
>> Hmm, MODPHP_VERSION is 7.0 on 6.4. Thus this update fails to run with
>>
>> This version of Nextcloud requires at least PHP 7.1
>> You are currently running 7.0.33. Please update your PHP version.
>>
>> How do I fix that (other than upgrading to 6.5) ?
>> --
>> Matthieu Herrb
>>
>
> 6.4 does have php 7.1.x (and 7.2.x), you could work around this by
> pkg_add'ing them and do the usual changeover steps (add symlinks in
> /etc/php-7.2 to ../php-7.2.sample, change php70_fpm to php72_fpm in
> pkg_scripts) and ignore the 7.0 packages.
>
> It's not ideal though.

Yes, this is the best option without upgrade to 6.5

Reply | Threaded
Open this post in threaded view
|

Re: nexcloud 16.0.0 on OPENBSD_6_4 Re: CVS: cvs.openbsd.org: ports

Matthieu Herrb-3
On Sun, May 19, 2019 at 09:49:54AM +0200, Gonzalo L. Rodriguez wrote:

>
>
> > On 18. May 2019, at 21:44, Stuart Henderson <[hidden email]> wrote:
> >
> >> On 2019/05/18 19:12, Matthieu Herrb wrote:
> >>> On Tue, Apr 30, 2019 at 01:54:06AM -0600, Gonzalo L. Rodriguez wrote:
> >>> CVSROOT:    /cvs
> >>> Module name:    ports
> >>> Changes by:    [hidden email]    2019/04/30 01:54:06
> >>>
> >>> Modified files:
> >>>    www/nextcloud  : Tag: OPENBSD_6_4 Makefile distinfo
> >>>    www/nextcloud/pkg: Tag: OPENBSD_6_4 PLIST
> >>>
> >>> Log message:
> >>> Update for Nextcloud to 16.0.0:
> >>>
> >>> https://nextcloud.com/changelog/
> >>>
> >>> Fart cloud all the things!
> >>
> >> Hmm, MODPHP_VERSION is 7.0 on 6.4. Thus this update fails to run with
> >>
> >> This version of Nextcloud requires at least PHP 7.1
> >> You are currently running 7.0.33. Please update your PHP version.
> >>
> >> How do I fix that (other than upgrading to 6.5) ?
> >> --
> >> Matthieu Herrb
> >>
> >
> > 6.4 does have php 7.1.x (and 7.2.x), you could work around this by
> > pkg_add'ing them and do the usual changeover steps (add symlinks in
> > /etc/php-7.2 to ../php-7.2.sample, change php70_fpm to php72_fpm in
> > pkg_scripts) and ignore the 7.0 packages.
> >
> > It's not ideal though.
>
> Yes, this is the best option without upgrade to 6.5

Hi,

I managed to upgrade my nextcloud installation. Thanks.

--
Matthieu Herrb