[newish] kde-applications/neochat and its deps

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[newish] kde-applications/neochat and its deps

Aaron Bieber-2
Hi, this is "newish" because it doesn't work \o/

I am mostly asking for cluesticks - for some reason x11/libquotient is not
happy. Its test app 'quotest' segfaults (I can get a backtrace if I disable
encryption in it, but it isn't of much help..).

Here is the bt from running neochat:
Starting program: /usr/local/bin/neochat

Program received signal SIGSEGV, Segmentation fault.
0x000005b96ccfad23 in _GLOBAL__sub_I_encryptionevent.cpp ()
(gdb) bt
#0  0x000005b96ccfad23 in _GLOBAL__sub_I_encryptionevent.cpp ()
#1  0x000005b96cb87329 in __do_init ()
#2  0x000005b96cd1bd79 in __init ()
#3  0x00007f7ffffe0300 in ?? ()
#4  0x000005b96cb871f3 in ___start ()
#5  0x0000000000000000 in ?? ()
(gdb)

(this is the same as quotest basically)

I am not sure if the failure is because of my ports, or if the program its self
is wonky (why not both?! \o/).

Anyway - if someone more versed in QT/KDE could give it a gander, I would
greatly appreciate it!

Cheers,
Aaron

neochat-and-friends.tgz (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [newish] kde-applications/neochat and its deps

Rafael Sadowski
On Wed Feb 03, 2021 at 05:34:36PM -0700, Aaron Bieber wrote:

> Hi, this is "newish" because it doesn't work \o/
>
> I am mostly asking for cluesticks - for some reason x11/libquotient is not
> happy. Its test app 'quotest' segfaults (I can get a backtrace if I disable
> encryption in it, but it isn't of much help..).
>
> Here is the bt from running neochat:
> Starting program: /usr/local/bin/neochat
>
> Program received signal SIGSEGV, Segmentation fault.
> 0x000005b96ccfad23 in _GLOBAL__sub_I_encryptionevent.cpp ()
> (gdb) bt
> #0  0x000005b96ccfad23 in _GLOBAL__sub_I_encryptionevent.cpp ()
> #1  0x000005b96cb87329 in __do_init ()
> #2  0x000005b96cd1bd79 in __init ()
> #3  0x00007f7ffffe0300 in ?? ()
> #4  0x000005b96cb871f3 in ___start ()
> #5  0x0000000000000000 in ?? ()
> (gdb)
>
> (this is the same as quotest basically)
>
> I am not sure if the failure is because of my ports, or if the program its self
> is wonky (why not both?! \o/).
>
> Anyway - if someone more versed in QT/KDE could give it a gander, I would
> greatly appreciate it!
>
> Cheers,
> Aaron

I see the same error. Somehow this looks strange:

Program received signal SIGSEGV, Segmentation fault.
0x00000aec5ee8f973 in _GLOBAL__sub_I_encryptionevent.cpp () from /usr/ports/pobj/libQuotient-0.6.5/build-amd64/libQuotient.so.0.0
(gdb) bt
#0  0x00000aec5ee8f973 in _GLOBAL__sub_I_encryptionevent.cpp () from /usr/ports/pobj/libQuotient-0.6.5/build-amd64/libQuotient.so.0.0
#1  0x00000aec5eddba39 in _do_init () from /usr/ports/pobj/libQuotient-0.6.5/build-amd64/libQuotient.so.0.0
#2  0x00000aec5eec1dc9 in _init () from /usr/ports/pobj/libQuotient-0.6.5/build-amd64/libQuotient.so.0.0
#3  0x00000aec5eec1dc0 in ?? () from /usr/ports/pobj/libQuotient-0.6.5/build-amd64/libQuotient.so.0.0
#4  0x00000aebe785846d in _dl_call_init_recurse (object=0xaec37909000, initfirst=0) at /usr/src/libexec/ld.so/loader.c:805
#5  0x00000aebe78583be in _dl_call_init_recurse (object=0xaec3a144000, initfirst=0) at /usr/src/libexec/ld.so/loader.c:790
#6  0x00000aebe78527a5 in _dl_call_init (object=0xaec3a144000) at /usr/src/libexec/ld.so/loader.c:760
#7  _dl_boot (argv=<optimized out>, envp=<optimized out>, dyn_loff=<optimized out>, dl_data=0x7f7ffffdb730) at /usr/src/libexec/ld.so/loader.c:682
#8  0x00000aebe7852fc6 in _dl_start () at /usr/src/libexec/ld.so/amd64/ldasm.S:61
#9  0x0000000000000000 in ?? ()

You can fined my changes here: https://github.com/sizeofvoid/wip-ports/tree/neochat

I enabled shared libs build in all libraries:
https://github.com/sizeofvoid/wip-ports/commit/aff136bd6d5e0225b4d2ba1f0db34ab659d69fe7

Anyway, I have no idea.