new www/py-yarl [hass: #11]

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

new www/py-yarl [hass: #11]

Joerg Jung
Hi,

please find attached a new port for www/py-yarl.

   $ cat pkg/DESCR
   Yet another URL library.

This port is a dependency for the upcoming homeassistant port.

Please test and comment. OK to import?

Regards,
Joerg

py-yarl.tar.gz (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: new www/py-yarl [hass: #11]

Joerg Jung
On Wed, Jan 17, 2018 at 12:12:06AM +0100, Joerg Jung wrote:
> Hi,
>
> please find attached a new port for www/py-yarl.
>
>    $ cat pkg/DESCR
>    Yet another URL library.
>
> This port is a dependency for the upcoming homeassistant port.
 
Meanwhile yarl-1.0.0 was release. Newer version is attached.

> Please test and comment. OK to import?
>
> Regards,
> Joerg

py-yarl.tar.gz (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: new www/py-yarl [hass: #11]

Klemens Nanni
On Wed, Jan 17, 2018 at 08:34:28PM +0100, Joerg Jung wrote:

> On Wed, Jan 17, 2018 at 12:12:06AM +0100, Joerg Jung wrote:
> > Hi,
> >
> > please find attached a new port for www/py-yarl.
> >
> >    $ cat pkg/DESCR
> >    Yet another URL library.
> >
> > This port is a dependency for the upcoming homeassistant port.
>  
> Meanwhile yarl-1.0.0 was release. Newer version is attached.
>
> > Please test and comment. OK to import?
Had the same update in my queue :)

In addition I'd like to add minimal version requirements to its RDEPS,
see diff below ontop of your tarball.

I'm getting these test results on amd64:

        755 passed, 9 xfailed in 2.45 seconds

--- Makefile.orig Wed Jan 17 21:12:58 2018
+++ Makefile Wed Jan 17 21:10:40 2018
@@ -21,8 +21,8 @@
 MODPY_SETUPTOOLS = Yes
 MODPY_VERSION = ${MODPY_DEFAULT_VERSION_3}
 
-RUN_DEPENDS = net/py-idna${MODPY_FLAVOR} \
- www/py-multidict
+RUN_DEPENDS = net/py-idna${MODPY_FLAVOR}>=2.0 \
+ www/py-multidict>=4.0
 TEST_DEPENDS = ${RUN_DEPENDS} \
  devel/py-test-runner${MODPY_FLAVOR}
 

Reply | Threaded
Open this post in threaded view
|

Re: new www/py-yarl [hass: #11]

Joerg Jung
On Wed, Jan 17, 2018 at 09:14:57PM +0100, Klemens Nanni wrote:

> On Wed, Jan 17, 2018 at 08:34:28PM +0100, Joerg Jung wrote:
> > On Wed, Jan 17, 2018 at 12:12:06AM +0100, Joerg Jung wrote:
> > > Hi,
> > >
> > > please find attached a new port for www/py-yarl.
> > >
> > >    $ cat pkg/DESCR
> > >    Yet another URL library.
> > >
> > > This port is a dependency for the upcoming homeassistant port.
> >  
> > Meanwhile yarl-1.0.0 was release. Newer version is attached.
> >
> > > Please test and comment. OK to import?
>
> In addition I'd like to add minimal version requirements to its RDEPS,
> see diff below ontop of your tarball.
Thanks, added. New tarball attached.

py-yarl.tar.gz (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: new www/py-yarl [hass: #11]

Klemens Nanni
On Wed, Jan 17, 2018 at 09:57:03PM +0100, Joerg Jung wrote:

> On Wed, Jan 17, 2018 at 09:14:57PM +0100, Klemens Nanni wrote:
> > On Wed, Jan 17, 2018 at 08:34:28PM +0100, Joerg Jung wrote:
> > > On Wed, Jan 17, 2018 at 12:12:06AM +0100, Joerg Jung wrote:
> > > > Hi,
> > > >
> > > > please find attached a new port for www/py-yarl.
> > > >
> > > >    $ cat pkg/DESCR
> > > >    Yet another URL library.
> > > >
> > > > This port is a dependency for the upcoming homeassistant port.
> > >  
> > > Meanwhile yarl-1.0.0 was release. Newer version is attached.
> > >
> > > > Please test and comment. OK to import?
> >
> > In addition I'd like to add minimal version requirements to its RDEPS,
> > see diff below ontop of your tarball.
>
> Thanks, added. New tarball attached.
Looks good to me.

Reply | Threaded
Open this post in threaded view
|

Re: new www/py-yarl [hass: #11]

Klemens Nanni
In reply to this post by Joerg Jung
On Wed, Jan 17, 2018 at 09:57:03PM +0100, Joerg Jung wrote:

> On Wed, Jan 17, 2018 at 09:14:57PM +0100, Klemens Nanni wrote:
> > On Wed, Jan 17, 2018 at 08:34:28PM +0100, Joerg Jung wrote:
> > > On Wed, Jan 17, 2018 at 12:12:06AM +0100, Joerg Jung wrote:
> > > > Hi,
> > > >
> > > > please find attached a new port for www/py-yarl.
> > > >
> > > >    $ cat pkg/DESCR
> > > >    Yet another URL library.
> > > >
> > > > This port is a dependency for the upcoming homeassistant port.
> > >  
> > > Meanwhile yarl-1.0.0 was release. Newer version is attached.
> > >
> > > > Please test and comment. OK to import?
> >
> > In addition I'd like to add minimal version requirements to its RDEPS,
> > see diff below ontop of your tarball.
>
> Thanks, added. New tarball attached.
As discussed off-list, I'm helping Joerg with his hass collection.

Upstream's new release does work fine here but as it bumps minimal
dependency requirements this is best to be dealt with in a separate
update.

        1.1.0 (2018-01-21)
            Make pure Python quoter consistent with Cython version (#162)

OK to import jung's 1.0.0 tarball with his OK?