Quantcast

mpbios NForce4 SATA

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

mpbios NForce4 SATA

chris-228
Hi all,

I've been trying to get a SATA hard disk to run on an ASUS P5ND2-SLI motherboard with an Intel Pentium D 3.2 XE. Everything works fine if I use the normal amd64 bsd kernel however if I use the SMP kernel I get problems attaching the the SATA hard disk, eventually causing the kernel to hang. It just displays:

wd2(pciide1:1:0): timeout
type:ata
c_bcount: 512
c_skip: 0

I noticed in sys/arch/amd64/amd64/mpbios_intr_fixup.c there has been code introuced to try and fix this, which wasnt being run on my board. I forced it to fun the NForce4 fixup routine and thus it does now call nforce4_mpbios_fixup() although maybe not correctly? but this does not seem to have helped.

I have found someone with a very similar problem at http://www.sigmasoft.com/~openbsd/archives/html/openbsd-bugs/2005-11/msg00047.html . Unfortuantly I cant get a dmesg as the board has no serial connection, but I have got a standard single proc dmesg...

Does anyone have any further ideas?

Thanks
Chris


dmesg:
OpenBSD 3.9-current (GENERIC) #629: Wed Jul 12 18:36:57 MDT 2006
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC
real mem = 2147020800 (2096700K)
avail mem = 1847033856 (1803744K)
using 22937 buffers containing 214908928 bytes (209872K) of memory
mainbus0 (root)
bios0 at mainbus0: SMBIOS rev. 2.3 @ 0xf0000 (73 entries)
bios0: ASUSTeK Computer INC. P5ND2-SLI
cpu0 at mainbus0: (uniprocessor)
cpu0: Genuine Intel(R) CPU 3.20GHz, 3200.70 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,LONG
cpu0: 1MB 64b/line 8-way L2 cache
pci0 at mainbus0 bus 0: configuration mode 1
pchb0 at pci0 dev 0 function 0 vendor "NVIDIA", unknown product 0x0071 rev 0xa1
vendor "NVIDIA", unknown product 0x007f (class memory subclass RAM, rev 0xa1) at pci0 dev 0 function 1 not configured
vendor "NVIDIA", unknown product 0x0075 (class memory subclass RAM, rev 0xa1) at pci0 dev 0 function 2 not configured
vendor "NVIDIA", unknown product 0x006f (class memory subclass RAM, rev 0xa1) at pci0 dev 0 function 3 not configured
vendor "NVIDIA", unknown product 0x00b4 (class memory subclass RAM, rev 0xa1) at pci0 dev 0 function 4 not configured
vendor "NVIDIA", unknown product 0x0076 (class memory subclass RAM, rev 0xa1) at pci0 dev 1 function 0 not configured
vendor "NVIDIA", unknown product 0x0078 (class memory subclass RAM, rev 0xa1) at pci0 dev 1 function 1 not configured
vendor "NVIDIA", unknown product 0x0079 (class memory subclass RAM, rev 0xa1) at pci0 dev 1 function 2 not configured
vendor "NVIDIA", unknown product 0x007a (class memory subclass RAM, rev 0xa1) at pci0 dev 1 function 3 not configured
vendor "NVIDIA", unknown product 0x007b (class memory subclass RAM, rev 0xa1) at pci0 dev 1 function 4 not configured
vendor "NVIDIA", unknown product 0x007c (class memory subclass RAM, rev 0xa1) at pci0 dev 1 function 5 not configured
vendor "NVIDIA", unknown product 0x007d (class memory subclass RAM, rev 0xa1) at pci0 dev 1 function 6 not configured
ppb0 at pci0 dev 2 function 0 "NVIDIA MCP04 PCIE" rev 0xa2
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 vendor "NVIDIA", unknown product 0x00f9 rev 0xa2
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
vendor "NVIDIA", unknown product 0x003f (class memory subclass RAM, rev 0xa1) at pci0 dev 9 function 0 not configured
pcib0 at pci0 dev 10 function 0 vendor "NVIDIA", unknown product 0x0030 rev 0xa3
"NVIDIA MCP04 SMBus" rev 0xa2 at pci0 dev 10 function 1 not configured
ohci0 at pci0 dev 11 function 0 "NVIDIA MCP04 USB" rev 0xa1: irq 3, version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: NVIDIA OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 5 ports with 5 removable, self powered
ohci1 at pci0 dev 11 function 1 "NVIDIA MCP04 USB" rev 0xa1: irq 5, version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: NVIDIA OHCI root hub, rev 1.00/1.00, addr 1
uhub1: 5 ports with 5 removable, self powered
ehci0 at pci0 dev 11 function 2 "NVIDIA MCP04 USB" rev 0xa2: irq 11
usb2 at ehci0: USB revision 2.0
uhub2 at usb2
uhub2: NVIDIA EHCI root hub, rev 2.00/1.00, addr 1
uhub2: 10 ports with 10 removable, self powered
pciide0 at pci0 dev 15 function 0 "NVIDIA MCP04 IDE" rev 0xf2: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <Maxtor 6Y080L0>
wd0: 16-sector PIO, LBA, 76293MB, 156250000 sectors
wd1 at pciide0 channel 0 drive 1: <Maxtor 4D040H2>
wd1: 16-sector PIO, LBA, 39083MB, 80043264 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 6
wd1(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <SAMSUNG, CDRW/DVD SM-352F, T902> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
pciide1 at pci0 dev 16 function 0 "NVIDIA MCP04 SATA" rev 0xf2: DMA
pciide1: using irq 5 for native-PCI interrupt
wd2 at pciide1 channel 1 drive 0: <WDC WD2500KS-00MJB0>
wd2: 16-sector PIO, LBA48, 238475MB, 488397168 sectors
wd2(pciide1:1:0): using PIO mode 4, Ultra-DMA mode 5
pciide2 at pci0 dev 17 function 0 "NVIDIA MCP04 SATA" rev 0xf2: DMA
pciide2: using irq 11 for native-PCI interrupt
ppb1 at pci0 dev 18 function 0 "NVIDIA MCP04 PCI-PCI" rev 0xa2
pci2 at ppb1 bus 2
bktr0 at pci2 dev 8 function 0 "Brooktree BT878" rev 0x11: irq 5
bktr0: Hauppauge Model 44805 C135
bktr0: Hauppauge WinCast/TV, Philips PAL I tuner.
"Brooktree BT878 Audio" rev 0x11 at pci2 dev 8 function 1 not configured
em0 at pci2 dev 12 function 0 "Intel PRO/1000MT (82540EM)" rev 0x02: irq 3, address 00:17:31:af:5d:2e
auich0 at pci0 dev 19 function 0 "NVIDIA MCP04 AC97" rev 0xa1: irq 3, MCP04 AC97
ac97: codec id 0x414c4790 (Avance Logic ALC850 rev 0)
audio0 at auich0
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
mpu0 at isa0 port 0x330/2: generic MPU-401 compatible
midi0 at mpu0: <MPU-401 MIDI UART>
pcppi0 at isa0 port 0x61
midi1 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
it0 at isa0 port 0x290/8: IT87
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
dkcsum: wd0 matches BIOS drive 0x80
wd1: no disk label
dkcsum: wd1 matches BIOS drive 0x81
wd2: no disk label
dkcsum: wd2 matches BIOS drive 0x82
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

Loading...