mod_python

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

mod_python

beavis-2
is mod_python on 3.9 possible? i would like to give it a try.. i tried
building it from source but it won't work maybe someone can give me
some hints on this.

thanks

Reply | Threaded
Open this post in threaded view
|

Re: mod_python

Bernd Ahlers
edgar mortiz [Tue, Jun 13, 2006 at 11:23:32AM -0600] wrote:
>is mod_python on 3.9 possible? i would like to give it a try.. i tried
>building it from source but it won't work maybe someone can give me
>some hints on this.
>
I tried it some days ago. But since python is build with threads,
mod_python needs an apache with threads support... (Which we don't
have.)

Bernd

Reply | Threaded
Open this post in threaded view
|

Re: mod_python

Will Maier
In reply to this post by beavis-2
On Tue, Jun 13, 2006 at 11:23:32AM -0600, edgar mortiz wrote:
> is mod_python on 3.9 possible? i would like to give it a try.. i tried
> building it from source but it won't work maybe someone can give me
> some hints on this.

I wouldn't expect it to (at least out of the box): mod_python
requires Apache 2.x and OpenBSD ships a hacked Apache 1.3.x. You
should be able to build mod_python against a hand-compiled Apache
2.x, though.

--

o--------------------------{ Will Maier }--------------------------o
| jabber:..[hidden email] | [hidden email] |
| freenode:..............lt_kije | freenode:........#madlug,#wilug |
*------------------[ BSD Unix: Live Free or Die ]------------------*

Reply | Threaded
Open this post in threaded view
|

Re: mod_python

Marc Balmer-2
* Will Maier wrote:
> On Tue, Jun 13, 2006 at 11:23:32AM -0600, edgar mortiz wrote:
> > is mod_python on 3.9 possible? i would like to give it a try.. i tried
> > building it from source but it won't work maybe someone can give me
> > some hints on this.
>
> I wouldn't expect it to (at least out of the box): mod_python
> requires Apache 2.x and OpenBSD ships a hacked Apache 1.3.x. You

hacked == improved

Reply | Threaded
Open this post in threaded view
|

Re: mod_python

Adam-29
In reply to this post by Will Maier
On Tue, 13 Jun 2006 12:33:44 -0500 Will Maier <[hidden email]> wrote:

> On Tue, Jun 13, 2006 at 11:23:32AM -0600, edgar mortiz wrote:
> > is mod_python on 3.9 possible? i would like to give it a try.. i tried
> > building it from source but it won't work maybe someone can give me
> > some hints on this.
>
> I wouldn't expect it to (at least out of the box): mod_python
> requires Apache 2.x and OpenBSD ships a hacked Apache 1.3.x. You
> should be able to build mod_python against a hand-compiled Apache
> 2.x, though.

Last I heard there was a mod_python version for 1.3.x and one for 2.x.
I had the one for 1.3.x working, you just need to set LD_PRELOAD to
load libpthread when starting apache, since its not compiled with
threading.

Adam

Reply | Threaded
Open this post in threaded view
|

Re: mod_python

Will Maier
In reply to this post by Marc Balmer-2
On Tue, Jun 13, 2006 at 07:45:00PM +0200, Marc Balmer wrote:
> * Will Maier wrote:
> > I wouldn't expect it to (at least out of the box): mod_python
> > requires Apache 2.x and OpenBSD ships a hacked Apache 1.3.x. You
>
> hacked == improved

Agreed -- it's what I run.

--

o--------------------------{ Will Maier }--------------------------o
| jabber:..[hidden email] | [hidden email] |
| freenode:..............lt_kije | freenode:........#madlug,#wilug |
*------------------[ BSD Unix: Live Free or Die ]------------------*

Reply | Threaded
Open this post in threaded view
|

Re: mod_python

Joachim Schipper
In reply to this post by beavis-2
On Tue, Jun 13, 2006 at 11:23:32AM -0600, edgar mortiz wrote:
> is mod_python on 3.9 possible? i would like to give it a try.. i tried
> building it from source but it won't work maybe someone can give me
> some hints on this.

Not a way to get this working, but have you looked into FastCGI? It
should be comparable in speed, slightly more complex, and quite a bit
more secure if used properly.

                Joachim

Reply | Threaded
Open this post in threaded view
|

Re: mod_python

Tamer Fahmy-2
In reply to this post by Adam-29
On 6/13/06, Adam <[hidden email]> wrote:
> Last I heard there was a mod_python version for 1.3.x and one for 2.x.
> I had the one for 1.3.x working, you just need to set LD_PRELOAD to
> load libpthread when starting apache, since its not compiled with
> threading.

hmm, interesting! alternatively you can build and install your own
python version with thread support disabled and make mod_python for
1.3.x apache to link against this python lib.

cheers,
  tamer.

--
  hardware, n: The parts of a computer system that can be kicked.