minor too small - pkg_add

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

minor too small - pkg_add

Patrick Marchand
Hello,
I updated to the latest snapshot yesterday and when I run
pkg_add -Dsnap -u a bunch of pkg will not upgrade because it cant find
ssl.44.9

It does find 44.8 and 45 but not that specific version, last week I had
a similar issue with libm. Now I can get around the error by building
the packages in ports, but I was wondering if there was an easy fix.

Thanks,
Patrick

Reply | Threaded
Open this post in threaded view
|

Re: minor too small - pkg_add

Solene Rapenne
Le 2018-03-19 16:18, Patrick Marchand a écrit :

> Hello,
> I updated to the latest snapshot yesterday and when I run
> pkg_add -Dsnap -u a bunch of pkg will not upgrade because it cant find
> ssl.44.9
>
> It does find 44.8 and 45 but not that specific version, last week I had
> a similar issue with libm. Now I can get around the error by building
> the packages in ports, but I was wondering if there was an easy fix.
>
> Thanks,
> Patrick

Hello,

It seems you have to update your snapshot because it's too old. It was
shipped with the lib version 44.8 and the current is now 44.9 from the
output. That mean your snapshot is too old and the packages have been
built
against a more recent snapshot.

Regards

Reply | Threaded
Open this post in threaded view
|

Re: minor too small - pkg_add

Patrick Marchand
> It seems you have to update your snapshot because it's too old. It was
> shipped with the lib version 44.8 and the current is now 44.9 from the
> output. That mean your snapshot is too old and the packages have been built
> against a more recent snapshot.
>
> Regards
Hhmm I guess it's possible that the snapshot was updated at the same
time I was installing the last snapshot. I'll try updating again and
will report back.

Reply | Threaded
Open this post in threaded view
|

Re: minor too small - pkg_add

Christian Weisgerber
In reply to this post by Patrick Marchand
Patrick Marchand:

> I updated to the latest snapshot yesterday and when I run
> pkg_add -Dsnap -u a bunch of pkg will not upgrade because it cant find
> ssl.44.9
>
> It does find 44.8 and 45 but not that specific version, last week I had

You updated from a base snapshot that had libssl.so.44.8 to one that
has 45.0, but skipped the intervening 44.9 one.  Unfortunately, the
package snapshot had been built against 44.9.

> a similar issue with libm. Now I can get around the error by building
> the packages in ports, but I was wondering if there was an easy fix.

Wait a few hours until the next packages, built against 45.0, hit
the mirrors.

--
Christian "naddy" Weisgerber                          [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: minor too small - pkg_add

Patrick Marchand
> You updated from a base snapshot that had libssl.so.44.8 to one that
> has 45.0, but skipped the intervening 44.9 one.  Unfortunately, the
> package snapshot had been built against 44.9.
>
> > a similar issue with libm. Now I can get around the error by building
> > the packages in ports, but I was wondering if there was an easy fix.
>
> Wait a few hours until the next packages, built against 45.0, hit
> the mirrors.
>

Oh that makes a lot more sense, I'll check it out when I get back from
work.
Thanks

Reply | Threaded
Open this post in threaded view
|

Re: minor too small - pkg_add

Patrick Marchand
> > Wait a few hours until the next packages, built against 45.0, hit
> > the mirrors.
Yep retrying today all the packages installed correctly!