libGL error: failed to open drm device: Permission denied

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

libGL error: failed to open drm device: Permission denied

Gabriel Guzman-2
Hello misc@,

I noticed the following error while running chrome from the shell this
evening:

libGL error: failed to open drm device: Permission denied
libGL error: failed to load driver: i965

Which I think means that I'm not getting accelerated X.

A search of misc archives led me to this:
https://marc.info/?l=openbsd-misc&m=146159057503035&w=2 which in turn
led to: https://marc.info/?l=openbsd-misc&m=145125527304834&w=2 

Based on the information in those threads, I checked to see what TTY I
was logged in on:

gabe@xps:~$ env
_=/usr/bin/env
LOGNAME=gabe
WINDOWPATH=ttyC4
WINDOWID=20971533
XTERM_SHELL=/bin/ksh
HOME=/home/gabe
LC_CTYPE=en_US.UTF-8
XTERM_VERSION=XTerm/OpenBSD(330)
DISPLAY=:0
SSH_AGENT_PID=92062
GOPATH=/home/gabe
PATH=/home/gabe/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin:/usr/games
SSH_AUTH_SOCK=/tmp/ssh-xfkLowrabhm9/agent.77539
PS1=\[\u@\]\[\h\]:\[\w\]\$
TERM=screen-256color
SHELL=/bin/ksh
USER=gabe
XTERM_LOCALE=en_US.UTF-8

Seemingly WINDOWPATH=ttyC4 (but I don't really know the right way to
check this) - so I added an entry to my /etc/fbtab:

/dev/ttyC4      0600 /dev/console:/dev/wskbd:/dev/wskbd0:/dev/wsmouse:/dev/wsmouse0:/dev/ttyCcfg:/dev/drm0

duplicating what I saw for ttyC0.

I rebotted and confirmed that I was indeed now the owner of /dev/drm0:

gabe@xps:~$ ls -l /dev/drm*
crw-------  1 gabe  wheel   87,   0 Aug 25 21:18 /dev/drm0
crw-------  1 root  wheel   87,   1 Aug 25 21:18 /dev/drm1
crw-------  1 root  wheel   87,   2 Aug 25 21:18 /dev/drm2
crw-------  1 root  wheel   87,   3 Aug 25 21:18 /dev/drm3

Then I ran glxgears, and got the permission denied message again:

gabe@xps:~$ glxgears  
libGL error: failed to open drm device: Permission denied
libGL error: failed to load driver: i965

And, sure enough when I rechecked /dev/drm:

gabe@xps:~$ ls -l /dev/drm*
crw-------  1 root  wheel   87,   0 Aug 25 21:18 /dev/drm0
crw-------  1 root  wheel   87,   1 Aug 25 21:18 /dev/drm1
crw-------  1 root  wheel   87,   2 Aug 25 21:18 /dev/drm2
crw-------  1 root  wheel   87,   3 Aug 25 21:18 /dev/drm3

I'm no longer the owner.  I'm not sure when this started, but
I don't have this issue on my 6.1 box, just on the one running current.

Sometimes, forcing the permissions on /dev/drm0 does work:

gabe@xps:~$ doas chown gabe /dev/drm0
doas ([hidden email]) password:
gabe@xps:~$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.

But then, as soon as I exit glxgears, /dev/drm0 goes right back to being
owned by root, and the error message comes back.  

Xorg log, and dmesg below... there are some drm0 errors in the dmesg
that maybe are related?  If anyone has any ideas, I'm open to trying
them out.  If not, I'l probably do a clean install on this machine as it
has been awhile since the last one.  

Also, not sure if it's relevant, but I'm a member of the `staff` login
class on this machine

Thanks,
gabe.

gabe@xps:~$ cat /var/log/Xorg.0.log
[    20.707] (WW) checkDevMem: failed to open /dev/xf86 and /dev/mem
        (Operation not permitted)
        Check that you have set 'machdep.allowaperture=1'
        in /etc/sysctl.conf and reboot your machine
        refer to xf86(4) for details
[    20.707] linear framebuffer access unavailable
[    20.716] (--) Using wscons driver on /dev/ttyC4
[    20.730]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[    20.730] X Protocol Version 11, Revision 0
[    20.730] Build Operating System: OpenBSD 6.2 amd64
[    20.730] Current Operating System: OpenBSD xps.my.domain 6.2 GENERIC.MP#40 amd64
[    20.730] Build Date: 25 August 2017  11:23:34AM
[    20.730]  
[    20.730] Current version of pixman: 0.34.0
[    20.730] Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    20.730] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    20.731] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 25 22:22:37 2017
[    20.732] (==) Using system config directory "/usr/X11R6/share/X11/xorg.conf.d"
[    20.733] (==) No Layout section.  Using the first Screen section.
[    20.733] (==) No screen section available. Using defaults.
[    20.733] (**) |-->Screen "Default Screen Section" (0)
[    20.733] (**) |   |-->Monitor "<default monitor>"
[    20.734] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    20.734] (==) Disabling SIGIO handlers for input devices
[    20.734] (==) Automatically adding devices
[    20.734] (==) Automatically enabling devices
[    20.734] (==) Not automatically adding GPU devices
[    20.734] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    20.740] (==) FontPath set to:
        /usr/X11R6/lib/X11/fonts/misc/,
        /usr/X11R6/lib/X11/fonts/TTF/,
        /usr/X11R6/lib/X11/fonts/OTF/,
        /usr/X11R6/lib/X11/fonts/Type1/,
        /usr/X11R6/lib/X11/fonts/100dpi/,
        /usr/X11R6/lib/X11/fonts/75dpi/
[    20.740] (==) ModulePath set to "/usr/X11R6/lib/modules"
[    20.740] (II) The server relies on wscons to provide the list of input devices.
        If no devices become available, reconfigure wscons or disable AutoAddDevices.
[    20.740] (II) Loader magic: 0x1a276d439000
[    20.740] (II) Module ABI versions:
[    20.740] X.Org ANSI C Emulation: 0.4
[    20.740] X.Org Video Driver: 20.0
[    20.740] X.Org XInput driver : 22.1
[    20.740] X.Org Server Extension : 9.0
[    20.741] (--) PCI:*(0:0:2:0) 8086:0a16:1028:060a rev 11, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x00003000/64
[    20.741] (II) LoadModule: "glx"
[    20.743] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
[    20.754] (II) Module glx: vendor="X.Org Foundation"
[    20.754] compiled for 1.18.4, module version = 1.0.0
[    20.754] ABI class: X.Org Server Extension, version 9.0
[    20.754] (==) AIGLX enabled
[    20.754] (==) Matched modesetting as autoconfigured driver 0
[    20.754] (==) Assigned the driver to the xf86ConfigLayout
[    20.754] (II) LoadModule: "modesetting"
[    20.755] (II) Loading /usr/X11R6/lib/modules/drivers/modesetting_drv.so
[    20.756] (II) Module modesetting: vendor="X.Org Foundation"
[    20.756] compiled for 1.18.4, module version = 1.18.4
[    20.756] Module class: X.Org Video Driver
[    20.756] ABI class: X.Org Video Driver, version 20.0
[    20.756] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    20.756] (**) modeset(0): claimed PCI slot 0@0:2:0
[    20.756] (II) modeset(0): using default device
[    20.757] (II) modeset(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    20.757] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    20.758] (==) modeset(0): RGB weight 888
[    20.758] (==) modeset(0): Default visual is TrueColor
[    20.758] (II) Loading sub module "glamoregl"
[    20.758] (II) LoadModule: "glamoregl"
[    20.759] (II) Loading /usr/X11R6/lib/modules/libglamoregl.so
[    20.774] (II) Module glamoregl: vendor="X.Org Foundation"
[    20.774] compiled for 1.18.4, module version = 1.0.0
[    20.774] ABI class: X.Org ANSI C Emulation, version 0.4
[    20.774] (II) glamor: OpenGL accelerated X.org driver based.
[    20.815] (II) glamor: EGL version 1.4 (DRI2):
[    20.829] (II) modeset(0): glamor initialized
[    20.830] (II) modeset(0): Output eDP-1 has no monitor section
[    20.830] (II) modeset(0): Output DP-1 has no monitor section
[    20.831] (II) modeset(0): Output HDMI-1 has no monitor section
[    20.832] (II) modeset(0): EDID for output eDP-1
[    20.832] (II) modeset(0): Manufacturer: CMN  Model: 1345  Serial#: 0
[    20.832] (II) modeset(0): Year: 2013  Week: 21
[    20.832] (II) modeset(0): EDID Version: 1.4
[    20.832] (II) modeset(0): Digital Display Input
[    20.832] (II) modeset(0): 8 bits per channel
[    20.832] (II) modeset(0): Digital interface is DisplayPort
[    20.832] (II) modeset(0): Max Image Size [cm]: horiz.: 29  vert.: 17
[    20.832] (II) modeset(0): Gamma: 2.20
[    20.832] (II) modeset(0): No DPMS capabilities specified
[    20.832] (II) modeset(0): Supported color encodings: RGB 4:4:4
[    20.832] (II) modeset(0): First detailed timing is preferred mode
[    20.832] (II) modeset(0): Preferred mode is native pixel format and refresh rate
[    20.832] (II) modeset(0): redX: 0.650 redY: 0.338   greenX: 0.329 greenY: 0.608
[    20.832] (II) modeset(0): blueX: 0.148 blueY: 0.047   whiteX: 0.313 whiteY: 0.329
[    20.832] (II) modeset(0): Manufacturer's mask: 0
[    20.832] (II) modeset(0): Supported detailed timing:
[    20.832] (II) modeset(0): clock: 138.8 MHz   Image Size:  293 x 165 mm
[    20.832] (II) modeset(0): h_active: 1920  h_sync: 1966  h_sync_end 1996 h_blank_end 2080 h_border: 0
[    20.832] (II) modeset(0): v_active: 1080  v_sync: 1082  v_sync_end 1086 v_blanking: 1112 v_border: 0
[    20.832] (II) modeset(0): Supported detailed timing:
[    20.832] (II) modeset(0): clock: 111.0 MHz   Image Size:  293 x 165 mm
[    20.832] (II) modeset(0): h_active: 1920  h_sync: 1966  h_sync_end 1996 h_blank_end 2080 h_border: 0
[    20.832] (II) modeset(0): v_active: 1080  v_sync: 1082  v_sync_end 1086 v_blanking: 1112 v_border: 0
[    20.832] (II) modeset(0):  DFTH4133HSE
[    20.832] (II) modeset(0): Unknown vendor-specific block 0
[    20.832] (II) modeset(0): EDID (in hex):
[    20.832] (II) modeset(0): 00ffffffffffff000dae451300000000
[    20.832] (II) modeset(0): 15170104a51d117802a705a656549b26
[    20.832] (II) modeset(0): 0c505400000001010101010101010101
[    20.832] (II) modeset(0): 010101010101363680a0703820402e1e
[    20.832] (II) modeset(0): 240025a51000001a5e2b80a070382040
[    20.833] (II) modeset(0): 2e1e240025a51000001a000000fe0044
[    20.833] (II) modeset(0): 46544834813133334853450a00000000
[    20.833] (II) modeset(0): 000a4131a3001000000a010a2020000d
[    20.833] (II) modeset(0): Printing probed modes for output eDP-1
[    20.833] (II) modeset(0): Modeline "1920x1080"x60.0  138.78  1920 1966 1996 2080  1080 1082 1086 1112 +hsync -vsync (66.7 kHz eP)
[    20.833] (II) modeset(0): Modeline "1920x1080"x48.0  111.02  1920 1966 1996 2080  1080 1082 1086 1112 +hsync -vsync (53.4 kHz e)
[    20.833] (II) modeset(0): Modeline "1400x1050"x60.0  122.00  1400 1488 1640 1880  1050 1052 1064 1082 +hsync +vsync (64.9 kHz d)
[    20.833] (II) modeset(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz d)
[    20.833] (II) modeset(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz d)
[    20.833] (II) modeset(0): Modeline "1024x768"x120.1  133.47  1024 1100 1212 1400  768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[    20.833] (II) modeset(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[    20.833] (II) modeset(0): Modeline "960x720"x120.0  117.00  960 1024 1128 1300  720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[    20.833] (II) modeset(0): Modeline "928x696"x120.1  109.15  928 976 1088 1264  696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[    20.833] (II) modeset(0): Modeline "896x672"x120.0  102.40  896 960 1060 1224  672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[    20.833] (II) modeset(0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[    20.833] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[    20.833] (II) modeset(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[    20.833] (II) modeset(0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[    20.833] (II) modeset(0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[    20.833] (II) modeset(0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[    20.833] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[    20.833] (II) modeset(0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[    20.833] (II) modeset(0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[    20.833] (II) modeset(0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[    20.833] (II) modeset(0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[    20.833] (II) modeset(0): EDID for output DP-1
[    20.834] (II) modeset(0): EDID for output HDMI-1
[    20.834] (II) modeset(0): Output eDP-1 connected
[    20.834] (II) modeset(0): Output DP-1 disconnected
[    20.834] (II) modeset(0): Output HDMI-1 disconnected
[    20.834] (II) modeset(0): Using exact sizes for initial modes
[    20.834] (II) modeset(0): Output eDP-1 using initial mode 1920x1080 +0+0
[    20.834] (II) modeset(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[    20.834] (==) modeset(0): DPI set to (96, 96)
[    20.834] (II) Loading sub module "fb"
[    20.834] (II) LoadModule: "fb"
[    20.836] (II) Loading /usr/X11R6/lib/modules/libfb.so
[    20.837] (II) Module fb: vendor="X.Org Foundation"
[    20.837] compiled for 1.18.4, module version = 1.0.0
[    20.837] ABI class: X.Org ANSI C Emulation, version 0.4
[    20.837] (==) Depth 24 pixmap format is 32 bpp
[    21.093] (==) modeset(0): Backing store enabled
[    21.093] (==) modeset(0): Silken mouse disabled
[    21.093] (II) modeset(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    21.096] (==) modeset(0): DPMS enabled
[    21.096] (WW) modeset(0): DRI2: glamor lacks support for pixmap import/export
[    21.097] (II) modeset(0): [DRI2] Setup complete
[    21.097] (II) modeset(0): [DRI2]   DRI driver: i965
[    21.097] (II) modeset(0): [DRI2]   VDPAU driver: i965
[    21.102] (--) RandR disabled
[    21.136] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    21.136] (II) AIGLX: enabled GLX_ARB_create_context
[    21.136] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    21.136] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[    21.136] (II) AIGLX: enabled GLX_INTEL_swap_event
[    21.136] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    21.136] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    21.136] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    21.136] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[    21.136] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    21.136] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[    21.136] (II) AIGLX: Loaded and initialized i965
[    21.136] (II) GLX: Initialized DRI2 GL provider for screen 0
[    21.141] (II) modeset(0): Damage tracking initialized
[    21.141] (II) modeset(0): Setting screen physical size to 508 x 285
[    21.316] (II) config/wscons: checking input device /dev/wskbd
[    21.316] (II) wskbd: using layout us
[    21.317] (II) LoadModule: "kbd"
[    21.318] (II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so
[    21.318] (II) Module kbd: vendor="X.Org Foundation"
[    21.318] compiled for 1.18.4, module version = 1.9.0
[    21.318] Module class: X.Org XInput Driver
[    21.318] ABI class: X.Org XInput driver, version 22.1
[    21.318] (II) Using input driver 'kbd' for '/dev/wskbd'
[    21.318] (**) /dev/wskbd: always reports core events
[    21.318] (**) /dev/wskbd: always reports core events
[    21.318] (**) Option "Protocol" "standard"
[    21.318] (**) Option "XkbRules" "base"
[    21.318] (**) Option "XkbModel" "pc105"
[    21.318] (**) Option "XkbLayout" "us"
[    21.318] (II) XINPUT: Adding extended input device "/dev/wskbd" (type: KEYBOARD, id 6)
[    24.322] (II) config/wscons: checking input device /dev/wsmouse2
[    24.322] (II) LoadModule: "ws"
[    24.323] (II) Loading /usr/X11R6/lib/modules/input/ws_drv.so
[    24.328] (II) Module ws: vendor="X.Org Foundation"
[    24.328] compiled for 1.18.4, module version = 1.3.0
[    24.328] Module class: X.Org XInput Driver
[    24.328] ABI class: X.Org XInput driver, version 22.1
[    24.328] (II) Using input driver 'ws' for '/dev/wsmouse2'
[    24.328] (**) /dev/wsmouse2: always reports core events
[    24.328] (II) ws: /dev/wsmouse2: debuglevel 0
[    24.328] (**) Option "Device" "/dev/wsmouse2"
[    24.328] (**) ws: /dev/wsmouse2: ZAxisMapping: buttons 4 and 5
[    24.328] (**) ws: /dev/wsmouse2: WAxisMapping: buttons 6 and 7
[    24.328] (**) ws: /dev/wsmouse2: associated screen: 0
[    24.329] (**) ws: /dev/wsmouse2: device will work in raw mode
[    24.329] (II) ws: /dev/wsmouse2: minimum x position: 0
[    24.329] (II) ws: /dev/wsmouse2: maximum x position: 2972
[    24.329] (II) ws: /dev/wsmouse2: minimum y position: 0
[    24.329] (II) ws: /dev/wsmouse2: maximum y position: 1680
[    24.329] (==) ws: /dev/wsmouse2: Buttons: 7
[    24.329] (**) ws: /dev/wsmouse2: YAxisMapping: buttons 4 and 5
[    24.329] (II) XINPUT: Adding extended input device "/dev/wsmouse2" (type: TOUCHSCREEN, id 7)
[    24.330] (**) /dev/wsmouse2: (accel) keeping acceleration scheme 1
[    24.330] (**) /dev/wsmouse2: (accel) acceleration profile 0
[    24.330] (**) /dev/wsmouse2: (accel) acceleration factor: 2.000
[    24.330] (**) /dev/wsmouse2: (accel) acceleration threshold: 4
[    24.331] (II) config/wscons: checking input device /dev/wsmouse
[    24.331] (II) Using input driver 'ws' for '/dev/wsmouse'
[    24.331] (**) /dev/wsmouse: always reports core events
[    24.331] (II) ws: /dev/wsmouse: debuglevel 0
[    24.331] (**) Option "Device" "/dev/wsmouse"
[    24.331] (**) ws: /dev/wsmouse: ZAxisMapping: buttons 4 and 5
[    24.331] (**) ws: /dev/wsmouse: WAxisMapping: buttons 6 and 7
[    24.331] (**) ws: /dev/wsmouse: associated screen: 0
[    26.330] (II) ws: /dev/wsmouse: minimum x position: 0
[    26.330] (II) ws: /dev/wsmouse: maximum x position: 1919
[    26.330] (II) ws: /dev/wsmouse: minimum y position: 0
[    26.330] (II) ws: /dev/wsmouse: maximum y position: 1079
[    26.330] (==) ws: /dev/wsmouse: Buttons: 7
[    27.331] (**) ws: /dev/wsmouse: YAxisMapping: buttons 4 and 5
[    27.331] (II) XINPUT: Adding extended input device "/dev/wsmouse" (type: MOUSE, id 8)
[    29.331] (**) /dev/wsmouse: (accel) keeping acceleration scheme 1
[    29.331] (**) /dev/wsmouse: (accel) acceleration profile 0
[    29.331] (**) /dev/wsmouse: (accel) acceleration factor: 2.000
[    29.331] (**) /dev/wsmouse: (accel) acceleration threshold: 4
[    36.401] (II) modeset(0): EDID vendor "CMN", prod id 4933
[    36.401] (II) modeset(0): Printing DDC gathered Modelines:
[    36.401] (II) modeset(0): Modeline "1920x1080"x0.0  138.78  1920 1966 1996 2080  1080 1082 1086 1112 +hsync -vsync (66.7 kHz eP)
[    36.401] (II) modeset(0): Modeline "1920x1080"x0.0  111.02  1920 1966 1996 2080  1080 1082 1086 1112 +hsync -vsync (53.4 kHz e)

gabe@xps:~$ dmesg
OpenBSD 6.2-beta (GENERIC.MP) #40: Fri Aug 25 11:07:23 MDT 2017
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 8474284032 (8081MB)
avail mem = 8210436096 (7830MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xe0fc0 (69 entries)
bios0: vendor Dell Inc. version "A06" date 11/07/2014
bios0: Dell Inc. XPS13 9333
acpi0 at bios0: rev 2
acpi0: sleep states S0 S1 S3 S4 S5
acpi0: tables DSDT FACP ASF! HPET LPIT APIC MCFG SSDT SSDT SSDT SSDT SSDT UEFI POAT BATB FPDT SLIC UEFI SSDT BGRT CSRT
acpi0: wakeup devices P0P1(S4) GLAN(S4) EHC1(S4) EHC2(S4) XHC_(S4) HDEF(S4) PXSX(S4) RP01(S4) PXSX(S4) PXSX(S4) RP03(S4) PXSX(S4) PXSX(S4) PXSX(S4) PXSX(S4) PXSX(S4) [...]
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 2394.79 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: TSC frequency 2394791940 Hz
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 2394.45 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 2 (application processor)
cpu2: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 2394.45 MHz
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 0, core 1, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 2394.45 MHz
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (P0P1)
acpiprt2 at acpi0: bus 1 (RP01)
acpiprt3 at acpi0: bus 2 (RP03)
acpiprt4 at acpi0: bus -1 (PEG0)
acpiprt5 at acpi0: bus -1 (PEG1)
acpiprt6 at acpi0: bus -1 (PEG2)
acpiec0 at acpi0
acpicpu0 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpitz0 at acpi0: critical temperature is 105 degC
acpitz1 at acpi0: critical temperature is 105 degC
"PNP0C14" at acpi0 not configured
"INT3F0D" at acpi0 not configured
acpials0 at acpi0: ALSD
"MSFT0001" at acpi0 not configured
"SYN0608" at acpi0 not configured
dwiic0 at acpi0: I2C1 addr 0xfe105000/0x1000 irq 7
iic0 at dwiic0
ihidev0 at iic0 addr 0x2c irq 39dwiic0: timed out reading remaining 29
, failed fetching initial HID descriptor
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: LID0
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "Dell" serial 1727 type LION oem "SIMPLO"
"DELLABCE" at acpi0 not configured
"INT340E" at acpi0 not configured
"INT33A0" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD1F
cpu0: Enhanced SpeedStep 2394 MHz: speeds: 2401, 2400, 2300, 2200, 2000, 1900, 1700, 1600, 1500, 1400, 1300, 1200, 1100, 900, 800, 768 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x0b
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x0b
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 1920x1080, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
azalia0 at pci0 dev 3 function 0 "Intel Core 4G HD Audio" rev 0x0b: msi
xhci0 at pci0 dev 20 function 0 "Intel 8 Series xHCI" rev 0x04: msi
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
"Intel 8 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
azalia1 at pci0 dev 27 function 0 "Intel 8 Series HD Audio" rev 0x04: msi
azalia1: codecs: Realtek/0x0668
audio0 at azalia1
ppb0 at pci0 dev 28 function 0 "Intel 8 Series PCIE" rev 0xe4
pci1 at ppb0 bus 1
ppb1 at pci0 dev 28 function 2 "Intel 8 Series PCIE" rev 0xe4: msi
pci2 at ppb1 bus 2
iwm0 at pci2 dev 0 function 0 "Intel Dual Band Wireless AC 7260" rev 0x6b, msi
ehci0 at pci0 dev 29 function 0 "Intel 8 Series USB" rev 0x04: apic 2 int 23
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel 8 Series LPC" rev 0x04
ahci0 at pci0 dev 31 function 2 "Intel 8 Series AHCI" rev 0x04: msi, AHCI 1.3
ahci0: port 2: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 2 lun 0: <ATA, LITEON IT LMT-12, HM71> SCSI3 0/direct fixed t10.ATA_LITEON_IT_LMT-128L9M-11_MSATA_128GB_TW0921PN5508544A1906
sd0: 122104MB, 512 bytes/sector, 250069680 sectors, thin
ichiic0 at pci0 dev 31 function 3 "Intel 8 Series SMBus" rev 0x04: apic 2 int 18
iic1 at ichiic0
iic1: addr 0x29 80=03 81=ad 82=ff 83=ff 8f=02 91=01 92=44 93=11 94=3a 96=1f 98=11 9a=0b 9f=14 a0=03 a1=ad a2=ff a3=ff af=02 b1=01 b2=44 b3=11 b4=3a b6=1f b8=11 ba=0b bf=14 c0=03 c1=ad c2=ff c3=ff cf=02 d1=01 d2=44 d3=11 d4=3a d6=1f d8=11 da=0b df=14 e0=14 e1=14 e2=14 e3=14 e4=14 e5=14 e6=14 e7=14 e9=14 ea=14 eb=14 ec=14 ed=14 ee=14 ef=14 f0=14 f1=14 f2=14 f3=14 f4=14 f5=14 f6=14 f7=14 f8=14 f9=14 fa=14 fb=14 fd=14 ff=14 words 00=0000 01=0100 02=0200 03=0300 04=0400 05=0500 06=0600 07=0700
iic1: addr 0x4c 00=30 01=35 04=06 05=55 07=55 0a=06 0b=55 0d=55 15=55 19=55 1a=55 1e=5b 20=55 21=0a 22=70 23=2d 24=80 25=0f 26=0f 27=12 28=12 60=06 70=06 71=07 72=07 a4=70 ac=28 ad=d4 ae=04 af=df b0=20 b1=20 fd=23 fe=5d ff=04 words 00=30ff 01=35ff 02=80ff 03=00ff 04=06ff 05=55ff 06=00ff 07=55ff
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pms0: disable error
pms0: disable error
pms0: disable error
pms0: disable error
pms0: disable error
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT
efifb at mainbus0 not configured
error: [drm:pid0:intel_uncore_check_errors] *ERROR* Unclaimed register before interruptuhidev0 at uhub0 port 2 configuration 1 interface 0 "Logitech USB Receiver" rev 2.00/12.03 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev1 at uhub0 port 2 configuration 1 interface 1 "Logitech USB Receiver" rev 2.00/12.03 addr 2
uhidev1: iclass 3/1, 8 report ids
ums0 at uhidev1 reportid 2: 16 buttons, Z and W dir
wsmouse1 at ums0 mux 0
uhid0 at uhidev1 reportid 3: input=4, output=0, feature=0
uhid1 at uhidev1 reportid 4: input=1, output=0, feature=0
uhid2 at uhidev1 reportid 8: input=1, output=0, feature=0
uhidev2 at uhub0 port 2 configuration 1 interface 2 "Logitech USB Receiver" rev 2.00/12.03 addr 2
uhidev2: iclass 3/0, 33 report ids
uhid3 at uhidev2 reportid 16: input=6, output=6, feature=0
uhid4 at uhidev2 reportid 17: input=19, output=19, feature=0
uhid5 at uhidev2 reportid 32: input=14, output=14, feature=0
uhid6 at uhidev2 reportid 33: input=31, output=31, feature=0
uhidev3 at uhub0 port 3 configuration 1 interface 0 "SYNAPTICS Synaptics Large Touch Screen" rev 2.00/0.01 addr 3
uhidev3: iclass 3/0, 15 report ids
ums1 at uhidev3 reportid 1: 1 button, tip
wsmouse2 at ums1 mux 0
ums2 at uhidev3 reportid 2: 2 buttons
wsmouse3 at ums2 mux 0
ums3 at uhidev3 reportid 7
ums3: mouse has no X report
uhid7 at uhidev3 reportid 8: input=0, output=0, feature=1
uhid8 at uhidev3 reportid 9: input=0, output=63, feature=0
uhid9 at uhidev3 reportid 10: input=0, output=5, feature=0
uhid10 at uhidev3 reportid 11: input=61, output=0, feature=0
uhid11 at uhidev3 reportid 12: input=1, output=0, feature=0
uhid12 at uhidev3 reportid 15: input=0, output=0, feature=1
uvideo0 at uhub0 port 5 configuration 1 interface 0 "CN0Y2TKG724873CED0DKA00 Integrated_Webcam_HD" rev 2.01/39.02 addr 4
video0 at uvideo0
ugen0 at uhub0 port 6 "Intel product 0x07dc" rev 2.00/0.01 addr 5
uhub2 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.04 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (c0be31cb1e50e248.a) swap on sd0b dump on sd0b
iwm0: hw rev 0x140, fw ver 16.242414.0, address e8:2a:ea:ab:49:24
error: [drm:pid51970:intel_uncore_check_errors] *ERROR* Unclaimed register before interrupt
pckbc: command timeout
pckbc: command timeout
pms0: enable error
pms0: not in sync yet, discard input (state 0)
pckbc: command timeout
pms0: disable error
pckbc: command timeout
pckbc: command timeout
pms0: enable error
pms0: not in sync yet, discard input (state 0)
pckbc: command timeout
pms0: disable error
pckbc: command timeout
pckbc: command timeout
pms0: enable error