lib-depends-check and soname question

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

lib-depends-check and soname question

Adam Montague
I'm attempting to make a port of nettle (a crypto lib).  It includes
libnettle.so.2.4, but its soname is libnettle.so.2, which I think is
causing lib-depends-check complains about "Missing: libnettle.so.2".

Am I correct that this is the problem, and if so, what is the right way
to fix it?  The initial version of the port is attached.

Thanks
Adam

nettle_port-1.13.tar.gz (2K) Download Attachment